Imovie lecture vidéo saccadée dans timeline

realu

Membre junior
19 Février 2012
11
0
J'ai un problème intermittent avec le montage vidéo dans Imovie. Lorsque je veux lire des clips vidéos dans la Timeline, il arrive parfois (assez souvent) que leur lecture est saccadée, hachurée, l'image rendue n'est pas fluide (le son est OK).. Par contre, lorsque je les lis dans l'événement, c'est fluide, sans problème. Si je redémarre l'ordinateur, parfois le problème est résolu, parfois il persiste. Je peux travailler une heure sur un montage vidéo sans problème puis ça commence à être saccadé. Je fais du montage vidéo depuis des années et je n'avais jamais eu ce problème. J'ai mis à niveau mon OS ainsi que Imovie sans succès. J'ai fait des vérifications avec Malwarebytes et Etrecheck et ils n'ont constaté aucun problème, si ce n'est une utilisation élevée du CPU par Imovie à l'occasion. J'ai contacté l'assistance Apple, on a réinstallé Catalina et fait quelques autres manipulations mais on n'a pas su résoudre mon problème . Quelqu'un-e a une idée ? J'ai des centaines d'heures de vidéos de voyage en attente de montage, il me faudrait bien résoudre ce problème... Merci

Voici la configuration de mon ordi : IMac iMac (Retina 4K, 21.5-inch, 2019), processeur 3,6 GHZ CORE i3 4 coeurs, mémoire 8 Go, Catalina 10.15.4, 277Go libres sur 1 To.
 

peyret

Vétéran
Club MacG
22 Octobre 2001
5 080
1 103
70
43110
J'ai un problème intermittent avec le montage vidéo dans Imovie. Lorsque je veux lire des clips vidéos dans la Timeline, il arrive parfois (assez souvent) que leur lecture est saccadée, hachurée, l'image rendue n'est pas fluide (le son est OK).. Par contre, lorsque je les lis dans l'événement, c'est fluide, sans problème. Si je redémarre l'ordinateur, parfois le problème est résolu, parfois il persiste. Je peux travailler une heure sur un montage vidéo sans problème puis ça commence à être saccadé. Je fais du montage vidéo depuis des années et je n'avais jamais eu ce problème. J'ai mis à niveau mon OS ainsi que Imovie sans succès. J'ai fait des vérifications avec Malwarebytes et Etrecheck et ils n'ont constaté aucun problème, si ce n'est une utilisation élevée du CPU par Imovie à l'occasion. J'ai contacté l'assistance Apple, on a réinstallé Catalina et fait quelques autres manipulations mais on n'a pas su résoudre mon problème . Quelqu'un-e a une idée ? J'ai des centaines d'heures de vidéos de voyage en attente de montage, il me faudrait bien résoudre ce problème... Merci

Voici la configuration de mon ordi : IMac iMac (Retina 4K, 21.5-inch, 2019), processeur 3,6 GHZ CORE i3 4 coeurs, mémoire 8 Go, Catalina 10.15.4, 277Go libres sur 1 To.
Salut,

Filevault ne serait-il pas activé ?
 
  • J’aime
Réactions: Findor

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 216
440
Je fais du montage vidéo depuis des années et je n'avais jamais eu ce problème.
Bonjour,

Mais depuis des années, la nature des rushes a bien changé, et il n'y a rien de commun entre du dv ou du HDV qui étaient monnaie courante il y a justement des années et de l'UHD en HEVC que l'on rencontre couramment aujourd'hui, ne serait-ce qu'en filmant avec un iPhone…
Et avec de tels rushes et une machine comme la tienne, il ne serait nullement étonnant que cela rame…

Il y a donc une première information essentielle manquante : la nature de tes rushes.

Ensuite il serait intéressant de savoir de quel GPU ton iMac est'il équipé.

Enfin, et si ta bibliothèque est localisée sur ton DDI, de quel type est ce dernier, FD ou SSD ?
 

madmaxmac

Membre émérite
22 Mars 2004
541
12
pour ma part ayant monté des années du DV sur des vieilles machines comme imac marguerite , je pense que les pb des saccades ds les logiciels de montage sont toujours de meme nature outre bien sur la nature des rushes surtout actuellement .



sources possibles de la saccade :

fragmentation du fichier video due en général a un DD chargé en multiples petits fichiers comme images , textes etc…
conséquence : le processeur peine a chercher les morceaux de fichiers video sur le DD…cela ralentit le tout…

quand on monte une video , la mémoire cache de l'appli devient énorme d'autant plus si on a fait bop de manip
conséquence : tjrs la meme : ralentissement du tout et saccade
c'est le cas quand on monte 1h de video…a la fin le cache est saturé et saccade donc.



pourquoi pas de saccade ds un player : parce que il n'y a pas de manip.



la nature des rushes : et la c'est encore un autre problème de decompression des images et selon le codec ..ça peut ramer

et enfin les 3 sources de pb en meme temps : fragmentation , cache , codec.



donc

quel est le format de vos images ?
quelles sources : iphone , camera …
espace du DD libre ?
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 216
440
la mémoire cache de l'appli devient énorme d'autant plus si on a fait bop de manip
Bonjour,
Je ne suis pas sûr que la mémoire cache d'iMovie soit un problème car sauf erreur de ma part, les caches ne contiennent pas de fichiers lourds.
En revanche, il existe dans la bibliothèque pour chaque projet, un dossier très lourd intitulé Render Files/High Quality Media où sont stockés tous les fichiers ProRes de chaque intervention sur la TL.
Mais ce ne sont pas ces fichiers (qui ne sont pas en mémoire) qui provoquent les saccades.
 

peyret

Vétéran
Club MacG
22 Octobre 2001
5 080
1 103
70
43110
...ou anti-virus de type Avast ? ;) qui travaillerait en tâche de fond...

Pour le savoir, poste un rapport Etrecheck... on en saura peut-être mieux ?
tuto pour poster un rapport
 
  • J’aime
Réactions: Findor

realu

Membre junior
19 Février 2012
11
0
Bonjour,

Mais depuis des années, la nature des rushes a bien changé, et il n'y a rien de commun entre du dv ou du HDV qui étaient monnaie courante il y a justement des années et de l'UHD en HEVC que l'on rencontre couramment aujourd'hui, ne serait-ce qu'en filmant avec un iPhone…
Et avec de tels rushes et une machine comme la tienne, il ne serait nullement étonnant que cela rame…

Il y a donc une première information essentielle manquante : la nature de tes rushes.

Ensuite il serait intéressant de savoir de quel GPU ton iMac est'il équipé.

Enfin, et si ta bibliothèque est localisée sur ton DDI, de quel type est ce dernier, FD ou SSD ?

Voici les réponses vos questions :

  • la nature de tes rushes ? fichiers .MOV 1920x1080, codec linear PCM, Timecode, HJ.264
  • source : caméscope Sony HDR XRV-520
  • de quel GPU ton iMac est'il équipé ? IMac iMac (Retina 4K, 21.5-inch, 2019), processeur 3,6 GHZ CORE i3 4 coeurs, mémoire 8 Go, Catalina 10.15.4,
  • bibliothèque sur DDI, type Fusion Drive, 277Go libres sur 1 To.
Merci
 
Dernière édition:

peyret

Vétéran
Club MacG
22 Octobre 2001
5 080
1 103
70
43110
Bonjour,

Pas grand chose à dire.... si ce n'est comme tu as pu le constater ....
Peut-être que des membres du forum pourront en dire un peu plus.... Je pensais qu'il y aurait des extensions qui ferait "ramer"
TimesMachine à l'air d'être en fonction, essaie de la désactiver au moins quand tu te sers d'Imovie....

.... et Apple a osé mettre un 5400 tours avec Catalina !! et 1 SSD de 28 Go !!!

disk0 - APPLE SSD SM0032L 28.00 Go (SSD - TRIM : Oui)
disk1 - APPLE HDD HTS541010A9E632 1.00 To (Mécanique - 5400 tr/min)
macOS Catalina 10.15.4 (19E287)
2020-05-08 16:49:44 iMovie (original).app Usage du processeur élevé (4 fois)
Exécutable : /Applications/iMovie (original).app

2020-05-08 10:10:44 backupd Usage du processeur élevé (3 fois)
Exécutable : /System/Library/CoreServices/backupd.bundle/Contents/Resources/backupd

2020-05-05 19:38:33 iMovie.app Usage du processeur élevé (2 fois)
Exécutable : /Applications/iMovie.app
 
Dernière édition:

madmaxmac

Membre émérite
22 Mars 2004
541
12
  • J’aime
Réactions: peyret

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 976
5 746
Nancy___
Bloc de code:
Problèmes légers :
  Les problèmes qui figurent ici n’ont pas besoin de correction immédiate, mais il est possible qu’ils deviennent plus graves dans le futur ou qu’ils soient des occasions d’amélioration.
  Logiciel en plantage - Il y a eu quelques plantages de logiciel.
  Logiciel avec grande usage de l’unité centrale - Il y a eu quelques logiciels qui ont eu grande usage de l’unité centrale.


Ca sent l'installation de Chrome :
Bloc de code:
Agents launchd de l’utilisateur :
  [Engagé] com.google.keystone.agent.plist (Google, Inc. - installé 2020-04-30)
  [Engagé] com.google.keystone.xpcservice.plist (Google, Inc. - installé 2020-04-30)


Là il va y avoir du ménage à faire :
Bloc de code:
 24 instantanés locaux
  Instantané local le plus vieux : 2020-05-09 18:10:11
  Dernier instantané : 2020-05-10 18:08:39


Le performances sont très correctes, voire excellentes avec le tout petit SSD du FD !
Bloc de code:
Performance :
  Charge du système : 1.74 (1 min) 1.25 (5 min) 1.12 (15 min)
  Vitesse nominale d’E / S : 0.85 Mo/s
  Système de fichiers : 25.18 seconds
  Vitesse écrire : 610 Mo/s
  Vitesse lire : 1454 Mo/s


Toute la RAM est utilisée :
Bloc de code:
Informations de la mémoire virtuelle :
  Mémoire vive : 8 Go
 
  Mémoire libre : 66 Mo
  Mémoire utilisé  6.51 Go
  Cache du fichier : 1.42 Go
 
  Mémoire disponible : 1.49 Go
  Fichier d’échange utilisé : 97 Mo


Enfin, plein de plantages avec des applications Apple, c'est pas normal :
Bloc de code:
Événements du diagnostic (7-30 dernier jours) :
  2020-05-09 19:11:17 Notes.app Plantage (4 fois)
    Exécutable : /Applications/Notes.app
    Détails :
      dyld: launch, loading dependent libraries
 
  2020-05-08 16:49:44 iMovie (original).app Usage du processeur élevé (4 fois)
    Exécutable : /Applications/iMovie (original).app
 
  2020-05-08 10:10:44 backupd Usage du processeur élevé (3 fois)
    Exécutable : /System/Library/CoreServices/backupd.bundle/Contents/Resources/backupd
 
  2020-05-05 19:38:33 iMovie.app Usage du processeur élevé (2 fois)
    Exécutable : /Applications/iMovie.app
 
  2020-05-05 18:22:33 photoanalysisd Usage du processeur élevé
    Exécutable : /System/Library/PrivateFrameworks/PhotoAnalysis.framework/Versions/A/Support/photoanalysisd
 
  2020-05-04 15:39:29 com.apple.WebKit.WebContent Plantage (6 fois)
    Exécutable : /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.WebContent.xpc/Contents/MacOS/com.apple.WebKit.WebContent
 
  • J’aime
Réactions: madmaxmac et peyret

realu

Membre junior
19 Février 2012
11
0
je vois ecrit :
  1. 2020-05-08 16:49:44 iMovie (original).app Usage du processeur élevé (4 fois)...si en meme temps il y a une sauvegarde Time machine automatique...cela peut etre une cause
J'ai désactivé Time Machine et j'ai toujours le même problème et je dirais même que ça empire, auparavant le problème de saccade était intermittent, maintenant, c'est toujours présent !!!
 

realu

Membre junior
19 Février 2012
11
0
Bloc de code:
Problèmes légers :
  Les problèmes qui figurent ici n’ont pas besoin de correction immédiate, mais il est possible qu’ils deviennent plus graves dans le futur ou qu’ils soient des occasions d’amélioration.
  Logiciel en plantage - Il y a eu quelques plantages de logiciel.
  Logiciel avec grande usage de l’unité centrale - Il y a eu quelques logiciels qui ont eu grande usage de l’unité centrale.


Ca sent l'installation de Chrome :
Bloc de code:
Agents launchd de l’utilisateur :
  [Engagé] com.google.keystone.agent.plist (Google, Inc. - installé 2020-04-30)
  [Engagé] com.google.keystone.xpcservice.plist (Google, Inc. - installé 2020-04-30)


Là il va y avoir du ménage à faire :
Bloc de code:
 24 instantanés locaux
  Instantané local le plus vieux : 2020-05-09 18:10:11
  Dernier instantané : 2020-05-10 18:08:39


Le performances sont très correctes, voire excellentes avec le tout petit SSD du FD !
Bloc de code:
Performance :
  Charge du système : 1.74 (1 min) 1.25 (5 min) 1.12 (15 min)
  Vitesse nominale d’E / S : 0.85 Mo/s
  Système de fichiers : 25.18 seconds
  Vitesse écrire : 610 Mo/s
  Vitesse lire : 1454 Mo/s


Toute la RAM est utilisée :
Bloc de code:
Informations de la mémoire virtuelle :
  Mémoire vive : 8 Go

  Mémoire libre : 66 Mo
  Mémoire utilisé  6.51 Go
  Cache du fichier : 1.42 Go

  Mémoire disponible : 1.49 Go
  Fichier d’échange utilisé : 97 Mo


Enfin, plein de plantages avec des applications Apple, c'est pas normal :
Bloc de code:
Événements du diagnostic (7-30 dernier jours) :
  2020-05-09 19:11:17 Notes.app Plantage (4 fois)
    Exécutable : /Applications/Notes.app
    Détails :
      dyld: launch, loading dependent libraries

  2020-05-08 16:49:44 iMovie (original).app Usage du processeur élevé (4 fois)
    Exécutable : /Applications/iMovie (original).app

  2020-05-08 10:10:44 backupd Usage du processeur élevé (3 fois)
    Exécutable : /System/Library/CoreServices/backupd.bundle/Contents/Resources/backupd

  2020-05-05 19:38:33 iMovie.app Usage du processeur élevé (2 fois)
    Exécutable : /Applications/iMovie.app

  2020-05-05 18:22:33 photoanalysisd Usage du processeur élevé
    Exécutable : /System/Library/PrivateFrameworks/PhotoAnalysis.framework/Versions/A/Support/photoanalysisd

  2020-05-04 15:39:29 com.apple.WebKit.WebContent Plantage (6 fois)
    Exécutable : /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.WebContent.xpc/Contents/MacOS/com.apple.WebKit.WebContent

Bonjour,

Quand vous dites :
Là il va y avoir du ménage à faire :
Bloc de code:
 24 instantanés locaux
  Instantané local le plus vieux : 2020-05-09 18:10:11
  Dernier instantané : 2020-05-10 18:08:39

Comment je fais ce ménage ? Que sont ces "instantanés locaux" qui vous déplaisent ?

Et quant à Chrome, devrais-je le désinstaller ?, je ne l'utilise pas vraiment.
Merci.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 976
5 746
Nancy___
Oui pour désinstaller Chrome.

Pour les instantanés Time machine, d'abord une question : branches tu régulièrement ton disque Time machine ?
 

realu

Membre junior
19 Février 2012
11
0
Oui pour désinstaller Chrome.

Pour les instantanés Time machine, d'abord une question : branches tu régulièrement ton disque Time machine ?
OK je vais désinstaller Chrome
Mon disque Time Machine est toujours branché. Est-ce une bonne façon de faire ? Merci
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 976
5 746
Nancy___
Désactive la sauvegarde Time machine dans les Préférences de TM.
Eteins ton disque TM.
Puis entre la commande suivante dans le Terminal :
Bloc de code:
 tmutil listlocalsnapshots /
et poste le résultat de la commande, entre deux balises #Code# comme indiqué ci dessous :


Note du modérateur de service (ici Aliboron) :
Merci de mettre les copies de compte-rendus de Terminal entre des balises de "bloc de code" (et pas _ Code). On les trouve dans la barre d'outils, dans le menu déroulant aux trois petits points :
Bloc de code.png
 

realu

Membre junior
19 Février 2012
11
0
Désactive la sauvegarde Time machine dans les Préférences de TM.
Eteins ton disque TM.
Puis entre la commande suivante dans le Terminal :
Bloc de code:
 tmutil listlocalsnapshots /
et poste le résultat de la commande, entre deux balises #Code# comme indiqué ci dessous :


Note du modérateur de service (ici Aliboron) :
Merci de mettre les copies de compte-rendus de Terminal entre des balises de "bloc de code" (et pas _ Code). On les trouve dans la barre d'outils, dans le menu déroulant aux trois petits points :
Voir la pièce jointe 173181
Désolé, je n'ai pas ce menu dans Terminal, où le trouve-t-on ? Quant à la réponse à la commande Tmutil... j'ai eu ceci comme réponse :
Snapshots for volume group containing disk /:
com.apple.TimeMachine.2020-05-11-100714.local
iMac-de-Real:~ realsavard$

Est-ce tout ça que je mets entre les deux balises CODE ?
Merci.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 976
5 746
Nancy___
Désolé, je n'ai pas ce menu dans Terminal, où le trouve-t-on ?
Dans les Préférences Système / Time machine ;)


Quant à la réponse à la commande Tmutil... j'ai eu ceci comme réponse :
Snapshots for volume group containing disk /:
com.apple.TimeMachine.2020-05-11-100714.local
iMac-de-Real:~ realsavard$
Bizarre. C'est comme si tu n'avais plus d'instantes locaux…

Peux tu refaire un rapport EtreCheck stp et le poster comme précédemment ?
 

realu

Membre junior
19 Février 2012
11
0