MacBook Pro Impossible de reformater SSD interne

AlmaxLacrimosa

Nouveau membre
14 Décembre 2019
7
0
25
Bonjour,
J'ai installé il y a plusieurs mois un SSD mx500 crucial 1to dans mon Macbookpro mid 2009. Ça fonctionnait bien jusqu'à ce que mon ordi d'éteigne tout à coup sans pouvoir se rallumer _ barre de chargement jusqu'à la moitié puis s'éteint. Etant donné que j'ai un disque dur externe comprenant une copie de mon ordi de Carbon Copy Cloner avec laquelle j'avais originellement installé le SSD interne, j'ai fini par essayer d'effacer le SSD pour recréer une partition dans utilitaire de disque (atteint grâce à cmd+r au démarrage). Mais impossible! Alors au bout de plusieurs tentatives différentes trouvées sur des forums je me suis dit qu'il était mort et j'ai essayé de remettre l'ancien DDinterne que j'avais toujours (lent mais qui fonctionnait) et exactement pareil , impossible de démarrer dessus ni de le reboot ... Donc je comprends plus du tout et ça fait 1 semaine que je galère donc j'appelle à l'aide, si quelqu'un a une idée. Merci beaucoup !
 

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
3 892
878
Dole 39
Salut,

Tu arrives à démarrer sur ton Clone en USB ?

Si tu as de quoi brancher ton SSD interne en USB et faire un essai de démarrage ... et qu'il démarre en USB ... c'est la Nappe Sata ! 50€ chez IfiXit. Personnellement, je la change d'office quand je place un SSD en remplacement d'un HD
 

AlmaxLacrimosa

Nouveau membre
14 Décembre 2019
7
0
25
Salut, merci pour ta réponse !
Alors j'ai pas de boitier externe donc non j'ai pas essayé encore, mais j'ai essayé les manip diskutil dans le Terminal et ça donne ça, qu'en penses-tu ? Est-ce possible que le disque soit détecté même si la nappe SATA est cassée ?
Merci encore !

Bloc de code:
Last login: Mon Dec 16 15:15:48 on console
MBP-de-Noel:~ noel$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS ALMAX                   999.9 GB   disk0s2
/dev/disk1 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *2.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS TOSHIBA EXT             2.0 TB     disk1s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
MBP-de-Noel:~ noel$ diskutil verifyDisk /dev/disk0
Started partition map verification on disk0
Checking prerequisites
Checking the partition list
Checking the partition map size
Checking for an EFI system partition
Checking the EFI system partition's size
Checking the EFI system partition's file system
Checking the EFI system partition's folder content
Problems were found with the partition map which might prevent booting
Error: -69842: Couldn't mount disk
MBP-de-Noel:~ noel$ diskutil verifyVolume /dev/disk0s2
Started file system verification on disk0s2 ALMAX
Verifying file system
Checking Journaled HFS Plus volume
Checking extents overflow file
Checking catalog file
Checking multi-linked files
Checking catalog hierarchy
Checking extended attributes file
Checking volume bitmap
Checking volume information
The volume ALMAX appears to be OK
File system check exit code is 0
Finished file system verification on disk0s2 ALMAX
MBP-de-Noel:~ noel$ diskutil repairDisk /dev/disk0
Repairing the partition map might erase disk0s1, proceed? (y/N) y
Started partition map repair on disk0
Checking prerequisites
Checking the partition list
Adjusting partition map to fit whole disk as required
Problems were encountered during repair of the partition map
Error: -69697: Partition map repair failed while adjusting structures to fit current whole disk size
Underlying error: 5: POSIX reports: Input/output error
MBP-de-Noel:~ noel$
 

oyapoque

Membre d’élite
Club MacG
2 Novembre 2017
2 476
259
59
Les spécialistes pourront t’en dire plus mais tu as
- un problème d’accès au disque avec une erreur entrée / sortie,
- un disque externe qui démarre normalement,
Un faisceau d’indices conduisant à la nappe évoquée par @Fullcrum.
Dans l’utilitaire, le disque est bien monté quand tu tentes un formatage ?
La vérification montre un problème de montage du disk0
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
38 925
5 089
Nancy___
Un faisceau d’indices conduisant à la nappe évoquée par @Fullcrum.
Pour en être sûr, il faut sortir le SSD, le mettre dans un boitier externe et redémarrer sur ce SSD en externe. Si le redémarrage se passe sans souci, alors la démonstration est faite qu'il faut changer la nappe.
 

AlmaxLacrimosa

Nouveau membre
14 Décembre 2019
7
0
25
@oyapoque Non impossible de le monter dans Utilitaires...
@Sly54 je vais acheter ça oui il vaut mieux essayer avant d'acheter une nouvelle nappe.
Ce qui me parait bizarre c'est que ça a cessé de fonctionner hyper subitement sans que j'y touche, alors que ça marchait très bien depuis plusieurs mois.
J'avais aussi téléchargé une version pas forcément très safe de Indesign il y a 1 mois (vu que les nouvelles versions sur le creative cloud ne marchent plus avec El Capitan), qui elle aussi a fonctionné pendant 3 semaines sans problème, et n'était pas ouverte au moment du beug ; mais pensez-vous que ça pourrait éventuellement avoir un lien ?
Merci pour vos réponses
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
31 775
3 444
Ce qui me parait bizarre c'est que ça a cessé de fonctionner hyper subitement sans que j'y touche, alors que ça marchait très bien depuis plusieurs mois.
Vu le symptôme, je penche pour un problème avec la nappe SATA. Mais commence par faire ce qui est demandé en réponse #7 dans par exemple ce type de boîtier pas cher et sans vis... https://www.amazon.fr/Seatay-HD213C-Boîtier-Disque-Externe/dp/B07X3FRXN7/ref=sr_1_1?__mk_fr_FR=ÅMÅŽÕÑ&keywords=Seatay+HD213C+Boîtier+de+Disque+Dur+Externe+SATA+vers+Type-C+GEN1+2,5&qid=1576514115&sr=8-1
J'avais aussi téléchargé une version pas forcément très safe de Indesign il y a 1 mois (vu que les nouvelles versions sur le creative cloud ne marchent plus avec El Capitan), qui elle aussi a fonctionné pendant 3 semaines sans problème, et n'était pas ouverte au moment du beug ; mais pensez-vous que ça pourrait éventuellement avoir un lien ?
Non et ici on ne parlera pas de ce qui est illégal. ;)
 
  • J’aime
Réactions: AlmaxLacrimosa

oyapoque

Membre d’élite
Club MacG
2 Novembre 2017
2 476
259
59
Tu as d’un côté ton SSD interne qui refuse de fonctionner,
Tu le remplaces en interne par l’ancien disque qui lui aussi ne fonctionne pas,
Tu démarres sur un clone en externe, le Mac fonctionne.
Certes nous ne sommes pas à une démonstration à 100% puisque le SSD comme l’ancien disque installé en lieu et place pour un test peuvent montrer des signes de faiblesses en même temps .
Mais bon....
Les prix d’un boîtier ou d’une nappe étant du même ordre, la question du choix peut se poser si tu n’as pas besoin de boîtier.
Maintenant tu peux également utiliser un boîtier pour te servir de ton ancien disque en sauvegarde ou stockage.... à toi de voir

Édit : les anciennes nappes peuvent mal supporter les débits plus conséquents d’un SSD surtout s’ils sont liés a une application exigeante
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
38 925
5 089
Nancy___
Les prix d’un boîtier ou d’une nappe étant du même ordre, la question du choix peut se poser si tu n’as pas besoin de boîtier.
50€ la nappe, 10-15€ le boitier…

Mais le boitier est réutilisable comme tu l'as dit, ça devrait faire partie de la trousse du bon bricoleur :up:
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
38 925
5 089
Nancy___
Vous ne me conseillez pas les nappes à 15 € de Amazon du coup j'imagine ? Vraie différence avec celles à 50 ?
Si je dis une différence de qualité, tu pourrais me rétorquer "mais comment tu le sais ?" (j'aime bien faire les questions et les réponses ;))
Dans les faits, je crois qu'on n'a (quasiment) jamais vu de problème avec les nappes MacWay ou iFixit, alors qu'avec des nappes à 10-15 balles achetées ailleurs le problème n'était pas toujours réglé. Donc on préfère recommander d'acheter directement les nappes qui semblent être de qualité.
 
  • J’aime
Réactions: AlmaxLacrimosa

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
31 775
3 444
Vous ne me conseillez pas les nappes à 15 € de Amazon du coup j'imagine ? Vraie différence avec celles à 50 ?
Commence avec un boitier qui sera en quelque sorte le juge de paix, par la suite ce boîtier te servira. Pour une nappe SATA, mieux vaut commander chez MacWay en précisant par téléphone le modèle exact. Attention au prix trop attractif, généralement la qualité n'est pas au rendez-vous, en cas de problème le SAV de MacWay est à la hauteur pour un échange.
 
  • J’aime
Réactions: AlmaxLacrimosa

oyapoque

Membre d’élite
Club MacG
2 Novembre 2017
2 476
259
59
Pour la part’ j’ai tout acheté autour de 30 € unitaire. Là boîtier et la nappe chez Macway. Le prix des nappes doivent varier selon la qualité mais aussi selon le Mac.
J’ai eu un boîtier à une dizaine d’euros qui fermait mal. Bien dans sa trousse à outils, pas terrible en disque de stockage externe
 
  • J’aime
Réactions: AlmaxLacrimosa

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
3 892
878
Dole 39
AlmaxLacrimosa

Je vois que le post est bien fourni en réponses, comme évoquées, je maintiens la Nappe Sata. Ton retour de commande rapporte une multitude de processus non aboutis au Boot ... il cherche le volume pour démarrer .

Une repose collégiale donc;)
 
  • J’aime
Réactions: AlmaxLacrimosa

AlmaxLacrimosa

Nouveau membre
14 Décembre 2019
7
0
25
J'ai acheté le boîtier et mon SSD fonctionne en externe ! C'est donc bien la nappe Sata, je vais la commander.
Merci à tout le monde pour vos réponses précises ⚡
 

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
3 892
878
Dole 39