10.6 Snow Leopard Impossible d'entrer dans mon iMac

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 985
23 650
Forêt de Fontainebleau
Bon. On va faire le test suivant : supprimer le fichier .GlobalPreferences.plist qu'on a édité précédemment > puis le remplacer par le fichier .GlobalPreferences.plist du dossier copié sur ton Bureau.

- je te suppose dans la session toto. Utilise son terminal pour passer les commandes (l'une après l'autre) :​
Bloc de code:
sudo rm /Users/mohamednajar/Library/Preferences/.GlobalPreferences.plist
sudo cp /Users/mohamednajar/Desktop/Preferences/.GlobalPreferences.plist /Users/mohamednajar/Library/Preferences
sudo chown mohamednajar /Users/mohamednajar/Library/Preferences/.GlobalPreferences.plist
  • qui : suppriment le fichier incriminé > le remplacent par une copie de celui du dossier du Bureau > confirment mohamednajar en propriétaire du fichier copié

Est-ce que les 3 commandes sont passées sans message d'erreur ?
 

Moms77

Membre junior
28 Octobre 2020
35
0
43
La première commande m'a demandé le mot de passe sinon pas de message d'erreur
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 985
23 650
Forêt de Fontainebleau
Passe la commande de vérification :
Bloc de code:
sudo defaults read /Users/mohamednajar/Library/Preferences/.GlobalPreferences.plist AppleLanguages
  • qui lit le tableau des langues associé comme valeur à la clé AppleLanguages > dans le fichier qu'on vient de copier dans les Preferences de la Bibliothèque de mohamednajar

Poste le retour.
 

Moms77

Membre junior
28 Octobre 2020
35
0
43
Bloc de code:
2020-10-30 22:43:38.120 defaults[166:1707]
The domain/default pair of (/Users/mohamednajar/Library/Preferences/.GlobalPreferences.plist, AppleLanguages) does not exist
iMac-van-toto:~ toto$
 
Dernière édition par un modérateur:

Moms77

Membre junior
28 Octobre 2020
35
0
43
C'est bon la session est revenue. C'est toujours en néerlandais. j'ai essayé de changer dans "langue et région" mais il ne me donne qu'une seule langue (néerlandais)
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 985
23 650
Forêt de Fontainebleau
D'accord -->

- comme il se fait un peu tard pour moi (je ne suis pas trop du soir) > je te propose de nous en tenir là pour aujourd'hui. Je reviendrai demain dans ce fil pour qu'on reprenne la question à têtes reposées. Car il y a un truc qui m'échappe. J'ai expérimentalement édité le fichier des Préférences Globales d'un autre compte de mon Mac qui me sert pour des tests => et je n'ai pas eu ce problème d'affichage de session planté.​
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 985
23 650
Forêt de Fontainebleau
Il se trouve qu'entre les nombreux comptes d'utilisateurs expérientaux que j'ai dans le volume de mon OS --> un en particulier présentait une anomalie analogue à celle de ton principal : des menus du Finder obstinément en Anglais cette fois > qu'aucune édition du fichier .GlobalPreferences.plist de la Bibliothèque de ce compte (soit à partir d'une session extérieure > soit en mode live depuis cette même session ouverte) => ne permettait de changer.

- je n'ai toujours pas capturé la "raison théorique" de cette persistance dans l'anomalie > mais j'ai trouvé un "palliatif pratique" qui a fonctionné - du moins en ce qui concerne ma session expérimentale. Tu n'auras qu'à refaire signe ici quand tu seras de nouveau disponible => qu'on teste ce palliatif.​
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 985
23 650
Forêt de Fontainebleau
Et me voilà -->

- l'astuce qui a marché sur mon Mac et qui marchera peut-être sur le tien : supprimer le fichier des Préférences Globales (qui dicte entre autre la langue du Finder et des applications dans la session) de ton compte Ouachen > le remplacer par une copie du fichier des Préférences Globales du compte toto > restaurer les autorisations sur le fichier copié > redémarrer > tester l'ouverture de la session Ouachen. Donc non plus une édition interne au fichier conservé > mais un remplacement de fichier.​

=> d'accord pour le test ?

Loge-toi d'abord dans la session toto (on va tout faire depuis cette session externe à la session Ouachen).

- quand tu y es > passe d'abord la commande informative :​
Bloc de code:
defaults read -g AppleLanguages
  • qui lit le tableau des langues associé comme valeur à la clé AppleLanguages dans le fichier des Préférences Globale de toto

Poste le retour => qu'on voie si la langue prioritaire est bien le Français pour ce fichier.

Note : ferme la session Ouachen avant de te loger dans celle de toto (ne bascule pas en laissant la session Ouachen ouverte).
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 985
23 650
Forêt de Fontainebleau
Une floppée de langues encore > mais le Français est bien en position prioritaire et commande la langue de session. Bon fichier donc qu'on laisse intact sans y toucher.

- passe les commandes (l'une après l'autre - mot-de-passe toto uniquement pour le 1er sudo dans les 5') :​
Bloc de code:
sudo mv /Users/mohamednajar/Lib*/Preferences/.GlobalPreferences.plist /Users/mohamednajar/Lib*/Preferences/BAK.GlobalPreferences.plist
sudo cp ~/Lib*/Preferences/.Glo* /Users/mohamednajar/Lib*/Preferences
sudo chown mohamednajar /Users/mohamednajar/Lib*/Preferences/.GlobalPreferences.plist
  • la 1ère renomme le fichier des Préférences Globales de la session Ouachen => BAK.GlobalPreferences.plist (ce qui le sauvegarde en le neutralisant)
  • la copie le fichier des Préférences Globales de la session toto => dans les Preferences de la Bibliothèque Ouachen
  • la refait de mohamednajar (nomcourt de l'utilisateur Ouachen) le propriétaire du fichier copié

Est-ce que tu as obtenu un retour d'aucune de ces 3 commandes ?
 

Moms77

Membre junior
28 Octobre 2020
35
0
43
Voici ce que j'ai obtenu :
Bloc de code:
iMac-van-toto:~ toto$ sudo mv /Users/mohamednajar/Lib*/Preferences/.GlobalPreferences.plist /Users/mohamednajar/Lib*/Preferences/BAK.GlobalPreferences.plist
Password:
mv: rename /Users/mohamednajar/Lib*/Preferences/.GlobalPreferences.plist to /Users/mohamednajar/Lib*/Preferences/BAK.GlobalPreferences.plist: No such file or directory
iMac-van-toto:~ toto$ sudo cp ~/Lib*/Preferences/.Glo* /Users/mohamednajar/Lib*/Preferences
cp: /Users/mohamednajar/Lib*/Preferences: No such file or directory
iMac-van-toto:~ toto$ sudo chown mohamednajar /Users/mohamednajar/Lib*/Preferences/.GlobalPreferences.plist
chown: /Users/mohamednajar/Lib*/Preferences/.GlobalPreferences.plist: No such file or directory

iMac-van-toto:~ toto$
 
Dernière édition par un modérateur:

epm

Nouveau membre
1 Octobre 2020
3
1
81
En redémarrant, l'ordi me demande un mot de passe, ce qu'il ne fait jamais. J'ai donc introduit mon mot de passe mais il ne le reconnait pas, du coup il m'est impossible d'entrer dans mon ordinateur.
si le mot de passe ne fonctionne plus, tout d'abord vérifier quel est le clavier (par défaut il pourrait avoir été changé en clavier américain...) on peut le vérifier en haut à droite à coté de la date... dans ce cas, soit le changer, en clavier FR ou taper en prenant en compte le changement de position des lettres et chiffres (clavier réduit ou complet Fr ou US)

vérifier le clavier par défaut FR ou US... et taper le mot de passe en prenant en compte les différences de position des lettres et chiffres...
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 985
23 650
Forêt de Fontainebleau
@ epm

Son mot-de-passe toto fonctionne très bien : là n'est pas le problème.

------------

@ Moms

Ça n'a pas eu l'air de fonctionner avec des abréviations ça et là. Peut-être à cause de ton OS Snow Léopard.

- on refait tout en adresses absolues et commande à commande.​

Passe d'abord la commande :
Bloc de code:
sudo mv /Users/mohamednajar/Library/Preferences/.GlobalPreferences.plist /Users/mohamednajar/Library/Preferences/BAK.GlobalPreferences.plist
  • qui renomme le fichier cible

=> est-ce que tu as eu un retour ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 985
23 650
Forêt de Fontainebleau
Bon : éviter les abréviations alors.

- passe en 2è commande :​
Bloc de code:
sudo cp /Users/toto/Library/Preferences/.GlobalPreferences.plist /Users/mohamednajar/Library/Preferences
  • qui copie le fichier

=> as-tu eu un retour ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 985
23 650
Forêt de Fontainebleau
Parfait (les commandes muettes passent ici).

- passe en 3è commande :​
Bloc de code:
sudo chown mohamednajar /Users/mohamednajar/Library/Preferences/.GlobalPreferences.plist
  • qui restaure les autorisations du fichier copié

=> as-tu eu un retour ?