"/index.php" rewrite en "/"

tabasko

Membre émérite
1 Décembre 2003
699
15
45
Paris
www.123boost.com
Hello !



Je tourne en rond avec une petite solution que je n'arrive pas à trouver.

Lorsque je demande à mon navigateur d'aller sur http://www.monsite.fr, j'atterris sur https://www.monsite.fr/index.php

Je voudrai forcer l'url https://www.monsite.fr/ dans le navigateur.


Voici mon fichier .htaccess à la racine de mon site :


Bloc de code:
RewriteEngine on
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

ErrorDocument 404 https://www.monsite.fr/portfolio/

RedirectPermanent /index.html /index.php
RedirectPermanent /Album-Photo-Mariage /portfolio


Alors bien entendu j'ai tenté de remplacer :

RedirectPermanent /index.html /index.php
par

RedirectPermanent /index.php /



Lorsque je fais çà cela ne fonctionne pas.



(j'ai d'autre .htaccess sur mon site mais je pense que c'est celui ci qui nous intéresse)
 

pouppinou

Une vie de Chien et de Pommé, et je suis heureux !
17 Juin 2017
2 385
2 443
49
Niche.
Tu as bien entendu essayé en enlevant la ligne :
Bloc de code:
RedirectPermanent /index.html /index.php
Pour voir si le problème venait bien de là ?
 

pouppinou

Une vie de Chien et de Pommé, et je suis heureux !
17 Juin 2017
2 385
2 443
49
Niche.
Alors cela ne doit pas venir de ce fichier .htaccess
Enlèves le complètement pour vérifier.

Tu es sûr qu'il n'y a pas une redirection dans ton code de l'index.html ?
 

tabasko

Membre émérite
1 Décembre 2003
699
15
45
Paris
www.123boost.com
Alors cela ne doit pas venir de ce fichier .htaccess
Enlèves le complètement pour vérifier.

Tu es sûr qu'il n'y a pas une redirection dans ton code de l'index.html ?

He ! bien vu !!!!! si je retire le htaccess j'ai l'impression que çà corrige le problème.... et le reste semble fonctionner sans broncher.
Par contre, htaccess retiré, quand j'appelle mon site en http ... le navigateur le bascule quand même en https ... pas très logique ! non ?
 

pouppinou

Une vie de Chien et de Pommé, et je suis heureux !
17 Juin 2017
2 385
2 443
49
Niche.
Faut voir les autres .htaccess de ton site.
Sinon recrées un .htaccess avec la redirection inverse https -> http :

Bloc de code:
Redirect permanent / http://www.monsite.fr/

EDIT : Voir aussi côté serveur. Exemple chez ovh on peut gérer les redirections dans le manager, dans les options du domaine sans modifier le htaccess. Dans ce cas il va prendre le dessus même si tu as enlevé le .htaccess (qui faisait doublon d'ailleurs).
Voir également dans le code header .index.html
 
Dernière édition:

tabasko

Membre émérite
1 Décembre 2003
699
15
45
Paris
www.123boost.com
Le problème que j'ai, est obligatoirement lié au passage des serveurs ovh d'apache 2.2 à 2.4 (mon .htaccess fonctionnait très bien jusqu'à cette mise à jour).

Bloc de code:
Redirect permanent / http://www.monsite.fr/
ne fonctionne pas (çà me laisse ma page en erreur 500.

L'ensemble des .htaccess sont dans ce post sur un site voisin.
 

tabasko

Membre émérite
1 Décembre 2003
699
15
45
Paris
www.123boost.com
Faut voir les autres .htaccess de ton site.
Sinon recrées un .htaccess avec la redirection inverse https -> http :

Bloc de code:
Redirect permanent / http://www.monsite.fr/

EDIT : Voir aussi côté serveur. Exemple chez ovh on peut gérer les redirections dans le manager, dans les options du domaine sans modifier le htaccess. Dans ce cas il va prendre le dessus même si tu as enlevé le .htaccess (qui faisait doublon d'ailleurs).
Voir également dans le code header .index.html

On peut faire çà du manager ???? :) c'est où ? par domaine j'imagine !

Je file regarder de ce pas.

Sinon à priori j'ai trouvé la rustine :
j'ai retiré :
Bloc de code:
RedirectPermanent /index.html /index.php

et j'ai ajouté
Bloc de code:
RewriteEngine On
RewriteRule ^index\.php$ / [R=301,L]
RewriteRule ^(.*)/index\.php$ /$1/ [R=301,L]