Installation d'Apache 2, php 5.2 et MySQL 4

SetBlue

Membre junior
20 Août 2004
32
1
41
Bonjour,

Je suppose que cette question a du être posée mille fois mais à chaque fois que je tente un tutorial, quelque chose cloche. Je pense que je dois avoir un problème spécifique (peut-être est-ce un bug de l'interface chaise-clavier :p ).

Je souhaite installer apache 2, php 5.2 et mysql 4 sur mon MBP. Je précise qu'une solution genre MAMP ne convient pas (j'utilise MAMP par ailleurs mais là je veux installer un Framework et m'approcher le plus possible de la config d'un serveur en production (pour info c'est Symfony que je veux installer, et les tutoriaux de leurs wiki, bien que complets, ne m'ont pas aidé).

Or donc :

Pour le moment, si je fais un :

$ sudo apachectl fullstatus

Je vois que l'apache qui tourne est en version 1.3.33

Si je fais un :

$ php -v

La version installé de PHP est la 5.1.6

Pour installer ce qu'il me faut, j'ai d'abord installé DarwinPorts (http://darwinports.opendarwin.org/docs/ch01s03.html )

Ensuite aprés avoir fait un :

$ sudo port sync

et un :

$ sudo port upgrade

pour mettre à jour les DarwinPorts, j'ai fait :

$ sudo port install mysql4

Le téléchargement des packages et l'installation se déroulent bien (c'est super long mais ça c'est normal)

Ensuite j'ai fait :
$ sudo port install php5 +macosx +mysql4 +apache2

Là aussi, pas de pépin.

Et donc si aprés ça je refais un :

$ sudo apachectl fullstatus

Il me dit que je tourne encore sous apache 1.3.33

de même un php -v me dit que je suis encore en 5.1.6

Je dois dire que je suis totalement débutant en ce qui concerne le terminal et ce genre de manip ainsi que dans l'architecture d'OS X

A priori je dois avoir plusieurs versions d'installée mais je ne sais pas comment faire pour que tout marche bien.

Pour résumer, je voudrais que :

- Apache 2 et PHP 5.2 se lancent au démarrage
- mysql 4 se lance au démarrage

Toute mon estime à la personne qui voudra bien me prêter assistance. J'en suis à penser à me suicider au yahourt périmé.


 

SetBlue

Membre junior
20 Août 2004
32
1
41
Je suis certain que sur mon système, PHP 5.2 , Apache 2 etc sont présents. c'est juste que j'arrive pas à remplacer les anciennes versions avec les nouvelles.

Il doit forcément exister un truc quelque part pour dire à OS X d'utiliser les versions que j'ai installé :/
 
A

Anonyme

Invité
Dans le package Mysql que je t'ai donné, il y a un tableau de bord qui permet de lancer ou non le démon au démarrage. ;)