Installation Flash Player sur MacBoock MacIntel

jmoneyron

Membre confirmé
26 Juin 2001
488
10
90
Ayant accès provisoirement à un MacBook MacIntel équipé d'OSX 4.9, je cherche à y installer Flash Player pour pouvoir utiliser la webcam incorporée avec Yahoo Messanger.
Je bute à chaque pas !!
Est-ce même possible?
Quelqu'un peut-il me renseigner et m'aider ?
 
D

Deleted member 18124

Invité
Ayant accès provisoirement à un MacBook MacIntel équipé d'OSX 4.9, je cherche à y installer Flash Player pour pouvoir utiliser la webcam incorporée avec Yahoo Messanger.
Je bute à chaque pas !!
Est-ce même possible?
Quelqu'un peut-il me renseigner et m'aider ?
Flash Player est déjà installé. Donc pas la peine de le faire. Et pour les mises à jour, il faut laisser faire les mises à jour de Mac OS X. Les installations manuelles sont généralement sources de gros problèmes.
 

vleroy

Vétéran
Club MacG
6 Novembre 2004
6 749
1 918
bonjour,

1/ le flash player est effectivement installé sous OS 10.4.9 mais la version nécessite un upgrade en v9, gratuite et facile à installer. tapes flash player mac dans google, et tu download. Le tout est léger et simple.
2/ Il m'est arrivé sur certaines machines d'avoir besoin de me placer en root pour contourner un petit problème de droit sur safari en compte mobile, mais cela ne doit pas être ton cas. Au cas où, tu as déjà l'astuce.

A+
 

jmoneyron

Membre confirmé
26 Juin 2001
488
10
90
Après passage du désinstalleur et contôle par le test, il apparaît bien qu'il n'y a plus de flash player à bord.
Le téléchargement d'une version flash 9 à partir du site Adobe à l'aide de Safari s'effectue normalement mais l'installation est refusée, même lancée par l'administrateur de la machine, un message apparaît :

you do not have enough access privileges for this installation

Et ça ne va pas plus loin.
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
tu as quel types de droits sur ce Mac?
standard?
Administrateur?

oops
tu es admi

je vais fouiller car j'ai déjà vu ca

edit
Tu peux fouiller
avec des recherches genre flash et "you do not have enough access privileges for this installation "
(avec ou sans "")
 

jmoneyron

Membre confirmé
26 Juin 2001
488
10
90
pascalformac;4287294 Tu peux fouiller avec des recherches genre flash et "you do not have enough access privileges for this installation " (avec ou sans "")[/QUOTE a dit:
Je viens de lire des pages et des pages sur la question, dont certaines remontant à 2006, sans rien trouver que je n'aie déjà fait....sans le moindre succès.

J'ai une furieuse envie de tenter de forcer le passage en me loggant en root, mais j'ose pas, qu'en penses-tu ?
 

vleroy

Vétéran
Club MacG
6 Novembre 2004
6 749
1 918
Je viens de lire des pages et des pages sur la question, dont certaines remontant à 2006, sans rien trouver que je n'aie déjà fait....sans le moindre succès.

J'ai une furieuse envie de tenter de forcer le passage en me loggant en root, mais j'ose pas, qu'en penses-tu ?
relis mon premier post, passe en root, et on va ainsi clore ce sujet, dans la joie et la bonne humeur:up:
 

Mobyduck

Vétéran
Club MacG
10 Août 2005
7 140
1 727
Le resto' en bas de la rue...
Après passage du désinstalleur et contôle par le test, il apparaît bien qu'il n'y a plus de flash player à bord.
Le téléchargement d'une version flash 9 à partir du site Adobe à l'aide de Safari s'effectue normalement mais l'installation est refusée, même lancée par l'administrateur de la machine, un message apparaît :

you do not have enough access privileges for this installation

Et ça ne va pas plus loin.
Ca m'est déjà arrivé, une simple réparation des autorisations règle le problème.
 

vleroy

Vétéran
Club MacG
6 Novembre 2004
6 749
1 918
les autorisations n'y changeront rien, l'update s'attaque au noyau, dont seul root est autorisé à faire des modifications.
Donc, on passe en root, on fait l'install, et on quitte le compte root, et tout baigne. C'est un cas un peu particulier, convenons en, mais la solution est à la portée de tous.
Onyx ou les bidouilles sur les droits n'y changeront rien.
 

maousse

Vétéran
Club MacG
20 Avril 2002
7 224
445
39
Paris
orbl.eu
flash ne "s'attaque" pas au noyau (ça veut dire quoi d'ailleurs?.......précisément, j'aimerais comprendre).

En installant flash en root, ça "résout" le problème, mais il se posera sans doute à nouveau à la prochaine mise à jour. D'ailleurs, toute manipulation à partir du compte root est à éviter, quoiqu'il arrive. sudo est là pour ça, c'est la manière de fonctionner de mac os x.

C'est juste qu'adobe est vraiment une entreprise qui a l'art d'emmerder son monde avec ses installeurs. Ça n'est pas nouveau et ça n'a pas l'air près de changer. :)
 
  • J’aime
Réactions: Mobyduck

vleroy

Vétéran
Club MacG
6 Novembre 2004
6 749
1 918
loin de me moi de contester la solution mais quand elle est aussi simple et exceptionnelle de passer par root, d'ailleurs sans désinstaller l'ancien, je ne vois pas pourquoi s'en priver.
Pour le resten je partage les avissur adobe;)