java 1.5 sur 10.3.9

febu

Membre junior
7 Janvier 2002
89
2
48
www.lillustrefabrique.net
Bonjour, je voudrais installer Java 1.5 sur mon ibook sous Panther, dans le but d'utiliser Thingamablog qui recommande cette version, j'ai fait une petite recherche qui m'a amené à installer Java 1.5 avec Pacifist, comme conseillé ici : http://www.macosxhints.com/article.php?story=2005043002313964

J'ai également trouvé ceci qui avait l'air simple :
"If you install the JDK 5 distribution available from Apple?s Developer Connection website, the installer will check your OS level and politely tell you that the JDK 5 update is only for Tiger users. There is no technical reason why this is the case, as many developers who choose not to upgrade their operating system simply use the excellent Pacifist application to install the JDK without going through Apple?s OS test. Apple?s JDK update simply installs the latest Java JDK in /System/Library/Frameworks/JavaVM.framework/Versions/, updates the symbolic links and goes away. The fact that there is no difference in how Java was distributed between Tiger (10.4) Panther (10.3) and even Jaguar (10.2) shows how transparent and deplorable this restriction is."

Seulement, comme je suis un parfait ignare dans ce domaine, ça n'a pas marché.
Est-ce qu'il serait possible d'avoir un coup de main ? Pour info, voici comment je m'y suis pris jusqu'ici :

J'ouvre le paquet téléchargé depuis le site d'Apple, je demande à Pacifist d'installer le contenu, ça démarre puis j'obtiens ce message :
"BUNDLE EXISTE DEJA L'application bundle /Applications/Utilities/Java/Input Method HotKey.app existe déjà. Voulez-vous remplacer le bundle existant par celui que vous installez ou préférez-vous mettre à jour le bundle existant ? Si vous installez une nouvelle application, vous devriez cliquer sur Remplacer. Si vous installez une mise à jour, vous devriez cliquer sur Mettre à jour pour empêcher que l'application existante ne devienne un dossier."

J'ai essayé les 2 options et j'ai à chaque fois ce message :

"Un fichier existe déjà à l'endroit suivant :
/System/Library/Frameworks/JavaVM.framework/Headers

Voulez-vous le remplacer ?"

Je fais OK et j'obtiens :
"L'erreur suivante s'est produite en tentant d'installer le fichier /System/Library/Frameworks/JavaVM.framework/Versions/1.3: Un dossier ne peut être remplacé par un fichier."


...
 

GrandGibus

Membre d’élite
Club MacG
8 Mars 2004
1 262
103
47
Bordeaux
homepage.mac.com
/System/Library/Frameworks/JavaVM.framework/ est le répertoire de départ aux installations des JDKs / JREs sur mac.

Je n'ai jamais réalisé la manipulation que tu tentes, mais théoriquement, cela semble possible. L'erreur que tu décris semble liée à Pacifist par rapport à ce que contient déjà le répertoire Java.VM/framework.

Une proposition dont j'ignore totalement les effets potentiellement indésirables consisterait à:
  1. faire une sauvegarde de JavaVM.framework (en JavaVM.Framework2 par ex.)
  2. de recréer un nouveau répertoire (vide) de JavaVM.Framework
  3. de lancer l'installation depuis Pacifist


Cependant, j'ignore si le contenu des installs est complet.... De plus, j'ignore si ce genre de manip est risquée :mouais:.

Dans le cas où le contenu n'est pas complet, tu peux toujours procéder à une recopie depuis la sauvegarde pour compléter.
 

febu

Membre junior
7 Janvier 2002
89
2
48
www.lillustrefabrique.net
Merci pour cette solution très claire, cependant je ne trouve nulle part de fichier JavaVM.framework, ni par le chemin Système/Bibliothèque/Java/... ni en faisant une recherche toute bête !
Est-ce qu'il y a quelque chose qui m'échappe ?
 

febu

Membre junior
7 Janvier 2002
89
2
48
www.lillustrefabrique.net
Eh bien, il semblerait que ça ait marché, j'ai encore quelques petites questions cependant :

Je ne sais pas comment vérifier que ma version de Java est à présent la 1.5, y a-t-il un test simple à effectuer ?

Et sinon, mon nouveau dossier JavaVM.framework ne contient que les dossiers "Headers, JavaVM, Resources et Versions", est-ce qu'il faut que j'y ré-introduise les dossiers "Classes, Commands, Home et Libraries" de ma sauvegarde ?
 

febu

Membre junior
7 Janvier 2002
89
2
48
www.lillustrefabrique.net
Merci, j'ai fait tout ça, mais malheureusement ça semble ne pas fonctionner : après avoir complété le dossier en question, impossible de relancer Thingamablog. Une recherche approfondie sur le forum (macosxhints) que je citais au début de mon questionnement m'a appris qu'il valait bien mieux s'en tenir à la version 1.4.2 sous Panther, sous peine de ne plus pouvoir faire fonctionner bon nombre de programmes Java... Voilà, à l'instant j'ai donc réinstallé Java 1.4.2 à son emplacement (simplement en glissant le contenu sauvegardé dans le repertoire Frameworks), j'espère que ça suffira ! (en tout cas, Thingamablog semble fonctionner à présent)...

Quoiqu'il en soit un grand merci à toi, monsieur GrandGibus !