iMac Lenteur de connexion ethernet

ccciolll

Vétéran
Club MacG
Bonjour,

Je viens de mesurer la vitesse de connexion (speedtest Ookla en ligne) d'un poste imac8,1 (core2duo 2,4 ghz*2 early 2008).
Les résultats m'ont paru anormalement bas.
J'ai donc branché un simple PC portable sur le même câble, et ça confirme qu'il y a un problème avec ce mac.
Le problème ne viendrait à priori pas de la connexion.

Avec le PC j'ai ping 9 / Down 941 Mb / up 476 Mb
Avec l'iMac j'ai Ping 9 / Down 189 Mb / Up 172 Mb

Est-ce que la prise ou la carte ethernet est bridée ?
Est-ce qu'un réglage peut faire évoluer ça ou ce mac est déjà à son maximum ?
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 066
376
92
Bonjour,

Quels sont les réglages de la connexion dans les paramètres ? Es-tu bien en Gb ?
 

ccciolll

Vétéran
Club MacG
Je ne peux pas installer l'appli sur ce mac (osx trop ancien).
J'ai fait le test avec FFox, mais sur un autre mac de la maison, avec Ffox, j'ai de très bon résultats, donc pas sûr que ça vienne du navigateur.
 

ccciolll

Vétéran
Club MacG
Bonjour,

Quels sont les réglages de la connexion dans les paramètres ? Es-tu bien en Gb ?
Il ne propose que Mbps et Kbps sur la page https://www.speedtest.net/fr/settings
D'ailleurs ça m'avait un peu intrigué au départ car effectivement le « compteur » est un peu différent sur ce mac et sur l'autre.
Il montre un compteur qui va jusqu'à 100, alors que sur le mac « qui va bien », ça va 10 fois plus loin.
 

edenpulse

Membre émérite
10 Août 2010
898
193
Testes tu en wifi ou en cable ethernet? Tout les cables ne sont pas égaux non plus. En fonction de la génération du cable, les débits ne sont pas les mêmes.
 

radioman

Membre confirmé
23 Octobre 2007
496
98
Limoges
il faut aller voir dans Préférences Système / Réseau / Ethernet / bouton "Avancé" / onglet "Matériel" mettre Vitesse sur 1000base T en Duplex Intégral .

… et être sûr d'avoir un câble RJ45 avec les 4 paires câblées: Ethernet 10/100 passe sur deux paires, le 1000 sur 4 !!!
 

Lamahi

Membre confirmé
29 Mai 2020
318
85
14
Aix-en-Provence
Bonjour,

je possède le même iMac et je te confirmes qu’il n’est pas bridé : résultat Speedtest (j'ai la fibre)

Je ne peux pas installer l'appli sur ce mac (osx trop ancien).
J'ai fait le test avec FFox, mais sur un autre mac de la maison, avec Ffox, j'ai de très bon résultats, donc pas sûr que ça vienne du navigateur.
Je possède bien l'app, sous OS X El Capitan. Je viens de vérifier, elle est encore compatible.

Bonjour,
Tu devrais essayer de télécharger l'application Speedtest pour comparer sans navigateur
J'ai bien de meilleurs résultats avec l'app.

Coincidence, j'ai exactement la même config que toi o_O
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 066
376
92
Il ne propose que Mbps et Kbps sur la page https://www.speedtest.net/fr/settings
D'ailleurs ça m'avait un peu intrigué au départ car effectivement le « compteur » est un peu différent sur ce mac et sur l'autre.
Il montre un compteur qui va jusqu'à 100, alors que sur le mac « qui va bien », ça va 10 fois plus loin.
Quelles sont les caractéristiques des tes ports Ethernet sur le Mac (100 MB ou 1 GB ?) et sur le PC (10 GB ???) ?
 

maxou56

Membre d’élite
14 Avril 2020
1 941
398
Lorient
J'ai donc branché un simple PC portable sur le même câble, et ça confirme qu'il y a un problème avec ce mac.
Bonsoir,
Ton iMac est aussi connecté en wifi?
Si oui vérifier que l’ethernet est bien en premier dans les réglages réseaux.

Sinon 189Mbit/s signifie que tu es bien en Gigabit. Voir aussi l’usage du CPU lors du test, car le cpu peut aussi être limitant, pas aussi bas normalement.
 
Dernière édition:

ccciolll

Vétéran
Club MacG
Testes tu en wifi ou en cable ethernet? Tout les cables ne sont pas égaux non plus. En fonction de la génération du cable, les débits ne sont pas les mêmes.

Ethernet FTP CAT6 4 paires, tout neuf.
Et de toutes façons, comme indiqué au départ, le test avec un portable sur ce même câble montre que ce dernier n'est pas un facteur limitant.

il faut aller voir dans Préférences Système / Réseau / Ethernet / bouton "Avancé" / onglet "Matériel" mettre Vitesse sur 1000base T en Duplex Intégral .

Sur cet iMac, c'était automatiquement sur 1000baseT / Duplex intégral contrôle de flux.
J'ai changé pour intégral tout court et refait un test, ça n'améliore pas le résultat.
Est-ce qu'il peut y avoir des conséquences néfastes à avoir modifié ça manuellement et faut-il le remettre comme avant ?

je possède le même iMac et je te confirmes qu’il n’est pas bridé : résultat Speedtest (j'ai la fibre)
Je possède bien l'app, sous OS X El Capitan. Je viens de vérifier, elle est encore compatible.

En effet, ce sont le type de chiffres que je devrais pouvoir atteindre.
Par contre, mon mac est en 10.10 Yosemite, soit juste en dessous de ElCap (10.11) et sur l'appstore c'est indiqué à partir de 10.11.

Quelles sont les caractéristiques des tes ports Ethernet sur le Mac (100 MB ou 1 GB ?) et sur le PC (10 GB ???) ?

Je ne sais pas comment vérifier ça. Mais comme Lamahi juste au-dessus dit obtenir des résultats corrects avec la même ordi…

Ton iMac est aussi connecté en wifi?
Si oui vérifier que l’ethernet est bien en premier dans les réglages réseaux.
Sinon 189Mbit/s signifie que tu es bien en Gigabit. Voir aussi l’usage du CPU lors du test, car le cpu peut aussi être limitant, pas aussi bas normalement.

Non, wifi déconnecté, uniquement ethernet.
Et, en effet, 189 c'est déjà honorable et je pourrais m'en contenter (surtout que ce poste est secondaire). Mais c'est juste que je n'aime pas quand je ne comprends pas un truc.
le CPU, tu veux dire s'il y a d'autres applis qui tournent en même temps ?
Il n'y avait quasiment rien qui tournait. Et sur mon autre mac (Mac mini Server (Late 2012) / macos10.12) , même avec des applis qui tournent, j'obtiens Up 608 via Ffox et Up 937 via l'appli.
 
  • J’aime
Réactions: Lamahi

maxou56

Membre d’élite
14 Avril 2020
1 941
398
Lorient
le CPU, tu veux dire s'il y a d'autres applis qui tournent en même temps ?
Non c'est regarder la charge du CPU lors du Test. Si il monte à 90-100% de charge CPU c'est probablement lui qui limite (comme c'est un 2 coeurs, si tu regardes dans les processus le total du CPU c'est 200%).

Et sur mon autre mac (Mac mini Server (Late 2012) / macos10.12) , même avec des applis qui tournent, j'obtiens Up 608 via Ffox et Up 937 via l'appli.
Les 2 machines ne sont pas comparable. Le mini 2012 à un core i (i5 ou i7) de 3éme Génération. Il est beaucoup plus puissant que le core2duo (entre 2.5 et 5x), de plus il supporte matériellement plus de technologies "modernes" (par exemple l'AES) ce que le core2duo doit faire logicielement ce qui demande beaucoup plus de ressource et comme le CPU est beaucoup moins puissant :sorry:
 
Dernière édition:

ccciolll

Vétéran
Club MacG
OK, et bien je pourrai tester ça, alors.
Effectivement peut-être que c'est une bonne piste à explorer.
Ceci étant dit, Lamahi m'annonce de très bon résultats avec le même appareil que moi.
 

ccciolll

Vétéran
Club MacG
Voici. Je ne sais pas si ma méthode est la plus complète pour tester la charge du CPU, mais sur le graphique ci-joint, on voit que c'est monté assez haut sans pour autant atteindre le plafond.
Capture d’écran 2021-04-14 à 15.46.31.png