10.15 Catalina Mauvais disque de démarrage

olicoche

Nouveau membre
6 Avril 2021
4
0
34
Bonjour,
Il y a plus d'un an j'avais branché un SSD en USB sur mon iMac (fin 2013) afin de l'utiliser comme disque de démarrage à la place du HD d'origine (toujours en place et utilisé pour le stockage). Depuis quelques semaines, il arrive parfois que le redémarrage se fasse sur le HD alors que le SSD est toujours sélectionné dans les préférences système. Avec une manipulation (sélectionner le HD puis remettre le SSD comme disque de démarrage), j'arrivais à corriger le problème.
Cependant aujourd'hui rien à faire, l'iMac démarre systématiquement sur le HD, et le SSD apparaît comme disque externe (il est pourtant toujours sélectionné comme disque de démarrage dans les préférences).
Quelqu'un aurait-il une solution ou une idée de l'origine du problème ?
Merci !
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
50 709
9 528
Nancy___
Bonjour,

Cependant aujourd'hui rien à faire, l'iMac démarre systématiquement sur le HD, et le SSD apparaît comme disque externe (il est pourtant toujours sélectionné comme disque de démarrage dans les préférences).
N'hésite pas à la dé-selectionner puis à la re-sélectionner.
Si ça ne fais toujours rien, fais voir une réinitialisation de la mémoire NVRAM/PRAM
 

olicoche

Nouveau membre
6 Avril 2021
4
0
34
Merci pour cette réponse. J'ai ressayé plusieurs fois, sans succès. J'ai tenté de réinitialiser la mémoire NVRAM, mais bien que j'ai fait la manip des 4 touches lors de plusieurs démarrage je n'ai pas l'impression qu'il se soit passé quelque chose... (j'avais aussi essayé la manip pour pouvoir sélectionner le bon disque au démarrage, sans succès non plus).
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
50 709
9 528
Nancy___

olicoche

Nouveau membre
6 Avril 2021
4
0
34
J'ai refait la manip pour le reset de la NVRAM et ça a fonctionné, je pense que je n'avais pas appuyé assez vite. La sélection du disque de démarrage ayant été effacée j'ai pu resélectionner le SSD et ça a marché, un grand merci à toi.

Est-ce que je peux faire quelque chose pour éviter que ça recommence ? Par exemple en supprimant la partition Macintosh HD (pas celle Macintosh HD - Données) ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
50 709
9 528
Nancy___
J'ai refait la manip pour le reset de la NVRAM et ça a fonctionné, je pense que je n'avais pas appuyé assez vite. La sélection du disque de démarrage ayant été effacée j'ai pu resélectionner le SSD et ça a marché, un grand merci à toi.
:up:


Est-ce que je peux faire quelque chose pour éviter que ça recommence ? Par exemple en supprimant la partition Macintosh HD (pas celle Macintosh HD - Données) ?
Comme ça, je dirais non…
Quel est ton OS actuel ?
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 502
5 086
Est-ce que je peux faire quelque chose pour éviter que ça recommence ?
Le plus simple pour moi serait de démarrer sur ta version de macOS de ton disque dur interne, d'aller dans Préférences Système/Disque de démarrage de sélectionner ton SSD et tu fais un clic sur Redémarrer. Par défaut, ce sera ta session de macOS de ton SSD qui sera lancé et là même motif, même punition tu vas dans Préférences Système/Disque de démarrage, tu sélectionnes ton SSD et un clic sur Redémarrer. Ça fait faire deux fois les mêmes manipulations, mais si ton problème recommence, il y aura anguille sous roche.