Mavericks très long à s'éteindre sur MBA 2013

Marco31

Membre confirmé
19 Septembre 2011
102
1
Bonjour,

j'aimerai avoir vos avis - et vos lumières - sur un petit souci que j'ai : j'ai un MBA 2013 Haswell (8 GO RAM, I5, 256 GO DD) que j'ai passé sous Mavericks. Clean install sans souci, je réinstalle mes soft et mes docs et, au moment d'éteindre, écran gris pendant plusieurs secondes, plus roulettes pendant plusieurs secondes et, au final, entre 15 et 20 secondes pour l'éteindre !

J'ai attendu la sortie d'Onyx, ces derniers jours, pour l'installer et voir si ça arrangerait les choses : pas de résultat.

Puis j'ai bouclé la boucle en achetant Cleanmymac 2 : pas de résultat.

Auriez-vous une idée sur la raison de ce ralentissement et une piste pour m'aider à le résoudre ?

Merci par avance à ceux qui prendront un peu de temps pour me répondre :)
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 841
5 242
Bonjour,

j'aimerai avoir vos avis - et vos lumières - sur un petit souci que j'ai : j'ai un MBA 2013 Haswell (8 GO RAM, I5, 256 GO DD) que j'ai passé sous Mavericks. Clean install sans souci, je réinstalle mes soft et mes docs et, au moment d'éteindre, écran gris pendant plusieurs secondes, plus roulettes pendant plusieurs secondes et, au final, entre 15 et 20 secondes pour l'éteindre !

J'ai attendu la sortie d'Onyx, ces derniers jours, pour l'installer et voir si ça arrangerait les choses : pas de résultat.

Puis j'ai bouclé la boucle en achetant Cleanmymac 2 : pas de résultat.

Auriez-vous une idée sur la raison de ce ralentissement et une piste pour m'aider à le résoudre ?

Merci par avance à ceux qui prendront un peu de temps pour me répondre :)
Aie, ce n'est pas ce qu'il y avait de mieux à faire. Tu aurais pu économiser en installant Onyx ou Maintenance (le petit frère de Onyx).

Ce problème d'extinction lente est apparu depuis Mountain Lion et persiste sous Mavericks. Une solution temporaire avait été trouvé, mais elle ne fonctionne plus depuis la MAJ en 10.8.5 de Mountain Lion.
 

Marco31

Membre confirmé
19 Septembre 2011
102
1
Merci pour ta réponse. Si je t'entends bien, il n'y a donc pas de solution, Onyx et Cleanmymac n'y peuvent rien...

Ce qui me surprend plus, c'est cet article dont j'ai mis le lien en copie, qui identifie le problème et semble donner une solution, mais qui ne marche pas chez moi...

J'avoue que cela me laisse perplexe. et ça m'agace de voir que mon disque en SSD, super rapide le reste du temps, met un temps fou à s'éteindre. Difficile à accepter quand on aété sous Snow Leopard, avec ses 2 secondes pour l'extinction...

Je ne comprends pas la politique d'Apple sur ce sujet : c'est une régression, et tout le monde ne fait pas le choix de la veille plutôt que l'extinction. Moi, par exemple, qui suis nomade et donc préfère avoir un ordi éteint pendant mes déplacements...
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 841
5 242

Marco31

Membre confirmé
19 Septembre 2011
102
1
Sous Mountain Lion ce problème est connu... http://forums.macg.co/mac-os-x/10-8-2-plus-long-a-s-eteindre-1201031-5.html ...à partir de la réponse #85. Mais depuis la MAJ en 10.8.5, cela ne fonctionne plus.

Mais bon, 20 secondes ça peut aller. :zen:

Oui, ça peut aller, mais c'est surtout que t'as du mal à accepter de passer de 2 secondes à 20 secondes, et que cela soit considéré comme normal. Quand tu prends un Macbook Air, c'est pour que tout aille vite:)
Une régression pareillle pour "le système d'exploitation le plus avancé au monde", ça fait pitié... D'autant plus qu'Apple connait forcément ce problème et qu'il semble ne rien faire du tout pour le réparer, ni sous ML, ni sous Mavericks. Ca donne envie d'envoyer un petit mail bien senti à Tim Cool pour lui demander s'il ne se fout pas un peu de notre gueule...
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 841
5 242
Je suis en train de tester les manips du lien... 7 Known Issues With OS X Mavericks and How to Fix Them | Gadget Lab | Wired.com ...que tu cites.

J'en suis à 3 extinctions qui se passent pas mal chez moi. Maxi 5 secondes. Entretemps j'ai installé la dernière version de Onyx, non pas pour résoudre ce problème, mais pour vérifier qu'il n'y a pas une interférence suite à la 1ère réparation des permissions. A suivre...

Et il faut rester :zen: pour 20 petites secondes à attendre.
 

Marco31

Membre confirmé
19 Septembre 2011
102
1
Je suis en train de tester les manips du lien... 7 Known Issues With OS X Mavericks and How to Fix Them | Gadget Lab | Wired.com ...que tu cites.

J'en suis à 3 extinctions qui se passent pas mal chez moi. Maxi 5 secondes. Entretemps j'ai installé la dernière version de Onyx, non pas pour résoudre ce problème, mais pour vérifier qu'il n'y a pas une interférence suite à la 1ère réparation des permissions. A suivre...

Et il faut rester :zen: pour 20 petites secondes à attendre.

La manip semble donc marcher, chez toi. 5 secondes, c'est acceptable...
Comment as-tu donc fait ? (moi aussi, j'ai mis Onyx dernière version) : tu copies-colles chaque ligne, avec mot de passe après la première, puis fermeture de Terminal (pas de manip particulière sauf fermer l'appli ?) puis lancement de l'utilitaire disk pour réparer les permissions et reboot ? C'est ce que j'ai fait, sans résultat...
Si tu peux me dire ce que tu fais de différent, je prends.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 841
5 242
Bon, après 10 extinctions, le temps maxi aura été de 5 secondes. A vérifier dans le temps...

Pour les manipulations, rien de particulier dans le Terminal, il suffit de copier chaque ligne, la 1ère fois il faut le mot de passe. Ensuite copier chaque ligne en validant à chaque fois par Entrée.

---------------------------------------------------------------------------------------------------------------------------------------
sudo defaults write /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchDaemons/com.apple.securityd ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchDaemons/com.apple.mDNSResponder ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchDaemons/com.apple.diskarbitrationd ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchAgents/com.apple.coreservices.appleid.authentication ExitTimeOut -int 1
---------------------------------------------------------------------------------------------------------------------------------------

Après, il faut ouvrir l'Utilitaire de disque et Réparer les permissions du disque ou est installé Mavericks et c'est tout.

Comme mentionné plus haut, entretemps j'avais installé la dernière version de Onyx, pour vérifier qu'il n'y aurait pas d'interférence suite la 1ère réparation des Permissions. J'ai exécuté Onyx en mode Automation en décochant les 2 premières cases.

Pour le reste, que vont en penser les spécialistes des lignes de commande sudo ?
 
Dernière édition:

Marco31

Membre confirmé
19 Septembre 2011
102
1
Bon, après 10 extinctions, le temps maxi aura été de 5 secondes. A vérifier dans le temps...

Pour les manipulations, rien de particulier dans le Terminal, il suffit de copier chaque ligne, la 1ère fois il faut le mot de passe. Ensuite copier chaque ligne en validant à chaque fois par Entrée.

---------------------------------------------------------------------------------------------------------------------------------------
sudo defaults write /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchDaemons/com.apple.securityd ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchDaemons/com.apple.mDNSResponder ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchDaemons/com.apple.diskarbitrationd ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchAgents/com.apple.coreservices.appleid.authentication ExitTimeOut -int 1
---------------------------------------------------------------------------------------------------------------------------------------

Après, il faut ouvrir l'Utilitaire de disque et Réparer les permissions du disque ou est installé Mavericks et c'est tout.

Comme mentionné plus haut, entretemps j'avais installé la dernière version de Onyx, pour vérifier qu'il n'y aurait pas d'interférence suite la 1ère réparation des Permissions. J'ai exécuté Onyx en mode Automation en décochant les 2 premières cases.

Pour le reste, que vont en penser les spécialistes des lignes de commande sudo ?

Bon, je laisse la parole aux spécialistes, je vais retenter la manip car je ne comprends pas pourquoi ça ne marche pas chez moi...
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 841
5 242
Et bien j'en suis à plus de 20 extinctions, et toujours le même constat hormis une exception, l'extinction s'effectue en 2 secondes. Ca me parait stable, entre chaque extinction j'ai fait bosser mon MBP avec divers logiciels, dont un très long, ClamXav, histoire de bien monopoliser le processeur.
 

Marco31

Membre confirmé
19 Septembre 2011
102
1
Et bien j'en suis à plus de 20 extinctions, et toujours le même constat hormis une exception, l'extinction s'effectue en 2 secondes. Ca me parait stable, entre chaque extinction j'ai fait bosser mon MBP avec divers logiciels, dont un très long, ClamXav, histoire de bien monopoliser le processeur.

Alors là, ça me fait baver d'envie... Mais pourquoi ça marche pas, chez moi ???
Ravi pour toi, en tout cas.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 841
5 242
C'est bien, mais j'aimerais bien avoir l'avis des spécialistes des commandes sudo. :zen:
 

Marco31

Membre confirmé
19 Septembre 2011
102
1
Ca marche !!! Pour ceux que ça intéresse, j'ai refait une clean install puis, juste après, j'ai intégré les lignes de code et bingo : extinction en 2 secondes...
Rien que du bonheur, et pourvu que ça dure.:rateau:
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 841
5 242
Ca marche !!! Pour ceux que ça intéresse, j'ai refait une clean install puis, juste après, j'ai intégré les lignes de code et bingo : extinction en 2 secondes...
Rien que du bonheur, et pourvu que ça dure.:rateau:

Je continue à tester et pour le moment rien à redire, ça fonctionne toujours.
 

Marco31

Membre confirmé
19 Septembre 2011
102
1
Si ça se trouve aprés la C.I tu n'avais pas besoin de passer par le terminal...
Tu ne le sauras jamais :siffle:

Si : après la clean install, j'ai éteint le Mac : aucun effet. C'est seulement après avoir fait les manips de code que ça a fonctionné. Et ça fonctionne toujours, d'ailleurs...:up:
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 841
5 242
Si ça se trouve aprés la C.I tu n'avais pas besoin de passer par le terminal...
Tu ne le sauras jamais :siffle:

J'ai fait les 2 types d'installation dont 3 clean install dans mon MBP, ce problème est récurrent, Apple n'a rien fait sous Mavericks.
 

Hurrican

Vétéran
Club MacG
1 Septembre 2000
6 014
735
58
Jura seek parc
www.clan-m4k.com
De mon côté, pas de chance. :hein:
J'ai fait les manips, mais mon mbp C2D 2.4 sous 10.9.4 met toujours sa bonne vingtaine de secondes à s'éteindre malgré le SSD. :rateau:
C'est quand même dingue qu'Apple n'ait pas mis le nez dans ce problème. Sans être grave, il est pénible et gâche l'image de la machine !
 

Marco31

Membre confirmé
19 Septembre 2011
102
1
D'accord avec toi : ce n'est pas grave, mais c'est très vite pénible quand on a fait le choix d'un SSD, entre autres pour sa vitesse d'allumage et d'extinction. Au prix d'un Mac, c'est même une honte de laisser cette dégradation du service en plan depuis plusieurs OS successifs.
Il y avait une manip qui marchait sur 10.9.2, mais depuis la 3 et maintenant la 4, ca a sauté et impossible de contourner ce problème, malgré toutes mes recherches sur le Net.

De mon côté, pas de chance. :hein:
J'ai fait les manips, mais mon mbp C2D 2.4 sous 10.9.4 met toujours sa bonne vingtaine de secondes à s'éteindre malgré le SSD. :rateau:
C'est quand même dingue qu'Apple n'ait pas mis le nez dans ce problème. Sans être grave, il est pénible et gâche l'image de la machine !