10.14 Mojave Message ne s'ouvre plus sur MBP

mto1

Membre confirmé
5 Août 2004
208
6
Bjr à toutes et tous,

Depuis quelques jours et sans avoir subi de crash particulier, Message ne s'ouvre plus sur le MBP, mais m'affiche une me disant "une erreur interne deMessage s'est produite.". Ok, tests faits, rien. Ré-installe système pensant que cela ré-installerait le logiciel, rien. Les prèfs jetés, rien. Autre session, ça marche... dont, la machine va bien, et ds les bonnes conditions, ça tourne.
Maintenant, comment ré-installer juste CE logiciel ? Soit c'est compliqué, soit je ne sais pas soit et c'est sur, j'ai perdu la main !
Merci de votre aide...
Ci joint... : Message vous a envoyé un... message...
 

Fichiers joints

  • Message de Message.png
    Message de Message.png
    57,6 KB · Affichages: 13

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 041
980
Toulouse.cong
faq.office.macintosh.free.fr
Autre session, ça marche... donc, la machine va bien, et ds les bonnes conditions, ça tourne.
Pas seulement la machine, l'application aussi va bien. Pas besoin de réinstaller.

C'est dans ton compte utilisateur qu'il faut chercher ce qui cloche... Est-ce que tu as regardé, dans la Bibliothèque de ton compte habituel, le dossier ~/Bibliothèque/Messages ? Les différents dossiers com.apple.messages... dans ~/Bibliothèque/Containers ? Eh oui, il n'y a pas que les préférences, dans les versions récentes de macOS. ;)
 

mto1

Membre confirmé
5 Août 2004
208
6
C'est dans ton compte utilisateur qu'il faut chercher ce qui cloche... Est-ce que tu as regardé, dans la Bibliothèque de ton compte habituel, le dossier ~/Bibliothèque/Messages ? Les différents dossiers com.apple.messages... dans ~/Bibliothèque/Containers ?
J'avais déjà fait du ménage dans la bibliothèque (com.apple... et ~containers), mais pas dans ce dossier-là, en particulier (~/Bibliothèque/Messages).
En terme de message, c'est monté d'une cran... redémarrage obligé, je pense !
 

Fichiers joints

  • Capture d’écran 2021-05-14 à 10.03.03.png
    Capture d’écran 2021-05-14 à 10.03.03.png
    66,3 KB · Affichages: 19
Dernière édition par un modérateur:

mto1

Membre confirmé
5 Août 2004
208
6
le dossier ~/Bibliothèque/Messages ?
Et bien, cela semble bien avoir fonctionné au redémarrage... Quelque peu étonnant. J'ai perdu tout l'historique, mais ça marche, au moins je sais où taper ! Et du coup, je sais ce que je vais devoir restaurer en terme fichiers.
Et je reviendrai dire comment cela s'est passé.
Encore merci !
 
  • J’aime
Réactions: Aliboron

mto1

Membre confirmé
5 Août 2004
208
6
Comme promis, je reviens pour la suite et fin, heureuse de l'histoire.
J'ai sorti la sauvegarde TM la plus récente, et j'ai rechargé tous les éléments du dossier ~/~message... et tous est là, avec 4 jours de perte seulement, donc juste nickel !
Merci Aliboron ! J'ai raté le dossier alors que j'ai, j'avais fouillé et vider des trucs plus compliqué... J'ai appris quelque chose, et c'est nettement plus simple que la ré-installe de Mail, à moins qu'il y ait un mode d'emploi vraiment clair quelque part...
Bon week-end.
 

mto1

Membre confirmé
5 Août 2004
208
6
Du coup, il serait intéressant de voir les causes, mais pour cela, je vais ouvrir un nouveau fils...