Mon Macbook incompatible avec les SD cards ?

Bastl

Membre junior
11 Janvier 2009
72
1
Bonjour à tous,

Je m'en remets à vous pour trouver une solution à mon problème de compatibilité. Je pense que mon Macbook unibody est incompatible avec les cartes mémoire SD. Lorsque je connecte une carte SD Transcend à mon mac via un lecteur de cartes mémoire, iPhoto s'ouvre et affiche mes photos. Jusque là, aucun problème. Sauf qu'environ 30 secondes après, une fenêtre surgit pour me dire "Retrait de périphérique incorrect", sans que je n'ai rien touché ! 2 secondes après, ma carte est à nouveau reconnue par iPhoto, avant de disparaître à nouveau (avec la même fenêtre "Retrait de périphérique incorrect"...). Ca n'arrête pas pendant 5 secondes, sans que je ne touche à rien et à la fin, j'en ai tellement marre que j'éjecte (correctement) une bonne fois pour toute mon lecteur de carte.

J'ai d'abord pensé qu'il y avait un problème avec iPhoto. J'ai bien fait les mises à jour, mais rien de nouveau. J'ai décoché l'option qui ouvre iPhoto automatiquement quand on insère une carte mémoire avec des photos. J'ai voulu accéder à mes photos depuis le Finder mais je retombe sur le même problème : le périphérique se connecte et se déconnecte sans arrêt en quelques secondes. Impossible de voir mes photos plus de quelques secondes d'affilée. J'en déduis donc que ce n'est pas iPhoto qui est en cause.

J'ai ensuite pensé que c'était mon lecteur de carte qui avait un problème (comme un faux contact au niveau de la prise USB). Sauf qu'en l'essayant sur l'ordi d'un ami, il lit les cartes mémoire sans problème.

Enfin, j'ai pensé que ma carte SD devait avoir un problème. J'ai essayé avec une autre carte (celle de mon téléphone : une micro SD) et là... je retombe sur le même problème ! La carte est reconnue par intermittence et au final, j'éjecte tout puisque je ne peux rien faire !

Conclusion : il y a bien un problème entre mon mac et les SD cards.

Je ne sais plus quoi faire.... Quelqu'un a-t-il déjà eu un problème semblable ? Mieux encore : quelqu'un aurait-il une solution ?

Merci à tous !
 

Bastl

Membre junior
11 Janvier 2009
72
1
De mieux en mieux : les MS Micro (M2) ne sont pas non plus reconnues.... Même problème : le périphérique est reconnu par intermittence... Help....
 

Bastl

Membre junior
11 Janvier 2009
72
1
peut-être un problème de driver...
as-tu essayer de chercher sur google par exemple?
Je cherche sur google depuis des jours mais en vain.
Normalement, je n'ai pas besoin de driver sur Mac OS X, si ?
Et je ne pense pas qu'il faille un driver pour un lecteur de cartes mémoire, si ?
 

Simbouesse

Membre d’élite
Club MacG
24 Novembre 2007
3 616
333
C'est le Nooooord...
normalement, non, enfin on n'a pas a s'en soucier...
Mais là, je ne sais pas quoi te dire...
Il faudrait que tu puisse essayer un autre lecteur de carte sur ton MB et une autre carte avec ton lecteur de carte.
Faut essayer de localiser le problème quoi!

Sinon, les cartes se déconnectent également du Finder ou juste de iPhoto?
 

Bastl

Membre junior
11 Janvier 2009
72
1
normalement, non, enfin on n'a pas a s'en soucier...
Mais là, je ne sais pas quoi te dire...
Il faudrait que tu puisse essayer un autre lecteur de carte sur ton MB et une autre carte avec ton lecteur de carte.
Faut essayer de localiser le problème quoi!

Sinon, les cartes se déconnectent également du Finder ou juste de iPhoto?
Les cartes se déconnectent de iPhoto ET du Finder (ce qui est beaucoup plus problématique....)

J'ai essayé avec une MS Micro (M2) et le problème est le même : la carte se déconnecte. Donc ce n'est pas qu'un problème avec les SD Cards....

Je viens d'essayer avec un autre lecteur de carte et le problème se répète.... Mes cartes ne sont pas non plus bien reconnues par ce nouveau lecteur....

Se pourrait-il qu'il y ait un gros bug entre les nouveaux mac et les cartes mémoires ??
 

Simbouesse

Membre d’élite
Club MacG
24 Novembre 2007
3 616
333
C'est le Nooooord...
Entre les cartes SD et le tien, oui, après généraliser pour les autres je ne sais pas et je ne pense pas. Surtout que les cartes sont tout de même reconnues à un moment donné (même pas longtemps!).

Peut-être faudrait-il essayer les manip' classiques en cas de pépin:
  • Vérification (et réparation si nécessaire) des autorisations par l'utilitaire de disque Apple
  • Vérification des volumes (HDD) et réparation si nécessaire via le même utilitaire
  • Automation complète avec Onyx

Après cela, réessaie, on verra par la suite si il y a toujours un problème!
 

Bastl

Membre junior
11 Janvier 2009
72
1
Je viens d'essayer de transférer mes photos depuis mon imprimante HP qui comprend un lecteur de cartes mémoires. Et je retombe sur le même problème ! iPhoto s'ouvre correctement, affiche pendant 30 secondes mes photos et puis plus rien : la carte mémoire (ici la SD Transcend) lue par l'imprimante ne s'affiche plus, avant de réapparaître 5 secondes après. Cette fois-ci, j'ai même dû redémarrer iPhoto qui a planté complètement !

Je commence vraiment à croire que le Macbook unibody a un sérieux problème pour prendre en charge les cartes mémoires !...
 

Bastl

Membre junior
11 Janvier 2009
72
1
Entre les cartes SD et le tien, oui, après généraliser pour les autres je ne sais pas et je ne pense pas. Surtout que les cartes sont tout de même reconnues à un moment donné (même pas longtemps!).

Peut-être faudrait-il essayer les manip' classiques en cas de pépin:
  • Vérification (et réparation si nécessaire) des autorisations par l'utilitaire de disque Apple
  • Vérification des volumes (HDD) et réparation si nécessaire via le même utilitaire
  • Automation complète avec Onyx

Après cela, réessaie, on verra par la suite si il y a toujours un problème!
Ok, je fais tout ça et je vous tiens au courant !
 

Bastl

Membre junior
11 Janvier 2009
72
1
Ok, je fais tout ça et je vous tiens au courant !
Bon alors j'ai fait les deux vérifications/réparations et l'automation complète avec Onyx.... mais ça n'a rien changé. Pendant les vérifications, le périphérique n'arrêtait pas de se déconnecter. Il a fallu que je m'y reprenne à plusieurs fois....

Je ne sais vraiment plus quoi faire...
 

Bastl

Membre junior
11 Janvier 2009
72
1
Et je viens d'essayer mon lecteur de carte sur l'ordinateur PC d'un ami : le lecteur est reconnu, la carte mémoire aussi et tout se passe sans aucun problème.

Je commence vraiment à croire que mon mac a un problème avec la reconnaissance et la lecture des cartes mémoire..... Que faire ?
 

Arlequin

Membre masqué
Club MacG
4 Août 2004
12 229
989
DTC
petit test tout con

crée un second utilisateur
quitte ta session
log toi sur le nouvel utilisateur
test

dis nous ce que ça donne
 

Bastl

Membre junior
11 Janvier 2009
72
1
petit test tout con

crée un second utilisateur
quitte ta session
log toi sur le nouvel utilisateur
test

dis nous ce que ça donne
J'ai créé une seconde session pour un second utilisateur.... et j'ai exactement le même problème.

Par ailleurs, je viens d'essayer de lire mes cartes mémoires avec mon lecteur sur le mac d'une amie, un ancien Macbook blanc : et là, tout fonctionne parfaitement. Le périphérique est bien reconnu, mes photos apparaissent (et restent à l'écran plus de 30 secondes !) et ma carte mémoire n'est pas éjectée toutes les 5 secondes....

J'en déduis donc que mon macbook unibody a un sérieux problème. Je suis le seul dans ce cas ? Faut-il que j'aille voir un Apple Center ?
 

Arlequin

Membre masqué
Club MacG
4 Août 2004
12 229
989
DTC
soit ton Os a un sérieux soucis (réinstallation de la combo conseillée)

soit ton mac ne délivre pas assez de courant à tes lecteurs (mais j'en doute puisque même via ton imprimante ça ne marche pas)

Et en branchant l'APN sur ton mac, ça donne quoi ?
 

Bastl

Membre junior
11 Janvier 2009
72
1
soit ton Os a un sérieux soucis (réinstallation de la combo conseillée)

soit ton mac ne délivre pas assez de courant à tes lecteurs (mais j'en doute puisque même via ton imprimante ça ne marche pas)

Et en branchant l'APN sur ton mac, ça donne quoi ?
Je ne peux pas brancher mon APN sur mon ordi : j'ai perdu le câble pour les relier. C'est pour cela que je me suis acheté ce lecteur de cartes mémoire.

Je ne pense pas non plus que ce soit un problème de courant : je n'ai aucun problème avec d'autres périphériques (comme une clé USB TNT).

Je vais devoir me rendre dans un Apple Center aujourd'hui je crois....
 

Bastl

Membre junior
11 Janvier 2009
72
1
et si celà venait de iphoto ? essayes donc avec un autre application .
Je ne pense pas non plus que ça vienne d'iPhoto : le problème est identique si j'observe ma carte mémoire depuis le Finder. Elle est reconnue par intermittence et je n'ai pas accès à mes photos plus de 5 secondes d'affilée.
 

Arlequin

Membre masqué
Club MacG
4 Août 2004
12 229
989
DTC
Je ne peux pas brancher mon APN sur mon ordi : j'ai perdu le câble pour les relier. C'est pour cela que je me suis acheté ce lecteur de cartes mémoire.

Je ne pense pas non plus que ce soit un problème de courant : je n'ai aucun problème avec d'autres périphériques (comme une clé USB TNT).

Je vais devoir me rendre dans un Apple Center aujourd'hui je crois....

et le cable du lecteur de carte, ne peut il pas servir (en général ce sont les même) ?

je parlais du soucis de courant, car mon DD externe, qui monte correctement sans alim extérieure sur mon powerbook, ne monte plus sur mon MBPro >> je dois utiliser soit un cable en Y soit un transfo

Apple Center > mouais, tu peux essayer, mais je pense qu'il vont te faire réinstaller le système