MacBook Pro plantages en série

Mikael M

Membre junior
6 Décembre 2020
32
2
40
Bonjour à tous, j'ai un petit soucis que je n'arrive pas à régler malgré les réparations et je voudrais avoir un avis, sait on jamais , peut être que quelqu'un a rencontré le même soucis.
J'ai un Mac book pro de 2012 ou 2013, un 13 pouces. Début 2020 les navigateurs ont commencé à planter, avec le message d'erreur disant que l'onglet avait rencontré un problème, qu'il avait dû fermer, puis quelques instants plus tard, un message indiquant clairement un kernel panic. j'ai trainé jusqu'au mois de mai, et l'ordi, qui cumulait une batterie vieillissante, s'est éteint. Je l'ai emmené chez un réparateur mac (ils sont pas légions où je vis), qui me dit après diagnostic que c'est un kernel qui vient du dd. Il me pose donc un ssd, me change la batterie.
Je récupère l'ordi, ça recommence.
Il me demande de sauvegarder mes données, puis de lui ramener afin de faire un reset du système.
J'ai récupéré mon ordi y 3 jours. Mozilla a commencé à planter. Après désinstallation de firefox, j'ai mis chrome. Et au bout de 3 h de marche, l'ordi s'est arrêté puis rallumé.
Le réparateur m'assure que ça ne peut pas venir de la carte mère, j'ai un doute... Quelqu'un aurait il déjà rencontré ce soucis ?
Merci d'avance pour vos réponses.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
49 942
9 287
Nancy___

Mikael M

Membre junior
6 Décembre 2020
32
2
40
Bonjour,



On peut connaitre ton modèle de Mac ? L'OS installé ?

Information système / Matériel : identifiant du modèle : xxxxxx ??

ou bien :

Pour connaitre précisément le modèle de Mac avec son numéro de série à entrer là : https://support.apple.com/fr_FR/spe...UW0NxyJTEhwUx0Mo3EzUkiUhSVVG3n-RI0&ircid=7616
Bonsoir,
oui bien sûr.
MacBook Pro 13 pouces, de mi-2012. Tourne actuellement sous Catalina, 10.15.7, 2,5 GHz Intel Core i5 double cœur, 8 Go 1600 MHz DDR3, Intel HD Graphics 4000 1536 Mo, avec un ssd 480 Go Disque SATA SSD installé la semaine dernière.
J'espère avoir répondu à tes questions et t'avoir fourni les infos demandées...
Merci encore.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
49 942
9 287
Nancy___

Mikael M

Membre junior
6 Décembre 2020
32
2
40
Parfait.

Sais tu si la nappe de ton SSD a aussi été changée ?

Peux tu faire un rapport EtreCheck et le poster ici en suivant ces instructions : https://forums.macg.co/threads/memoire-saturee-par-systeme-575-go-sur-1-to.1314779/post-13631395
Bonjour,
écoute je dois appeler le réparateur ce matin afin de le tenir au courant des plantages du week-end, j'en profiterai pour lui demander pour la nappe SSD. Mais je suppose non ? car j'avais un dd normal, il l' a dégagé pour poser le SSD, tout doit donc être "neuf".
Je m'occupe du "Etrecheck" ce soir après le boulot et je reviens vers toi.

Je te remercie.

Concernant le post modéré, y a des manips que je préfère m'abstenir de faire pour le moment...
 

Mikael M

Membre junior
6 Décembre 2020
32
2
40
Parfait.

Sais tu si la nappe de ton SSD a aussi été changée ?

Peux tu faire un rapport EtreCheck et le poster ici en suivant ces instructions : https://forums.macg.co/threads/memoire-saturee-par-systeme-575-go-sur-1-to.1314779/post-13631395
Je viens d'avoir le réparateur, la nappe n'a pas été changée. Il m'assure avoir fait toute une batterie de test, et l'ordi n'a jamais planté. Ce serait uniquement quand je le récupère. Ca commence à me chauffer copieux... J'ai évoqué la carte mère, selon lui après ses tests elle est en bon état, bref. Je reviens vers toi ce soir.
 
Dernière édition:

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
49 942
9 287
Nancy___
Je viens d'avoir le réparateur, la nappe n'a pas été changée
Il est possible que ta nappe ait du mal avec le SSD alors qu'elle est OK avec les disques durs. Tout simplement parce que le taux de transfert est beaucoup plus élevé avec le SSD qu'avec le disque dur. Mais peut être que la nappe est OK.
Pour le savoir, il te faudrait mettre le SSD dans un boitier externe, démarrer sur ton SSD en externe et voir si les problèmes sont les mêmes.

Néanmoins, un défaut de nappe avec un SSD entraine d'autres plantages que ceux que tu observes.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
49 942
9 287
Nancy___
Il faut activer le Trim.
Bloc de code:
disk0 - PNY CS900 480GB SSD 480.10 Go (SSD - TRIM : Non)
Pour activer le Trim, tu entres cette commande dans le Terminal :
Bloc de code:
sudo trimforce enable
tu valides avec la touche Enter et tu entres ton mot de passe à l'aveugle.
Tu dis Yes et tu redémarres ton Mac.


AppCleaner n'est pas utile. Supprime Chrome, mal adapté aux Mac. Préfère, FireFox, Safari, Brave, Vivaldi, Opéra…



Mais le problème se situe plutôt là :
Bloc de code:
Événements du diagnostic (7-30 dernier jours) :
  2020-12-07 17:42:35 AppleUserHIDDrivers Plantage (9 fois)
    Exécutable : /System/Library/DriverExtensions/AppleUserHIDDrivers.dext/AppleUserHIDDrivers
    Détails :
      dyld: launch, loading dependent libraries
      /System/DriverKit/usr/lib/system/libdispatch.dylib
 
  2020-12-06 22:01:25 WindowServer Plantage (3 fois)
    Exécutable : /System/Library/PrivateFrameworks/SkyLight.framework/Versions/A/Resources/WindowServer
    Détails :
      StartTime:2020-12-06 10:01:01
      GPU:IG
      MetalDevice for accelerator(0x4933): 0x7fc6e27216c8 (MTLDevice: 0x7fc6
      e3b16000)
      IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IGPU@2/AppleInt
      elFramebuffer@0
 
  2020-12-06 14:17:12 Firefox.app Plantage
    Exécutable : /Applications/Firefox.app
 
  2020-12-05 18:21:04 bird Plantage
    Exécutable : /System/Library/PrivateFrameworks/CloudDocsDaemon.framework/Versions/A/Support/bird
    Détails :
      dyld3 mode
      Assertion failed: (db was corrupted
 
  2020-12-05 11:54:50 sandboxd Plantage
    Exécutable : /usr/libexec/sandboxd
    Détails :
      dyld3 mode
      create_symbol_owner_data -- UUID: 224FDBFA-9A2C-38E3-8464-BC9DE9885727
      , Path: /Library/Application Support/Malwarebytes/MBAM/Engine.bundle/C
      ontents/PlugIns/RTProtectionDaemon.app/Contents/MacOS/RTProtectionDaem
      on, DSYM Path: <none>, is_dyld_shared_cache: No
 
  2020-12-04 08:48:40 systemmigrationd Plantage
    Exécutable : /System/Library/PrivateFrameworks/SystemMigration.framework/Versions/A/Resources/systemmigrationd
    Détails :
      dyld3 mode
      *** Terminating app due to uncaught exception 'NSInvalidArgumentExcept
      ion', reason: '-[__NSCFString hasPrefix:]: nil argument'
      terminating with uncaught exception of type NSException
      abort() called


Tu as plein de plantages. Je dirais que la clean install est surement ce que tu as de mieux à faire.
 
  • J’aime
Réactions: peyret

Mikael M

Membre junior
6 Décembre 2020
32
2
40
Il faut activer le Trim.
Bloc de code:
disk0 - PNY CS900 480GB SSD 480.10 Go (SSD - TRIM : Non)
Pour activer le Trim, tu entres cette commande dans le Terminal :
Bloc de code:
sudo trimforce enable
tu valides avec la touche Enter et tu entres ton mot de passe à l'aveugle.
Tu dis Yes et tu redémarres ton Mac.


AppCleaner n'est pas utile. Supprime Chrome, mal adapté aux Mac. Préfère, FireFox, Safari, Brave, Vivaldi, Opéra…



Mais le problème se situe plutôt là :
Bloc de code:
Événements du diagnostic (7-30 dernier jours) :
  2020-12-07 17:42:35 AppleUserHIDDrivers Plantage (9 fois)
    Exécutable : /System/Library/DriverExtensions/AppleUserHIDDrivers.dext/AppleUserHIDDrivers
    Détails :
      dyld: launch, loading dependent libraries
      /System/DriverKit/usr/lib/system/libdispatch.dylib

  2020-12-06 22:01:25 WindowServer Plantage (3 fois)
    Exécutable : /System/Library/PrivateFrameworks/SkyLight.framework/Versions/A/Resources/WindowServer
    Détails :
      StartTime:2020-12-06 10:01:01
      GPU:IG
      MetalDevice for accelerator(0x4933): 0x7fc6e27216c8 (MTLDevice: 0x7fc6
      e3b16000)
      IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IGPU@2/AppleInt
      elFramebuffer@0

  2020-12-06 14:17:12 Firefox.app Plantage
    Exécutable : /Applications/Firefox.app

  2020-12-05 18:21:04 bird Plantage
    Exécutable : /System/Library/PrivateFrameworks/CloudDocsDaemon.framework/Versions/A/Support/bird
    Détails :
      dyld3 mode
      Assertion failed: (db was corrupted

  2020-12-05 11:54:50 sandboxd Plantage
    Exécutable : /usr/libexec/sandboxd
    Détails :
      dyld3 mode
      create_symbol_owner_data -- UUID: 224FDBFA-9A2C-38E3-8464-BC9DE9885727
      , Path: /Library/Application Support/Malwarebytes/MBAM/Engine.bundle/C
      ontents/PlugIns/RTProtectionDaemon.app/Contents/MacOS/RTProtectionDaem
      on, DSYM Path: <none>, is_dyld_shared_cache: No

  2020-12-04 08:48:40 systemmigrationd Plantage
    Exécutable : /System/Library/PrivateFrameworks/SystemMigration.framework/Versions/A/Resources/systemmigrationd
    Détails :
      dyld3 mode
      *** Terminating app due to uncaught exception 'NSInvalidArgumentExcept
      ion', reason: '-[__NSCFString hasPrefix:]: nil argument'
      terminating with uncaught exception of type NSException
      abort() called


Tu as plein de plantages. Je dirais que la clean install est surement ce que tu as de mieux à faire.
ok... merci. Mais la clean install je crois que c'est que le reparateur a fait, il est reparti de 0 là... Et une fois chez moi, à l'utilisation, BIM ! c'est firefox qui a ouvert le bal du plantage... Je vais voir avec lui demain je te remercie.
 
Dernière édition:

Mikael M

Membre junior
6 Décembre 2020
32
2
40
Trim activé, tout a marché pdt des heures, puis j'ai lancé Safari, l'onglet s'est fermé seul et kernel panic. Voilà voilà. Je vais tout réinstaller.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
49 942
9 287
Nancy___
Trim activé, tout a marché pdt des heures, puis j'ai lancé Safari, l'onglet s'est fermé seul et kernel panic. Voilà voilà. Je vais tout réinstaller.
Avant de tout réinstaller, peux tu tester dans une autre session si le comportement de Safari, FireFox, etc. est le même ?
 

Mikael M

Membre junior
6 Décembre 2020
32
2
40
Une Autre session utilisateur ? Je vais tester . Et en fait tu viens de me faire penser que c est peut être pour ça que le réparateur n'a pas de soucis ... il s est crée une session à part ....

merci de prendre du temps hein ... et je m Interroge sur un point : si je fais une clean install, puis que je remets le dossier utilisateur , je prends pas le risque de relancer le soucis?
 
Dernière édition:

Mikael M

Membre junior
6 Décembre 2020
32
2
40
Bon je veux pas faire de flood avoir voilà les nouvelles : la clean Install a été réalisée par le réparateur. Sur la session qu'il a ouverte il n'a eu aucun plantages. Cela n'arrive que de ma session.Donc on va refaire une clean Install et je vais dégager tous mes fichiers en ne conservant que le plus important, à savoir les photos et certains documents. Ça m'ennuie un peu, je vais probablement perdre des tas de choses, type plugins MAO etc, mais tant pis, si ça me permet de ne plus avoir de soucis..
je voulais le faire de chez moi mais n'ayant pas la fibre et mettant 3 h à DL 800 mo, je lui ramène il s'occupe de ça. Merci en tout pour le temps passé à m'aider à trouver une solution.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
49 942
9 287
Nancy___
je voulais le faire de chez moi mais n'ayant pas la fibre et mettant 3 h à DL 800 mo, je lui ramène il s'occupe de ça. Merci en tout pour le temps passé à m'aider à trouver une solution.
Le plan B c'est que tu te crées une nouvelle session. Donc tu ne touches pas à l'OS, tu n'as rien à retélécharger. Tes applications sont déjà en place.
Après se pose la question de tes plugins MAO; je ne sais pas où ils sont stockés. Si c'est à la racine du disque, de nouveau tu n'auras aucun souci. Si c'est spécifique au dossier Utilisateur, ça sera un problème.
 

Mikael M

Membre junior
6 Décembre 2020
32
2
40
c est d'ailleurs pour ça que le type n'a eu aucun plantage tout le temps où il l'a eu entre les mains . Autre session . Dans le doute c est pas grave , on repart à 0. Quant aux plugins ma foi, je les réinstallerai . Ça me forcera à me mettre à jour des nouvelles sorties .
 
  • J’aime
Réactions: Sly54

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
49 942
9 287
Nancy___
c est d'ailleurs pour ça que le type n'a eu aucun plantage tout le temps où il l'a eu entre les mains . Autre session . Dans le doute c est pas grave , on repart à 0. Quant aux plugins ma foi, je les réinstallerai . Ça me forcera à me mettre à jour des nouvelles sorties .
OK et je confirme quand tu écris :

puis que je remets le dossier utilisateur , je prends pas le risque de relancer le soucis?
Oui tu vas rapatrier le problème.
Donc il ne faut pas faire comme ça !
 

Mikael M

Membre junior
6 Décembre 2020
32
2
40
Bon et bien après avoir récupéré l'ordi, quelques heures dessus et installer un ou deux softs, voilà que ça recommence.
Capture d’écran 2020-12-08 à 18.25.36.png