Pourquoi mon clic gauche devient un clic droit ?

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
38 937
5 096
Nancy___
Oui, j'ai tout sauvegardé et j'ai même un clône. Mais peux-tu m'éclairer sur la façon dont on "teste" les fichiers com.apple.plist?
Une fois mis sur le Bureau, il faut continuer à travailler et voir si le problème réapparait. Pas de solution miracle… mais se concentrer sur quelques fichiers précis, en lien avec le trackpad / souris / System Preferences…

Cela dit, depuis mon démarrage sans échec et mon redémarrage en mode normal... il semble que mon soucis de clic gauche - clic droit ait disparu.... Est-ce qu'un démarrage sans échec a pour conséquence d'éliminer certains problèmes?
Ça pourrait (tu notes le conditionnel ? ;)) vu que ça purge les caches.
 

alessmuse

Membre confirmé
9 Novembre 2009
139
4
Merci pour cette réponse! Oui j'ai noté le conditionnel :)... d'ailleurs j'aurais dû aussi mettre au conditionnel car... problème finalement réapparu malgré le mode sans échec, et que je contourne avec mon diabolique Ctrl Alt Sup en appuyant longtemps... quelle horreur... . je vais essayer de travailler plus longuement sur la nouvelle session que j'ai créée pour voir si là-aussi il y a ce défaut de clic... et également tester mes fichiers .plist. sur ma session. Je reviendrai donner les résultats! Merci pour l'aide!
 

alessmuse

Membre confirmé
9 Novembre 2009
139
4
Bien, petit bilan des manipulations qui n'ont pas réglé le problème pour moi, mais peut-être à faire au cas où cela marcherait pour certains: réinitialisation SMC, de la mémoire NVRAM, redémarrage en mode sans échec, création d'une nouvelle session (apparemment pas de soucis de clic dans la nouvelle session mais toujours dans ma session initiale), isolation sur le bureau de divers fichiers de Bibliothèque perso de type plist com.apple ayant un rapport avec "mouse", "trackpad" "préférence système".
Suite à tout ça, réinstallation de l'OS. Idem, problème toujours présent (ce qui était prévisible)....
Le service Chat d'Apple conseille la migration vers Catalina... qu'en pensez-vous? (problème des applications 32 bits)... merci pour les avis!
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
38 937
5 096
Nancy___
Le service Chat d'Apple conseille la migration vers Catalina... qu'en pensez-vous? (problème des applications 32 bits)... merci pour les avis!
Je crois que c'est la solution par défaut quand les tech ne savent plus quoi proposer…
Tu peux tester sans risque en faisant un clone de ton disque interne sur un disque externe. Tu vérifies que tu as le bug sur le disque externe. Si oui tu y installes Catalina. Tu restes sur ton disque externe si le bug est toujours présent.
 

alessmuse

Membre confirmé
9 Novembre 2009
139
4
Même bug avec Catalina... je vais faire ce que j'aurais peut-être dû faire au départ... mettre une souris à la place du pad... et observer. Et si c'était un problème matériel du pad...
:iwatch:
(10 minutes plus tard) bug aussi avec souris externe... Aller, reformatage et clean install...
 
Dernière édition:

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
38 937
5 096
Nancy___
(10 minutes plus tard) bug aussi avec souris externe... Aller, reformatage et clean install...
Si le formatage n'est pas lancé, il y a fait toujours moyen de sortir du dossier Préférences tous les fichiers "com.apple se terminant par .plist" et de les mettre dans un dossier, sur le Bureau, puis quitter la session et la relancer. Pour voir.
 

alessmuse

Membre confirmé
9 Novembre 2009
139
4
:) Euh.... trop tard.... et puis alors le meilleur du meilleur : bug toujours là malgré formatage et clean install :banghead:..... j'ai tenté un truc : Malwarebytes..... pour le moment, bug disparu.... mais à chaque fois que je dis qu'il a disparu, je poste le contraire peu de temps après.... si seulement ça pouvait être ça! :angelic:
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
38 937
5 096
Nancy___
Tu as vraiment fait une clean install ? Donc formatage, installation de l'OS et test sans rien installer ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
38 937
5 096
Nancy___
:) Euh.... trop tard.... et puis alors le meilleur du meilleur : bug toujours là malgré formatage et clean install :banghead:..... j'ai tenté un truc : Malwarebytes..... pour le moment, bug disparu.... mais à chaque fois que je dis qu'il a disparu, je poste le contraire peu de temps après.... si seulement ça pouvait être ça! :angelic:
Si le bug revient, il va falloir se dire que le problème est matériel. Mais où ?
 

alessmuse

Membre confirmé
9 Novembre 2009
139
4
Oui! Dans ce cas je finirai à l'Apple Store et je posterai ici leur réponse! Si cela ne revient pas (je vais attendre un peu ! ) on pourra peut-être supposer un malware ou virus.... j'y crois moyen mais bon!
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
38 937
5 096
Nancy___
Disons qu'un malware sur un OS neuf, heu…
L'OS vient bien de l'app store ? Il n'a pas été téléchargé quelque part sur Internet ?
 

alessmuse

Membre confirmé
9 Novembre 2009
139
4
Oui oui, App Store.... non mais je pense aussi à un problème matériel, l'absence du bug après le scan Malwarebytes est peut-être une pure coïncidence.... cela dit plus de soucis pour le moment....
 

alessmuse

Membre confirmé
9 Novembre 2009
139
4
Le problème effectivement n'est pas apparu dans une autre session utilisateur... je pensais donc qu'il ne réapparaîtrait pas non plus après une clean install... mais si. Non je n'ai pas désactivé le clic droit!
 

alessmuse

Membre confirmé
9 Novembre 2009
139
4
Merci pour le lien! J'ai fait la manipulation sous Hight Sierra pour quatre fichiers .plist en rapport avec "mouse", "trackpad"... pas de changements, mais si cela recommence je la referai, j'élargirai la recherche... pour le moment, toujours pas de bug revenu suite à scan Malwarebytes, (?), cela s'était pourtant produit juste après la clean install de Catalina... à suivre...
 

alessmuse

Membre confirmé
9 Novembre 2009
139
4
Le bug étant revenu (Malware hors sujet...), je vais donc refaire l'isolation de fichiers .plist. et observer. Cela dit, sur Catalina, je constate que ce bug est beaucoup plus facile à éliminer... quelques clics successifs et le pad (ou la souris, puisque cela bug avec les deux) refonctionne normalement. Mais... ai-je mal reformaté avant ma clean install pour que cela revienne? Certains bugs perdurent-ils malgré l'effacement des disques? (en espérant ne pas trop sortir du thème de ce forum "accessoires") Merci pour un éclairage éventuel!
 

alessmuse

Membre confirmé
9 Novembre 2009
139
4
Bonjour,

Il semble que le fichier corrompu soit celui-ci : com.apple.AppleMultitouchMouse.plist
Tout marche bien, le clic gauche reste à gauche, le droit à droite, le défilement... défile (et ne fait plus de zoom absurde, dans un sens ou dans l'autre) ! :)
Bonne journée!