10.13 High Sierra Problème accès données récurent et stabilité OS

YellowSeed

Membre enregistré
14 Décembre 2021
2
1
35
Bonjour à tous,

Je viens vers vous pour éclairer mes incompréhensions et nourrir mes pistes de travail. La fatigue et le ras le bol me poussent à vous demander de l'aide.
Je ne parviens pas à rétablir une installation stable sous 10.13.
J'ai deux hypothèses actuellement : panne matériel contagieuse ; conflit HFS - APFS qui corrompt les fichiers mais pas définitivement…

Mon ordi est un macbook pro mi-2012 upgrade 16Go RAM et 1To SSD. Je fonctionnais sous 10.13 sans aucun soucis : SSD formaté HFS, une partition OS sous 10.13 et une pour les données, Sandisk d'1 an d'âge.
J'ai dû installer 10.15 sur un ancien DD via un patch, en complément du SSD (appelons le A), pour pouvoir installer indesign qui demande 10.15 ou +. Je ne sais pas sous quel format était la partition OS de mon DD, mais je me suis retrouvé avec 2 partitions OS + 1 data, les partitions OS en APFS, la data toujours en HFS.
J'ai souhaité garder deux OS bootable, l'un en 10.15 et l'autre en 10.13, pour des questions de compatibilité logiciel (j'aimerais ne pas avoir à upgrader Ableton live).

Au bout de quelques jours où tout fonctionnait bien, indesign a planté sous 10.15 en m'indiquant un problème de lecture écriture sur les fichiers. À partir de ce moment, pas moyen de récupérer mes données, y compris avec diskdrill et autres logiciels de récupération. Les partitions ne sont plus accessibles, montrable ou quoi que ce soit. Seules quelques données peuvent être récupérées via diskdrill, mais pas celles que j'utilisais.
J'étais tellement le nez dans le guidon depuis un mois que je n'avais pas sauvegardé… du coup j'ai cru perdre 1 gros mois de travail… à 2j seulement du rendu final d'un projet très important pour moi. Les délais de Noël ont sauté par la même occasion. Je vous laisse imaginer mon état émotionnel.

Une semaine plus tard, je m'attelle à récupérer ce qui peut l'être, en connectant un ancien SSD (appelons-le B, avec partition OS 10.11 et 2 partitions data, en HFS) pour récupérer le reste de mes données de sauvegarde. Tout commence bien, puis à nouveau un message d'erreur similaire apparait me disant que je ne peux plus accéder un lecture ou écriture aux fichiers.

Je monte ce même SSD sur un macbook air sous 10.13, et là pas de problème pour accéder à mes données… Je connecte alors mon SSD A à ce même ordinateur, et là miracle, je peux monter le disque via utilitaire de disque, et accéder sans soucis à toutes mes données. Je fais donc les sauvegarde et me voilà avec toutes mes données.

Je tente donc le coup de rebooter mon macbook pro sur ce SSD A, comme avant, et cela fonctionne deux jours sans soucis. Puis une veille prolongée d'une nuit le fait planter, avec impossibilité de redémarrer dessus. Dès lors, je peux en général démarrer dessus, mais de temps à autre un bug intervient avec message d'erreur de possibilité d'accès aux fichiers.

J'achète un SSD C. J'y fais un clone des deux partitions du SSD A via Carbon Copy Cloner. Je formate le SSD C en HFS+. Le même problème semble avoir migré : il ne supporte pas une mise en veille d'une nuit et il lui arrive de me remettre les mêmes messages d'erreur.

Je tente donc une réinstallation propre de la partition OS de mon SSD A, que je formate cette fois-ci en HFS+, puis sur laquelle j'installe 10.13 à partir de ma partition recovery du SSD A (l'installation d'une partition recovery lors du clonage vers le SSD C avait planté, laissant entendre effectivement qu'un soucis avait migré et que le problème n'était pas matériel). Je choisis d'importer les données de la partition OS de mon SSD C pour faciliter la réinstallation de mes logiciels, raccourcis et préférences. Désormais, la plupart des logiciels ne veulent pas se lancer alors qu'ils apparaissent dans applications. J'ai pu bizarrement en transférer deux ou trois depuis SSD C vers SSD A en choisissant de remplacer les applications, puis ça a buggé avec le même message d'erreur (seul le numéro d'erreur change de temps en temps) quand j'ai voulu transférer toutes les applications qui m'intéressaient. Maintenant je ne peux même plus les transférer une à une, dont firefox par exemple. Ce qui m'amène à utiliser safari pour vous contacter ici. Rebelotte, il n'a pas supporté la mise en veille de la nuit, et là au démarrage il a mis un temps fou à me proposer l'écran de choix de disque sur lequel booter (1min peut-être ou plus au lieu de quelques secondes normalement…).

J'envisage à présent à nouveau une réinstallation propre de mon SSD A puis téléchargement de mes applications et réglages manuels pour éviter d'importer depuis le SSD C potentiellement corrompu.
Ou alors j'upgrade tout vers 10.15 ou +, quitte à payer 200€ (j'aimerais autant éviter) pour l'upgrade du seul logiciel qui ne supportera pas la mise à niveau (Ableton live 9). La nouvelle version de ce logiciel est très bien, mais je n'en ai pas particulièrement besoin.

Pouvez-vous m'éclairer sur les raisons possibles du problème SVP ?
Merdier foutu dans le catalogue ou l'indexation (je ne sais pas comment ça fonctionne) entre HFS et APFS ou entre 10.13 et 10.15 ? Comment réparer ou contourner pour éviter de perdre toutes mes anciennes données qui fonctionnaient très bien sous 10.13 ?
Problème matériel contagieux : mes SSD A et C seraient foutus !?
Autre piste ?

Merci beaucoup d'avoir lu jusqu'à cette ligne et pour vos avis et éclairages. Cette aventure me pèse sérieusement sur les nerfs. J'ai besoin de récupérer l'accès à un environnement de travail stable pour me permettre de finir un projet important qui a déjà été reporté de plusieurs semaines à cause de ces conneries.