10.9 Mavericks Problème MAJ OS X 10.9.5 pour installation Xcode

Mathieu6444

Membre enregistré
22 Avril 2020
5
0
38
Bonjour,

Je débute sur Mac. Je me bagarre depuis 3 jours tout seul sans succès...
J'essaye d'installer Xcode pour me former à la programmation.
Je n'arrive pas à installer Xcode. Sur l'Apple store on me dit : "Xcode ne peut pas être installé sur “Macintosh HD” car OS X 10.15.2 ou ultérieur y est requis." Pourtant toujours sur l'Apple store on me dit que Catalina est installée :

Capture d’écran 2020-04-22 à 00.30.33.png

Si vous pouviez m'aider...

Merci par avance

Cordialement

Mathieu
 
Dernière édition par un modérateur:

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 777
167
Paris
Est-ce que tu peux aller dans le menu pomme a propos de ce mac et nous donner là version qui est affichée s’il te plaît. ça nous aidera déjà à savoir où tu en es
 

Mathieu6444

Membre enregistré
22 Avril 2020
5
0
38
Bonjour,

Merci beaucoup pour ton aide

MacBook Pro
Retina, 13 pouces, fin 2013
Logiciel OS X 10.9.5 (13F1911)

Cordialement

Mathieu
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
52 053
9 884
Nancy___
Logiciel OS X 10.9.5 (13F1911)
Tu es encore sous Mavericks, donc tu n'es pas sous Catalina.
Est-ce que dans ton dossier Applications, tu n'aurais pas un fichier Installer macOS Catalina ?

Et fais attention si tu installes Catalina, tu ne pourras plus ouvrir d'applications 32 bits.

Combien de RAM ?
 

Mathieu6444

Membre enregistré
22 Avril 2020
5
0
38
Salut Sly54,

En pièce jointe les infos système :

Capture d’écran 2020-04-22 à 17.56.12.png

Non je n'ai pas de fichier Installer dans le menu Application.
Par contre j'ai réussi à installer Xcode mais comme il provient de firefox il me met un message d'erreur après la Vérification Mac :

Capture d’écran 2020-04-22 à 18.10.29.png

Je ne poste que le message de Vérification, le message d'erreur me dit que l'origine de téléchargement ne peut pas être confirmé. Je l'ai pris sur Firefox.
 
Dernière édition par un modérateur:

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
52 053
9 884
Nancy___
Un clic droit sur Xcode pour l'ouvrir devrait régler le problème.

Et tu as 8 Go de RAm, c'est assez pour Catalina si tu veux vraiment l'installer…
 

Mathieu6444

Membre enregistré
22 Avril 2020
5
0
38
L'idéal serait que je puisse installer une version antérieure de Xcode qui soit compatible avec mon Mac OS

Le clic droit cela n'a pas fonctionné.
Ce que je ne comprends pas c'est que dans l'App Store ils me mettent que Catalina est bien installée :

Capture d’écran 2020-04-22 à 18.17.29.png

Désolé je suis perdu

------------------------------------------

Je viens de comprendre, j'avais macOS Catalina dans le dossier "Téléchargements"
 
Dernière édition par un modérateur:

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 777
167
Paris
Quels logiciels utilises-tu exactement ? Il faut planifier ta mise à jour, mais faire en sorte qu’elle n’impacte pas ton utilisation.
 

Mathieu6444

Membre enregistré
22 Avril 2020
5
0
38
Désolé de ne pas avoir répondu plus tôt.
J'ai réussi à me rappeler de mes identifiants de l'App Store.
J'ai téléchargé une ancienne version de Xcode via l'App Store qui était compatible avec ma version de Mac (c'est juste pour apprendre le C++).

On peut clôturer le topic.

Merci beaucoup pour ton aide.