MacBook Pro Problème SSD externe qui se démonte tout seul régulièrement et ne veut plus se monter

adpl

Nouveau membre
2 Juin 2018
9
0
30
Bonjour à tous,
je poste sur ce forum car il m'a déjà sauvé la vie plusieures fois et j'espère que cette fois en sera une de plus. Je m'explique :

J'ai acquéri en décembre un petit SSD 1TO avec branchement USB-C vers USB-3.0.
Le problème est le suivant : depuis que je l'ai malencontreusement débranché sans l'éjecter (en réalité je n'avais plus de batterie et au rallumage j'avais le fameux message du "veuillez ejecter le disque avant de le retirer"), le disque a beaucoup de mal à se monter et se démonte tout seul régulièrement.

Voici les informations que j'obtiens avec la commande diskutil list :

Bloc de code:
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         1000.0 GB  disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +1000.0 GB  disk1
                                 Physical Store disk0s2
   1:                APFS Volume Sans titre              892.3 GB   disk1s1
   2:                APFS Volume Preboot                 49.0 MB    disk1s2
   3:                APFS Volume Recovery                507.4 MB   disk1s3
   4:                APFS Volume VM                      8.6 GB     disk1s4

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:       Microsoft Basic Data Vidéo Son               1000.0 GB  disk2s2

Ledit disque est le disk2. Je n'arrive pas à appliquer de SOS dessus et je ne sais plus que faire... Quelqu'un aurait-il une idée de comment le réparer car il semble avoir une anomalie .
 

sinbad21

Membre émérite
2 Décembre 2004
781
99
68
Bonjour à tous,
je poste sur ce forum car il m'a déjà sauvé la vie plusieures fois et j'espère que cette fois en sera une de plus. Je m'explique :

J'ai acquéri en décembre un petit SSD 1TO avec branchement USB-C vers USB-3.0.
Le problème est le suivant : depuis que je l'ai malencontreusement débranché sans l'éjecter (en réalité je n'avais plus de batterie et au rallumage j'avais le fameux message du "veuillez ejecter le disque avant de le retirer"), le disque a beaucoup de mal à se monter et se démonte tout seul régulièrement.

Voici les informations que j'obtiens avec la commande diskutil list :

Bloc de code:
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         1000.0 GB  disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +1000.0 GB  disk1
                                 Physical Store disk0s2
   1:                APFS Volume Sans titre              892.3 GB   disk1s1
   2:                APFS Volume Preboot                 49.0 MB    disk1s2
   3:                APFS Volume Recovery                507.4 MB   disk1s3
   4:                APFS Volume VM                      8.6 GB     disk1s4

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:       Microsoft Basic Data Vidéo Son               1000.0 GB  disk2s2

Ledit disque est le disk2. Je n'arrive pas à appliquer de SOS dessus et je ne sais plus que faire... Quelqu'un aurait-il une idée de comment le réparer car il semble avoir une anomalie .
Il est formaté en NTFS je suppose ?
 

adpl

Nouveau membre
2 Juin 2018
9
0
30
voici le message de réponse :
Bloc de code:
imac-de-prenom-nom-4:~ Louis$ diskutil verifyVolume /dev/disk2s2
Started file system verification on disk2s2 Vidéo Son
Verifying file system
Volume is already unmounted
Performing fsck_exfat -n -x /dev/rdisk2s2
File system check exit code is 1
Restoring the original state found as unmounted
Error: -69845: File system verify or repair failed
Underlying error: 1
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
2 766
362
Bloc de code:
Performing fsck_exfat -n -x /dev/rdisk2s2
File system check exit code is 1

Le plus prudent serait de le reformater sans se poser de question. ExFAT n'est pas un format très résistant (il n'est pas journalisé) et les incohérences de format ne se réparent pas d'elle-même.
 

adpl

Nouveau membre
2 Juin 2018
9
0
30
Bloc de code:
Performing fsck_exfat -n -x /dev/rdisk2s2
File system check exit code is 1

Le plus prudent serait de le reformater sans se poser de question. ExFAT n'est pas un format très résistant (il n'est pas journalisé) et les incohérences de format ne se réparent pas d'elle-même.

Si je reformatte je dois mettre quel format ?
 

adpl

Nouveau membre
2 Juin 2018
9
0
30
Si tu ne l'utilise que sur Mac : APFS
Si tu l'utilise aussi sur Windows : ExFAT (ou NTFS qui est plus sûr, mais nécessite un logiciel payant sur Mac)

Ok super merci beaucoup ! J'ai changé le cable et je n'ai presque plus jamais le problème, je ne sais pas si c'est le cable ou le format APFS mais tout est réglé, merci beaucoup ! :)