Publier sur Youtube avec FinalCut

JM66

Membre actif
17 Avril 2004
488
7
54
Genève
Bonjour,
Je suis en train d'utiliser la fonction "Partage" de Final Cut pour essayer de placer un film sur Youtube. J'ai un idle depuis 20 minutes…

Pourquoi? Le mot de passe est juste…**** J'avoue avoir mis quelque chose au hasard dans la case balise

jm66-albums-captures-image16642-fcu-youtube.png

 
Dernière édition:

JM66

Membre actif
17 Avril 2004
488
7
54
Genève
Depuis tout à l'heure j'ai essayé ça ne marche pas.

Essayé également en mp4 depuis streamclip, sans succès.

Ce qui marche, c'est depuis QuickTime, exporter pour le web, en mv4. Malheureusement la résolution est trop faible et non paramétrable.

Je trouve tout ça étrangement peu au point… La fonction export YouTube de Final Cut ne marche simplement pas...

Une solution?


 

JLB21

Membre expert
Club MacG
22 Novembre 2007
5 863
601
Je dispose de FCP X.
Je n'exporte jamais sur YouTube en direct. Je crée un mp4, au format 720 x 1280 avec un débit de l'ordre de 5 Mbps.
Puis via Safari, j'upload directement sur mon compte.
 

Olivoude

Membre actif
7 Avril 2010
795
27
Sur Terre
J'ai utilisé plusieurs fois le partage YT et ça marche bien. Un peu long mais ça marche. Il vaut mieux mettre de suite les tags, et ton film est privé => tes amis risquent de ne pas le voir.
 
Q

quark67

Invité
Bonjour, comment faites-vous pour que l'export Youtube fonctionne chez vous ? J'entre le nom d'utilisateur et le mot de passe du compte Youtube, et l'export ne marche tout simplement pas. Après traitement de la vidéo, FCPX m'envoie le message :
« La publication dans YouTube a échoué car le nom d’utilisateur ou le mot de passe n’est pas valide. »
Mais évidemment, sinon ça ne serait pas drôle, le nom d'utilisateur et le mot de passe sont valides (ils fonctionnent très bien dans l'export Youtube de iMovie, ainsi que sur la page web de Youtube).
FCPX est en version 10.0.1 (mais ça ne marchait pas non plus en 10.0).

Quelle est l'astuce ?
À un moment, j'ai pensé que le blocage provenait d'un caractère non alphanumérique dans mon mot de passe, j'ai donc utilisé un compte @gmail.com sans caractère autre que des lettres et des chiffres dans le mot de passe pour tester, et là non plus, l'export Youtube ne fonctionne pas dans FCPX.
Donc en un mot : Help ! Merci.
 

JM66

Membre actif
17 Avril 2004
488
7
54
Genève
Bonjour, comment faites-vous pour que l'export Youtube fonctionne chez vous ? J'entre le nom d'utilisateur et le mot de passe du compte Youtube, et l'export ne marche tout simplement pas. Après traitement de la vidéo, FCPX m'envoie le message :
« La publication dans YouTube a échoué car le nom d’utilisateur ou le mot de passe n’est pas valide. »
Mais évidemment, sinon ça ne serait pas drôle, le nom d'utilisateur et le mot de passe sont valides (ils fonctionnent très bien dans l'export Youtube de iMovie, ainsi que sur la page web de Youtube).
FCPX est en version 10.0.1 (mais ça ne marchait pas non plus en 10.0).

Quelle est l'astuce ?
À un moment, j'ai pensé que le blocage provenait d'un caractère non alphanumérique dans mon mot de passe, j'ai donc utilisé un compte @gmail.com sans caractère autre que des lettres et des chiffres dans le mot de passe pour tester, et là non plus, l'export Youtube ne fonctionne pas dans FCPX.
Donc en un mot : Help ! Merci.


A mon avis, et au vu des précédents posts, la fonction ad hoc de FC ne marche tout simplement pas.

Il faut exporter le média depuis FC en local, et l'uploader depuis le compte YouTube.

Comme j'ai vu dans Flash Video Encoder un profil spécifique qui contenait H.264, je veille à cocher ce format à l'exportation depuis FC. J'ai des fichiers nettement moins volumineux et qui "montent" donc plus rapidement sur YT.

Comme la qualité en plein écran n'est pas réellement top, je vais faire l'essai avec un FLV des mêmes vidéos et comparer.

Est-ce que quelqu'un sait si YT récrit le FLV dans un format propriétaire ou va-t-il afficher du FLV, et donc rendre impossible la lecture sur iPads et iPhones?
 

JLB21

Membre expert
Club MacG
22 Novembre 2007
5 863
601

Comme la qualité en plein écran n'est pas réellement top, je vais faire l'essai avec un FLV des mêmes vidéos et comparer.

Est-ce que quelqu'un sait si YT récrit le FLV dans un format propriétaire ou va-t-il afficher du FLV, et donc rendre impossible la lecture sur iPads et iPhones?
Je suis d'accord avec toi, la qualité plein écran n'est pas top. C'est pourquoi je privilégie systématiquement Vimeo pour du partage privé.
 

Olivoude

Membre actif
7 Avril 2010
795
27
Sur Terre
Pourtant, Olivoude dit le contraire. J'attends donc ses explications :).
Et bien, c'est difficile d'expliquer pourquoi quelque chose marche bien...
Disons que je remplis tous les champs (mon compte et mon mot de passe ne comportent pas de caractères exotiques). Puis dans la fenêtre d'exportation, je vois l'encodage puis la diffusion s'exécuter. En fonction de la qualité de la connexion internet, ça peut être plus ou moins long.

Si la connexion à ton compte ne se fait pas, change effectivement de compte. Chez moi elle se fait bien aussi... Désolé de ne pas pouvoir plus vous aider.:confused:
 

JM66

Membre actif
17 Avril 2004
488
7
54
Genève
Et bien, c'est difficile d'expliquer pourquoi quelque chose marche bien...
Disons que je remplis tous les champs (mon compte et mon mot de passe ne comportent pas de caractères exotiques). Puis dans la fenêtre d'exportation, je vois l'encodage puis la diffusion s'exécuter. En fonction de la qualité de la connexion internet, ça peut être plus ou moins long.

Si la connexion à ton compte ne se fait pas, change effectivement de compte. Chez moi elle se fait bien aussi... Désolé de ne pas pouvoir plus vous aider.:confused:

A mon avis c'est parce qu'on attend pas assez longtemps. Olivemoud, quel est le poids de ton fichier? Le mien a une durée de 13 minutes à 1080x720px, donc au final 14Gb sur le disque (1.5Gb en H.264 mais quand même…)

Ça m'est venu car un upload que j'avais cru en idle a finalement abouti parce que je l'avais oublié…
 
Q

quark67

Invité
Bonsoir, mais comment faites-vous donc pour publier sur Youtube ? C'est hallucinant que cela ne fonctionne pas chez moi :(. J'ai bien tenté de changer de compte, pareil, ça ne marche pas. J'ai changé la langue du système dans les préférences système pour mettre l'anglais (des fois, il peut y avoir un bug en français), j'ai relancé FCP X, pareil, message d'erreur :
La publication dans YouTube a échoué car le nom d’utilisateur ou le mot de passe n’est pas valide.
(On notera que le message d'erreur est en français, alors que FCP X est lancé en anglais !, encore une bizarrerie). Dois-je donner mon nom d'utilisateur et mon mot de passe (par message privé) afin que vous constatiez que ces éléments permettent de se connecter sur mon compte sur Youtube.com et afin que vous testiez par vous-même la possibilité ou non de placer une vidéo sur Youtube par l'intermédiaire de FCP X ? :confused:
Je me sens bien seul, c'est ça le pire, personne d'autre n'a de problème pour publier sur Youtube via FCP X (je répète que par iMovie ça passe bien, donc a priori, le problème ne vient pas de moi : je sais recopier un mot de passe de 9 caractères tout de même).
Votre compte Youtube qui fonctionne, c'est un compte créé il y a plusieurs mois (lorsque le compte youtube créé n'avait rien à voir avec Google, c'est à dire un compte de type blabla) ?
Ou un compte Youtube créé récemment (depuis que le compte Youtube créé est un compte Google, c'est à dire un compte du type blabla@mail.fr) ?

(j'ai bien essayé les 2 alternatives, sans succès ni pour l'un, ni pour l'autre, mais autant en savoir le maximum sur une méthode réputée fonctionner)
 
Dernière édition:

JLB21

Membre expert
Club MacG
22 Novembre 2007
5 863
601
Mais pourquoi dans ces conditions insistes-tu pour publier en direct de FCP ?
Tous ceux qui le font reconnaissent que c'est extrêmement long et fastidieux…

Mettre 30 mn comme Olivoude le rapporte pour envoyer 1 à 2 ' de vidéo, c'est hallucinant…

Edite un mp4 au format adéquat (en principe 720 x 1280 en HD avec un débit de l'ordre de 5000 Kbps) et télécharge le sur ton compte via ton navigateur, c'est infiniment plus rapide et sans aucun soucis…
 
Q

quark67

Invité
Oui, mais j'aimerais comprendre pourquoi cela ne marche pas chez moi, c'est quand-même un truc hallucinant ! Les mêmes causes produisant les mêmes effets, j'aimerais savoir ce qui diffère chez moi de sorte que cela ne marche pas. C'est une sorte de curiosité intellectuelle... Qu'est-ce qui diffère sur mes comptes Youtube qui font que ça bug ? Ou bien est-ce mon modem-routeur ADSL qui bloque un port ? Pourtant j'ai hier soir téléchargé Little Snitch (il comporte 3 heures d'essai gratuit), et je n'ai pas constaté l'utilisation d'un port particulier par FCP X lors de la tentative d'export vers Youtube. J'ai vraiment tenté tout ce qui pouvait me passer par la tête qui expliquerait l'échec du transfert vers Youtube.
J'ai bien évidemment téléchargé FCP X sur le Mac App Store, ce qui élimine encore une source possible de l'erreur. J'ai mis à jour FCP X en version 10.0.2...
Bref, c'est vraiment un truc dingue !
Soyons fous ! Quelqu'un pourrait-il me créer un compte Youtube pour moi, puis vérifier que l'export FCP X vers Youtube fonctionne chez lui, puis me laisser tester l'export de chez moi ?
Si cela ne convient pas, c'est moi qui crée le compte de test sur Youtube, puis je donne le nom du compte et le mot de passe afin qu'une tierce personne puisse tester de chez lui.