Quick time 7.2 ne lit plus les .avi ?

fredroy

Membre confirmé
16 Novembre 2005
272
5
Paris 08
Bonjour,

Depuis la mise à jour de QuickTime (7.2) ce dernier ne lit plus les .avi qu'il lisait habituellement. Aucun pb avec les .mov et .mp4.

Si je lance une séquence, il se lance puis je se bloque et j'obtiens : QuickTime Player (ne répond pas) : obligé de forcer pour quitter.

D'autres ds le même cas que moi ?

J'ai réparé les autorisations du disque, sup les fichiers temporaire de QuickTime, résinstaller les codecs divx, xvid, mais rien n'y fait...

Une idée ?

Merci par avance.
 

whereismymind

Membre d’élite
Club MacG
8 Juillet 2006
3 816
107
42
Paris
Tu avais testé ton fichier vidéo sur une version antérieure à celle ci ?

L'AVI reste lisible bien entendu dans QuickTime 7.2 pour répondre à ta question.
 
A

Anonyme

Invité
Hello!

fredroy et autres membres,

Je suis dans le même cas. Les problèmes évoqués sont identiques. Lecture fichiers .avi impossible depuis la màj en 7.2
Après avoir tenté bien des choses (autorisations, réinstallation mise à jour Combo, suppression de .plist etc...), j'ai dû revenir (par l'intermédiaire d'une sauvegarde sur un DD où je n'avais pas encore effectué la mise à jour en 7.2) à la version précédente 7.1.6 et tout est rentré dans l'ordre.
Je cherche, je cherche un peu partout (y compris sur MacFixIt), mais en vain.
Une aide serait la bienvenue. Merci.
Salutations.


Bon, on va aller faire un tour dans le forum vidéo, ça sera plus à sa place !
 

remiP5

Membre confirmé
27 Avril 2004
101
2
39
de mon coté pas de pb je lis toujours les .avi avec quicktime 7.2

ton problème doit venir surement d'ailleurs;

à plus
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 924
3 895
Là-haut
de mon coté pas de pb je lis toujours les .avi avec quicktime 7.2

ton problème doit venir surement d'ailleurs;

à plus
Pareil, j'ai d'ailleurs testé tous mes codecs avec QT 7.2 sur une partition externe avant de faire le grand saut.

Il y a quoi dans tes .avi ?
 

Calvinico

Nouveau membre
28 Novembre 2005
2
0
idem pour les problèmes de lecture des .avi qui se lisent parfaitement sur VLC mais plus sur QT et Nice Player. ils bloquent les apps et les forcent à quitter...
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 924
3 895
Là-haut
idem pour les problèmes de lecture des .avi qui se lisent parfaitement sur VLC mais plus sur QT et Nice Player. ils bloquent les apps et les forcent à quitter...
MAIS IL Y A QUOI DANS VOS .AVI ????

Est-ce spécifique à un codec ou à tout .avi ? Avez-vous essayés avec des .avi contenant différents format ?

Comment ces .avi ont-ils été créés ?
 

miaou

Membre d’élite
Club MacG
25 Mars 2001
1 465
48
marseille
il n'y a que les mac intel qui des problèmes ? ou c'est tout le monde ? merci
 
A

Anonyme

Invité
Bonjour...

...et merci à tous pour vos réponses.


Pour répondre à la question précédente, il n'y a pas que les Intel qui sont concernés (lecture avi depuis màj QT 7.2), je suis sous PPC. D'ailleurs, les problèmes sont divers et variés chez plusieurs utilisateurs que ce soit Intel ou PPC.
Mes .avi sont des films (DivX pour l'essentiel). Ils étaient parfaitement lus (et le sont toujours) avec QT 7.1.6 et les codecs habituels.
Evidemment, avec VLC (qui intègre beaucoup de codecs) il n'y a aucun problème : il lit pratiquement tout et bien.
 

miaou

Membre d’élite
Club MacG
25 Mars 2001
1 465
48
marseille
je te remercie pour l'info. alors je crois bien que je vais attendre encore un peu pour la faire cette maj
je ne sais pas si tu connais mais il y aussi ça , QTAmateur qui n'est pas mal du tout .
il reprend certaines options de QT Pro et il est gratuit

http://mac-gratuit.fr/gratuit-91.html
 
A

Anonyme

Invité
je te remercie pour l'info. alors je crois bien que je vais attendre encore un peu pour la faire cette maj
je ne sais pas si tu connais mais il y aussi ça , QTAmateur qui n'est pas mal du tout .
il reprend certaines options de QT Pro et il est gratuit

http://mac-gratuit.fr/gratuit-91.html

Merci miaou. Oui, je l'avais essayé, mais je préfère un programme plus complet.
Pour le moment, en attendant d'autres infos ou une nouvelle màj QT, je reste avec QT 7.1.6 qui ne me pose pas de problème.

Salutations
 

fredroy

Membre confirmé
16 Novembre 2005
272
5
Paris 08
Il y a quoi dans tes .avi ?
Un est encodé en mpeg4 yuv420p 720x320, une autre mpeg4 yuv420p 688X400.

Mais bon c'est pas très précis... Si tu as un soft qui permet d'avoir les codecs utilisés je suis preneur :)
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 924
3 895
Là-haut
Perian comprend un avi importer, j'ai lu que la version 0.5 ne fronctionnait plus avec QT 7.2 et qu'il fallait passer à la 1.0.

Le XviD_avi_import_preview4 ne m'a jamais vraiment donné satisfaction sur Intel, de toute manière Perian le rend inutile.

A mon expérience, QuickTime 7.2 peut parfaitement fonctionner pour l'ensemble des codecs que j'utilise que ce soit dans du .mov, .avi, .divx ou même du .mkv.


Pour connaître le codec contenu dans un .avi on peut utiliser VLC (Pomme+I>options avancées) ou QuickTime (Pomme+I).
 
A

Anonyme

Invité
Du nouveau en ce qui me concerne :

J'ai installé QT 7.2 sur un disque dur externe (juste pour tester).

Les seuls codecs qui ont été installés lors de l'installation (bibliothèque/QuickTime) sont les suivants :

3ivx D4 4.5.1 for OSX
3ivx Delta 3.5
DivX Decoder.component
DivX Encoder.component
x264Codec.component
x264Encoder.component

Dans ce cas, les fichiers .avi sont lus sans problème.

Il suffirait alors d'ajouter un par un les autres codecs (dont certains sont sans doute indispensables)
pour trouver le responsable de ce dysfonctionnement.

S'il ne s'agit pas d'autre chose bien sûr, étant donné que le disque sur lequel j'ai fait l'essai est "propre".
 
A

Anonyme

Invité
Me concernant, le problème est réglé (détail message précédent)
J'ai ajouté les autres codecs que j'avais et tout semble OK.

Information :

J'ai remarqué que dans mon cas (à vérifier si cela se produit chez d'autres utilisateurs qui ne peuvent pas lire les .avi) QuickTime 7.2 n'installe rien dans le dossier Bibliothèque/QuickTime (pour tous les utilisateurs).
Pas étonnant que les fichiers .avi ne soient pas lus.
 

fredroy

Membre confirmé
16 Novembre 2005
272
5
Paris 08
J'ai réinstallé Mac OS et refait lamise à jour. Maintenant tout fonctionne normalement.
 

yocouto

Membre junior
24 Janvier 2007
63
1
bonjour à tous,
j'ai copié le codeck perian dans ma bibliothèque "Qt" d'utilisateur et j'arrive enfin à lire mes .avi.
J'ai d'autres codecks dans ma bibliothèque générale "quicktime" que je n'ai pas encore déplacé mais ça na pas l'air d'avoir besoin.
maintenant: Pourquoi ?
pourquoi ça marche comme ça ?
pourquoi une bibliothèque "Qt" dans utilisateur et une bibliothèque "quicktime" dans le général?