• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

[Resolu] Mamp : Activer php5 par default

foufouner1977

Membre confirmé
28 Mars 2015
141
3
42
Bonjour
Je viens de mettre à jours mon mac vers Mojave 10,14,6
J'ai également installé Mamp 5.6
Problème : Les version php d'activer par defaut sont les versions 7 hors moi j'ai un site en version 5
Je sais qu'on peut modifier les version par defaut des php en renommant les dossiers config->Php mais je sais plus en quoi !
Quelqu'un saurait ?
merci
 

subsole

Vénérable sage
Club MacG
16 Octobre 2010
11 021
3 380
Bonjour
"Arrêtez d'abord le serveur s'il fonctionne. Allez dans "/ Applications / MAMP / bin /", renommez la version PHP dont vous n'avez pas besoin (MAMP n'est autorisé à utiliser que 2 versions PHP), par exemple "_php5.2.17". Maintenant, MAMP utilisera les versions php restantes. Accédez au gestionnaire MAMP, puis aux paramètres, puis passez à la version php dont vous avez besoin.
Dans mon cas (et le vôtre de la même manière), j'ai renommé le dossier nommé php7.1.1 en _php7.1.1 et maintenant MAMP me montre 5.6.30 et 7.0.15 dans le volet des préférences."

Source ==> https://stackoverflow.com/questions/43137191/how-to-change-php-version-on-mamp-4-1