10.13 High Sierra Session « System Administrator » à la sortie de veille

David1er

Membre confirmé
20 Janvier 2012
104
6
Bonjour,

Depuis l’installation de high Sierra sur un mbp 15” fin 2016 avec touchbar, quand ma fille utilise sa session (contrôlée) à la sortie de veille j’ai systématiquement l’invite de session « System Administrator ».

Ça n’arrive pas quand la sortie de veille se fait après ma session (administrateur). La récente mise à jour n’y a rien changé.

Ce n’est pas gênant à l’usage mais on perd du temps à cliquer sur autre utilisateur pour qu’il me propose les 4 sessions que j’ai créé sur ce mac. Surtout que dans ce cas l’affichage des utilisateurs est plus long que la normale (5s au moins je dirais).

Si vous avez une idée ou si vous avez aussi ce cas merci de votre aide ou de votre témoignage.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 537
21 454
Forêt de Fontainebleau
Salut David

System Administrator
est le Long Name (nom complet) de l'utilisateur dont le Short Name (nom court) est root.

Une icône proposant un login System Administrator (ou Autre permettant, quand on clique, une saisie du nom d'utilisateur root) s'affiche, normalement, lorsque l'utilisateur root a été rendu capable d'ouvrir une session graphique (« enabled ») par la définition d'un mot-de-passe d'ouverture de session.

Pour vérifier l'état des lieux > va à : Système > Bibliothèque > CoreServices > Applications > lance l'«Utilitaire d'annuaire» > barre de menus supérieure du logiciel > Édition > dans le bas de la fenêtre déroulante --> est-ce que tu lis : Désactiver l'utilisateur root ?

=> si c'est le cas > tout est dit : l'utilisateur root est « enabled » --> il te suffit de presser le menu Désactiver l'utilisateur root > de re-démarrer une fois > et de vérifier si l'icône de login du System Administrator a disparu de l'affiche.
 

David1er

Membre confirmé
20 Janvier 2012
104
6
J'ai suivi tes instructions et fait un test rapide, ça semble fonctionner.

C'est l'installation de high sierra qui "oublie" de désactiver l'utilisateur root ?

En tous ça merci oh dieu de Mac OS.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 537
21 454
Forêt de Fontainebleau
Si l'utilisateur root était « activé » (à la capacité d'ouvir une session graphique par mot-de-passe) --> c'est que quelqu'un l'avait activé (il est toujours « in-capacité » ou disabled par défaut à cette possibilité).

Dans l'environnement de ton précédent OS peut-être > alors la mise-à-niveau à High Sierra a respecté ce choix. Sinon > et à moins d'activation accidentelle à l'installation > c'est quelqu'un qui l'a activé.
 

David1er

Membre confirmé
20 Janvier 2012
104
6
J’ai du le faire à un moment même si je n’en ai plus vraiment le souvenir. Mais sous Sierra je n’ai pas rencontré ce problème. A priori ce n’est arrivé qu’avec high Sierra. Enfin ça marche maintenant.
 

David1er

Membre confirmé
20 Janvier 2012
104
6
Ben en fait non je ne l’ai pas fait et le problème est revenu avec l’installation des dernières mises à jour de high Sierra. Je vais refaire la manip mais bon c’est quand même pas normal
 

David1er

Membre confirmé
20 Janvier 2012
104
6
Finalement c’est plus compliqué que ça sur ma session (administrateur) Root est déjà désactivé mais le problème se reproduit essentiellement quand le mbp sort de veille après une session d’un utilisateur contrôlé.