• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Throttling respawn ???

piercoco

Membre confirmé
8 Juillet 2007
238
45
Bonjour,

en consultant la system.log, je trouve ce message ..... 4000 fois depuis hier !!!!!

"Aug 1 10:26:44 Macintosh org.x.X11[402]: /usr/X11/libexec/x11-exec: Unable to find application for org.x.X11
Aug 1 10:26:44 Macintosh com.apple.launchd[74] (org.x.X11[402]): Exited with exit code: 4
Aug 1 10:26:44 Macintosh com.apple.launchd[74] (org.x.X11): Throttling respawn: Will start in 10 seconds"

Maj de sécurité faite, nettoyage avec Onyx .... après je fais quoi ?????

Auriez vous une idée à me proposer pour arrêter ce truc ??

Merci
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 820
3 120
Deux choses à considérer :

a) comment on arrête le bousin : pour cela il faut utiliser le Terminal et la commande launchctl ; je pense qu'il s'agit du service défini par le fichier /System/Library/LaunchAgents/org.x.X11.plist. Donc la commande pour arrêter cela serait :
Bloc de code:
sudo launchctl unload -w /System/Library/LaunchAgents/org.x.X11.plist
b) pourquoi le bousin est là : c'est sympa, ton fil, car je viens de réaliser que l'on peut (j'ai Leopard, mais peut-être depuis Tiger, je ne sais) lancer une application X11 et automatiquement cela lance le serveur X11. Trop fort ! ;) Si tu n'utilises pas du tout X11, alors tu peux désactiver l'agent. Sinon, il va falloir essayer d'aller plus loin dans la compréhension de l'erreur.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 820
3 120
Réflexion faite, j'ai tout bêtement l'impression que :

1) tu utilises (éventuellement à ton insu) une application X11

2) X11 n'est pas installé ...

Peux-tu simplement vérifier que le fichier /usr/X11/libexec/x11-exec existe ?
 

piercoco

Membre confirmé
8 Juillet 2007
238
45
Je pense avoir résolu le problème en lançant X11 manuellement, il est bien installé sur mon Mac,
je le voyait apparaitre en utilisant OOO.

Maintenant j'utilise NeoOffice, et X11 ne semble pas se manifester avec lui.

J'ai donc "tuer" X11 en le forçant à quitter, et à cet instant les messages se sont arrêtés.

Merci de tes réponses, une petite chose, je ne sais pas voir "/usr/X11/libexec/x11-exec" :rose:
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 820
3 120
NeoOffice utilise une interface graphique écrite en Java au lieu d'utiliser X11 comme le fait la version standard de OO. Note qu'il y a une version Aqua (i.e. Mac pur jus) de OO en cours de finition (elle doit être en bêta — voir le site).

Ce devait donc être le serveur X11 qui était dans les choux ;)

Pour voir le fichier, c'est facile : dans le Finder, menu "Aller à" tu choisis l'item pour aller vers un dossier et tu tapes le nom du dossier : "/usr/X11/libexec". Pas plus compliqué. :zen:
 

piercoco

Membre confirmé
8 Juillet 2007
238
45
Et bien merci encore, j'ai appris quelque chose de plus .... la découverte de OS X continue ... et n'est pas finie !!! ;)
 

piercoco

Membre confirmé
8 Juillet 2007
238
45
Deux choses à considérer :

a) comment on arrête le bousin : pour cela il faut utiliser le Terminal et la commande launchctl ; je pense qu'il s'agit du service défini par le fichier /System/Library/LaunchAgents/org.x.X11.plist. Donc la commande pour arrêter cela serait :
Bloc de code:
sudo launchctl unload -w /System/Library/LaunchAgents/org.x.X11.plist
b) pourquoi le bousin est là : c'est sympa, ton fil, car je viens de réaliser que l'on peut (j'ai Leopard, mais peut-être depuis Tiger, je ne sais) lancer une application X11 et automatiquement cela lance le serveur X11. Trop fort ! ;) Si tu n'utilises pas du tout X11, alors tu peux désactiver l'agent. Sinon, il va falloir essayer d'aller plus loin dans la compréhension de l'erreur.
Re bonjour,

le problème est de retour, curieusement d'après la console juste à la suite de l'utilisation de Néo office !!!
Mais là je n'arrive pas à corriger ... toutes les 10 secondes message :

05/08/08 17:06:36 com.apple.launchd[72] (org.x.X11[5565]) Exited with exit code: 4
05/08/08 17:06:36 com.apple.launchd[72] (org.x.X11) Throttling respawn: Will start in 10 seconds

D'après ton point B on peut le désactiver, comment stp ??? :)

PS : j'&i trouvé le coupable !!! :

05/08/08 17:30:25 com.apple.launchd[72] ([0x0-0x12012].MacFreePOPs 2.5[113]) Stray process with PGID equal to this dead job: PID 160 PPID 1 freepopsd

freepopsd m'est utile pour récupérer mon compte hotmail dans mail !!!

Merci pour toute infos de correction
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 820
3 120
Qu'est-ce qui t'amène à penser que le coupable est MacFreePOPs ?
 

piercoco

Membre confirmé
8 Juillet 2007
238
45
Ben le message listé !!!

Après manip "légère" sur macfreepops mon compte hotmail sur mail est en point d'exclamation.

Les messages continus après Eteindre et re-connexion :

05/08/08 18:26:39 com.apple.loginwindow[21] wall: /dev/tty??: No such file or directory
05/08/08 18:26:39 com.apple.loginwindow[21] Shutdown NOW!
05/08/08 18:26:39 com.apple.loginwindow[21] System shutdown time has arrived
05/08/08 18:29:27 com.apple.launchctl.System[2] launchctl: Please convert the following to launchd: /etc/mach_init.d/dashboardadvisoryd.plist
05/08/08 18:29:27 com.apple.launchd[1] (org.cups.cupsd) Unknown key: SHAuthorizationRight
05/08/08 18:29:27 com.apple.launchd[1] (org.ntp.ntpd) Unknown key: SHAuthorizationRight
05/08/08 18:29:39 com.apple.launchd[1] (com.apple.UserEventAgent-LoginWindow[67]) Exited: Terminated
05/08/08 18:29:50 [0x0-0x11011].org.x.X11_launcher[112] command=/usr/X11/bin/xterm
05/08/08 18:29:50 com.apple.launchd[72] ([0x0-0x11011].org.x.X11_launcher[112]) Stray process with PGID equal to this dead job: PID 115 PPID 1 login
05/08/08 18:29:50 org.x.X11[117] /usr/X11/libexec/x11-exec: Unable to find application for org.x.X11
05/08/08 18:29:50 com.apple.launchd[72] (org.x.X11[117]) Exited with exit code: 4
05/08/08 18:29:50 com.apple.launchd[72] (org.x.X11) Throttling respawn: Will start in 10 seconds
05/08/08 18:29:54 com.apple.launchd[72] ([0x0-0x12012].MacFreePOPs 2.5[113]) Stray process with PGID equal to this dead job: PID 141 PPID 1 freepopsd
05/08/08 18:30:01 org.x.X11[177] /usr/X11/libexec/x11-exec: Unable to find application for org.x.X11
05/08/08 18:30:01 com.apple.launchd[72] (org.x.X11[177]) Exited with exit code: 4
05/08/08 18:30:01 com.apple.launchd[72] (org.x.X11) Throttling respawn: Will start in 10 seconds
05/08/08 18:30:11 org.x.X11[181] /usr/X11/libexec/x11-exec: Unable to find application for org.x.X11
05/08/08 18:30:11 com.apple.launchd[72] (org.x.X11[181]) Exited with exit code: 4
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 820
3 120
Pas si sûr. On cherche à lancer X11 en raison du lancement de XTerm.
Mais MacFreePOPs semble avoir des soucis aussi.

C'est sans doute que ces programmes plantent, amenant launchctl à relancer n fois les processus. Il faut donc vérifier leur configuration.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 820
3 120
XTerm, c'est une application façon Terminal, mais pour X11.

Le principe, ici, est que lorsqu'une application requiert X11 (en se lançant, elle cherche à se connecter au serveur graphique de X11, sur le port 6000 de la machine), launchd lance ce dernier. Peut-être t'es-tu amusé à utiliser le port 6000 pour MacFreePOPs ?
 

piercoco

Membre confirmé
8 Juillet 2007
238
45
Non non, j'utilise le port 2000 comme indiqué dans le tuto de ce forum.

Je désinstalle et ré installe Macfreepops ... pour voir !!

A plus

Suite .... ça ne change rien !!!

Suite de la suite .... j'ai trouvé ça :
http://www.macosxhints.com/article.php?story=20071027071326229

avant de faire ce genre de mani, je voudrais une avis ... avisé !!

Merci de me dire ce que tu en penses.
 

piercoco

Membre confirmé
8 Juillet 2007
238
45
A priori le problème est réglé, je n'ai plus les messages !! :)

J'ai effectué une maj de X11 via kle site quartz et tout semble bon, sauf MacfreePOPs !!

Je cherche, peut être u autre sujet.

Merci pour ton aide.
 

nalfein

Nouveau membre
28 Juin 2010
14
1
Bonjour (et désolé pour le déterrage de vieux topic)

Mon launchd tente aussi de lancer un soft désinstallé (magican pour 10.6+, et je suis sous leopard, ironie)

Ma console affiche ce motif en boucle :

Bloc de code:
13/11/11 10:53:04 com.apple.launchd[1] (com.magican.castle[756]) posix_spawnp("/Library/Application Support/Magican/McDaemon", ...): No such file or directory 
13/11/11 10:53:04 com.apple.launchd[1] (com.magican.castle[756]) Exited with exit code: 1 
13/11/11 10:53:04 com.apple.launchd[1] (com.magican.castle) Throttling respawn: Will start in 10 seconds
Find Any File me renseigne ces fichiers :



Si j'ai bien compris, je dois encoder ceci dans le terminal :

Bloc de code:
sudo launchctl unload w- /library/launchdaemons/com.magican.castle.plist
et effacer le fichier .plist du répertoire ?

J'aimerais que quelqu'un vérifie, j'y connais pas grand-chose et j'ai peur de faire une connerie.

Merci d'avance :)
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 820
3 120
Ça a l'air très bien à un détail près : il faut écrire '-w' au lieu de 'w-', soit :
Bloc de code:
sudo launchctl unload -w /library/launchdaemons/com.magican.castle.plist
 

nalfein

Nouveau membre
28 Juin 2010
14
1
Merci beaucoup, ça a fonctionné =)

Au fait, je peux effacer les autres fichiers sans problème? (ceux dans /library/receipts/boms)
 
Dernière édition:

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 820
3 120
Oui.
Note que ce sont ces fichiers qui renseigne sur ce qui a été initialement installé.