URGENT : problème de migration d'un compte

JediMac

Membre expert
Club MacG
26 Octobre 2000
6 462
207
là-bas si j'y suis !
Bonjour,

Deux iMac sous Leopard dernière version. Je dois ramener l'utilisateur de l'un vers l'autre.
J'ai donc lancé Assistant de migration, une première fois en voulant utiliser la sauvegarde TM, mais ça n'a pas fonctionné. Une deuxième fois avec un câble FW, mais l'iMac le plus récent n'a pas la prise correspondante à mon câble :sleep:.
Une 3è fois via le réseau et là cela a transféré l'utilisateur, MAIS !
Chose étrange lorsque je me connecte via le profil de l'utilisateur transféré (toto on va dire) l'iMac l'ouvre comme si c'était un nouvel utilisateur et non un immigré ;), avec en plus l'impossibilité d'ouvrir les dossiers à la racine du compte de toto (document, bibliothèque, ...). D'ailleurs ceux-ci sont en anglais.
Toto ne peux ouvrir aucune application devant faire appel à des données propres à un utilisateur, du genre Mail ou iCal.
Lorsque je me connecte sous un autre profil admin (titi), et que je vais dans les dossiers racine de toto, ben là j'accède à leur contenu :eek:.
Comment faire pour que toto accède à ses dossiers ?

Avec le panneau information (pomme+I) j'ai vu que toto n'était même pas listé dans la rubrique permissions, mais que titi y était avec les droits de lecture/écriture. J'ai donc essayé de corriger en ajoutant toto et en lui donnant les permissions de lire/écrire et en l'appliquant au contenu, mais ça ne marche pas bien, seule une partie des dossiers se débloque.

J'ai déjà réparé 2 fois les utilisations, mais rien ne change. Je pense qu'il doit y avoir une ou deux lignes à taper dans Terminal, mais lesquelles ?

Précisions : toto est un admin (identifié comme tel dans la préf. système "Compte").
Toto était sur un Mac dont j'avais partitionné le DD avec délocalisation des utilisateurs. Le Mac cible n'est pas partitionné.

Voilà, vous savez tout !

Merci de votre aide :zen:
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Bonjour,

Pour t'éviter tes ennuis actuels, il aurait peut-être suffi de créer le compte Toto avant de lancer la migration à partir du compte Titi.


Pour rattraper simplement et efficacement le coup, je démarrerais sur le DVD d'install Leopard pour aller dans la barre des menus de la deuxième page et y trouver "Réinitialiser le mot de passe" à la rubrique "Utilitaires",
et dans cet utilitaire, je lancerais la "Réinitialisation des autorisations et ACL" sur le compte Toto : il suffit de sélectionner le bon dossier dans le pop-up pour que tout se corrige ensuite en un clic.
 

JediMac

Membre expert
Club MacG
26 Octobre 2000
6 462
207
là-bas si j'y suis !
Bonjour,

Pour t'éviter tes ennuis actuels, il aurait peut-être suffi de créer le compte Toto avant de lancer la migration à partir du compte Titi.
Pourquoi pas, mais il ne me semble pas avoir vu la possibilité de lui indiquer de rapatrier un compte vers un existant. Je pense qu'il y a forcément création d'un compte.


Pour rattraper simplement et efficacement le coup, je démarrerais sur le DVD d'install Leopard pour aller dans la barre des menus de la deuxième page et y trouver "Réinitialiser le mot de passe" à la rubrique "Utilitaires",
et dans cet utilitaire, je lancerais la "Réinitialisation des autorisations et ACL" sur le compte Toto : il suffit de sélectionner le bon dossier dans le pop-up pour que tout se corrige ensuite en un clic.
Ha, je ne connaissais pas ! Je m'en vais essayer.

Merci
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Je pense qu'il y a forcément création d'un compte.
Il y a création du compte quand tu lances la migration à partir du même compte cible déjà créé.
Il n'y a pas création du compte s'il est déjà créé (Toto cible) ET que la migration est lancée à partir d'un autre compte du Mac cible (Titi).
 

JediMac

Membre expert
Club MacG
26 Octobre 2000
6 462
207
là-bas si j'y suis !
Hé, je veux bien que ma mémoire ait été mis à mal à cause des ce grand pont, mais il me semble qu'une partie des messages s'est évaporée.
Notamment celle où j'indiquais le résultat des derniers essais.

Pour résumer, cela n'a pas marché et il y a même des effets très surprenants. Je vais effacer ce compte, le récréer et importer à nouveau.

Je me demande quand même si tout ça ne vient pas du fait que les utilisateurs du Mac source sont délocalisés alors que ce n'est pas le cas sur le Mac cible.
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Oui, des messages ont disparu dans plusieurs fils : une journée a été effacée.

Tu parles d'effets très surprenants ?
 

JediMac

Membre expert
Club MacG
26 Octobre 2000
6 462
207
là-bas si j'y suis !
Oui, des messages ont disparu dans plusieurs fils : une journée a été effacée.

Tu parles d'effets très surprenants ?
Yep ! J'ai suivi ce que tu proposais, réparation des autorisations, réinitialisation ACL avec le DVD d'installation sans que ça ne résolve quoi que ce soit.
J'ai appliqué la ligne de code et ça n'a rien changé non plus :eek:.
J'ai à nouveau testé de changer les permissions avec l'inspecteur d'éléments, en "appliquant au contenu", et là ça à eu un effet, mais opposé à ce qui aurait dû se passer, à savoir que les permissions que j'avais mise une par une à toto sont revenues à titi :hein:.

Et à l'instant, j'ai effacé toto, puis je l'ai récréé. Depuis titi j'ai importé avec Assistant de migration l'ancien toto vers le nouveau. Parmi les choix possibles, je n'avais pas mettre l'ancien dans le nouveau, mais c'était soit changer le nom du compte importé et là on revient à la case départ, soit recréer toto. J'ai pris le deuxième choix, mais là rien n'a été importé.

Je me lasse, je crois que je vais faire e transfert à la main.
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
J'ai à nouveau testé de changer les permissions avec l'inspecteur d'éléments, en "appliquant au contenu"
Ça, c'est à éviter formellement sur tout dossier Utilisateur : les autorisations varient dans les sous-dossiers. :eek:

Et à l'instant, j'ai effacé toto, puis je l'ai récréé. Depuis titi j'ai importé avec Assistant de migration l'ancien toto vers le nouveau.
Tu ne l'aurais pas recréé avant de le migrer… :p

Je me lasse, je crois que je vais faire le transfert à la main.
Évite de créer Toto dans le Mac cible avant le transfert si tu transfères tout le dossier Toto d'un coup.
Si tu crées Toto, il te faudra transférer par sous-dossier (et même par contenu de sous-dossier pour Bibliothèque, Bureau, Documents).
 

JediMac

Membre expert
Club MacG
26 Octobre 2000
6 462
207
là-bas si j'y suis !
Après quelques jours passés, je pense pouvoir dire que la méthode "bourin" a fonctionné.
J'ai transféré à la main tous les dossiers de "Départ" de toto ancien vers la boite de dépôt de toto nouveau. Puis depuis le nouveau Mac, j'ai rangé ces dossiers de la boite de dépôt vers Départ.
Il y a eu quelques bizarreries, notamment avec Carnet d'adresses, mais elles se sont réglées d'elles-mêmes, par magie ! :cool:

Mon collègues bosse sans aucun souci depuis.

En tout cas merci de ton aide !