Xcode 3.0 et ajout de "Project Templates"

Satcheur

Membre junior
7 Septembre 2006
23
7
Charleroi (Belgique)
www.catbikers.be
Salut à tous !

Je suis entrain de suivre les tutos du Site du Zero pour le C et j'attaque la partie touchant à l'utilisation de la bibliothèque SDL.

La bonne nouvelle c'est que la procédure d'installation de cette bibliothèque est détaillée sur plein de sites... La mauvaise c'est que je suis sur Xcode 3.0 et que cette procédure n'est pas valide. Enfin, pas totalement valide... :hein: Je m'explique ! Cette procédure se déroule en 2 étapes :

a) recopier les fichiers de fonctionnement de la SDL au bon endroit :
/Bibliothèque/Frameworks/SDL.framework

b) recopier deux dossiers (fournis avec la SDL) pour définir de nouveaux "project templates" parmis lesquels on doit faire un choix lors de la création de projet avec Xcode :
/Bibliothèque/Application Support/Apple/Developer Tools/Project Templates/Application/...

Si le point a) me semble ok, quelque chose ne doit pas coller avec le point b) : lorsque je crée un nouveau projet, Xcode ne me propose pas de type de projet en relation avec cette SDL... :mouais:

Par contre, si je lance moi même le fichier template (ex : SDL App.pbproj) tout s'ouvre correctement dans Xcode et je peux compiler sans soucis.

Devrais-je placer ces "templates" à un autre endroit pour Xcode 3.0 ?

Merci pour vos réponses :)
 

6ix

Membre junior
12 Juillet 2005
28
0
35
Est-ce tout fonctionne correctement?

J'ai suivi exactement la même procédure (testé aussi bien avec la version 1.2.11 que 1.2.12), puis créé un projet SDL Application, mais ensuite j'ai des erreurs de compilation sur chaque méthode glXXX (symbols not found).

Pareil en reprenant mes projets qui fonctionnaient pourtant parfaitement sur Tiger et Xcode 2.4 (tout en contrôlant que le SDL.framework soit toujours lié au bon endroit).


Est-ce que quelqu'un aurait une idée du problème?
 

6ix

Membre junior
12 Juillet 2005
28
0
35
Hem, je me réponds à moi-même, à force de chercher bêtement du côté de SDL je n'avais pas remarqué que le framework OpenGL n'était pas ajouté au projet. :rolleyes:
 

Gercofis

Membre junior
14 Septembre 2005
18
0
75
Chambery
Pour que ça fonctionne il faut probablement changer les autorisations du dossier mais comment fait-on pour donner une autorisation Systeme ?