Besoin d'aide phpMyAdmin

Tom45

Membre junior
1 Juillet 2005
73
1
37
Salut !
J'ai installé mysql 5, apache 2.2 et php 5.1.2, pour ces deux installations j'ai suivi ce tutorial http://phpmac.com/articles.php?view=244.
Et puis j'ai voulu installé phpmyadmin pour pouvoir utiliser le tout plus facilement mais une fois que je tape "http://localhost/phpMyAdmin/" ca marche pas "The requested URL /phpMyAdmin/ was not found on this server."
Il doit y avoir kke chose de pa bien configuré mais koi ?
Si kk'un peut m'aider. Merci :)
 

Marc-André

Membre émérite
24 Juillet 2003
559
17
45
Ottawa
As-tu configuré le fichier config.inc.php qui se trouve à l'intérieur du dossier php?

Ton dossier phpmyadmin se retrouve t'il dans le dossier /bibliothèque/webserver/documents/
ou dans /Utilisateur/tonuser/Site/

l'adresse est différente dans les 2 cas....


Marc-André
 

Tom45

Membre junior
1 Juillet 2005
73
1
37
j'ai installer php ds /usr/local/php5 mais j'y trouve pa de fichier config.inc.php.
Sinon pour phpmyadmin je l'ai installé ds le rep /usr/local/apache2/htdocs.
 

Pochtroi

Membre confirmé
Tom45 a dit:
j'ai installer php ds /usr/local/php5 mais j'y trouve pa de fichier config.inc.php.

J'avais eu ce problème moi aussi. Je ne sais pas pourquoi, il semble que le fichier ait été déplacé ou supprimé. Ca doit maintenant être possible de le configurer d'autre part, mais une autre technique qui semble fonctionner, c'est de télécharger un vieux phpmyadmin (voire très vieux) et de placer le fichier config.inc.php dans le dossier phpmyadmin tout récent que tu as déjà.

En revanche, je suis débutant mais je crois que http://localhost/phpmyadmin/, c'est l'adresse pour quand tu as placé le fichier dans bibiliotheque(comme dirait Homer Simpson)/webserver/documents...
 

Tom45

Membre junior
1 Juillet 2005
73
1
37
J'ai peur malheureusement de m'etre lancé ds une installation trop difficile puisque j'ai peu de connaissance en Unix.
Je voudrait simplement avoir un environnement avec PHP5, Apache, Mysql5, et phpMyAdmin.
Existe-il un tutorial simple ou quelqu'un pourrait-il me guider ?
Merci d'avance.
 

Marc-André

Membre émérite
24 Juillet 2003
559
17
45
Ottawa
Tom45 a dit:
J'ai peur malheureusement de m'etre lancé ds une installation trop difficile puisque j'ai peu de connaissance en Unix.
Je voudrait simplement avoir un environnement avec PHP5, Apache, Mysql5, et phpMyAdmin.
Existe-il un tutorial simple ou quelqu'un pourrait-il me guider ?
Merci d'avance.
Pourquoi ne pas utiliser MAMP...

Ce n'est peut-être pas PHP5 mais je crois que c'est une option facile à installer ensuite et en plus l'installation ce fait en quelques clicks... :up:


Marc-André
 

Tom45

Membre junior
1 Juillet 2005
73
1
37
En fait je voudrait tout de meme installer les sources de ses outils séparément pour un soucis de propreté et aussi pour apprendre.
Pour mysql5, j'ai telechargé l'image dmg sur le site officiel, donc lui il est bien installé.
Apache 2.20 et PHP 5.1.2 ont été installé en suivant le tuto ke j'ai indiqué. Peut-être que le tuto contient trop d'options pour mon utilisation, mais je peux peut-etre les réinstaller avec les options de base.
En fait ce qui pose probleme c'est phpMyAdmin 2.7, j'ai télécharger les sources sur le site officiel, mais je n'ai pa trouvé de tuto preci sur comment l'installer et le configurer sur un OS X.
Voila pourquoi je suis venu demander de l'aide ici.;)
Merci.
 

Pochtroi

Membre confirmé
Je crois qu'il n'y a ppas grand chose à faire sur phpmyadmin: juste ouvrir le fichier config.machin et configurer ton nom et ton mot de passe, le reste étant déjà fait, (et encore, je n'ai pas configuré mon mot de passe puisque mysql ne mm'autorisais pas à installer de mot de passe et par magiie, je ne vois que ça, ça s'est mis à fonctionner). J'ai trouvé un tutorial sur MacG ou quelqu'un avait des problemes pour faire fonctionner php (désolé, ça me saoule de chercher) qui est très bien expliqué... (mais auquel je n'ai rien compris, je n'ai fais que suivre les étapes, ca ne fonctionnait pas, et deux jours après ca fonctionnait, demandes à Marc-André si besoin, c'est un Dieu en PHP...) (lol)
 

Marc-André

Membre émérite
24 Juillet 2003
559
17
45
Ottawa
Tom45 a dit:
En fait je voudrait tout de meme installer les sources de ses outils séparément pour un soucis de propreté et aussi pour apprendre.
Pour mysql5, j'ai telechargé l'image dmg sur le site officiel, donc lui il est bien installé.
Apache 2.20 et PHP 5.1.2 ont été installé en suivant le tuto ke j'ai indiqué. Peut-être que le tuto contient trop d'options pour mon utilisation, mais je peux peut-etre les réinstaller avec les options de base.
En fait ce qui pose probleme c'est phpMyAdmin 2.7, j'ai télécharger les sources sur le site officiel, mais je n'ai pa trouvé de tuto preci sur comment l'installer et le configurer sur un OS X.
Voila pourquoi je suis venu demander de l'aide ici.;)
Merci.
D'accord alors pour l'installation de PhpMyAdmin c'est vraiment simple.

Le mieux "selon moi" est de l'installer dans /bibliothèque/webserver/documents/
Pourquoi? simplement que je trouve plus simple http://localhost/phpmyadmin que http://localhost/~monuser/phpmyadmin comme adresse :)

Une fois le dossier dans le répertoire à l,intérieur de celui-ci il y a un fichier: "config.default.php"
Fais un copie de celui-ci et nous allons travailler sur la copie que tu nommera: "config.inc.php"

Dans ce fichier ouvre le avec un éditeur de texte par exemple "BBEdit" (mon logiciel fétiche depuis plusieurs années)

À la ligne 57 de ce fichier
Bloc de code:
$cfg['Servers'][$i]['host']          = 'localhost'; // MySQL hostname or IP address

À la ligne 72 et 73
Bloc de code:
$cfg['Servers'][$i]['user']          = 'root';      // MySQL user
$cfg['Servers'][$i]['password']      = 'Mot de passe root MySQL';          // MySQL password (only needed

Les lignes c'est à peu près elle peuvent varier d'une ou 2 donc ça pourrait-être 58 ou 59 ou 74 et 75 :D

tu sauves le fichier et tu tente la connexion via ton navigateur
à l'adresse mentionné plus haut

Marc-André

P.S
Pochtroi a dit:
Je crois qu'il n'y a ppas grand chose à faire sur phpmyadmin: juste ouvrir le fichier config.machin et configurer ton nom et ton mot de passe, le reste étant déjà fait, (et encore, je n'ai pas configuré mon mot de passe puisque mysql ne mm'autorisais pas à installer de mot de passe et par magiie, je ne vois que ça, ça s'est mis à fonctionner). J'ai trouvé un tutorial sur MacG ou quelqu'un avait des problemes pour faire fonctionner php (désolé, ça me saoule de chercher) qui est très bien expliqué... (mais auquel je n'ai rien compris, je n'ai fais que suivre les étapes, ca ne fonctionnait pas, et deux jours après ca fonctionnait, demandes à Marc-André si besoin, c'est un Dieu en PHP...) (lol)
:rose: :rose: :D
 

Tom45

Membre junior
1 Juillet 2005
73
1
37
J'ai suivi tes conseils pour configurer phpmyadmin. J'ai placer le dossier dans /Library/Webserver/Documents/.
Ensuit je demarre mysql et apache2.
Mais qd je tape http://localhost/phpmyadmin/ dans Safari, j'ai pa acces à mes bases mysql, ca m'affiche juste le contenu du dossier phpmyadmin.
sinon autre chose bizare, en bas de page j'ai ecrit "Apache/1.3.33 Server at powerbook-g4-de-tom.local Port 80", pourtant j'ai lancé apache2:eek:
Ca vient d'où ?
Pour mes reglages de apache se sont ceux du tuto.
 

Marc-André

Membre émérite
24 Juillet 2003
559
17
45
Ottawa
Tom45 a dit:
J'ai suivi tes conseils pour configurer phpmyadmin. J'ai placer le dossier dans /Library/Webserver/Documents/.
Ensuit je demarre mysql et apache2.
Mais qd je tape http://localhost/phpmyadmin/ dans Safari, j'ai pa acces à mes bases mysql, ca m'affiche juste le contenu du dossier phpmyadmin.
sinon autre chose bizare, en bas de page j'ai ecrit "Apache/1.3.33 Server at powerbook-g4-de-tom.local Port 80", pourtant j'ai lancé apache2:eek:
Ca vient d'où ?
Pour mes reglages de apache se sont ceux du tuto.

À tu suivi toutes les étapes de ton tutorial?

en particulier celle-ci
Also, You now have a choice. By default your new document root will be /apache2/htdocs. If you want to change this back to the Apple default of /Library/WebServer/Documents you need to open the httpd.conf file (/apache2/conf/httpd.conf) and change the following:

DocumentRoot "/apache2/htdocs"


to

DocumentRoot "/Library/WebServer/Documents"


and

<Directory "/apache2/htdocs">


to

<Directory "/Library/WebServer/Documents">


Marc-André
 

Tom45

Membre junior
1 Juillet 2005
73
1
37
Oue j'ai fait tout ca. Je vais t'expliquer comment j'ai installé apache et php.
Je l'ai installé sous /usr/local/apache2. J'ai installé php sous /usr/local/php5.
Pour php5 j'ai pa installé les librairies jpeg et png.
Sinon apres j'ai tout fait comme le tuto, j'ai meme fait les parametre additionnelshttp://phpmac.com/articles.php?view=214.

Mais j'ai comme l'impression que c php ki est pa activé. Par exemple, quand je tape http://localhost/phpmyadmin/index.php, ca m'affiche le contenu du fichier. Ca devrait pas m'afficher le resultat, enfin interpreter php ?
 

Tom45

Membre junior
1 Juillet 2005
73
1
37
Je relance ce post pour que quelqu'un m'aide.
J'ai cherché de mon coté et j'ai suivi les conseils de Marc-André mais rien y fait j'ai toujours le même problème, quand je lance phpmyadmin j'ai le contenu du rep de phpmyadmin et non l'affichage de la gestion de mysql.
J'ai installé mysql 5, apache 2.20 et php 5.1.2.
Je pense que mysql et apache sont bien installé vu ke j'arrive à les lancer. J'ai cependant un doute pour apache car qd je me connect sur localhost ca me met toujours "apache server 1.33" ca devrait pas me mettre "apache server 2.20" ?
Y-a-t-il tout simplement un moyen de verifier que tout est bien installer ?
Pouvez-vous m'aider à tout bien configurer ?
Je peux vous fournir mes fichier de config pour aider.
Merci ;)
 

NeoDym.art

Membre junior
24 Novembre 2005
87
0
Tiens je vais me plaindre aussi:

J'ai suivi aussi un tuto pour installer phpmyadmin... Tout est bien décris dans la doc de phpmyadmin, j'ai copié confi.default.php pour en faire config.inc.php... changé les lignes, activé mon serveur apache, installé mysql, contrôlé que mysql marche bien à l'aide du terminal (par contre des pages avec l'extension .php n'affiche que le code avec mon naviguateur). Tout sans difficulté. Mais soudain, lorsque la phase final se déroule, c'est à dire que j'appel l'interface de phpmyadmin sur mon naviguateur, il me répond que je n'ai pas les autorisations???
Bloc de code:
URL:

http://localhost/~user/phpMyAdmin-2.8.0-rc2/

Réponse:

Forbidden

You don't have permission to access /~user/phpMyAdmin-2.8.0-rc2/ on this server.

Apache/1.3.33 Server at mac_de_user.local Port 80

Apparement j'ai un problème avec mon serveur, mais j'ai bien vérifié; la case "partage web personnel" est cochée et le partage activé. De plus, j'ai essayé de clicker sur l'adresse par défaut donnée dans le préfs. Même chose. Malheur! Et si j'ai Mamp, j'aurais préféré commencer avec des instruments de bases...

mon problème est il grave docteur?

Enfin...
 

helium

Nouveau membre
16 Décembre 2005
4
0
J'ai pu tout installé mais quand je veux lancer phpmyadmin j'obtiens ce message :
phpMyAdmin - error

Could not load any language, please check your language settings and folder



que dois je faire ?
 

helium

Nouveau membre
16 Décembre 2005
4
0
j'ai résolu une partie de mon problème cité précédemment, mais j'ai un souci quand je demande d'aller à l'adresse suivante : http://localhot/phpmyadmin il m'affiche une fenetre ou je doit saisir un login et un mot de passe dans lequel je mets mon login (root) et mon mot de passe du root mysql mais pas possible, il me dit qu'il y a une erreur de mot de passe
que dois je faire ?

j'ai cherché des solutions mais rien.
 

weblamu

Nouveau membre
19 Janvier 2006
8
1
helium a dit:
j'ai résolu une partie de mon problème cité précédemment, mais j'ai un souci quand je demande d'aller à l'adresse suivante : http://localhot/phpmyadmin il m'affiche une fenetre ou je doit saisir un login et un mot de passe dans lequel je mets mon login (root) et mon mot de passe du root mysql mais pas possible, il me dit qu'il y a une erreur de mot de passe
que dois je faire ?

j'ai cherché des solutions mais rien.

Quelqu'un aurait-il une solution à ce dernier post parce que je rencontre les mêmes problèmes ?