iMac Disque SSD non reconnu en interne par iMac 21'' 2011

stanval

Membre junior
28 Mai 2020
15
0
57
Bonjour,

Problème: suite au remplacement d'un HDD par un SSD, le SSD n'est pas reconnu par El Capitan lors du démarrage.

Configuration:
  • iMac 21'' 2011 avec El Capitan 10.11.5 et HDD 1 to, 4 go RAM.
  • SSD Samsung 860 QVO V-NAND 1 TB
  • boitier Kingston " 2.5'' to 3.5'' SATA Drive Carrier" pour l'intégration du SSD dans l'iMac

Situation: j'ai effectué un formatage du SSD (mis sur boitier externe et reconnu par El Capitan) avec partition GUID et format Mac OS étendu (journalisé), puis un clonage du HDD sur le SSD. J'ai mis le SSD comme disque de démarrage puis j'ai remplacé le HDD par le SSD dans l'iMac. Au démarrage le SSD n'est pas reconnu. Avec la touche Alt, il me demande un réseau pour aller chercher une version d'un OS mac sur internet. Lorsque j'indique le SSD comme disque de démarrage, j'ai un dossier avec un ?.

Questions: que faire pour que ça fonctionne ? Passer à High Sierra ? Est-ce un problème lié au boitier Kingson ? Est-ce le SDD ?

Merci d'avance de vos suggestions, solutions, car là je sèche un peu...je vais boire un coup ça ira mieux ;-)

Valentino
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 159
6 047
Nancy___
Bonjour,

Situation: j'ai effectué un formatage du SSD (mis sur boitier externe et reconnu par El Capitan) avec partition GUID et format Mac OS étendu (journalisé), puis un clonage du HDD sur le SSD.
Tant que ton SSD était dans le boitier externe, as tu essayé de démarrer dessus ?
Ca m'apparait être le 1er test à faire.

Si tu arrives à démarrer sur ton SSD branché en externe, alors qu'en interne le SSD n'est pas vu, je pense que la nappe sera émettre en cause (sauf s'il y a de l'électronique dans ton boitier Kingston " 2.5'' to 3.5'' SATA Drive Carrier")
 

stanval

Membre junior
28 Mai 2020
15
0
57
Bonjour Sly54 (j'ai adoré la dernière BD de Bilal, Bug et j'attend impatiemment la suite...)

Merci pour ta réponse. Le SSD est lu en externe sur un boitier simple ICY Box fait pour les disques 2.5'' branché avec USB.

Je n'ai pas essayé avec le boitier Kingston en externe, car c'est une boitier interne (à vrai dire je ne sais pas comment le tester avec ce boitier). Il n'y a a priori pas d'électronique, c'est un adapteur 2.5 à 3.5 avec une mini-carte SATA pour brancher et lire le SSD.

Est-ce que la version El Capitan serait en cause ?
Stanval

Quel test est-ce que je pourrais faire pour vérifier le fonctionnement du boitier Kingston ?
 
Dernière édition par un modérateur:

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 159
6 047
Nancy___
Le SSD est lu en externe sur un boitier simple ICY Box fait pour les disques 2.5'' branché avec USB.
Tu dis que le SSD est lu dans son boitier externe, OK, good.
Mais as tu démarré sur le SSD externe ?
C'est ça qu'il faut faire.



Il n'y a a priori pas d'électronique, c'est un adapteur 2.5 à 3.5 avec une mini-carte SATA pour brancher et lire le SSD.
OK, donc c'est "réducteur" de taille en fait ? Donc rien à tester.



j'ai adoré la dernière BD de Bilal, Bug et j'attend impatiemment la suite...)
Pas encore lu, je me le ferai offrir… un jour !
 
  • J’aime
Réactions: stanval

stanval

Membre junior
28 Mai 2020
15
0
57
Tu dis que le SSD est lu dans son boitier externe, OK, good.
Mais as tu démarré sur le SSD externe ?
C'est ça qu'il faut faire.




OK, donc c'est "réducteur" de taille en fait ? Donc rien à tester.




Pas encore lu, je me le ferai offrir… un jour !
Après le clonage du HDD, j'avais mis le SSD comme disque de démarrage, puis éteint le iMac et installé le SSD à la place du HDD, pour le forcer à démarrer sur le SSD, mais il n'a pas aimé.

Je vais essayer de démarrer le iMac en laissant le SSD en externe, bien vu! Faut y aller petit à petit avec l'info....
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 159
6 047
Nancy___
Après le clonage du HDD, j'avais mis le SSD comme disque de démarrage, puis éteint le iMac et installé le SSD à la place du HDD
OK, tu avais donc presque tout juste… ;)


Je vais essayer de démarrer le iMac en laissant le SSD en externe, bien vu!
Et si jamais tu arrives bien à démarrer sur ton SSD externe, tu auras démonté que ton SSD externe est OK.
 

stanval

Membre junior
28 Mai 2020
15
0
57
Tu dis que le SSD est lu dans son boitier externe, OK, good.
Mais as tu démarré sur le SSD externe ?
C'est ça qu'il faut faire.




OK, donc c'est "réducteur" de taille en fait ? Donc rien à tester.




Pas encore lu, je me le ferai offrir… un jour !
Là je suis un peu perdu... Le iMac a démarré avec le SSD en lecture externe sans problème. Soit c'est le "réducteur" qui foire, soit autre chose, soit ça marche ! Je vais à nouveau l'installer dans le iMac. Mais dois-je changer le disque de démarrage dans "Disque de démarrage" AVANT de faire le changement ou ne rien lui dire ? Je pourrais aussi mettre le HDD en externe et on verra bien!
 

stanval

Membre junior
28 Mai 2020
15
0
57
Là je suis un peu perdu... Le iMac a démarré avec le SSD en lecture externe sans problème. Soit c'est le "réducteur" qui foire, soit autre chose, soit ça marche ! Je vais à nouveau l'installer dans le iMac. Mais dois-je changer le disque de démarrage dans "Disque de démarrage" AVANT de faire le changement ou ne rien lui dire ? Je pourrais aussi mettre le HDD en externe et on verra bien!
Lorsque j'enlève le HDD, il y a le contrôleur de température pour le ventilateur que j'enlève directement, car pas de prise sur le boitier Kingston. D'après le tuto d'Exoaware, pour un SSD, un contrôleur de ventilateur virtuel va très bien.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 159
6 047
Nancy___
Le iMac a démarré avec le SSD en lecture externe sans problème. Soit c'est le "réducteur" qui foire, soit autre chose, soit ça marche !
C'est déjà une bonne nouvelle : l'installation sur le SSD est OK et ton SSD est OK.


Mais dois-je changer le disque de démarrage dans "Disque de démarrage" AVANT de faire le changement ou ne rien lui dire ?
Tu peux démarrer avec la touche alt enfoncée au démarrage : si le SSD interne ne t'est pas présenté, je dirais que c'est la nappe (le connecteur entre le SSD et la carte mère) le fautif.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 159
6 047
Nancy___
Lorsque j'enlève le HDD, il y a le contrôleur de température pour le ventilateur que j'enlève directement, car pas de prise sur le boitier Kingston. D'après le tuto d'Exoaware, pour un SSD, un contrôleur de ventilateur virtuel va très bien.
Ca par contre, je ne maitrise pas bien…
 

stanval

Membre junior
28 Mai 2020
15
0
57
C'est déjà une bonne nouvelle : l'installation sur le SSD est OK et ton SSD est OK.

Tu peux démarrer avec la touche alt enfoncée au démarrage : si le SSD interne ne t'est pas présenté, je dirais que c'est la nappe (le connecteur entre le SSD et la carte mère) le fautif.
Tu veux dire le boitier Kingston ?

J'ai fait le test sans installer le SSD dans le iMac, avec la touche Alt, je peux choisir le SSD comme disque de démarrage qui est en externe.
 
Dernière édition par un modérateur:

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 159
6 047
Nancy___
  • J’aime
Réactions: stanval

stanval

Membre junior
28 Mai 2020
15
0
57
Non, la nappe : étape 12
--> https://fr.ifixit.com/Tutoriel/Remplacement+du+disque+dur+de+l'iMac+Intel+215-Inch+EMC+2428/5954

(Débranchez le connecteur du câble de données SATA et le connecteur d'alimentation SATA de leurs prises respectives sur le disque dur)

si tu as bien un 21,5" 2428, donc un mid-2011.
Super le tutoriel! Mais si la nappe ne fonctionnait pas pour le SSD, ce serait pareil pour le HDD, alors que le HDD fonctionne (je l'ai déjà enlevé et remis 3x...) ? Comme dans l'étape 19 je n'ai pas de connecteur pour la température lorsque je met le SSD en interne, ça pourrait aussi être ça qui pose problème.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 159
6 047
Nancy___
Super le tutoriel! Mais si la nappe ne fonctionnait pas pour le SSD, ce serait pareil pour le HDD, alors que le HDD fonctionne (je l'ai déjà enlevé et remis 3x...) ?
Non, les nappes peuvent laisser passer le débit des disques durs et ne pas réussir à laisser passer le débit (beaucoup plus important) du SSD.
C'est un grand classique dans certains modèles de MBP, c'est plus rare sur les iMac.
 
  • Wow
Réactions: stanval

stanval

Membre junior
28 Mai 2020
15
0
57
Non, les nappes peuvent laisser passer le débit des disques durs et ne pas réussir à laisser passer le débit (beaucoup plus important) du SSD.
C'est un grand classique dans certains modèles de MBP, c'est plus rare sur les iMac.
Mince, si c'est le cas, je dois changer de nappe ? Si tu as des infos la-dessus pour les iMac je suis preneur.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 159
6 047
Nancy___
Mince, si c'est le cas, je dois changer de nappe ? Si tu as des infos la-dessus pour les iMac je suis preneur.
Je trouve que dans ton cas, la nappe fait un coupable idéal : le SSD est parfaitement reconnu en externe, tu peux démarrer dessus. En interne, le SSD n'est pas reconnu.
Regarde chez MacWay ou iFixit pour trouver une nappe de qualité (35 à 50€).
 

stanval

Membre junior
28 Mai 2020
15
0
57
Je trouve que dans ton cas, la nappe fait un coupable idéal : le SSD est parfaitement reconnu en externe, tu peux démarrer dessus. En interne, le SSD n'est pas reconnu.
Regarde chez MacWay ou iFixit pour trouver une nappe de qualité (35 à 50€).
Salut,
J'ai réinstallé le SSD mais il n'est pas reconnu. Mon modèle est iMac 21,5'' mi-2010 EMC 2389. La ssd fan control ne diminue pas le bruit. Damned...
 

stanval

Membre junior
28 Mai 2020
15
0
57