DreamWeaver cs4 avec PHP en localhost

Michelou

Nouveau membre
2 Novembre 2008
6
1
69
Eure
Bonjour,
La visualisation du site ne se fait pas avec Safari.
Les réglages "Gérer les sites" en locales, distantes et évaluation apparaissent bien en détails dans Fichiers.
Par contre, lorsque je lance le navigateur, je tombe sur la page d'Apache :
« Vous voyez cette page au lieu du site attendu ? » qui se termine avec la plume et Apache.

Vous avez une p'tite idée du problème ?
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Bonjour,
La visualisation du site ne se fait pas avec Safari.
Les réglages "Gérer les sites" en locales, distantes et évaluation apparaissent bien en détails dans Fichiers.
Par contre, lorsque je lance le navigateur, je tombe sur la page d'Apache :
« Vous voyez cette page au lieu du site attendu ? » qui se termine avec la plume et Apache.

Vous avez une p'tite idée du problème ?
Tu as activé le partage web c'est ça ?

Il faut mettre ton site au bon endroit, je ne sais aps où c'est dans Leopard mais si tu le met dans ton dossiers Sites de ta maison, tu peux y accéder en allant sur http://localhost/~username/ (changer username par le tien).

:)
 

Michelou

Nouveau membre
2 Novembre 2008
6
1
69
Eure
Bonsoir,
Dans "Préf. Syst. » Partage", j'ai coché "Partage Web perso." et "Partage de fichiers (est) désacivé".
Le dossier (site1) du site "alibaba" est installé sur une partition du disque dur nommée Araignix.
Donc, avec Gérer les sites, on trouve :
» Infos locales :
- Nom du site : alibaba
- Dossier racine local : /Volumes/Araignix/site1
- Liens relatifs à : La racine du site
- Adresse HTTP : http://localhost/~michel/
» Infos distantes :
- Accès : Local/Réseau
- Répertoire distant : /Users/michel/Sites/site1
- (x) Conserver les informations de synchronisation
» Serveur d'évaluation :
- Modèle de serveur : PHP MySQL
- Accès : Local/Réseau
- Dossier du serveur d'évaluation : / Volumes/Araignix/site1
- Préfixe de l'URL : http://localhost/users/~michel/

Enfin, lorsque j'ouvre Fichiers » Affichage Local ou Distant ou Serveur d'évaluation, j'ai bien le dossier site1 dans les trois cas, associé à la page index.html.
Par contre, lorsque je lance l'aperçu avec Safari, j'ai le message : "Not Found
The requested URL /users/~michel/index.html was not found on this server.
Apache/1.3.41 Server at new-host.home Port 80"
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Bonsoir,
Dans "Préf. Syst. » Partage", j'ai coché "Partage Web perso." et "Partage de fichiers (est) désacivé".
Le dossier (site1) du site "alibaba" est installé sur une partition du disque dur nommée Araignix.
Donc, avec Gérer les sites, on trouve :
» Infos locales :
- Nom du site : alibaba
- Dossier racine local : /Volumes/Araignix/site1
- Liens relatifs à : La racine du site
- Adresse HTTP : http://localhost/~michel/
» Infos distantes :
- Accès : Local/Réseau
- Répertoire distant : /Users/michel/Sites/site1
- (x) Conserver les informations de synchronisation
» Serveur d'évaluation :
- Modèle de serveur : PHP MySQL
- Accès : Local/Réseau
- Dossier du serveur d'évaluation : / Volumes/Araignix/site1
- Préfixe de l'URL : http://localhost/users/~michel/

Enfin, lorsque j'ouvre Fichiers » Affichage Local ou Distant ou Serveur d'évaluation, j'ai bien le dossier site1 dans les trois cas, associé à la page index.html.
Par contre, lorsque je lance l'aperçu avec Safari, j'ai le message : "Not Found
The requested URL /users/~michel/index.html was not found on this server.
Apache/1.3.41 Server at new-host.home Port 80"
Ben apparemment c'est pas correctement configuré puisque l'url /users/~michel/index.html n'est pas trouvée alors que (si j'ai bien compris) ça devrait afficher /Volumes/Araignix/site1/index.html.

Mais là on peut pas t'aider on sait pas comment c'est configuré.
 

tatouille

Vétéran
1 Juin 2004
5 174
494
Stanford CA
quelque chose de bizarre ici ?
/users/~michel/index.html

l'erreur devrait etre : /~michel/index.html not found

racine http du virtual host
/~michel

document_root du vhost:
/Users/michel/Sites

/Users/michel/Sites/index.html

tu t'es merde dans ta config
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
quelque chose de bizarre ici ?
/users/~michel/index.html

l'erreur devrait etre : /~michel/index.html not found

racine http du virtual host
/~michel

document_root du vhost:
/Users/michel/Sites

/Users/michel/Sites/index.html

tu t'es merde dans ta config
mais il parle d'une configuration avec apache qui regarde dans une autre partoch et tout donc je pense que c'est une config perso d'où peut-être le /users.
 

Michelou

Nouveau membre
2 Novembre 2008
6
1
69
Eure
Bonsoir,
Pour Tatouille : mon disque dur est partitionné d'une part et il y a deux utilisateurs déclarés sur cet ordinateur d'autre part : c'est peut-être la raison du "users"

Pour P4b10 :
- Dois-je cocher "Partage web" à ton avis ? Je ne comprend pas bien cette fonction.
- Mon site est sur la partition "Sites" et dans le dossier "Site1".