MacBook Air Écran externe bloqué en zoom

Aquilane

Membre junior
8 Mars 2006
87
11
46
Bonjour !

Je rencontre un problème fort étrange et au moins tout aussi fort agaçant.

La version courte : mon MacBook Air est connecté sur un écran externe Dell via un adaptateur HDMI tierce. L’affichage est en zoom (comme après utilisation de l’option de zoom de « Accessibilité » et rien ne le fait revenir à un affichage normal. Je ne vois plus la barre de menu et seulement la moitié du Dock.

La version longue : je bossais sur le Mac quand je me suis interrompue pour répondre à quelqu’un. Du coin de l’œil, j’ai vu que le Mac passait en veille, donc j’ai passé le doigt sur le trackpad Bluetooth pour le garder éveillé. C’est depuis ce moment-là que l’écran est bloqué en zoom. À ce moment là, je pouvais, en bougeant la souris, naviguer dans l’écran (accessibilité,je vous dis !) mais j’ai perdu cette faculté après le premier redémarrage.

Si je me connecte au même écran avec l’adaptateur VGA, tout va bien.
J’ai essayé de passer en recopie vidéo puis de revenir sans succès.
J’ai zappé la P-Ram. Rien.
J’ai bidouillé tous les menus possibles sur le moniteur, nada.
J’ai changé d’utilisateur, même comportement.
J’ai démarré en mode sans échec sans plus de succès.
J’ai viré des préférences, mais je n’ai pas trouvé la bonne : celle qui enregistre la position d’un écran externe par rapport à l’écran interne. Je pense que mon Graal serait dans cette préférence là, mais impossible de mettre la main dessus...

Bref, je suis au bout de mon inspiration et j’en appelle donc à votre imagination et/ou à votre connaissance !

Merci d’avance !
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 242
6 078
Nancy___
Bonjour,

Avec une souris, c'est ctrl molette de défilement pour zoomer / dézommer.
Avec le trackpad, ctrl et pincer 2 doigts et rapprocher ???
 

Aquilane

Membre junior
8 Mars 2006
87
11
46
Bonjour,

Avec une souris, c'est ctrl molette de défilement pour zoomer / dézommer.
Avec le trackpad, ctrl et pincer 2 doigts et rapprocher ???
En fait, c’est soit pincer (sur un document), soit ctrl + balayage deux doigts vers le haut / le bas (pour tout l’écran).
Par acquis de conscience, je viens de tenter un ctrl + pincement deux doigt. Mais non... Merci pour l’idée quand même !

Le malheur est que je n’ai pas tenté la bonne manipulation avant de bêtement suspendre l’activité de mon mac en pensant qu’il allait se remettre d’aplomb en se réactivant. Je pense qu’à ce moment-là, ça aurait peut-être encore marché. Là, on dirait qu’il pense que l’écran est plus large, tout simplement.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 242
6 078
Nancy___
Et ça n'est pas un réglage lié à ton moniteur Dell, donc passer par les réglages directement sur l'écran ?
 

ecatomb

Membre d’élite
Club MacG
21 Septembre 2016
4 299
1 476
J'ai pensé à ça, mais vu comment c'est arrivé... je doute qu'un réglage directement sur l'écran soit dispo
 

Aquilane

Membre junior
8 Mars 2006
87
11
46
Et ça n'est pas un réglage lié à ton moniteur Dell, donc passer par les réglages directement sur l'écran ?
J’ai vérifié un par un tous les menus de l’écran, fait des essais mais ça n’a rien donné.
Et vu que ça marche via l’adaptateur VGA et que ça fonctionnait avant, ça ressemble plus à une préférence foireuse, non ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 242
6 078
Nancy___
Et vu que ça marche via l’adaptateur VGA et que ça fonctionnait avant, ça ressemble plus à une préférence foireuse, non ?
Un test dans une session Invité devrait répondre à cette question.
 

ecatomb

Membre d’élite
Club MacG
21 Septembre 2016
4 299
1 476
J'ai testé les gestes trackpad : double tap avec 3 doigts puis on fait défiler vers le haut (ou le bas) pour zommer (dézoomer). Cela me le fait sur les 2 écrans externe de mon mac mini. Aucune idée du résultat sur un macbook
Capture d’écran 2020-05-23 à 22.08.26.png
 

Aquilane

Membre junior
8 Mars 2006
87
11
46
Un test dans une session Invité devrait répondre à cette question.
J’ai changé d’utilisateur : même comportement.

J’ai du coup découvert que la disposition de l’écran est conservé entre les deux sessions ; la préférence doit donc être au niveau système et pas utilisateur.
 

Aquilane

Membre junior
8 Mars 2006
87
11
46
J'ai testé les gestes trackpad : double tap avec 3 doigts puis on fait défiler vers le haut (ou le bas) pour zommer (dézoomer). Cela me le fait sur les 2 écrans externe de mon mac mini. Aucune idée du résultat sur un macbook
Voir la pièce jointe 175217
J’ai vérifié les gestes qui sont paramétrés sur mon portable et je les ai déjà tous essayé.
Par acquis de conscience, j’ai activé le geste dont tu parles et je l’ai également essayé... toujours pareil ! ‍♀

Ça fonctionne d’ailleurs très bien : je zoome et je dézoome... sauf que le « dézoomage » s’arrête avant d’être complet...
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
42 242
6 078
Nancy___

Aquilane

Membre junior
8 Mars 2006
87
11
46
Etonnant mais ça peut se vérifier aisément : va dans le dossier Bibliothèque à la racine de ton disque, puis dans Préférences et là… cherche… (éventuellement par Date).[/URL].
C’est bien ce que j’avais fait... sans succès :
J’ai été dans le dossier bibliothèque du système pour regarder les préférences. J’ai d’abord cherché en regardant leur nom puis leur heure de modification. J’ai bougé la disposition de l’écran pour voir les fichiers qui étaient modifiés mais impossible de mettre la main sur le « bon ». J’en ai supprimé quatre qui semblaient prometteurs : deux .icc dont le nom est DELLxxx et qui semblent liés au connecteur VGA ou HDMI et deux plist (windowserver et apsd si je me souviens bien).
Avant de les supprimer, j’ai débranché l’écran que je n’ai rebranché qu’après le redémarrage complet.
J’y ai cru... mais non.
Il doit être planqué ailleurs ou bien dans un dossier d’un dossier d’un dossier...

Si,si, j’ai bien fait un démarrage sans échec et j’ai même zappé la PRAM (je ne savais pas que ça se faisait encore ! Pas dû faire ça depuis 10 ans au moins ;-) ).
Par contre, je n’ai pas réinitialisé le SMC. Je fais ça au plus vite et je reviens donner le résultat !
Merci des suggestions, en tout cas !
 

Aquilane

Membre junior
8 Mars 2006
87
11
46
Attention, je ne parle pas de Système / Bibliothèque, mais vraiment de la Bibliothèque à la racine de ton disque.
Oui, j’ai cherché dans les deux...
Mais je vais revérifier quand même, on ne sait jamais...
 

ecatomb

Membre d’élite
Club MacG
21 Septembre 2016
4 299
1 476
Branche ton macbook à un autre écran :p
 

Aquilane

Membre junior
8 Mars 2006
87
11
46
Branche ton macbook à un autre écran :p
Je viens de faire le test sur une télé Philipps HDMI. Je constate le même problème, alors que l’organisation des écrans n’a pas été conservée entre les deux configurations. Cela donne à mon sens deux possibilités : il y a un problème matériel avec l’adaptateur (Icy box IB-AD506 de RaidSonic - je viens de mettre un message sur leur site) ou bien il y a une préférence liée au type de liaison (HDMI / VGA) ou à l’adaptateur en lui-même. [comment ça, ça fait trois possibilités ??? :p )
 

ecatomb

Membre d’élite
Club MacG
21 Septembre 2016
4 299
1 476
Donc écran externe en hdmi : zoom actif
En VGA : zoom inactif
Peut-être une option lié au hdmi ?

Et sur le macbook air, il y a aussi le zoom ou pas sur son écran ?
 

ecatomb

Membre d’élite
Club MacG
21 Septembre 2016
4 299
1 476

Aquilane

Membre junior
8 Mars 2006
87
11
46
Donc écran externe en hdmi : zoom actif
En VGA : zoom inactif
Peut-être une option lié au hdmi ?

Et sur le macbook air, il y a aussi le zoom ou pas sur son écran ?
Bon résumé de la situation. Pas de zoom sur le MBA.

J’ai fait un essai tout à l’heure : si je sors de l’écran avec le pointeur et que je clique en haut à gauche, je vois bien un bout de menu qui s’ouvre. On est donc dans un espèce de truc bizarre, comme si le Mac considérait l’écran comme plus grand qu’il n’est.