Gros pb avec memoire vive, toute utilisée sans rien...

sodx

Membre confirmé
18 Novembre 2007
80
0
Je fais un historique un peu long mais pour etre certaine que je vous donne le max d'elements.

Vendredi j'ai eu un message me disant que je n'avais plus assez d'espace sur mon disque de demarrage pour les appli, j'ai cherché pourquoi car j'avais encore environ 50 Go de libre (mac book pro d'octobre 250go de dd et 4 de ram) et qu' il était tout ralenti, j'ai trouvé cette manip que j'ai effectué :http://www.commentcamarche.net/faq/15279-entretenir-et-reparer-mac-os-10 . En plus j'ai viré des trucs que je pouvais mettre ailleurs sur mon dd externe pour alleger au maximum, vidé mes cache et cookies, mais rien de technique pour moi (j'ai onyx mais j'ai tellement peur de faire des betises à la suite de ce que j'ai pu en lire que je ne l'utilise pas et fait seulement des trucs basiques "à la main").

Tout semblait refonctionner à merveille j'etais tres contente, surtout qu'avec mes diverses recherches j'ai découvert le moniteur d'activites et que je me suis dit que ce serait fort pratique à l'avenir pour controler quelle appli me mange quoi en memoire

Aujourd'hui il me semble que c'est + catastrophique...
Je n'avais aucune appli ouverte à part quicktime, je regardais une video deconnectée de tout (reseau wifi bluetooth, alim etc) quand la video a commencé a saccader et bloquer.

Là je regarde mon moniteur et je me retrouve avec 4go de memoire vive d'utilisée...

Je redemarre, ça semble ok, j'ouvre le moniteur d'activité qui me dit 1.10 go utilisé et 2.90 dispo... Je me dis ok, je commence à ouvrir le finder et là le vois le camembert de la memoire utilisée/ libre s'emballer et monter 4 go à nouveau

J'ai fait plusieurs reboot depuis mais c'est toujours la meme histoire
Au démarrage tout semble normal
Puis environ dans les 5 minutes d'un seul coup la mémoire utilisée monte jusqu'au maximum sans que je n'ai ouvert aucune application

Je suis assez paniquée car c mon outil de travail et que là je ne peux plus rien faire
Un virus pourrait faire cela ?
Est-ce le signe d'une memoire defaillante ?
Qu'est ce que je peux faire comme manip ?

J'ai fait des recherches sur le sujet mais n'ai rien trouvé, autant la phrase "disque de demarrage manque d'espace" m'apportait des resultats qui ont pu m'aider sur les moteurs autant là je ne sais pas avec quel mot clés chercher pour expliquer cette montée d'utilisation de memoire vive sans motif apparent...

Je vous remercie par avance de votre aide
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Mac OSX utilise la RAM au maximum, mais là, en 5mn, c'est anormal.
Que faire ?
Quelques suggestions :
1. Aller voir dans les préférences système à compte/ouverture, mais tu l'as sans doute déjà fait ...
2. Vérifier ton disque (par exemple avec Onyx, y compris la vérification de l'état smart). Déjà fait aussi, sans doute ...
3. Faire un test hardware en particulier pour voir ce qu'il dit de la mémoire...
 

sodx

Membre confirmé
18 Novembre 2007
80
0
en cours de test hardware avec le cd d'install...je reviens dès que j'en sais +

---------- Nouveau message ajouté à 19h17 ---------- Le message précédent a été envoyé à 18h53 ----------

mais j'ai peur... j'ai demandé un test étendu certes mais j'ai commencé le test à 19h47, il est 20h15 et je n'ai avancé que de 20% de la barre d'avancement et il est noté "durée du test 6min16"

---------- Nouveau message ajouté à 20h46 ---------- Le message précédent a été envoyé à 19h17 ----------

pfff aucun probleme materiel de détecté, ça devrait me rassurer mais comme ça ne résout rien je reste bien embetée
...

une idée d'autre test ?
 

sodx

Membre confirmé
18 Novembre 2007
80
0
nouvel indice :

finalement la situation semblait etre revenue à la normale, ma mémoire vive ne se retrouvait plus à saturation et je pouvais à nouveau ouvrir plusieurs appli et travailler

et puis j'ai voulu à nouveau regarder une video avec quicktime et là ça y est c reparti, l'occupation de la mémoire augmente jusqu'à son maximum...
J'arrive à sortir de quicktime sans violent reboot par la patience, à redemarrer, mais ça refait la même chose.

Alors je vais faire ce que j'ai déjà fait à savoir le truc fsck -fy meme si normalement cela concerne le disque de demarrage, la dernière fois ça a marché...

Mais je me demandais si cela n'étais pas le signe d'un problème avec la carte graphique ?
Et pour etre sur de cela que dois-je faire ?
Je rappelle que le scan materiel n'a rien détecté...

Merci de votre aide, je sens que je vais encore y perdre ma journée, mais bon je peux rien faire d'autre c mon outil de travail...
 

Romuald

Bof...
Modérateur
Club MacG
14 Septembre 2006
9 103
3 795
N'ai pas peur d'ONYX : il ne fait rien qu'éxécuter des tâches prévues par l'OS. Surtout tu dis que tu as un DD externe, donc tu peux commencer par faire un clone bootable de ton DD interne si tu veux être sure de pouvoir revenir à l'état 'avant ONYX'.

Dans un premier temps, inutile d'aller au fond des choses avec Onyx. Déjà rien qu'en lançant 'automation', ça va faire un nettoyage de base de ton ordi. En ce qui me concerne je coche tout, sauf 'affichage du contenu des dossiers' 'caches partagés dyld' 'index de spotlight' et 'caches systèmes'.
Cela prend du temps (surtout la réparation des autorisations), et le redémarrage aussi sera rallongé car OSX n'aura plus rien en cache. Patience...

Et bonne chance !
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
51 818
9 821
Nancy___
et puis j'ai voulu à nouveau regarder une video avec quicktime et là ça y est c reparti, l'occupation de la mémoire augmente jusqu'à son maximum...
Ce qui serait intéressant que tu fasses c'est de ne pas ouvrir QT pdt 1 journée : tu bosses avec tes logiciels normalement sauf QT, pour voir si le pb se produit ou pas.
S'il ne se produit pas ça orientera la recherche des causes (fichier préférence de QT vérolé par ex.)

2e piste : teste la lecture video dans QT dans une autre session.
 

sodx

Membre confirmé
18 Novembre 2007
80
0
je vais essayer
mais pas sure d'y arriver
comme ma ram part en sucette au bout de 5 minutes j'arrive pas à faire grand chose, tout est + que ralenti

---------- Nouveau message ajouté à 09h54 ---------- Le message précédent a été envoyé à 09h49 ----------

pour sly54, je suis pas tres douée, enfin disons que j'ai une utilisation tres basique alors ouvrir une session differente pour QT...

sinon je me souviens que le 1er "blocage" est apparu suite à un PPT (suite office pour mac) trop chargé en images...mais à ce moment là je ne connaissais pas le moniteur d'activites et je ne peux donc pas etre certaine qu'il s'agisse d'un plantage RAM...d'où ma question "carte graphique"... si ça me plante quand ya de l'image...

mais bon si ça me plante quand ya de l'image à gérer je suis pas sortie d'affaire
 

divoli

Membre vénérable
Club MacG
13 Août 2005
15 868
1 419
Il faudrait essayer de réinitialiser la PRAM. Mais bon, sans conviction...
 

sodx

Membre confirmé
18 Novembre 2007
80
0
pour la pram je l'ai fait plusieurs fois, sans succes effectivement

et puis là maintenant plus rien n'y fait
ce que je faisais avant qui n'etait pas forcement en rapport mais semblait quand meme regler mon probleme (fsck scan du disque...) n'y fait plus rien

je demarre ça semble normal puis dans les 5 minutes d'un seul coup j'entend l'ordi "travailler" et je regarde le moniteur d'activité et ma ram qui s'occupe s'occupe jusqu'au max sans aucune raison
je deviens desesperée, surtout de ne pas trouver un début d'explication...
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
51 818
9 821
Nancy___
pour sly54, je suis pas tres douée, enfin disons que j'ai une utilisation tres basique alors ouvrir une session differente pour QT...
Pour créer une nouvelle session, passe par Préferences système, l'item s'appelle "Comptes" et tu as un gros + pour ajouter un nouveau compte.

Ensuite, QT tu y as accès car il est dans le dossier applications…
 

sodx

Membre confirmé
18 Novembre 2007
80
0
merci sly je vais essayer des que possible, pour le moment je ne peux rien faire, dès que je redemarre dans les 3 à 5 minutes la ram s'enflamme et je ne peux plus cliquer sur quoi que ce soit...

---------- Nouveau message ajouté à 11h51 ---------- Le message précédent a été envoyé à 10h49 ----------

je suis complètement désespérée, je vais finir par aller vers un magasin agréé, toujours avec désespoir car je sens bien qu'ils vont pas résoudre mon problème dans la journée et que ça va me prendre la semaine (s'ils renvoient pas la machine à Apple) et que donc je ne peux absolument pas travailler pendant ce temps...

Avant je voudrais par nouvelle mesure de précaution (même si j'ai plusieurs sauvegardes par time machine sur 2 dd externes) faire "un clone bootable de mon DD interne" comme le préconisait Romuald, je fais comment svp ?

merci
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
51 818
9 821
Nancy___
dès que je redemarre dans les 3 à 5 minutes la ram s'enflamme et je ne peux plus cliquer sur quoi que ce soit...
Sans rien faire, sans lancer une seule application ?
Il doit y avoir des process lancés en tâche de fond…

Pour le clone bootable, utilise soit Carbon copy cloner, soit superduper, au choix. De l'aide sur ces 2 logiciels ici.
Mais si le pb vient de ton système ou de process lancés en tache de fond, alors le clone aura les mêmes problèmes !
 

Romuald

Bof...
Modérateur
Club MacG
14 Septembre 2006
9 103
3 795
.../... ma ram qui s'occupe s'occupe jusqu'au max sans aucune raison
je deviens desesperée, surtout de ne pas trouver un début d'explication...

Puisque tu as 5mn pour agir, histoire d'essayer d'y voir plus clair :

- Boot de l'ordi
- Dès que tu es dans ta session, lancer le moniteur d'activité
- Dans le menu déroulant du haut, vérifier que tu as bien 'toutes les opérations'
- Cliquer dans l'en-tête de colonne 'mémoire réelle' histoire de trier les process en fonction de ce qu'ils consomment en mémoire. triangle pointe en bas pour avoir un tri décroissant.

Et attendre que ton problème ressurgisse...

Sinon, quand tu dis que toute ta ram est occuppée, pourrais-tu nous dire de quelle manière (disponible, résidente,...) tout au début, puis au moment du problème ?
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Je réalise : le cryptage FileVault ne serait pas activé ? Si oui je crois qu'il ne faut pas chercher plus loin.
 

sodx

Membre confirmé
18 Novembre 2007
80
0
@ docteur "le cryptage FileVault" je sais pas ce que c'est donc a priori j'y ai pas touché, mais s'il faut vérifier alors il faudrait me dire par où et comment , merci

@romuald je vais essayé de faire des copies d'ecran et de les envoyer ici (ça va être un peu long 5 min pour les copies, puis reboot, puis 5 minutes pour les envoyer sur une boite mail externe que je puisse utiliser depuis le present pc qui est de la m...mais me permet de communiquer ;))

---------- Nouveau message ajouté à 14h19 ---------- Le message précédent a été envoyé à 13h32 ----------

voilà mon avancement...

en effet je n'avais pas toutes les operations dans mon moniteur, c'est pourquoi je n'arrivais pas à voir ce qui pouvait me manger autant de ram, merci romuald !
là sur la dernière montée j'ai pu remarquer un truc chelou "pdftopdf" qui est monté jusqu'à 100% à un moment pour redescendre à 30 environ
chelou car je n'ai rien ouvert comme appli
en cherchant il s'agirait peut etre de l'appli de l'imprimante hp
je poursuis mes investigations, car une fois arrivée à 100% d'utilisation je dois redemarrer bien évidemment...
si c'est cela je maudis HP !!!
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Préférences systèmes / Sécurité / Filevault

---------- Nouveau message ajouté à 15h27 ---------- Le message précédent a été envoyé à 15h23 ----------

Un clic droit sur "pdftopdf" et une recherche sur Google me dévoile par exemple ce post et m'apprend que c'est peut-être un gestionnaire HP (tiens donc!) qui te pourrit la vie. Apparemment c'est désinstallable : pas anglophobe ?
Ah oui, non ... il disent de désinstaller et réinstaller le logiciel HP (ce qui accessoirement tend à foutre le soukh dans la gestion des imprimantes) et ça ne règle pas le système.

Je dirais que tu devrais aller sur le site d'HP pour chercher un pilote plus récent pour Snow Léopard (tu es bien sous SL ?) et s'il y en a un, désinstaller cette cochonceté (je pèse mes mots), rebooter le système. Il n'est malheureusement pas impossible que HP laisse des bouts dans ton système et t'oblige à réinitialiser le système d'impression (c'est facile, pas d'inquiétude) : parce que souvent on se retrouve avec l'impression .PDF qui saute à la désinstallation (eh oui ! ils codent avec les pieds chez HP, mais ils semblent s'améliorer un peu dernièrement).
 

sodx

Membre confirmé
18 Novembre 2007
80
0
bon ben voilà qui est fait : j'ai désinstallé les imprimantes hp

ça a l'air d'etre + stable maintenant mais je me méfie, depuis 3 jours je croyais toujours en être sortie et ça recommençait l'heure d'après
et puis j'ai eu tellement de messages "disque de démarrage plein" alors qu'il ne s'agissait vraisemblablement pas de ça que bon je reste dubitative...
car comment expliquer aussi que ça se soit emballé en utilisant QT, qu'ensuite ça s'emballe sans même faire appel à une imprimante...
bref méfiance mefiance et maudit soit HP ;)

merci à tous pour vos soutien et conseils, j'espère ne pas avoir à revenir vous en demander, conclusion à noter donc pour le moment : imprimante HP peut faire ramer ...
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Vérifie si quand tu veux faire une impression, tu obtiens encore ce bouton :

20100531-tts7e5fyig2in84n1f6h8kcxsj.png


S'il a disparu (ou si quelque chose m... dans les imprimantes) va faire un tour dans le gestionnaire d'imprimantes : Préférences systèmes/Imprimantes et Fax /

Clic droit sur le panneau à droite pour faire apparaître ce menu :

20100531-msers227snrf1twsmn6ttembrk.png


Clic !

Tu retrouveras ton impression .PDF....
 

sodx

Membre confirmé
18 Novembre 2007
80
0
Merci Doc ;) j'ai vérifié et j'ai bien le bouton pour créer des pdf depuis l'impression, s'il disparaissait j'ai déjà la soluce maintenant !

ça a l'air de tenir la route pour le moment
ce qui fait que j'enrage encore + contre hp car depuis 3 jours que de temps perdu pour une imprimante que je n'utilise meme pas ... (je minimise au max l'utilisation du papier, tout est +tôt numérisé chez moi, mais résultat, sans ordi, c'est la panique)
Aucun des messages et des symptomes ne pouvait me faire penser à regarder de ce côté là, bref tout ça pour ça c'est bien beaucoup d'energie pour un truc finalement tout bête

Merci à tous, j'espère que ça pourra servir à d'autres, comme ça le temps aura été moins perdu !
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Au cas où tu utiliserais tout de même ton imprimante :
1. Elle marche peut-être toute seule avec Snow Leopard (quoique la désinstallation tend à virer aussi les pilotes HP Apple).
2. Aller voir sur le site HP s'il n'y a pas une version spéciales pour Snow Léopard.