gros probleme safari 5

Le docteur

Membre expert
Club MacG
8 Février 2008
6 148
737
53
Réinstallé Léopard (et non SL).
Pas encore testé avec les anti-pub. Mais je commence à me demander si ce n'est pas une réaction violente à ces logiciels qui est en train de s'amorcer auprès de nos chers fournisseurs de pub (dont Apple). Si ça s'avérait vrai, ce serait une belle dégueulasserie. Parce que franchement : le Net tel que je l'ai sous les yeux, c'est merdique.
 

Zacks

Membre enregistré
15 Janvier 2009
4
0
Bon. Il est clair que de gros problèmes existent avec Safari 5. On trouvera sur ce site de très nombreuses solutions (ôter Glims, désinstaller tel ou tel truc ou machin, etc ...) Pour certains cela marche; et pour d'autres le problème reste entier (le plus souvent, aucun accès http). L'assistance Apple (les gros malins ...) explique que Safari 5 est incompatible avec certains plug-ins et conseille de désinstaller tous les logiciels qui ne seraient pas Apple ... Bonne pomme !.
En clair, l'idéal est DE NE PAS EFFECTUER LA MISE A JOUR DE SAFARI !
Si malheureusement on s'est laissé tenter, il faut tout virer et se servir de Time Machine pour restaurer Safari 4.0.5. (à la condition de se servir de ce superbe outil et de l'avoir paramétré en conséquence).
Maintenant, si vous avez Mac OS X 10.5.8 et que vous ne disposez pas de Time Machine, il n'existe apparemment aucun site où il est possible de télécharger 4.0.5. pour 10.5.8. Vous le trouverez pour Tiger, mais pour Leopard, nib...
Il vous reste alors une solution : le réinstaller à partir des CDRom d'installation livrés avec l'ordi.
Entendons-nous bien : je vaux zéro en informatique et suis un piètre bidouilleur. Mon msg s'adresse donc à des gens comme moi.
Il y a sûrement des membres de ce forum capables, sans problème, d'offrir des solutions alternatives, globales et sûres. Bonne chance à tous.

---------- Post added at 21h29 ---------- Previous post was at 21h20 ----------

Bon. Il est clair que de gros problèmes existent avec Safari 5. On trouvera sur ce site de très nombreuses solutions (ôter Glims, désinstaller tel ou tel truc ou machin, etc ...) Pour certains cela marche; et pour d'autres le problème reste entier (le plus souvent, aucun accès http). L'assistance Apple (les gros malins ...) explique que Safari 5 est incompatible avec certains plug-ins et conseille de désinstaller tous les logiciels qui ne seraient pas Apple ... Bonne pomme !.
En clair, l'idéal est DE NE PAS EFFECTUER LA MISE A JOUR DE SAFARI !
Si malheureusement on s'est laissé tenter, il faut tout virer et se servir de Time Machine pour restaurer Safari 4.0.5. (à la condition de se servir de ce superbe outil et de l'avoir paramétré en conséquence).
Maintenant, si vous avez Mac OS X 10.5.8 et que vous ne disposez pas de Time Machine, il n'existe apparemment aucun site où il est possible de télécharger 4.0.5. pour 10.5.8. Vous le trouverez pour Tiger, mais pour Leopard, nib...
Il vous reste alors une solution : le réinstaller à partir des CDRom d'installation livrés avec l'ordi.
Entendons-nous bien : je vaux zéro en informatique et suis un piètre bidouilleur. Mon msg s'adresse donc à des gens comme moi.
Il y a sûrement des membres de ce forum capables, sans problème, d'offrir des solutions alternatives, globales et sûres. Bonne chance à tous.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 041
5 708
Là-haut
Encore un poste très mal informé dont l'auteur aurait pu s'épargner la peine de le rédiger.

Si tu veux des extensions, tu utilises Firefox ou tu attends qu'il y en ait de suffisamment développés pour Safari 5.

Les hacks divers ne sont et n'ont jamais été supportés par Apple.

Et pour finir, parce que j'en ai marre des pleureuses dans ton genre : http://support.apple.com/downloads/#safari

Ho ! Un site, avec plein de versions de Safari. Etonnant ! :siffle:

Banane !
 

Zacks

Membre enregistré
15 Janvier 2009
4
0
Encore un poste très mal informé dont l'auteur aurait pu s'épargner la peine de le rédiger.

Si tu veux des extensions, tu utilises Firefox ou tu attends qu'il y en ait de suffisamment développés pour Safari 5.

Les hacks divers ne sont et n'ont jamais été supportés par Apple.

Et pour finir, parce que j'en ai marre des pleureuses dans ton genre : http://support.apple.com/downloads/#safari

Ho ! Un site, avec plein de versions de Safari. Etonnant ! :siffle:

Banane !
Merci beaucoup pour l'adresse que je ne connaissais pas, quand bien même les versions y figureraient en anglais.

PS. Je me moque pas mal de me faire traiter de "pleureuse" par des prétentieux dans ton genre. Ce qui m'importe c'est qu'un vieil idiot comme moi arrive à faire marcher son bidule, au besoin en bénéficiant de tes conseils avisés. Je n'ai, hélas, ni les capacités, ni le temps d'avoir la science infuse. Et le ridicule ne tue plus depuis longtemps ...
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 041
5 708
Là-haut
Merci beaucoup pour l'adresse que je ne connaissais pas, quand bien même les versions y figureraient en anglais.

PS. Je me moque pas mal de me faire traiter de "pleureuse" par des prétentieux dans ton genre. Ce qui m'importe c'est qu'un vieil idiot comme moi arrive à faire marcher son bidule, au besoin en bénéficiant de tes conseils avisés. Je n'ai, hélas, ni les capacités, ni le temps d'avoir la science infuse. Et le ridicule ne tue plus depuis longtemps ...
Ben dis donc, c'est Raymond qui va être content. :siffle:

Safari 4.0.5 est bourré de failles de sécurité documentées, maintenant, tu fais comme tu veux...

Réinstaller Safari 4.0.5 sur 10.5.8 :
1. Prendre son DVD de Leopard et réinstaller l'OS en choisissant l'option "Archiver et installer"
2. Faire la mise à jour combinée 10.5.8
3. Appliquer la mise à jour de sécurité 2010-004
4. Installer Safari 4.0.5

Virer le dossier "Previous system".

Lancer la mise à jour de logiciel pour être sûr de n'avoir rien oublié (mais décocher la case vis-à-vis de Safari 5 avant de lancer l'installation).

P.S. : les liens renvoient vers les pages anglaises du support Apple mais les applications sont multi-langues. L'articles est également traduit. Je donne toujours les pages EN-US parce qu'elles sont mises à jour plus rapidement.
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 148
737
53
Suite de mes histoires...
Comme j'avais un peu de temps (pour une fois) et que je me disais que je refaisais le système pour l'année j'ai tenté.

- Une réinstallation de Léopard -> Nickel ! tout marchait bien
- Une mise à jour depuis Léopard vers Snow Léopard-> retour du bug qui rend Omnigraffle monstrueusement lent au démarrage. Ce bug m'a servi d'indice par la suite.
- Une installation propre de Snow Léopard et mise à jour immédiate vers la version 10.6.4 -> Nickel ! Tout marche bien aussi comme sous Léopard. Pas trace du bug d'OmniGraffle, Universalis 2009 mise à jour avec le dernier patch marche aussi bien que sous Léopard (par contre je remarque que la patch Universalis m'a encore réinstallé Java 5 (un des trucs que je soupçonnais comme facteur d'emmerde, en particulier dans le navigateur), mais sans changer l'ordre de préférence de l'utilisation de cette version : la 6 reste prioritaire.

Conclusion : une clean install immédiatement mise à jour dans la dernière version semble bien fonctionner chez moi. Ce qui m'étonne c'est que je crois avoir eu le bug d'OmniGrafflle dès le début de mon installation de SL (installé pourtant sur un disque formaté lui aussi).

Conclusion de la conclusion : je pense décidément qu'il ne faut pas se presser pour passer au système suivant et qu'attendre une version avoisinant les 3 ou 4 n'est pas une mauvaise chose. La "clean install" me semble aussi incontournable.
Reste le problème de l'occasion : personnellement ça m'arrange bien de faire mon ménage uniquement pendant les vacances d'été pour repartir sur des bases saines pour l'année.

Conclusion de la conclusion de la conclusion : je pense que je vais largement attendre pour installer 10.7 qu'il soit mature et que ce soit l'occasion. Mais on n'en est pas encore là ;)

Reste que j'avoue ne pas avoir traîné pour mettre à jour iOS4, et franchement j'ai bien fait, ne serait-ce que pour l'amélioration énorme de la connexion wifi. Comme quoi, ça dépend aussi des systèmes...
 

CDI2

Membre confirmé
1 Janvier 2010
26
0
Ben dis donc, c'est Raymond qui va être content. :siffle:

Safari 4.0.5 est bourré de failles de sécurité documentées, maintenant, tu fais comme tu veux...

Réinstaller Safari 4.0.5 sur 10.5.8 :
1. Prendre son DVD de Leopard et réinstaller l'OS en choisissant l'option "Archiver et installer"
2. Faire la mise à jour combinée 10.5.8
3. Appliquer la mise à jour de sécurité 2010-004
4. Installer Safari 4.0.5

Virer le dossier "Previous system".

Lancer la mise à jour de logiciel pour être sûr de n'avoir rien oublié (mais décocher la case vis-à-vis de Safari 5 avant de lancer l'installation).

P.S. : les liens renvoient vers les pages anglaises du support Apple mais les applications sont multi-langues. L'articles est également traduit. Je donne toujours les pages EN-US parce qu'elles sont mises à jour plus rapidement.

Pareil pour moi, une cata. Je vais tenter de repasser en 4, mais je ne trouve pas le dossier Previous system. Peux-tu me dire ou il se trouve ? Je suppose que c'est lui qui empêche d'installer une version moins ressente ? Merci d'avance.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 041
5 708
Là-haut
Pareil pour moi, une cata. Je vais tenter de repasser en 4, mais je ne trouve pas le dossier Previous system. Peux-tu me dire ou il se trouve ? Je suppose que c'est lui qui empêche d'installer une version moins ressente ? Merci d'avance.

Previous System est un dossier qui n'apparaît qu'après une réinstallation en mode "Archiver et installer".
http://support.apple.com/kb/HT1710?viewlocale=fr_FR

Ce qui empêche la réinstallation de Safari 4 après avoir installé Safari 5, ce sont les frameworks mis à jour par Safari 5 au plus profond de l'architecture de Mac OS X.
 

CDI2

Membre confirmé
1 Janvier 2010
26
0
Previous System est un dossier qui n'apparaît qu'après une réinstallation en mode "Archiver et installer".
http://support.apple.com/kb/HT1710?viewlocale=fr_FR

Ce qui empêche la réinstallation de Safari 4 après avoir installé Safari 5, ce sont les frameworks mis à jour par Safari 5 au plus profond de l'architecture de Mac OS X.

A ok, rien à voir donc. Est ce que tu sais si il y a une possibilité de désinstaller entièrement le 5 ? Encore merci pour ton aide.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 041
5 708
Là-haut
A ok, rien à voir donc. Est ce que tu sais si il y a une possibilité de désinstaller entièrement le 5 ? Encore merci pour ton aide.

Comme je l'ai indiqué, il faut réinstaller l'OS.

J'ai un jour essayé de retirer les frameworks impliqués en espérant qu'appliquer un Safari précédent remettrait les choses en place et ça n'a fait de détruire le système.

Tu peux aussi simplement poser Safari.app par-dessus les fondations de Safari 5 mais ça reste bancale.

Le mieux est de résoudre tes problèmes avec Safari 5 qui fonctionne normalement pour la plupart d'entre-nous. Au pire tu utilises Firefox si un site te pose un problème particulier.

Il y a par exemple le site du National Geographic US sur lequel la navigation est perturbée depuis la mise à jour du JavaScript de Safari 5.
 

CDI2

Membre confirmé
1 Janvier 2010
26
0
Ok, donc pour moi, c'est adios Safari. Il faut quand même le faire arriver à flinguer un système à cause d'une mise à jour qui est censé améliorer les choses. Car moi c'est clair, quand je lance Safari, c'est tout l'ordi qui rame de façon impressionnante.
 

amaeta

Membre confirmé
26 Juillet 2007
13
0
66
normandie
J'ai lu avec attention tout le sujet mais je dois dire que je n'ose pas me lancer dans une reinstalltion de l'osx10.4.11 dont je dispose. Non plus que je ne connais pas le petit nom de mon ordi leopard ou tigre pour installer des logiciels que l'on destine à l''un ou l'autre.

Bref peut importe, j'aimerai savoir comment virer totalement safari5 (et le reste d'avant si il y a) ... car je n'ai trouve aucun fichier "uninstal" dans le dossier safari.

Merci d'avance pour vos conseils (à la portée d'une ignare si possible).:D
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 148
737
53
Ton système est un Tigre (à jour, c'est un bon point).
On ne peut pas virer Safari, il fait partie du système. Mais tu veux sans doute dire : "revenir à la version précédente"...
Si tu as des problèmes avec Safari 5 tu devrais plutôt t'en prendre au véritable responsable : Flash que tu as sans doute installé depuis leur site, ce qu'il ne faut jamais faire.
Il faut donc suivre les conseils pour revenir à l'ancienne version de Flash.
 

tittof34

Membre enregistré
10 Février 2011
1
0
Bonjour, voilà j'ai un imac. J'avais mac osx 10.5 et comme j'ai achete le trackpad j'ai ete obliger de mettre a jour.Du coup avec snow leopard et le nouveau safai 5 c'la merde.Safari n'arrete pas de planter.Si quelqu un a la solution se serai cool merci ;);)