iweb et internet explorer

huderie

Membre junior
2 Juin 2010
31
0
bonjour, j'ai créé mon site sur iweb et l'ai publié
les utilisateurs de mac n'ont aucun problème
par contre avec ie certains liens ne marchent plus, il y a des refets qui n'existent pas sur l'original
comment modifier mon site pour qu'il puisse être vu par tout le monde
merci
 

monvilain

Membre d’élite
Club MacG
15 Avril 2004
1 909
50
West Coast, altitude 0
www.monvilain.com
Bonjour,

Les soucis d'affichage sont récurrents avec iWeb et surtout avec I.E (Internet Explorer).

Seule l'expérience (des autres et la tienne) amène aux solutions.

Souvent, les effets iWeb (genre, les ombres etc...) sont mal-intérprétés par ce foutu I.E
Contrairement à la programmation, nous n'avons pas vraiment accès au code html, c'est donc le revers de la médaille...


Tu peux utiliser Browershot pour contrôler l'affichage de ton site.

Concernant ton problème ,nous avons besoin d'un lien ou d'une capture d'ècran pour trouver ce qui doit être changé dans ton site.



-Une seconde solution est de modifier petit à petit ce qui te semble correspondre à l'endroit de la mauvaise intérprétation et de publier pour tester (un peu long, mais bien pour progresser)

-Une troisième solution est de ne pas te préoccuper de ce foutu I.E

-Une quatrième de créer ton site en respectant les standars (Dereamweaver etc...) Bien que I.E posera quand même des soucis...;


On parle des problèmes d'affichage dans ce post
 

huderie

Membre junior
2 Juin 2010
31
0
merci
pou aller à mon site www.huderie.com/Huderie
ce qui ne marche pas ce sont les 3 liens du milieuen haut
les 2 aux extrémités marchent et pourtant sur mon iweb c'est exactement pareil
huderie
 
D

Deleted member 18124

Invité
Le plus simple : tu mets sur la page d'accueil un message invitant tes visiteurs à utiliser Safari ou Firefox (avec liens de téléchargement).
 

koeklin

Membre d’élite
Club MacG
17 Août 2007
2 366
249
Je peux me tromper, mais je pense que c'est l'alignement vertical du texte avec le remplissage d'arrière-plan qui pose problème.

Ce que je vous conseille c'est d'éviter
de mettre le remplissage par dégradé et les liens sur la zone de texte.
d'utiliser l'alignement vertical supérieur du texte.
d'éviter le bord à bord avec des éléments n'appartenant pas au menu

Pour cela :

Dupliquez une de vos pages ayant un menu. Sur cette copie qui servira à faire un essai
Effacer l'intégralité de votre menu actuel

Placer 5 zones de textes de même hauteur parfaitement alignées horizontalement (English, Etalons, Elevage, Prix*, Ventes ).

*remplacer le texte "Prix du Haras de la Huderie" par "Récompenses" ou "Prix" dans le menu, il faut faire simple un lien sur deux lignes c'est moche et... en plus c'est moche.

le texte à l'intérieur de chacune de ces zones de textes doit rester en alignement vertical supérieur.

chaque zone de texte ne contient pas de remplissage

réduisez la hauteur des zones de textes au minimum autorisé

sélectionnez toutes les zones de textes du menu et placez-les en premier plan

Pour faire l'arrière-plan du menu, plusieurs possiblité, placez sous le menu :
  • une image glissée depuis votre finder sur votre page iweb
  • une zone de texte vide avec un remplissage en dégradé ou par image
  • une figure avec un remplissage en dégradé ou par image
alignez horizontalement et verticalement ce qui sert d'arrière-plan pour que le menu soit centré.

Exemple avec explications rapides illustrées :
http://iweb.debutersurmac.com/experience/un_menu.html