10.15 Catalina MacBook Pro 16" lent à démarrer/ouvrir session/ouvrir certaines applications

Captain Bumper

Membre confirmé
16 Février 2008
116
1
Bonjour à tous,

j'ai réceptionné mon MBP 16" (core i9 à 2,4 GHZ / 32 Go de RAM / 2 To SSD) avant-hier et après quelques galères à transférer via l'assistant de migration mon ancien MBP vers celui-ci (merci l'USB-C, pas d'adaptateur pour brancher mon DD Time Machine USB 3.1 USB-A, j'ai du passer par le Wi-Fi, ce qui est très lent et donne souvent l'impression que ça a planté, bref...), et je fais face à quelques soucis de réactivité de certaines opérations.

D'abord, j'ai du ré-installer complètement Lightroom et Photoshop parce qu'Adobe CC plantait (impossible de joindre les serveurs Adobe et vérifier l'identité) et donc ne se connectait pas à mon compte Adobe (peut-être une panne de leurs serveurs mais bref...)
Idem Office 2016 qui ne trouvait pas ma licence puis le lendemain l'a retrouvé.

Globalement j'en suis plutôt satisfait mais j'ai remarqué que les démarrages sont très lents comparés à mon iMac 2019 et mon MBP 2015 dont proviennent les données (30-40 secondes vs 10-12 secondes), il en va de même des ouvertures/fermetures de session, qui sont parfois anormalement longues (avant l'apparition du bureau et au moment où toutes les applications et le Finder sont fermées et qu'on attend la fermeture de la session) ; cela peut pendre entre 15 et 30 secondes au lieu de 2-3 secondes habituellement sur mon MBP ou mon iMac... C'est quasi-systématique et c'est vraiment lourd en plus d'être inquiétant d'avoir une machine haut de gamme et du double du prix de celle qu'elle remplace se faire poutrer là dessus alors qu'on s'attend à ce que ça soit instantané.

Le démarrage commence à peu près normalement puis arrivé à la moitié de la barre de progression ça s'arrête et ça avance lentement par saccades et ça semble un peu se débloquer quand la touch bar change d'aspect...

Serait-ce lié à la puce T2 / à la touch bar? À un autre problème? Qqn l'a-t-il déjà remarqué? Je demande cela car j'ai constaté des changements de contenu de la touch bar au moment où ça bloque et où ça se débloque.

De même le lancement de certaines applications est très lent : par exemple Black Magic Disk Speed Test : 2 rebonds que ce soit sur l'iMac ou l'ancien MBP, à froid comme à chaud, mais une douzaine au moins sur le nouveau MBP à froid, 3-4 à chaud! Idem Onyx fraichement installé pour Catalina. Et étrangement ça ne le fait pas avec toutes les applications (par exemple, Office, Lr et Ps ne semblent pas trop affectés même si leur démarrage est aussi long ou rapide (c'est selon le point de vue) que sur l'iMac voire peut-être 1-2 secondes de plus pour Ps). Mais là encore c'est très lourd de poireauter pour qu'un logiciel a priori très léger se lance comme à l'époque des disques à plateaux 5400 tr/min!! :(o_O:mad:

Serait-ce du aux bridages pénibles de Catalina (qui bloquent ou chipotent pour un oui ou un non au démarrage d'un logiciel ne venant pas du Mac App Store)?? Y a-t-il moyen d'améliorer ça?

J'ai déjà essayé
  • un passage d'Onyx (la totale, les caches, les scripts de maintenance, sans succès),
  • la remise à zéro de la NVRAM (sans succès),
  • le démarrage sans échec (idem, démarrage aussi lent),
  • le mode verbose pour voir ce qu'il se passait (impossible de lire, trop rapide et trop petit),
  • de jeter via le Terminal les fichier de préférence de la login windows (manip vue sur un forum Mac),
  • et en désespoir la ré-installation complète de Catalina en clean install (qui est passé de 10.15.2 à 10.15.4 par la même occasion...). Le redémarrage semble un poil plus rapide depuis la réinstallation et mise à jour, mais c'est à la marge (2 à 5 secondes gagnées selon le cas). Le lancement d'application est toujours aussi long pour les mêmes...

Je suis preneur de toutes infos/témoignages et bidouilles/réglages pour changer cela. Merci.
 

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 459
92
Paris
Je ne suis jamais partisan de remettre des sauvegardes quand on achète une nouvelle machine surtout des Time Machine je préconise plus de prendre un plus long moment pour tout transférer manuellement et réinstaller proprement tout les logiciels on test ensuite sur quelque chose de propre.

Est-ce que tu as tout remis apres ta réinstallation de Catalina ?
 

Captain Bumper

Membre confirmé
16 Février 2008
116
1
Oui et non, certains logiciels avaient déjà été réinstallés après désinstallation complète (j'ai pas fini de tout réinstaller d'ailleurs). Puis j'ai réinstallé Catalina. D'autres logiciels qui se lancent un peu lentement sont de toutes façons des logiciels déjà fraichement installés (Onyx et Test Black Magic pour ne citer qu'eux)

Ensuite le démarrage n'est pas affecté par ces éléments, ni l'ouverture de session (je parle du moment avant que le bureau n'apparaisse, juste après la validation du code, ou juste avant l'affichage des noms), donc ils ne devraient pas être lents avec un système neuf. C'était d'ailleurs le cas dès le premier démarrage (lenteur) une fois terminé l'installation initiale.... Enfin c'est l'impression que j'en avait. Car j'ai fait le transfert non pas au premier démarrage au déballage, mais après : j'ai utilisé l'installation initiale propre et vierge et j'ai créé un nouveau compte admin vide sur un ordinateur vierge, donc qui ne devait pas être affecté par ce problème en toute logique. Et c'est seulement là j'ai transféré mes données. Or ça m'avait paru déjà un peu lent à ce moment, avant d'avoir transféré mes données (je me suis dit que c'était peut-être normal pour les premiers démarrages, le temps de faire tous les index, Spotlight, etc donc j'ai pas chronométré). Je veux bien essayer de créer une seconde partition sur le SSD et d'y mettre Catalina vierge (via Pomme-R au démarrage? Il n'y a bien que cette méthode?) avec 2 utilisateurs et voir en démarrant dessus ce que cela fait, mais si le problème est identique...

D'autant plus que sur mon ancien MBP je n'ai aucun problème de démarrage/lenteurs, pourtant si les données étaient foireuses, ça déconnerait aussi sur celui-ci or ce n'est pas le cas.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 944
5 738
Nancy___
Le problème quand on migre des données d'une autre machine, d'un autre OS, vient souvent du dossier Bibliothèque de notre session.
Ca ne devrait donc pas influencer le temps de démarrage de la machine.

Mais c'est vrai que pour Ruben et moi, nouvelle machine => clean install. Je ne migre auncue application. Je réinstalle from scratch. Et j'y vais doucement quand ke réinstalle mes applications (d'autant que c'est souvent long), ce qui fait que je suis souvent amené à éteindre mon Mac / le rallumer et donc détecter assez vite u problème. Et je migre mes données avec parcimonie.
 
  • J’aime
Réactions: RubenF

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 459
92
Paris
Je préfère prendre le temps une fois mais commencer à bosser sur une machine parfaitement configurée et qui me durera dans le temps, et oui pour approfondir les dires de Sly, quand j’achète un appareil Apple très généralement je clean install avant même de faire quoi que ce soit.
 

Captain Bumper

Membre confirmé
16 Février 2008
116
1
je viens de faire un essai de clean install à vide : nouvelle partition, formatage, nouvelle install de Catalina, aucune install d'appli ni de transfert, mêmes réglages.... verdict : le démarrage est toujours aussi lent (à 1-2 secondes près), et toujours en rapport avec la touch bar : les ralentissements, les blocages et les "redémarrage" de la barre de progression sont liés au changement du contenu de celle-ci... Donc la puce T2 et son OS qui rament, couches supplémentaires que mon précédent MBP n'a pas à gérer?! Donc mon installation n'est pas responsable de ces pbs...


Quant aux applications, black magic démarre plus vite désormais, sans devoir la réinstaller.. Mystère...
 

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 459
92
Paris
essaie un reset de la PRAM
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 944
5 738
Nancy___
je viens de faire un essai de clean install à vide : nouvelle partition, formatage, nouvelle install de Catalina, aucune install d'appli ni de transfert, mêmes réglages.... verdict : le démarrage est toujours aussi lent (à 1-2 secondes près), et toujours en rapport avec la touch bar : les ralentissements, les blocages et les "redémarrage" de la barre de progression sont liés au changement du contenu de celle-ci... Donc la puce T2 et son OS qui rament, couches supplémentaires que mon précédent MBP n'a pas à gérer?! Donc mon installation n'est pas responsable de ces pbs...
OK, donc là au moins on est sûr que le souci provient de ta machine et pas de tes applications.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
33 096
3 702
Quant aux applications, black magic démarre plus vite désormais, sans devoir la réinstaller.. Mystère...
Alors tu n'as pas fait le formatage du disque dur interne, mais une installation par-dessus celle en cours qui ne touche pas aux fichiers, données personnelles, logiciels et réglages personnels. Pour moi, il est donc normal que rien ne change. Un logiciel qui est enregistré dans son compte Apple ne peut pas s'installer tout seul et surtout pas sans le mot de passe de l'Administrateur.
 

Captain Bumper

Membre confirmé
16 Février 2008
116
1
essaie un reset de la PRAM
Déjà fait (cf mon message initial)

OK, donc là au moins on est sûr que le souci provient de ta machine et pas de tes applications.
Il semble que je ne soit pas le seul à trouver le démarrage du MBP 16” lent en tout cas plus lent que les ancien MBP sans touch bar. Pour certains en rapport avec la MV (aussi gérée par la T2?). Donc je ne sais que conclure.....

Alors tu n'as pas fait le formatage du disque dur interne, mais une installation par-dessus celle en cours qui ne touche pas aux fichiers, données personnelles, logiciels et réglages personnels. Pour moi, il est donc normal que rien ne change. Un logiciel qui est enregistré dans son compte Apple ne peut pas s'installer tout seul et surtout pas sans le mot de passe de l'Administrateur.
Rien à voir cf mon message j’ai utilisé une partition vierge avec une install vierge. Puis j’ai installé BlackMagic pour voir. Par la suite dans ma partition initiale j’ai refait un test et ça là se lançait rapidement sans n’avoir rien fait sur cette partition.
 
Dernière édition par un modérateur:

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 459
92
Paris
Déjà fait (cf mon message initial)


Il semble que je ne soit pas le seul à trouver le démarrage du MBP 16” lent en tout cas plus lent que les ancien MBP sans touch bar. Pour certains en rapport avec la MV (aussi gérée par la T2?). Donc je ne sais que conclure.....


Rien à voir cf mon message j’ai utilisé une partition vierge avec une install vierge. Puis j’ai installé BlackMagic pour voir. Par la suite dans ma partition initiale j’ai refait un test et ça là se lançait rapidement sans n’avoir rien fait sur cette partition.
Je ne pense pas que la T2 soit en cause, j'en ai une et généralement mes démarrages et mes extinctions de veille sont sensiblement similaires à celles de mon MacBook Pro 2014 que j'avais.
 

Captain Bumper

Membre confirmé
16 Février 2008
116
1
Je ne pense pas que la T2 soit en cause, j'en ai une et généralement mes démarrages et mes extinctions de veille sont sensiblement similaires à celles de mon MacBook Pro 2014 que j'avais.
après peut-être en faisant une vidéo de ton démarrage pour que je me rende compte et que je compare...?
 

Captain Bumper

Membre confirmé
16 Février 2008
116
1
Je ne pense pas que la T2 soit en cause, j'en ai une et généralement mes démarrages et mes extinctions de veille sont sensiblement similaires à celles de mon MacBook Pro 2014 que j'avais.
Up! Combien met de temps à démarrer ton MBP du gong s'il en a encore un ou de l'appui de la touche d'allumage jusqu'à l'apparition du menu de session?
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
33 096
3 702
Up! Combien met de temps à démarrer ton MBP du gong s'il en a encore un ou de l'appui de la touche d'allumage jusqu'à l'apparition du menu de session?
Sans mot de passe de session, donc le bong et l'affichage du Bureau avec mon iMac il y a 18 secondes. C'est un temps moyen constaté avec la plupart des Mac ayant un SSD.
 

Captain Bumper

Membre confirmé
16 Février 2008
116
1
Sans mot de passe de session, donc le bong et l'affichage du Bureau avec mon iMac il y a 18 secondes. C'est un temps moyen constaté avec la plupart des Mac ayant un SSD.
Oui sur mon MBP 2015 et mon iMac 2019 c’est ça voire moins (écran d’ouverture de session) mais sur le MBP 16" c’est 29-32 secondes et j’ai vu d’autres modèle identique au mien qui met 40 secondes. Y a donc soit un pb (pas forcément propre au mien mais plus au modèle) soit une conception qui fait que...
 

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 459
92
Paris
Oui sur mon MBP 2015 et mon iMac 2019 c’est ça voire moins (écran d’ouverture de session) mais sur le MBP 16" c’est 29-32 secondes et j’ai vu d’autres modèle identique au mien qui met 40 secondes. Y a donc soit un pb (pas forcément propre au mien mais plus au modèle) soit une conception qui fait que...
En ce moment le mien met environ une minute à démarrer, mais mon OS s’est pourri il faudrait que je prenne le temps de faire une clean install mais comme je bosse sur pas mal de projets je ne peux pas me permettre de faire quoi que ce soit pour le moment.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 944
5 738
Nancy___
Oui sur mon MBP 2015 et mon iMac 2019 c’est ça voire moins (écran d’ouverture de session) mais sur le MBP 16" c’est 29-32 secondes et j’ai vu d’autres modèle identique au mien qui met 40 secondes. Y a donc soit un pb (pas forcément propre au mien mais plus au modèle) soit une conception qui fait que...
Mais tu as 32 Go sur ton MBP16"; combien de RAM sur ton MBP15" et iMac 2019 ?
 

Captain Bumper

Membre confirmé
16 Février 2008
116
1
Mais tu as 32 Go sur ton MBP16"; combien de RAM sur ton MBP15" et iMac 2019 ?
16 Go sur le MBP 2015 (sous El Capitan 10.11.6), 40 Go sur l'iMac (sous Mojave 10.14.4)... Pas certains que la quantité de mémoire ait un impact aussi lourd, sauf à considérer que presque 100% du temps de démarrage est consacré à vérifier la mémoire... En plus pas cohérent concernant l'iMac qui en possède le plus... Après peut-être que la puce T2 alourdi la procédure de démarrage... Peut-être aussi qu'elle vérifie la mémoire plus lentement ou plus scrupuleusement que les système non équipés... ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 944
5 738
Nancy___
Après peut-être que la puce T2 alourdi la procédure de démarrage... Peut-être aussi qu'elle vérifie la mémoire plus lentement ou plus scrupuleusement que les système non équipés... ?
Je n'ai pas l'expérience de cette puce et clairement, mon hypothèse sur la quantité de RAM et le temps de démarrage tombe l'eau !
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
33 096
3 702
Après peut-être que la puce T2 alourdi la procédure de démarrage... Peut-être aussi qu'elle vérifie la mémoire plus lentement ou plus scrupuleusement que les système non équipés... ?
Non, cette puce détecte la présence de disques durs externes, car macOS impose une vérification de sécurité qui ne va durer que quelques micros secondes tout comme pour la mémoire. C'est fini le temps de Windows depuis belle lurette.