No input file specified.

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Bonjour !

Je suis chez OVH depuis peu (hier :p) et j'ai un problème :
J'utilise le MultiViews (mais ça fait pareil avec le mod_rewrite d'après ce que j'ai lu) et quand on accède à un fichier avec un / à la fin de l'adresse le serveur retourne "No input file specified.".


Je m'explique : j'ai une page blog.php (ça ne le fait qu'avec les fichier php) et quand on y va via /blog ça marche bien, via /blog/quelquechosenimportequoi ça marche bien aussi, mais quand on y accède via /blog/ ça ne marche plus !

Et c'est pareil pour toute les pages php, et pareil si à la place de blog dans les chemin précédents je met blog.php



J'ai déjà cherché dans Google et les solutions que j'ai trouvés ne fonctionne pas :
- le DOCUMENT_ROOT est bien le bon (/home/monlogin/www)
- SCRIPT_FILENAME est bien définie et est correct


Si vous pouviez m'aider ça serait génial !
J'ai aussi poser la question au support d'OVH, mais je n'attend pas de réponse aujourd'hui (on est dimanche ^^). Toutefois dès que j'ai une réponse, si elle solve mon problème je la posterais ici. Ça servira bien à quelqu'un d'autre :)
 
A

Anonyme

Invité
C'est du php 4 ou 5? Parce que quand j'ai refait le livre d'or sur le site de MamaCass (livredor.php à la racine) je n'ai pas eu de problèmes, de même sur mon blog… :confused:
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
C'est du php 4 ou 5? Parce que quand j'ai refait le livre d'or sur le site de MamaCass (livredor.php à la racine) je n'ai pas eu de problèmes, de même sur mon blog… :confused:
PHP 5, parce que mon site utilise un peu SimpleXML qui n'est pas dispo en PHP 4 et j'ai pas envie de me farcir DomXML :rateau:

Je ne pense pas que cela vienne de mon code puisque le même code fonctionnait parfaitement chez Free :nailbiting:
 
A

Anonyme

Invité
Je ne pense pas que cela vienne de mon code puisque le même code fonctionnait parfaitement chez Free :nailbiting:

Certains hébergeurs ajoutent, modifient ou enlèvent des modules dans PHP pour éviter certains problèmes, j'espère pour toi que ce n'est pas ça. ;)
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Certains hébergeurs ajoutent, modifient ou enlèvent des modules dans PHP pour éviter certains problèmes, j'espère pour toi que ce n'est pas ça. ;)
Ben à priori non vu que le module en jeux est un module Apache : le MultiViews. Il est par défaut dans Apache et est activé par défaut depuis Apache 2.

En plus ça marche bien puisque si on ne met pas le / à la fin ça marche parfaitement.

Le seul cas où ça ne marche pas c'est quand on met juste après le fichier un / sans rien après.

par exemple : blog/ ne marche pas, mais
blog
blog/truc
blog/truc/
blog/truc@--_-,/test marche aussi ^^

c'est super bizarre comme truc...
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Bon ben j'ai un autre problème -_-'

Sans aucunes raisons d'un coup comme ça, p4bl0.net est redevenu une simple redirection vers l'hébergement OVH :eek:
Et www .p4bl0.net (sans l'espace) n'existe même plus -_-'

Ça me gonfle un peu leur truc là... Pourquoi c'est pas simple comme le reste ?! le domaine est bien transféré chez OVH, les dns sont les bonnes et tout marchait bien !
Qu'est ce qui a pu changer ??! c'est looouuuurd... :eek:
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Bon je comprend rien moi...

Ça remarche, je sais pas jusqu'à quand, mais ça remachre, c'est cool :)

Je suppose qu'habituellement les nom de domaine sont sur batterie (courant continu), et que je suis peut-être le seul à avoir un nom de domaine branché sur le secteur avec un courant alternatif : de temps en temps c'est une redirection, de temps en temps c'est un "vrai" nom de domaine... :D

Enfin... ":D"...


Bon il se fait tard j'ai l'impression... :rateau:

-------------------------------------------------------

EDIT : je ne parlais que du nom de domaine ici biensûr, mon problème de "No input file specified." est toujours présent :(
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Tiens j'ai vu un truc dans ce sujet sur le forum de discussion de dotclear (2) :

http://www.dotclear.net/forum/viewtopic.php?id=27992

On parle du no input machin... :)

Si ça peut aider...
J'ai tout lu mais je ne voit pas de solutions au problème :(

J'ai toujours ce problème est en plus du coup j'ai vérifier chez moi aussi le googlebot tombe sur des erreurs 404 à presque chaque page du sitemap alors que ces pages sont consultable sans problème -_-.

Je sais pas ce qu'ils ont foutus les tech de chez OVH mais c'est vraiment des abrutis imcompétents de merde !

Je vais tenter de forcé le header "HTTP/1.1 200 OK" sur les pages valides pour voir ce que ça donne... C'est pas propre du tout et ça m'énerve énormément de devoir faire ça mais au moins les pages de mon blog seront indexées par Google...

:(

Par contre pour le no input file specified j'ai toujours pas de solutions...
 
A

Anonyme

Invité
Oui avec php 5 chez OVH, il y a de quoi s'arracher les cheveux. :( Déjà pour installer Dotclear2 c'est assez sportif (à l'époque je n'y étais pas arrivé :rose:) et pourtant on ne peut pas dire qu'il soit mal programmé. On dirait qu'il y a des incompatibilités avec le rewrite rule et les programmes en path_info. :(

Je crois que je vais essayer la méthode du gars pour passer à Dotclear 2 ce soir. :)
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Oui avec php 5 chez OVH, il y a de quoi s'arracher les cheveux. :( Déjà pour installer Dotclear2 c'est assez sportif (à l'époque je n'y étais pas arrivé :rose:) et pourtant on ne peut pas dire qu'il soit mal programmé. On dirait qu'il y a des incompatibilités avec le rewrite rule et les programmes en path_info. :(

Je crois que je vais essayer la méthode du gars pour passer à Dotclear 2 ce soir. :)
J'ai résolu une bonne partie de mes problèmes en désactivant le MultiViews est un utilisant directement de mod_rewrite dans le .htaccess. Plus de "no input files specified" :):):):)

Reste plus qu'un problème avec la fonction mail de php qui envoie un message pas propre, mais je crois que leur support est complètement bidon... Je vais essayer de me débrouiller seul :)

Donc pour ton DotClear aussi ça devrait le faire :
Dans DotClear tu désactive les jolie URL avec QUERY_STRING ou PATH_INFO, tu garde un truc moche à la bien :D
Dans ton .htaccess tu désactive le MultiViews (Options -MultiViews)
Et dans le .htaccess tu fais toi même les jolie URL avec le mod_rewrite :)


Sinon dotclear2 est un module préinstallable chez OVH (dans le manager puis dans hébergement puis dans module puis dans ajouter). :)
 
A

Anonyme

Invité
J'ai résolu une bonne partie de mes problèmes en désactivant le MultiViews est un utilisant directement de mod_rewrite dans le .htaccess. Plus de "no input files specified" :):):):)

Reste plus qu'un problème avec la fonction mail de php qui envoie un message pas propre, mais je crois que leur support est complètement bidon... Je vais essayer de me débrouiller seul :)

Donc pour ton DotClear aussi ça devrait le faire :
Dans DotClear tu désactive les jolie URL avec QUERY_STRING ou PATH_INFO, tu garde un truc moche à la bien :D
Dans ton .htaccess tu désactive le MultiViews (Options -MultiViews)
Et dans le .htaccess tu fais toi même les jolie URL avec le mod_rewrite :)


Sinon dotclear2 est un module préinstallable chez OVH (dans le manager puis dans hébergement puis dans module puis dans ajouter). :)

Merci pour ces infos :up:, je vais aller voir tout ça...

Bon, première chose : couper les commentaires et les trackbacks dans la version actuelle et exporter le tout. :siffle:
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Pour la fonction mail de PHP, si on veux un truc propre sans
Message-Id: <20070719131534.8B25EBEA7@300gp.ovh.net> Date: Thu, 19 Jul 2007 15:15:34 +0200 (CEST)
et un envoyeur inconnu (unknown sender) &#224; la place de celui du header du mail, il faut utiliser un compte POP de chez OVH -_-

Bon heuresement que Gmail &#224; la fonctionnalit&#233; GMail Fetcher qui peux relever les mail des autres compte POP :):):):)


&#192; plus probl&#232;me moi :p content !
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Merci pour ces infos :up:, je vais aller voir tout &#231;a...

Bon, premi&#232;re chose : couper les commentaires et les trackbacks dans la version actuelle et exporter le tout. :siffle:
de rien ;)


EDIT: s'il n'y a pas de quoi dans DotClear (je connais pas du tout), j'ai fait un script de backup et de restauration de base de donn&#233;e, &#231;a marche que pour une seule base de donn&#233;e &#224; la fois (peut importe le nombre de table), si tu veux je te le passe :)
 
A

Anonyme

Invité
de rien ;)


EDIT: s'il n'y a pas de quoi dans DotClear (je connais pas du tout), j'ai fait un script de backup et de restauration de base de donnée, ça marche que pour une seule base de donnée à la fois (peut importe le nombre de table), si tu veux je te le passe :)

Ah oui ça serait sympa… Pour dotclear 1.2.X vers 2, ils dont développé un petit plug-in qui exporte les bases dans un fichier texte que je n'ai plus ensuite qu'à réimporter dans la version 2, je ne sais pas s'il y a le même dans la version 2 pour faire backup par contre. ;)
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Ah oui ça serait sympa… Pour dotclear 1.2.X vers 2, ils dont développé un petit plug-in qui exporte les bases dans un fichier texte que je n'ai plus ensuite qu'à réimporter dans la version 2, je ne sais pas s'il y a le même dans la version 2 pour faire backup par contre. ;)
j'te mp&#232;te :p
 
A

Anonyme

Invité
Pour ceux qui sont en dotclear 1.2.X : Yahou!!! Ça marche!!

Alors la procédure décrite par p4bl0 fonctionne parfaitement pour l'installation de dotclear2. C'est en effet très simple. Je n'ai plus eu qu'à réimporter le fichier de sauvegarde texte, et tout était réglé.

Pour info, voici le contenu de mon fichier .htaccess à la racine de mon site pour éliminer le vilain index.php (en path_info) des urls :

Bloc de code:
SetEnv PHP_VER 5


Options -MultiViews -Indexes


RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f 
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php/$1
Je dois encore recréer les redirections des anciens posts vers les nouvelles urls. ;) Et activer l'antispam.

Encore merci p4bl0. :p