Number : format selon résultats de calculs

Gregoryen

Membre actif
Club MacG
16 Juin 2013
526
27
30
Saint-Martin-de-Crau
www.gregoryen.fr
Bonjour :)

Voilà j'ai fait une cellule ou se fait un calcul sur Numbers, voici:

A1= Nombre de participations.
---A2= 1

B1= Temps de la participation
---B2= 4 minutes

C1= Résultat soit : A2*B2= 4 minutes.

Jusque la tout va bien vous me suivez.

Dans la cellule C1 du résultat, j'aimerais que si la réponse fasse 80 minutes, il me l'affiche en heure, soit 1h 20min.

Donc je sélectionne cellule et je choisit " h " et " m ".

Donc il me le fait.

Cependant, si le résultat est 4 minutes, il m'affiche "0h 4min".

J'aimerais ne pas avoir 0h si l'heure = à 0.

Comment faire la règles des " si " ?

Je vous remercie et bonne journée à tous :)
 
Dernière édition:

pepeye66

Jaccédeur
Club MacG
24 Février 2007
5 946
733
Capitale de la Catalogne Nord
Je n'ai pas vu ce formatage conditionnel pour une cellule et à mon avis la fonction "SI" ne te donnera pas deux possibilités de formatage de ta cellule selon le nombre de minutes (sachant que le top de basculement du formatage se ferait à 60')
Et si c'est possible (sur une seule cellule) je suis preneur !

;)
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 555
3 553
68
Sous la limite KT
Je confirme, pas de mise en forme conditionnelle dans Numbers, faut prendre Excel ou le tableur d'OOo pour avoir ça.
 

Gregoryen

Membre actif
Club MacG
16 Juin 2013
526
27
30
Saint-Martin-de-Crau
www.gregoryen.fr
Ok merci, et si je fait par exemple :

C1= Résultat
C2= Résultat format Minutes/Secondes

C3= Résultat format Heure/Minutes/Secondes

Et dans C4 je met: Si C1 = " Supérieure a 60 minutes " alors mettre cellule C2 sinon C2


C'est du bidouillage mais ça me dérange pas.
 

pepeye66

Jaccédeur
Club MacG
24 Février 2007
5 946
733
Capitale de la Catalogne Nord
Ta formule en C4 doit être la suivante:
=SI(C1<60;C2;C3) puis tu recopies C1, C2 et C3 vers le bas si besoin.
Et tu masques les colonnes C1, C2 et C3

Heu, je déconne !
Tu dois utiliser C1, D1, E1, F1 en y reportant les formules entrées C1, C2, C3, C4
et ta formule en F1 devient:
=SI(C1>60;E1;F1)

;)
 
Dernière édition:

pepeye66

Jaccédeur
Club MacG
24 Février 2007
5 946
733
Capitale de la Catalogne Nord
Tu n'as pas compris et il y a de quoi ! j'avais la tête ailleurs !
Si je reprends ton tableau, en E2 tu entres la formule:

=SI(C2<60;C2;D2)

Tu recopies vers le bas les formules dans les colonnes C, D et E et tu masques les colonnes C et D

;)
 

Gregoryen

Membre actif
Club MacG
16 Juin 2013
526
27
30
Saint-Martin-de-Crau
www.gregoryen.fr
J'avait déjà tenté cette formule, la j'ai recopier la tienne, mais il me met un point d'exclamation rouge.

On dirais qu'il sait pas ce que c'est 60 .. GRRR

------------------------------------------------------------

AHHH J'édite ce message je crois que j'ai trouvé !!!


Dans la règle des " SI " je vais mettre:

Si le nombre de participation < 15 alors tel case ou telle case. ( 15 * 4 minutes = 60 minutes ) :) :) :)

Car selon le nombre de participation la durée augmente ! :)

EDIT:---

Oui la formule que j'ai trouvé est bien la bonne merci encore ! Par contre quelqu'un sait comment faire pour quand je clique sur une case à cocher, sa sélectionne toutes les autres cases à cocher ? Merci :)
 
Dernière édition: