Pb clavier

petitchemin

Membre confirmé
17 Août 2007
304
11
Franche Comté
Bonjour,

j'ai un clavier en qwertz (suisse romand) lorsque j'utilise n importe kel soft, le clavier est bien en qwertz mais lorsque je dois saisir mon mot de passe pour installer une nouvelle appli par exemple il bascule en azerty et evidemment je ne le vois pas vu kil masque les caracteres.
ce qui est surprenant c que tout fonctionnait parfaitement jusqu'à aujourd'hui.

que faire ?

merci par avance

Christophe
 

lepetitpiero

Vétéran
Club MacG
20 Août 2005
8 662
483
49
tu regarde dan menu saisie que tu es bien sur le bon paramètre de clavier

clavier qwerty (unicode) dans la lanque de ton choix
 

hippo sulfite

Papy gateau
Club MacG
12 Avril 2003
7 111
1 458
Eaubonne (Meilleur le vin)
tu regarde dan menu saisie que tu es bien sur le bon paramètre de clavier

clavier qwerty (unicode) dans la lanque de ton choix

Pas qwerty : qwertz

Edit, je pense qu'il faut choisir le clavier "suisse roman" ou "suisse allemand"
 

lepetitpiero

Vétéran
Club MacG
20 Août 2005
8 662
483
49
ah ben lecture trop rapide... je ne connaissais pas les claviers qwertz à ces suisses faut toujours qu'ils se démarquent des autres :D
 

hippo sulfite

Papy gateau
Club MacG
12 Avril 2003
7 111
1 458
Eaubonne (Meilleur le vin)
ah ben lecture trop rapide... je ne connaissais pas les claviers qwertz à ces suisses faut toujours qu'ils se démarquent des autres :D

Remarque, je connais parce que j'ai travaillé 6 ans au Luxembourg et là bas, on utilise les claviers QWERTZ en grande majorité (le Français et l'Allemand y sont les deux langues administratives). Le clavier qwertz est aussi utilisé en Allemagne.
 

petitchemin

Membre confirmé
17 Août 2007
304
11
Franche Comté
Bonsoir,

en fait le reglage est bon et d'ailleurs quand j ecris sur ce forum mon clavier est bien en qwertz mais lorsque je veux ouvrir une autre session il bascule en azerty. je ne comprends pas !
 

hippo sulfite

Papy gateau
Club MacG
12 Avril 2003
7 111
1 458
Eaubonne (Meilleur le vin)
Bonsoir,

en fait le reglage est bon et d'ailleurs quand j ecris sur ce forum mon clavier est bien en qwertz mais lorsque je veux ouvrir une autre session il bascule en azerty. je ne comprends pas !

Les réglages sont spécifiques à chaque session non ?
 

Bassman

Vénérable sage
Club MacG
12 Septembre 2003
17 072
2 424
41
Coche la petite case "afficher le menu saisie dans la fenetre de session" ou un truc dans le genre (préférences systèmes / comptes / options) pour vérifier quelle saisie clavier est active quand tu es sur le menu d'ouverture de session ;)

Peut être ton problème se trouve t'il là
 

petitchemin

Membre confirmé
17 Août 2007
304
11
Franche Comté
J'ai activé le visualiseur de clavier et comme annoncé lorsque je suis dans une appli je suis en qwertz et lorsque je suis dans la fenetre de basculement de session je suis en azerty.
Dans le menu prefsyteme/compte/option il n'y a pas possibilité de voir le clavier activé.

je vous remercie pour votre aide.
 

Bassman

Vénérable sage
Club MacG
12 Septembre 2003
17 072
2 424
41
Si y'a une option dans les prefs systèmes / comptes.

là :
prefs.png
 

damien_t

Membre confirmé
21 Juin 2004
295
13
41
Juste un truc rapide en passant.

Il y a un énorme bug qui date d'au moins depuis Panther. Je sais pas si c'est mon ibook, mon installation de Tiger et de Panther:
Si on ouvre une session avec une langue donnée, puis qu'on change manuellement la langue du clavier une fois la session ouverte, toutes les boites de dialogue demandant le mot de passe (images disques, passage en mode administrateur, retour de mise en veille, etc.) passent automatiquement dans la langue de l'ouverture de session. Là où c'est particulièrement vicieux, c'est que la langue revient à celle qui a été choisie manuellement une fois le mot de passe entré ou lorsque la boite de dialogue a été annulée.

Ca m'a pris des mois avant de comprendre ce qu'il se passait, et à mon humble avis, je sais pas si c'est ma faute, mais je trouve que c'est bien pourri comme comportement.
 

apenspel

Vétéran
Club MacG
23 Juin 2002
7 056
329
.be - BXL
…Il y a un énorme bug qui date d'au moins depuis Panther. Je sais pas si c'est mon ibook, mon installation de Tiger et de Panther…
Tu devrais penser à faire une clean install. Mon iBook G4 fonctionne très bien avec Panther mis à jour en Tiger.
 

petitchemin

Membre confirmé
17 Août 2007
304
11
Franche Comté
Juste un truc rapide en passant.

Il y a un énorme bug qui date d'au moins depuis Panther. Je sais pas si c'est mon ibook, mon installation de Tiger et de Panther:
Si on ouvre une session avec une langue donnée, puis qu'on change manuellement la langue du clavier une fois la session ouverte, toutes les boites de dialogue demandant le mot de passe (images disques, passage en mode administrateur, retour de mise en veille, etc.) passent automatiquement dans la langue de l'ouverture de session. Là où c'est particulièrement vicieux, c'est que la langue revient à celle qui a été choisie manuellement une fois le mot de passe entré ou lorsque la boite de dialogue a été annulée.

Ca m'a pris des mois avant de comprendre ce qu'il se passait, et à mon humble avis, je sais pas si c'est ma faute, mais je trouve que c'est bien pourri comme comportement.


C'est exactement ce qui m'arrive. le pb c qu'a l ouverture de session je ne pas voir quelle langue est utilisée bien que la case correspondante soit cocher dans les options des pref de mon compte.

Comment as tu regle le pb ?
Merci
 

Bassman

Vénérable sage
Club MacG
12 Septembre 2003
17 072
2 424
41
Le mieux que tu es à faire est sans doutes une réinstallation d'OSX avec archivage. Ainsi tu repars sur un système propre avec la bonne langue entrée d'origine, tout en gardant tes applications, et dossiers Users.