Perdu Librairie/keyboard layout

dhenri13

Membre junior
26 Juin 2010
10
0
Bonjour à tous,

J’ai l’habitude, depuis de nombreuses années, d’utiliser le petit fichier de YEKELELE qui permet de “remaper” le clavier et ainsi avoir le point “.” à la place du point virgule “;” et € à la place de $ sans utiliser la touche Maj. Ce fichier je le déposais jusqu’à présent dans : librairie/keyboard layout; Depuis la mise à jour Maverick je ne trouve plus "keyboard layout”;
Quelqu’un a-t-il une idée ?

merci de votre aide.

henri
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 729
22 722
Forêt de Fontainebleau
Salut Henry!

Je te rassure : ton chat dossier n'est pas perdu (non plus que son précieux fichier) :D

Sache simplement que ton OS abrite au moins 3 Bibliothèques
- la Bibliothèque-Système (contenue dans le dossier 'Système' arborant un X bleu) ;

- la Bibliothèque-Générale (celle dont tu aperçois le répertoire intitulé 'Bibliothèque' entre le dossier 'Applications' et le dossier 'Documents' ;

- la Bibliothèqe-Personnelle (contenu dans ton répertoire domiciliaire que nous supposerons intitulé dhenri13.​

Chacune de ces 'Bibliothèques' embarque un dossier intitulé : 'Keyboard Layouts', dans lesquels se trouvent les fichiers-claviers.

- Dans celui de la Bibliothèque-Système, il s'agit des claviers par défaut Apple, contenus dans un paquetage intitulé : 'AppleKeyboardLayouts.bundle' ;

- dans celui de la Bibliothèque-Générale, tu peux (ou non) avoir affaire à des claviers additionnels, destiné à tous les utilisateurs éventuels du Mac, soit sous forme de .bundle, soit sous forme de fichier .keylayout ;

- enfin, dans ta Bibliothèque-Personnelle, il y a le produit de tes customisations de claviers destinées à toi seul : là encore, sous forme de fichiers '.keylayout', soit sous forme de '.bundle'.​

Ton clavier '.keylayout' customisé grâce à «Ukelele» réside à tous les coups dans le dossier 'Keyboard Layouts' de ta Bibliothèque-Personnelle. Mais voilà que tu te demandes pourquoi tu ne le retrouves plus après ton upgrade à «Mavericks 10.9»? Certainement parce que tu avais l'habitude de VOIR ta Bibliothèque-Personnelle, ce qui laisse supposer que tu étais sous «Snow Léopard 10.6.8», et que cette Bibliothèque-Personnelle se trouve masquée, et donc INVISIBLE à partir de «Lion 10.7», en passant par «Mountain Lion 10.8» et désormais maintenant «Mavericks 10.9» où tu sembles être passé abruptement. Donc tu ne la vois plus.

Pour démasquer ta Bibliothèque-Personnelle, clique le menu 'Aller' de la barre supérieure du Finder tout en pressant la touche d'option 'alt'. Tu vois un item 'Bibliothèque' vers le milieu de la liste. Un clic dessus ouvre en mode fenêtre-Finder le répertoire cette 'Bibliothèque' qui est ta Bibliothèque-Personnelle rendue à la visibilité :)D) et dans ses dossiers que vois-tu à la lettre 'K'? 'Keyboard Layouts' (le bon pour toi : celui de tes customisations). Et quand tu l'ouvres, que vois-tu? le fichier '.keylayout' attendu [du moins si le cheminement de ma logique n'a pas erré].

[Une question que je me pose : pourquoi, une fois ton fichier customisé '.keylayout' déposé dans son dossier d'accueil (le 'Keyboard Layouts' de ta BibliothèquePersonnelle), ne vas-tu pas à : Menu /Préférences Système/Clavier/Méthode de saisie/+ et dans la liste déroulante qui se démasque pourquoi ne navigues-tu pas jusqu'à l'intitulé de ton clavier customisé afin de choisir de l'ajouter aux claviers apparents? À partir de là, si tu coches l'option : 'Afficher le menu Saisie dans la barre des menus', tu verras l'icône d'un drapeau de la nationalité de langue du clavier (claviers Apple par défaut) ou d'un clavier gris (clavier customisé). Rien de plus facile en cliquant l'icône que de démasquer les claviers retenus dans les Préférences Système et de basculer de l'un à l'autre.]
 
Dernière édition:

dhenri13

Membre junior
26 Juin 2010
10
0
Merci pour cette longue et très précise réponse.

En fait j'étais bien sur Montain Lion et j'avais bien mis dans ma barre latérale ma bibliothèque que j'avais récupéré avec la manipe Aller etc...
Mais c'était ma bibliothèque perso et désormais cette bibliothèque perso ne contient plus Keyboard layout.
Grace à vous j'ai compris la subtilité et suis allé chercher dans bibliothèque "générale" et retrouvé Keuboard Layout.

Bref tout est rentré dans l'ordre et j'ai à nouveau mon clavier comme je l'aime.

Merci beaucoup pour votre patience et l'excellente réponse que vous m'avez faite.

Cordialement,
 

mailpacha

Nouveau membre
16 Décembre 2013
3
0
Bonjour,
J'ai tentéde faire la meme manip pour remplacer le ; par un ., avec ukelele. Mais lorsque je choisis , via preferences/clavier, le Keyboard layout nouveau que j'ai créé(avec une icone grise de clavier) , il semble qu'il n'y ait pas de "clavier disponible" . Du coup rien ne change quand je selectionne le nouveau keyboard layout. As tu rencontré ce probleme ? Merci de ton aide.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 729
22 722
Forêt de Fontainebleau
Salut mailpacha.

J'ai tenté de faire la meme manip pour remplacer le ; par un ., avec ukelele. Mais lorsque je choisis , via preferences/clavier, le Keyboard layout nouveau que j'ai créé(avec une icone grise de clavier) , il semble qu'il n'y ait pas de "clavier disponible" . Du coup rien ne change quand je selectionne le nouveau keyboard layout.
Arrête-moi quand ma description s'écarte de ce que tu as fait :

  1. Tu as choisi dans les ressources de «Ukelele» un modèle de clavier (par exemple : /System Keyboards/Roman/French.keylayout) ;

  2. Tu lui as appliqué ta customisation (substitution de ., à ;) ;

  3. Tu as enregistré sous un intitulé différent (pour ne pas affecter le modèle), supposons : Français ., - soit au format .keylayout, soit au format .bundle, ce qui donne supposons : Français .,.keylayout ;

  4. Tu as ouvert le fichier dans «TextEdit» pour remplacer dans l'en-tête ('header') l'intitulé "French" (que le nom du fichier n'a pas changé) par "Français .," avant de sauvegarder (afin que le nouveau nom soit lu par le Système) comme montré ici :



  5. Tu as déplacé le fichier : Français .,.keylayout à l'adresse : ~/Library/Keyboard Layouts (= Bibliothèque personnelle de mailpacha, dossier : 'Keyboard Layouts') et tu as re-démarré pour que la modification soit prise en compte ;

  6. Tu as été à : Préférences Système/Clavier/Méthodes de saisie (nous supposons que tu es sous «Mavericks 10.9») et tu as cliqué sur le bouton '+' comme imagé ici (NB. Dans la colonne de gauche sont listés mes actuels favoris, qui apparaissent dans la fenêtre déroulante du menu 'Clavier' de la barre du Finder) :



  7. Dans la liste des langues, tu as été à Français vérifier dans les sous-options si ton fichier apparaît (impossible si le fichier a été enregistré au format : .keylayout, car le Système ne liste en appartenance à des groupes de langues nominatives que les options de langues au format-système natif : .bundle), pour l'ajouter, comme montré ici où apparaissent quelques-unes de mes customisations antérieures (les langues en grisé sont celles qui ont déja été ajoutées aux favoris) :


  8. Ou tu as été en fin de liste à Autres, vérifier pareillement si ton fichier ajouté n'est pas listé parmi les options (nécessaire, si le fichier a été enregistré au format : .keylayout, qui pour le Système ressortit au groupe 'Autres' (= extra-bundle), pour l'ajouter, comme dans cet aperçu :


  9. Tu as coché la case de préférences : 'Afficher le menu Saisie dans la barre des menus'.

En résultat, le fichier Français ., apparaît dans la fenêtre déroulante quand on clique sur l'icône du drapeau de la langue active des menus du Finder et est donc sélectionnable. Du moins c'est ce qui m'arrive (sous «Mavericks 10.9») s'il me chante de me fabriquer un fichier de clavier customisé avec «Ukelele» et ça marche toujours [Et si je veux éviter l'icône rectangulaire grise par défaut en cas de non association d'une icône de drapeau spécifique, il me suffit de flanquer, dans : ~/Library/Keyboard Layouts, mon fichier Français .,.keylayout d'un fichier-icône collatéral de drapeau français du même intitulé exact avant extension soit : Français .,.keylayout.icns, pour que le Système affiche un joli drapeau bleu-blanc-rouge avant le nom du clavier dans la fenêtre déroulante du Finder]

♤​
Est-ce que tu peux repérer par rapport à ce pas-à-pas où tu procèdes différemment?

♡

J'attire notamment ton attention sur le fait que, si tu te contentes de donner un intitulé à ton fichier pour le Finder (le nom visible avant l'extension .keylayout) sans changer l'intitulé qu'il comporte dans l'en-tête ('header') du fichier lui-même, et que tu l'enregistres au format : .keylayout, le Système rattachera le fichier au groupe 'Autres'' (en tant qu'extra-bundle) ; et ne lira pas son nom-Finder, mais son nom-header, pour l'afficher tel quel en options du groupe 'Autres'.

Si donc tu n'as pas édité le nom-header du fichier, il demeure identifié pour le Système sous le nom générique Anglais de désignation de langue du modèle qui a servi de point-de-départ à la customisation. Si tu es parti d'un fichier «Ukelele» intitulé : French.keylayout, comme cet intitulé reflète le nom-header : French, tu auras beau sauvegarder ta customisation sous le nom-Finder que tu voudras, le Système lira toujours : French. Si tu as n customisations à base de French.keylayout, le Système listera dans les options de 'Autres' des Saisies_clavier n 'French', ce qui n'est guère commode pour s'y retrouver :D.

Ton fichier customisé n'apparaît-il pas sous le nom générique anglais de la langue de base, soit French pour un French.keylayout de départ, ce dans le groupe 'Autres'? Et, si tu l'y vois, est-ce que tu ne peux pas le sélectionner et l'ajouter à tes favoris?

♧
 
Dernière édition:

mailpacha

Nouveau membre
16 Décembre 2013
3
0
Un grand merci pour ta réponse très complète. je viens de tout reprendre à zero en suivant ta procédure.
d'entrée de jeu, à l'ouverture du fichier System Keyboards/Roman/French.keylayout), je reçois ce message : "The keyboard ID was invalid for the script specified in the keyboard layout. Do you want to fix this ?
YES NO
An invalid ID will likely lead to the keyboard layout not working correctly

j'en suis là.
J'abuse de te demander de l'aide à nouveau
Bonne soirée
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 729
22 722
Forêt de Fontainebleau
d'entrée de jeu, à l'ouverture du fichier System Keyboards/Roman/French.keylayout), je reçois ce message : "The keyboard ID was invalid for the script specified in the keyboard layout. Do you want to fix this ?
YES NO
An invalid ID will likely lead to the keyboard layout not working correctly

j'en suis là
Je te rassure, ça me le fait pareillement et... je réponds : YES :D. En réponse, «Ukelele» affiche régulièrement le clavier virtuel bleu, et tu peux te livrer à ta customisation des touches (je présume que tu sais comment procéder? - si tu as des doutes, tu peux t'inspirer de mon tuto de vacances : Le clavier de mes rêves existe-t-il?, message #7. La aussi, la réponse est : OUI :D).
 

mailpacha

Nouveau membre
16 Décembre 2013
3
0
J'ai enfin compris ce que pourtant tu avais bien mentionné :
"En résultat, le fichier Français ., apparaît dans la fenêtre déroulante quand on clique sur l'icône du drapeau de la langue active des menus du Finder et est donc sélectionnable."

je n'avais pas vu le petit drapeau pour choisir mon clavier personnalisé, dans la barre menu, à la droite de l'écran, a coté de l'affichage de l'heure ! je cherchais à sélectionner mon clavier dans les préférences clavier , au lieu de le faire dans le menu du finder, partie droite

un grand merci, bonne fetes de noel