Plantage sherlock

sifo

Membre junior
12 Janvier 2001
67
0
Quand je lance sherlock j'ai un gentil message qui me dit qu'il a quitté inopinément... (c'est pas le même plantage comme a une époque où un message récurrent revenait et on était obligé de forcer l'appli a quitter)
Un indice quand même j'ai le message suivant qui apparait dans la console :

*** malloc_zone_malloc[294]: argument too large: -1

ouila...
 

sifo

Membre junior
12 Janvier 2001
67
0
J'ai réinstallé OSX. AU redemarrage (donc en 10.0.0) et au lancement de Sherlock même erreur. J'ai upgradé en 10.0.4 (donc je suis revenu a ma config d'origine...) et toujours plantage...

GRRRRRRR

 

Gwenhiver

Membre d’élite
Club MacG
8 Décembre 2000
3 351
2
Visiter le site
Quand tu as fais la réinstallation, tu as initialisé le disque ? Sinon, Mac OS X conserve les réglages précédents.
Essaye de supprimer le fichier com.apple.sherlock.plist du dossier Library/Preferences de ton dossier utilisateur.
 

sifo

Membre junior
12 Janvier 2001
67
0
Non je n'ai pas réinitialisé. J'ai essayer de virer le fichier com.xxx : résultat idem. J'ai viré aussi les fichier préférences dans le sous dossier sherlock : toujours pareil.
Par contre nouvelle pièce au dossier : j'arrive a ouvrir sherlock si je (double) clique sur un des fichiers préférence. La je n'ai pas de fenetre de recherche. Quand je veux en ouvrir une patatrac ca redéconne.
J'ai réussi a trouver ça dans la console

Sep 16 21:09:26 localhost WindowServer[55]: CGXGetSharedWindow: Invalid window -1

Sep 16 21:09:26 localhost loginwindow[236]: kCGSErrorIllegalArgument : CGSLockWindowRectBits: Invalid window

Sep 16 21:09:26 localhost loginwindow[236]: kCGSErrorCannotComplete : Cannot create context device

Sep 16 21:09:26 localhost loginwindow[236]: kCGSErrorFailure : Cannot initialize context RIPContext

Sep 16 21:09:26 localhost loginwindow[236]: _windowDeviceRound: error creating graphics ctxt object for ctxt:8219, window:-1

Une idée peut-être ?...
 

Gwenhiver

Membre d’élite
Club MacG
8 Décembre 2000
3 351
2
Visiter le site
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par sifo:
Une idée peut-être ?...<HR></BLOCKQUOTE>

Euh…

A tout hasard, essaye de déplacer les plug-ins du dossier Internet Search Sites de ton dossier Library. Peut-être que c'est un des plug-ins qui pose problème.
 

macintroll

Membre d’élite
Club MacG
9 Septembre 2001
1 327
75
48
Trolland
macintroll.free.fr
Pour ma part j'ai occasionnellement eu des problèmes avec sherlock et même avec la version 10,0,4 mais j'ai jamais fait de réinstall avec initialisation du DD.

tout simplement le message m'indiquait avec beaucoup d'humour
" l'application Sherlock est introuvable "

pas mal pour un logiciel de recherches !!! (j'aurais du faire une capture tien !!)

j'ai vérifié et effectivement je l'avais déplacé dans un autre dossier. il avait pas du aimé...même avec les updates...
mais en le lancant directement il fonctionnait

depuis les dernières mises a jours plus aucun problèmes ...

Quelqu'un pourra t'il résoudre le mystère sherlock ?
 

sifo

Membre junior
12 Janvier 2001
67
0
Toujours pareil...

Bon au pire je peux utiliser Sherlock ...sous classic !!! On arrète pas le progrès !!

Je vais quand même jeter un zoeil sur les droits des fichiers au cas où...
 

sifo

Membre junior
12 Janvier 2001
67
0
Ben dans la 10.0.4 aussi y bondit si tu fait pomme+F sauf que chez moi y bondit et y disparait (j'ai peut être une version de sherlock qui a été programmée par Garcimore)
 

matmiev

Membre confirmé
19 Décembre 2000
151
1
Juste pour information.

Il m'arrive également qu'une fois sur dix (ou douze) que Sherlock plante de la même manière et de façon tout à fait inexplicable (OS 10.0.4). Dans mes prefs Sherlock du dossier Library, je n'ai que "SherlockChannels.src" et "SherlockDefault.src"…

Attendons la 10.1 !