Problème avec MAMP et le httpd.conf

djez

Membre junior
11 Septembre 2008
45
0
Brest
Bonjour à tous,
Voila, j'utilise mamp depuis un moment pour tester le site que je suis en train de coder mais voila: En local tout marche bien mais depuis le web j'ai ce mesage d'erreur.
Si vous lisez cette page, c'est que les propriétaires de ce domaine viennent d'installer le serveur web Apache avec succès. Ils doivent maintenant ajouter du contenu à ce répertoire et remplacer cette page, ou bien faire pointer le serveur vers l'endroit où se trouve le contenu réel du site.
Vous voyez cette page au lieu du site attendu ?

Vous voyez cette page parce que l'administrateur du site a modifié la configuration de ce serveur Web. Veuillez contacter l'administrateur du site concerné. La Fondation Apache (Apache Software Foundation), qui produit le logiciel Apache utilisé par ce site, n'a rien à voir avec la maintenance de ce site et ne peut intervenir sur sa configuration.
La documentation Apache est incluse dans cette distribution.
Le webmaster de ce site peut librement utiliser l'image ci-dessous sur un site web utilisant le logiciel Apache. Merci d'avoir choisi Apache !
apache_pb.gif
J'ai essayé de regarder dans le httpd.conf mais je ne vois pas quoi configurer.

HELP please :)

Merci DJEZ
 

da capo

abonné absent
Club MacG
12 Août 2001
17 433
3 685
es-tu placé derrière un routeur ? lequel ?
as-tu redirigé les requêtes pour atteindre ton site sur l'ordinateur ?
 

dmo95

Membre émérite
24 Mai 2007
584
14
Si tu as surinstallé un serveur Apache à l'aide de MAMP (et oui Leopard propose déjà un serveur web Apache ;)), il te suffit de mettre le dossier de ton site dans le dossier Applications/MAMP/htdocs.

Ensuite tu lances MAMP et tu vas sur ton adresse local, généralement :
http://localhost:8080/ par défaut, mais il se peut qu'il n'y ait pas les ports 80.

Sinon l'instruction pour définir l'endroit ou ton serveur web va chercher les documents, se trouve dans le fichier httpd.conf, aux environs de la ligne 360, et est :
DocumentRoot "/Applications/MAMP/htdocs"

Voilà j'espère que tu t'en sortiras ;)
 

djez

Membre junior
11 Septembre 2008
45
0
Brest
Si tu as surinstallé un serveur Apache à l'aide de MAMP (et oui Leopard propose déjà un serveur web Apache ;)), il te suffit de mettre le dossier de ton site dans le dossier Applications/MAMP/htdocs.

Ensuite tu lances MAMP et tu vas sur ton adresse local, généralement :
http://localhost:8080/ par défaut, mais il se peut qu'il n'y ait pas les ports 80.

Sinon l'instruction pour définir l'endroit ou ton serveur web va chercher les documents, se trouve dans le fichier httpd.conf, aux environs de la ligne 360, et est :
DocumentRoot "/Applications/MAMP/htdocs"

Voilà j'espère que tu t'en sortiras ;)
Et bien le problème c'est que le contenu de mon site est déja dans le htdocs.
En local j'ai pas de soucis poru l'afficher c'est vraiment en ligne que je n'y arrive pas.
#
# MAMP DOCUMENT_ROOT !! Don't remove this line !!
DocumentRoot "/Applications/MAMP/htdocs/"
# Each directory to which Apache has access can be configured with respect
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Il vaudrait mieux poster dans le forum de développement ouaibe.
Es-tu sûr que tu arrives bien sur le bon site (celui de MAMP) et que tu n'aurais pas deux Apache lancés écoutant sur des ports différents ?
 

dmo95

Membre émérite
24 Mai 2007
584
14
Oui effectivement, j'avais pas calculer... désolé.

Donc ta machine ferait office de serveur web, que tu ouvrirais à la toile ?
 

djez

Membre junior
11 Septembre 2008
45
0
Brest
Problème résolu après une réinstal de mamp .
J'avais du toucher à de mauvais réglage.
"Comme on dit matos inconnu touche a ton cul " :D

Merci a vous :)