Question sur FCPX.

Dredriban

Membre émérite
2 Juillet 2011
906
30
Bonjour !

J'ai une petite question sur FCPX, la réponse est sans doute toute bête. Du coup, je monte des vidéos pour les mettre sur YT. Jusque là, tout va bien. Je monte donc avec FCPX. Pas de soucis, je fais le montage, tout va bien. Le problème c'est quand je veux (Je ne sais pas comment ça s'appelle dans le jargon) que cela me sorte ma vidéo en .mov (Pour qu'ensuite je convertisse en MP4 et upload ensuite sur YT, enfin ça on s'en fout).

Du coup je clique sur la petite flèche à droite et je mets "Fichier Master". Je clique sur OK. Et c'est là qu'aléatoirement il y a une petite erreur. Soit tout marche nickel, quand je clique sur la barre de chargement, je vois bien que je suis dans la section "Partage" et que le "Transcodage" de ma vidéo est en cours. Une fois fini, QuickTime s'ouvre et se met à lire ma vidéo. Ça c'est quand TOUT MARCHE.

Mais des fois (Pas tout le temps) ce n'est pas le "Transcodage" qui se lance mais le "Rendu" (Donc cela ne me sort pas la vidéo) je suis donc obligé d'annuler et de recommencer jusqu'à temps que le transcodage soit enclenché. SOIT le "Transcodage" marche bien mais une fois arrivé à 100%, QuickTime ne s'ouvre pas donc cela signifie que rien n'est sorti. Je dois donc recommencer. Ou des fois encore le "Transcodage" se lance et au bout de quelques % ça met direct 100% et il n'y a rien comme sortie. Je ne sais pas si je suis très clair, mais j'aimerais résoudre tout ça pour qu'à chaque fois tout fonctionne sans que je ne sois obligé de le refaire 10 fois.

Merci beaucoup ! Bonne journée !
 

NestorK

Membre d’élite
19 Novembre 2013
1 464
377
Paris
Déjà tu peux sortir directement un MP4, il te suffit de choisir le H264 dans le choix des exports. Tu peux même directement envoyer depuis FCP X ta vidéo sur Youtube.

Je ne comprends pas ce que tu appelles transcodage. Sous FCP X, il sert globalement à transformer tes rush de leur format natif en prores. J'ai l'impression que tu confonds tout ceci avec export ? Désolé si je me plante mais ton message est tout sauf clair effectivement.

Enfin, quand tu sors un export (si c'est bien de ça que tu nous parles), FCP X s'occupe d'abord de "rendre" ta timeline si cela n'a pas déjà été fait avant voire de la transcoder si c'est nécessaire. Rien de plus normal. Il faut laisser les choses aller au bout, que ce soit le rendu ou le transcodage, l'export doit reprendre naturellement par la suite.

Si je ne m'abuse, j'imagine que tu laisses FCP X gérer les rendus en automatique, c'est à dire qu'il va lui même s'occuper de ça en tâche du fond quand tu lui en laisses l'opportunité. J'imagine que parfois, il a fini avant que tu sortes ton export et parfois non, ce qui explique le résultat aléatoire que tu constates.

Quelle est ta version de FCP X ? Es-tu à jour ?
 
Dernière édition:
  • J’aime
Réactions: Dredriban

Dredriban

Membre émérite
2 Juillet 2011
906
30
Salut ! Merci de ta réponse. J'ai la version 10.2.3.

Je ne connais pas trop le lexique FCPX. Moi je fais mon montage. Ensuite sur le screen 2, je vais dans "Partager le projet" et je clique sur "Fichier Master". Et là ça lance le %. Et quand ça marche du premier coup, t'as une barre qui apparaît dans l'onglet "Partage" (1er screen) avec une jauge où il y a écrit "Transcodage" et quand ça arrive au bout cela veut dire que c'est à 100% et généralement QuickTime s'ouvre.

Mais des fois, ça lance juste le "Rendu" où une jauge apparaît dans "Rendu" et non dans "Partage". Et des fois ça apparaît dans "Partage" mais au final QuickTime ne s'ouvre pas. La prochaine fois que je fais un montage faudrait que je screene pour te montrer, je ne sais pas comment m'exprimer. xD

Capture d’écran 2017-07-12 à 13.25.18.png
Capture d’écran 2017-07-12 à 13.25.26.png
 

NestorK

Membre d’élite
19 Novembre 2013
1 464
377
Paris
Quand tu vas dans fichier master, ça ne lance rien automatiquement, tu as toute une série d'options à ta dispo, la destination par exemple, le choix du codec et j'en passe...





Quand tu valides un export, l'export va jusqu'au bout, et il est tout à fait possible qu'avant il soit passé par la case transcodage ou rendu. Si je prends mon exemple, je ne fais jamais mes rendus pendant le montage donc je les récupère systématiquement au moment l'export.

Si tu n'as pas d'export à l'arrivée, c'est tout simplement que tu ne l'as pas lancé, à moins d'une erreur signalée par le logiciel. Ou alors je n'arrive pas à comprendre comment tu t'y prends...

Au passage, si tu as acquis légalement FCP X, je t'invite à le mettre à jour car tu as du retard...

PS : Quicktime n'est pas obligé de s'ouvrir à chaque export (si tu as décoché la case demandant son ouverture à la fin de l'export par exemple), du coup si rien ne se passe, ça en veut pas dire que ton export ne t'attend pas sagement sur ton disque dur.
 
Dernière édition:

Dredriban

Membre émérite
2 Juillet 2011
906
30
Merci. Oui, oui, je suis d'accord, on peut modifier plein de choses. Et tu m'en apprends une bonne pour le MP4. Ça m'évitera d'handbrake. Question annexe, mais mon but est d'avoir le fichier le plus petit possible (Ayant une connexion en mousse mes uploads YT sont longs dans j'essaie de limiter le plus possible ce temps via le format. Je peux faire autre chose ?).

Pour en revenir à nos moutons, je te parlais quand une fois dans fichier master je cliquais sur "Suivant".

(Je précise que dans mes réglages le truc QuickTime est coché ainsi que le truc rendu en arrière fond un truc du genre).

Du coup je clique sur "Suivant" et soit t'as le rendu qui se lance soit le partage qui se lance. Le problème c'est que si c'est le rendu qui se lance, une fois à 100% bah j'ai pas de sortie. J'ai mon fichier seulement quand le partage est fini (Transcodage). Or ce n'est pas ça qui se lance systématiquement. Du coup quand le rendu se lance, je clique sur la croix. Et je relance jusqu'à ce que j'ai la jauge "Partage" qui apparaisse. Sachant que j'ai coché le truc QuickTime pour moi c'est le signal que c'est terminé.
 

NestorK

Membre d’élite
19 Novembre 2013
1 464
377
Paris
Je ne comprends pas ton problème - et du coup j'ai pas de réponse à te donner, si quelqu'un d'autre passe par là ? J'utilise FCP X tous les jours et quand je lui demande un export, il me donne un export, sauf cas exceptionnel systématiquement mis en évidence par un message d'erreur.

Je peux te suggérer tout du moins de compléter tes rendus avant l'export, avec le raccourci Control + Maj + R : ceci va rendre toute ta timeline. Si tu fais un export derrière, il va s'atteler logiquement à la suite, puisqu'il n'y aura plus rien à rendre.

PS : mets ton logiciel à jour...
 

Dredriban

Membre émérite
2 Juillet 2011
906
30
Je vais le mettre à jour. Mais quand tu lui demandes un export il te donne un rendu + un partage ? Du coup une fois le montage fini je fais ta commande et j'exporte en fichier master ? Merci.
 

NestorK

Membre d’élite
19 Novembre 2013
1 464
377
Paris
Je vais le mettre à jour. Mais quand tu lui demandes un export il te donne un rendu + un partage ? Du coup une fois le montage fini je fais ta commande et j'exporte en fichier master ? Merci.
Ce que j'appelle un export, c'est la commande "partage" dans FCP X. Cette commande va rendre ta timeline si ce n'est pas déjà fait, la transcoder si nécessaire, pour sortir un master qui est le résultat de ton montage.
 

Dredriban

Membre émérite
2 Juillet 2011
906
30
Merci. Mais du coup ça va me faire un rendu donc encore un chargement jusqu'à 100% ? J'ai l'impression que le rendu est plus long que le partage.
 

NestorK

Membre d’élite
19 Novembre 2013
1 464
377
Paris
Merci. Mais du coup ça va me faire un rendu donc encore un chargement jusqu'à 100% ? J'ai l'impression que le rendu est plus long que le partage.
Lorsque j'étalonne lourdement une timeline, le rendu de cet étalonnage est effectivement plus long et laborieux que la phase d'export en elle même. Mais les deux phases font partie d'une même pièce et sont indissociables. Oublie tes %, lance ton "partage" (export) et fais toi un café. :D
 

Dredriban

Membre émérite
2 Juillet 2011
906
30
Ok merci ! Et du coup avant je fais ta commande ? :D

Juste en MP4 c'est le moyen pour avoir le fichier le plus léger possible ? Ouais uploader une vidéo de 10 minutes sur YT me prend 30 minutes. Si je peux diminuer ce temps.
 

NestorK

Membre d’élite
19 Novembre 2013
1 464
377
Paris
Un rendu de la timeline, c'est intéressant à lancer que si ton montage en a besoin : si tu arrives à tout lire de façon fluide avec l'effet posé sans rendu, pourquoi s'emmerder la vie ? C'est l'export ("partage") qui se chargera du rendu pour toi.

Si toutefois tu souhaites rendre avant de lancer la commande export, oui : Contrôle + Maj + R pour toute la timeline ou Contrôle + R sur le plan que tu veux rendre. Selon la complexité des effets ou leurs nombres, ça peut prendre son temps.

Si tu veux du léger, oui : H264. Par contre, j'obtiens de meilleur résultat en repassant sous Handbrake derrière (je n'utilise pas Compressor). Et je ne suis clairement pas un spécialiste du sujet.
 

Dredriban

Membre émérite
2 Juillet 2011
906
30
Ok merci donc dans tous les cas faut repasser par Handbrake et dans tous les cas on a un rendu avant le partage ! Merci !
 

NestorK

Membre d’élite
19 Novembre 2013
1 464
377
Paris
Ok merci donc dans tous les cas faut repasser par Handbrake et dans tous les cas on a un rendu avant le partage ! Merci !
Pour la compression, pas forcément, mais n'ayant pas Compressor, je me contente du minimum avec FCP X, il y a certainement mieux à faire...
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 201
433
Pardon si je rentre dans cette discussion à propos de laquelle je rejoins Nestork ;) dans les grandes lignes.

Pour YouTube, on ne fait pas n'importe quoi. Il y a des spécifications déterminées par YouTube que je t'invite à consulter, ici.

Alors avec FCP X, soit on utilise la sortie directe sur YouTube et l'on est certain d'obtenir quelque chose de parfait (ce que je ne fais jamais car j'aime bien tout vérifier avant d'uploader), soit l'on achète Compressor, et l'on crée un préset 'aux petits oignons' que l'on retrouvera à l'export dans FCP X.
Quand on achète FCP X, on peut bien rajouter 50 € pour Compressor (je trouve d'ailleurs ton comportement très curieux de ne pas effectuer les mises à jour pourtant gratuites auxquelles tu as droit)…
Sachant que l'on peut sophistiquer les réglage en faisant appel au codec x.264 en lieu et place de H.264.

En tous cas, je ne vois pas ce que vient faire Handbrake dans cette affaire.

Quant à l'histoire de rendu, tu mélanges tout. Evidemment qu'il faut effectuer un rendu avant export, c'est comme cela dans absolument et sans exception tous les logiciels de montage vidéo.
Donc, comme indiqué par Nestork, une fois le montage terminé, on s'assure de la réalisation du rendu de la timeline et l'on exporte ensuite.
 

Dredriban

Membre émérite
2 Juillet 2011
906
30
Merci. Je vais regarder tout cela de plus près. Bah j'avais l'impression qu'en mettant directement sur YT, c'était plus long que d'exporter + uploader. Après je me trompe sans doute. Handbreake est là pour réduire la taille du fichier.

Mais dans mes réglages j'ai le rendu en fond qui est activé aussi, c'est pour cela que cela me semblait curieux !
 

NestorK

Membre d’élite
19 Novembre 2013
1 464
377
Paris
Mais dans mes réglages j'ai le rendu en fond qui est activé aussi, c'est pour cela que cela me semblait curieux !
Comme je te l’ai dit, le rendu en tâche de fond n’est pas quelque chose de 100% automatique : si tu ne lui en laisses pas l’opportunité, il peut ne pas se faire, tout dépend de ton activité sur la timeline. Si elle est occupée par tes manipulations, FCPX te laisse la priorité et n’effectue aucun rendu.
 

Dredriban

Membre émérite
2 Juillet 2011
906
30
Ok. Merci. Du coup c'est à désactiver ou pas ? J'ai pas un montage de fou : une intro, outro, une piste vidéo, une piste audio et un fond. Par-rapport à le thème de ma chaîne (Actualité tennistique) j'ai besoin de sortir la vidéo le plus rapidement possible après le résultat. Y-a-t-il des astuces pour réduire le temps d'export/upload YT ou pas ?

Compressor sert à quoi au fait vu que vous faites qu'en parler. XD
 

Dredriban

Membre émérite
2 Juillet 2011
906
30
Je vais mettre à jour mais avant j'essaie de comprendre. Je crois que je commence à comprendre le début, pour faire un export, il faut un rendu. Comme lors de certains de mes montages, le rendu devait se faire en arrière plan (Car coché dans les réglages) quand j'exportais ça exportait directement. Du coup quand ça me ne le faisait pas (Car le rendu n'avait pas eu le temps de le faire) je pensais à l'anomalie.

Par-contre j'ai toujours 2 problèmes :

1) Rendu fait (J'ai vu le truc à 100%). Je lance l'export. Le chargement commence brièvement à se lancer puis BAM il s'annule comme ça sans crier garde. Et je dois le relancer.

2) Rendu fait. Je lance l'export. Cela va jusqu'à 100%. Et rien ne se passe (Pas de vidéo sur mon bureau. Pas QuickTime qui s'ouvre). Je dois donc encore relancer l'export.

Comment cela s'explique-t-il ? Merci.
 

NestorK

Membre d’élite
19 Novembre 2013
1 464
377
Paris
Aucune idée. Je n'ai jamais constaté ce genre de comportement. J'ai déjà eu des soucis à l'export, mais ils m'ont tous été signalés par un message d'erreur.
 
Dernière édition: