MacBook Pro recover admin account

Hamza123456

Nouveau membre
25 Février 2020
3
0
20
Help me, please I went into system preferences, clicked on the current user (advanced options), which was named 'user', which was also the administrator, and changed the name to 'grant'. I then tried to create another administrator user called 'grant'. When I logged back in the only user available to log in with was 'user'. When I opened user preferences I see that 'user' is no longer an administrator. I've tried every combination of 'user' and 'grant' and nothing works. I've tried the code (after restarting and press cmd +S ) mount -uw / nm /var/db/.AppleSetupDone But it shows me [ Erreur no developer tools were found at'application/Xcode.app' and no install could be required perhaps no UI is present please install manually from developer.apple.com ] I can't download Xcode cause I don't have an admin account. (MacBook pro 2015 high sierra)
 

Fichiers joints

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 793
21 532
Forêt de Fontainebleau
Hi ! Hamza

Once into the Single User's session (⌘S) > and first command :
Bloc de code:
mount -uw /
  • executed > the second command is actually :
Bloc de code:
rm /var/db/.AppleSetupDone
  • where first term is : rm (remove) > and not nm as you wrote it.

Do try again the operation into the Single User's session.
 
Dernière édition:
  • J’aime
Réactions: litobar71