Safari me cache des choses

c_c

Membre junior
20 Juillet 2006
71
0
Bonjour,

Si je visite un site avec FireFox ou Camino, tout est clair et dispo. Par contre, Safari (v 3.0.4) me cache des choses : une page qui ne s'affiche pas complètement ou une autre page qui ne s'affiche pas du tout. Ou mieux, pardon, pire : affiche une autre page à la place de la bonne.

Faut-il le mettre a la poubelle ?
Qu'en pensez vous?
Merci

C


.
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 321
59
St Germain en Laye - FRANCE
Essaie tout d'abord de purger le cache de Safari (dans l'un des menus tu trouveras cette option)

Et eventuellement donne-nous des liens vers les pages qui s'affichent mal pour qu'on essaie d'aller les visiter. Ca permettrait de vérifier que c'est un pb général lié à Safari, ou un pb limité à TON Mac.
 

c_c

Membre junior
20 Juillet 2006
71
0
Essaie tout d'abord de purger le cache de Safari (dans l'un des menus tu trouveras cette option)

Et eventuellement donne-nous des liens vers les pages qui s'affichent mal pour qu'on essaie d'aller les visiter. Ca permettrait de vérifier que c'est un pb général lié à Safari, ou un pb limité à TON Mac.

reBonjour,

Merci. Dans le menu "Debug" j'ai vu "show cache window", là j'ai tout vidé. J'ai aussi basculé sur "Use back/forward cache". J'au aussi effacé l'historique puis passé Onyx. Rien à faire.
La page Accueil de http://kim66.unblog.fr/ doit afficher
"Nous sommes au XXIe après JC ?* Toute la Gaule est occupée par l'Administration…", or Safari affiche la page des articles.


????

C
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 321
59
St Germain en Laye - FRANCE
Moi Safari m'affiche ça:

ZZ6E9505DF.jpg


Mais j'utilise la version 3.2.1 de Safari
(au passage... "Vider le cache" ce n'est pas dans le menu Debug, mais dans le menu Safari)
 

c_c

Membre junior
20 Juillet 2006
71
0
Moi Safari m'affiche ça:

Mais j'utilise la version 3.2.1 de Safari
(au passage... "Vider le cache" ce n'est pas dans le menu Debug, mais dans le menu Safari)

Merci encore. Bon, Ton affichage est correct. Pas avec mon v 4
J'ai vidé le cache via menu Safari. Rien n'a changé....
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 321
59
St Germain en Laye - FRANCE
POurquoi ne mets tu pas à jour Safari? Ton Mac n'accepte pas la toute dernière version 3.2.1 ?
 

c_c

Membre junior
20 Juillet 2006
71
0
POurquoi ne mets tu pas à jour Safari? Ton Mac n'accepte pas la toute dernière version 3.2.1 ?

C'est une bonne idée. J'ai essayé. D'abord Safari n'est pas proposé par "Mise à Jour Logiciels" après suis allé au site Apple Téléchargements... et (mon) Safari ne télécharge pas !
Il m'a fallu reprendre FireFox pour le faire. J'ai la Dmg, je l'installerai bientôt.
Merci

C
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 321
59
St Germain en Laye - FRANCE
quelle version de MacOS X utilises-tu? MacOS X 10.3.9?
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 321
59
St Germain en Laye - FRANCE
Alors avec 10.4.11 tu dois pouvoir passer Safari en version 3.2.1 !
 

c_c

Membre junior
20 Juillet 2006
71
0
J'ai donc installé le Saf 321. Il se passe quelque chose de curieux : J'avais un applescript qui l'ouvrait (avec d'autres). La nouvelle version s'ouvre mais elle "oublie" la fenêtre et affiche un message : "aucun document n'a pu s'ouvrir".
Je précise que les préférences ont "ouvrir avec une page vide"....


c
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 321
59
St Germain en Laye - FRANCE
TU pourrais nous mettre une copie de l'applescript en question? C'est peut-être lui qui envoie à Safari l'URL d'une page à ouvrir, non?
 

c_c

Membre junior
20 Juillet 2006
71
0
Voici le script:

tell application "FF"
activate
end tell

tell application "Safari"
activate
end tell

tell application "M$Ent"
activate
end tell



----
La nouvelle est bonne : En plus, Safari ne veux pas ouvrir une fenêtre nouvelle. Dans le menu "Fichier", "Nouvelle fenêtre" est gris.
Il en crée une en appelant un signet.

Il se passe une autre rare chose: l'éditeur de scripts 2.1.2 ne s'ouvre pas. Je dois appeler la v 2.1.1 (de OS 10.3) pour éditer.
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 321
59
St Germain en Laye - FRANCE
Très bizarre tout ça....

Chez moi le même script fonctionne parfaitement et Safari s'ouvre en affichant la page d'accueil par défaut (comme si je le lançait manuellement)

Concernant le Script Editor (dont la version 2.1.2 s'ouvre parfaitement aussi chez moi....), essaie de mettre à la corbeille le fichier com.apple.scriptEditor2.plist
 

marialouisa

Membre junior
13 Août 2007
25
1
Moi aussi j'ai plein de problèmes avec internet
firefox depuis la dernière mise à jour qui se fait automatiquement est d'une lenteur pas possible même pour s'éteindre il met 5 minutes et bloque tout
safari n'ouvre pas les forums de tricot où je vais et des jours on ne sait pas pourquoi il les ouvre sans problème
Peut-être que la connection livebox orange n'est pas fiable tout le temps à cause des intempéries (le portable s'est pareil il se met en urgence de temps en temps)
En tout cas quand j'ai des problèmes avec ces deux navigateurs, je retourne à mon vieux Mozilla (1.7.12) qui lui fonctionne. Bizarre ?
J'en profite pour poser une question : est ce qu'il existe un logiciel qui regroupe tous les favoris des différents navigateurs et qui pourrait les classer, éviter les doublons et ouvrir dans le navigateur utilisé (par forcément celui par défaut) ?
Mac ox 10,4,11
firefox 3,05
safari 3,2,1
Bonne journée
 

c_c

Membre junior
20 Juillet 2006
71
0
Concernant le Script Editor (dont la version 2.1.2 s'ouvre parfaitement aussi chez moi....), essaie de mettre à la corbeille le fichier com.apple.scriptEditor2.plist

Je l'ai mis. Script Editor version 2.1.2 ne s'ouvre toujours pas. Il n'y a pas eu de nouveau com.apple.scriptEditor2.plist de créé....

??
Un problème plus de fond ?


C
 

c_c

Membre junior
20 Juillet 2006
71
0
Je reprends cette histoire.

Maintenant, le script fonctionne et Safari aussi. Je ne sais pas pourquoi (les mystères de l'informatique), mais je présume que c'était Safari le coupable, Car il y a d'autres applis qui ne s'ouvrent pas (et ne dissent rien) : Automator, Dictionary, Image Capture, Éditeur de scripts; toutes du pack Apple et qui n'ont que l'icône générique.
Quelque chose cloche dans mon système?
Merci pour vos lumières.

C

.
 

PO_

Membre d’élite
Club MacG
29 Avril 2008
1 719
125
58
Biscarrosse (Landes)
on dirait oui ...

As tu essayé de réinstaller la mise à jour combo de 10.4.11 ? ? ? ON ne sait jamais, des fois ça remet des choses en place.

Mais face à tant de dysfonctionnements, je me demande si, même si on n'est pas sous WIndows, une bonne réiinstallation ne serait pas judicieuse ...