SSD non reconnu en interne [macbook pro 13 mi-2010]

apaloosa

Nouveau membre
8 Janvier 2014
2
0
Bonjour,

C'est mon premier sujet sur ce forum, j'ai besoin d'aide dans une sombre histoire concernant :
-un SSD crucial m500 480go tout neuf
-un macbook pro 13 pouces mi-2010
Problème : Le SSD est reconnu et booté en externe (boitier firewire ou USB) mais pas en interne (à l'emplacement sata II du disque dur initial).

Description des manipulations effectués : je cherchai à remplacer le disque dur interne par ce SSD, et d'effectuer par la même occasion une migration de OSX 10.6 Snow Leopard à Mavericks.
-J'ai créé une clé usb bootable d'installation Mavericks (à partir d'un macbook air récent tournant sous mavericks).
-J'ai monté le SSD à la place du disque initial dans le Macbook pro.
-J'ai booté depuis la clé usb Mavericks (touche alt au démarrage) pour faire une clean install.
Premier Problème (résolu) : le SSD était reconnu mais l'utilitaire de disque intégré dans la clé usb refusait de le formater (erreur "Le balayage des données du volume afin d’empêcher de futures recherches accidentelles a échoué"). En cherchant sur le net j'ai vu que ce problème pouvait provenir d'une nappe sata reliant la carte mère au disque défaillante et posant des problèmes avec les disques à haute vitesse. Solution : changer la pièce ou blinder la nappe avec de l'aluminium. Après avoir enveloppé la nappe dans de l'aluminium de cuisine et du cellophane pour isoler, le disque est formaté normalement).
-L'installation se poursuit ensuite normalement (après une erreur du type "la version de la clé usb bootable n'est pas reconnue" lors de l'installation, résolu en réglant une date et heure sur le mac à l'aide de l'instruction "date" au terminal). Arrivé à l'étape où on entre le mot de passe associé à l'identifiant apple "apple id", je fait une erreur sur le mot de passe, le mac affiche la roue colorée pendant longtemps, je décide de le redémarrer en appuyant sur le bouton d'allumage.
-Situation problématique : Suite à cet incident, le mac ne démarre plus (bloqué sur la pomme grise et même affichage d'un panneau d'interdiction au démarrage). Je me résouds à recommencer mais booter depuis la clé usb ou le cd d'installation snow Leopard est impossible (comportement aléatoire du boot, disques non-présents lorsque j'appuie sur alt au démarrage, ou alors impossible d'utiliser cette touche ou la touche C pour démarrer depuis le CD : inquiétant).
-Je remonte le disque d'origine dans le mac, je boote sur le système Snow Leopard installé, le SSD est reconnu dans un boitier externe, je le reformate en étendu avec la partition qui va bien (OSX étendu et table GUID).
-J'installe Mavericks avec succès sur le disque SSD en le laissant en externe (Installation en lançant l'application install Mavericks sur la clé usb bootable depuis le système snow Leopard).
-Situation actuelle : le SSD est parfaitement reconnu en externe actuellement, je boot sans problème sur le mavericks qui y est installé en démarrant avec "alt" enfoncé. En revanche il n'est absolument pas détecté lorsque je le remonte en interne (écran strictement blanc au démarrage, disque non détecté dans l'utilitaire de disque si je boote depuis la clé usb mavericks par exemple).

À ce stade je ne comprends pas ce qui peut clocher pour qu'un disque boote parfaitement en externe mais pas en interne, je manque de connaissances pour voir ce qui peux différer ici.

Quelques pistes :
-Peut-être la nappe sata ne fonctionne-t-elle pas bien malgré un comportement sans heurt lors de l'installation de Mavericks après l'envelopage dans l'alu (mais toute l'installation a quand même fonctionné jusqu'à l'apple id, je serais étonné). Des tests avec une pièce neuve ou fonctionnelle pourrait aider.
-> J'envisage de mettre à jour le EFI du mac pour pouvoir effectuer une restauration par internet de OSX sur le SSD préalablement effacé totalement ( cf. OS*X*: à propos de la fonctionnalité de restauration OS*X ).

Je suis à l'écoute de toute suggestion ou connaissance technique aidante, je ne vois vraiment pas ce qui peut différer entre un boot interne et externe ici. Je vous remercie déjà de m'avoir lu jusqu'ici ! :)

Édition : zut j'ai oublié de mettre des tag au sujet et je n'y arrive pas en éditant :-(
 
Dernière édition:

zol68

Membre confirmé
18 Novembre 2007
121
0
Salut,
Si j'ai bien compris le SSD ne fonction pas dans ton MacBook Pro, mais fonction en
externe. Moi je crois que en changent la nappe du disque dur ton SSD seras reconnu et fonctionnerais normalement. Déjas le fait de entourer la nappe avec du
l'alu pour installer l'OS n'est pas normale. Moi même j'ai installer plusieurs SSD et seulement une fois j'avais de problème avec la nappe. Je la changé et plus de problème. Donc tu doit changer la nappe et remettre le SSD dans ton MacBook Pro.
 

apaloosa

Nouveau membre
8 Janvier 2014
2
0
Merci pour votre réponse, j'ai fait quelques tests de plus et j'en était arrivé à cette conclusion également. J'ai commandé une nappe de marque ifixit, je vous tiens au courant :)