texmaker et aspell : problème d'accents

Thomas76

Nouveau membre
3 Juin 2007
6
0
43
Bonjour,
Je viens de passer de TeXShop à TeXMaker car je trouve ce dernier un peu plus complet (notamment au niveau de l'édition maths où de nombreuses commandes sont directement accessibles).
J'ai bien configuré le aspell mais j'ai un soucis d'encodage. Je n'arrive pas à avoir les accents avec aspell (j'ai pourtant essayé tous les encodages mais ça ne marche pas). Quelqu'un a t il une idée ?
Par ailleurs, tant que j'y suis, savez vous s'il y a moyen de faire de la correction orthographique "a la volée" avec TeXMaker ?
Merci beaucoup,
Thomas
 

Ratatouille

Membre junior
1 Octobre 2007
82
2
je n'arrive pas non plus à configurer l'encodage correctement. Je ne sais pas ce qu'est aspell mais j'ai fait les réglages dans les préférences et ça ne suffit pas.
Je veux compiler en latin1 bien sûr, pas en applemac !
Merci d'avance
 

Luitel

Membre junior
22 Janvier 2005
69
4
48
Il faut aussi insérer la ligne
Bloc de code:
\usepackage[T1]{fontenc}
en préambule de votre document, en plus des \usepackage[applemac]{inputenc} ou \usepackage[latin1]{inputenc}.

Sinon, même si votre PDF affiche les caractères accentués correctement, LaTeX les interprétera comme "\'e, \`e", même si dans Texmaker vous les avez insérés directement (é, è, à…). Parce que la police par défaut (Computer Modern), ne conçoit les caractères accentués que comme une superposition de deux caractères*: l'accent et le caractère de base. Ce qui fait qu'un correcteur ne les reconnaît pas.

Avec la ligne ci-dessus, vous imposez à LaTeX d'utiliser une police définissant chaque caractère accentué" comme un caractère entier. Par défaut, si on se contente de cette seule ligne, c'est la police "cm-super". Mais il y en a d'autres. Je recommande plutôt les Latin Modern*:
Bloc de code:
\usepackage[T1]{fontenc}
\usepackage{lmodern}
parce qu'elles ont exactement la même apparence extérieure que les Computer Modern (avec les caractères accentués en plus*!)
 

MatPhD

Nouveau membre
27 Janvier 2009
2
0
bonjour,
j'ai exactement le meme probleme d'accent avec Texlipse+aspell et l'entete n'a rien résolu
Mon entete :
\usepackage[latin1]{inputenc}

\usepackage[french]{babel}

\usepackage[T1]{fontenc}

\usepackage{lmodern}


La commande Aspell : /usr/local/bin/aspell
option : -a -t --lang=fr_FR --encoding=iso8859-1

et rien à faire les mots accentués sont coupés en 2. De plus les mots proposés dans la liste sont mal encodés -> il y a des caractères bizarres...
est ce que ca vient du fait que Aspell gère l'utf8 et gère mal le ISO 8859 1 ?

Merci de votre aide
Mat.
 

Ratatouille

Membre junior
1 Octobre 2007
82
2
je ne connais pas aspell, mais il doit y avoir moyen de changer l'encodage des caractères quelque part, genre dans les préférences... Sinon il faudra trouver l'encodage utilisé ! Mais ce n'est pas le mieux si tu veux que tes fichiers soient modifiés par d'autres gens !
Bon courage pour tes problèmes d'accents !
 

MatPhD

Nouveau membre
27 Janvier 2009
2
0
ouais c'est pas gagné :(
je me demande si le probleme ne vient pas de eclipse sur mac : en effet, j'ai testé sous windows, et là ça fonctionne : les mots proposés par aspell sont correctement accentués....
eclipse transforme en mac roman les suggestions de aspell. Je ne sais pas du tout comment résoudre cela :s
 

Ratatouille

Membre junior
1 Octobre 2007
82
2
j'crois que j'avais lu en grande diagonale !
j'ai l'impression que t'es pas le premier à avoir ce genre de problème. Perso, je n'utilise pas de correcteur d'orthographe pour documents tex ! j'ai choisi de les faire relire par plusieurs personnes, et c'est tout aussi efficace !
Courage pour trouver la solution !