iMac Catalina sur Imac 27 " mi 2011 et carte graphique 1/4

nemorigolo

Membre junior
8 Mars 2010
13
0
Ouai je sais bien que c'est écrit no :up:
Mais est ce que c'est no parce qu'il n'y a pas assez de place (sans modification), de puissance, que le refroidissement n'est pas assez dimensionné ??? :bookworm:

Je vais essayer de me documenter et je vous tient au jus si je trouve quelque chose.
Merci.
Bonne soirée à tous
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
258
108
Nice
www.nojo.fr
Ouai je sais bien que c'est écrit no :up:

Je me doutais bien que tu savais ;)

Mais est ce que c'est no parce qu'il n'y a pas assez de place (sans modification), de puissance, que le refroidissement n'est pas assez dimensionné ??? :bookworm:

Certains ont essayé mais il semble que la plupart ont eu des problèmes...

"Has anyone had any overheating issues using an MXM-b card in a 21.5" frame???"

"Its a bit tricky to fit and the heatsink is designed for a smaller card. TDP might be an issue, because for example a k1100m is 45W, while the 765m is 75W. But some people still using it, so it might be fine. But i would go with a mxm-a quadro, it fits better and perfectly fine for a 21". Might be a bit slow for 27"(higher resolution)"


"Yes, this has been tested here and was not stable, even with custom clocks. The card actually overdrew the power supply, rather than overheating. I would stick with the Quadro cards."

"After updating my iMac to to 10.4.6, it is haveing random Kernel panics that only happen while booted in Mojave. To verify this being strictly related to Mojave I have reinstalled Mojave to another SSD and still experience the same issue. On a new install the Kernel panics happen same spot Everytime, creating an account. My theory for this issue is my 770m in the 21.5" iMac is drawing too much power causing the iMac to reboot. My iMac is configured with a i7 2600s and 2 SSD's with an optical drive. I have also experienced a BSOD at least once while booted in Windows 10. Again further concluding the card is drawing too much power for the iMac to deliver. This issue does not happen in High Sierra, but from me digging around in High Sierra months ago I remember there were GPU power management kexts in High Sierra.
The TLDR is with the new ROM my iMac can no longer Handle the 770M as it's requesting too much power. I will be swapping the 770m for a k2000m once there is a ROM released."
 

globetribe

Membre junior
12 Décembre 2020
50
5
41
Question toute bête mais on est d'accord si je dois changer la CG et DD. Je commence d'abord par le DD, je check que tout fonctionne nickel et une fois que c'est le cas, je redemonte la bête et je monte la nouvelle CG en priant qu'elle soit compatible ?
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
258
108
Nice
www.nojo.fr
Question toute bête mais on est d'accord si je dois changer la CG et DD. Je commence d'abord par le DD, je check que tout fonctionne nickel et une fois que c'est le cas, je redemonte la bête et je monte la nouvelle CG en priant qu'elle soit compatible ?

Quand j'avais prévu de changer la CG de mon iMac, j'en ai profité aussi pour changer le SSD principal. En effet, j'ai commencé par changer le SSD, tout tester, et ensuite j'ai changé la CG.

1) Lors du changement du disque, il est possible de ne pas remonter l'écran pour limiter le nombre de manipulations des petits connecteurs. Il suffit de connecter un écran externe sur un des connecteurs mini display port / Thunderbolt et on peut faire l'installation de l'OS sur le nouveau disque le cas échéant. Cette méthode fonctionne la plupart du temps.

2) De la même façon, il est possible de faire 2 trous à l'arrière pour rechanger la CG , si nécessaire :( , sans démonter la carte mère:

IMG_7247.jpeg
 

globetribe

Membre junior
12 Décembre 2020
50
5
41
Merci pour tes précieux conseils !

Je viens juste de recevoir la CG :up: on va pouvoir gentiment commencer.
En relisant tes posts et le thread sur macrumors, j'ai encore deux trois trucs qui me semble moins clairs.
Tu avais fait comment pour le XBracket ?
Et pour le morceau de cuivre, j'ai un gros doute. Tu mets de la pate Kryonaut sur le chips de la CG tu rajoutes par dessus le bout de cuivre, et enfin tu rajoutes de la pate sur le bout de cuivre et tu plaques le tout sur le heatsink ? c'est cela ?
le bout de cuivre, il faut qu'il soit pile poil découpé à la taille de la puce ? j'ai pris la reference que tu m'avais conseillé sur Amazon, les pièces font 2cm x 2cm alors que la puce doit faire 1x1. si je peux eviter une découpe ça m'arrangerait ;-)
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
258
108
Nice
www.nojo.fr
Merci pour tes précieux conseils !

Je viens juste de recevoir la CG :up: on va pouvoir gentiment commencer.
En relisant tes posts et le thread sur macrumors, j'ai encore deux trois trucs qui me semble moins clairs.
Tu avais fait comment pour le XBracket ?

On a du prendre l'ancien car le nouveau est fileté et l'ancien non (ou l'inverse ;)) .

Et pour le morceau de cuivre, j'ai un gros doute. Tu mets de la pate Kryonaut sur le chips de la CG tu rajoutes par dessus le bout de cuivre, et enfin tu rajoutes de la pate sur le bout de cuivre

Oui.

et tu plaques le tout sur le heatsink ? c'est cela ?

Oui. Il ne faut pas en mettre trop, l'équivalent d'un grain de riz suffit entre le chip et le cuivre.

le bout de cuivre, il faut qu'il soit pile poil découpé à la taille de la puce ? j'ai pris la reference que tu m'avais conseillé sur Amazon, les pièces font 2cm x 2cm alors que la puce doit faire 1x1. si je peux eviter une découpe ça m'arrangerait ;-)

Je viens de demander à mon frère qui a une carte WX41xx sous les yeux, à priori la pièce de cuivre de 2 cm * 2 cm devrait être OK sans découpage. Vérifie bien que ça ne touche rien. A priori, pour 2 cm * 2 cm, tu peux mettre l'équivalent de 2 grains de riz entre la pièce et le radiateur :).

Les pièces de cuivre font bien 1 mm d'épaisseur ?

Bonne chance pour la carte :up:
 

globetribe

Membre junior
12 Décembre 2020
50
5
41
salut à tous,

@sergiodadi étape 1 réalisé hier soir. j’ai changé hier le HDD vers SSD. J’ai du remonter l’ecran car l’écran externe branché sur mini display est resté noir... et au bout de qq instants ( genre 2 min) les ventilateurs se mettaient à tourner à donf . j’espère que ça ne posera pas problème pour la suite. En tout cas Rien que ça c’est déjà le jour et la nuit, sur les perf de la bête ! Le boot Time est raccourci à qq dizaine des secondes et les installations prennent qq minutes au lieu de quasi une heure !

Je m’attaque à la phase 2 aujourd’hui. J’ai un peu commencé les préparatifs hier soir, du coup J’ai encore une flopée de questions... vais quand même essayer d’éviter le spam massif :)

concernant la distro Linux bootable. Quand je regarde dans les fichiers je ne vois pas l’utilitaire amdvbfmash que tu as utilisé. Tu l’as ajouté de ton côté ? Sur macrumors ils utilisent un autre utilitaire qui lui est bien présent dans le répertoire de fichier.
Pour le catalinaloader et OC, il suffit juste de créer l’image sur la SD c’est bien cela ? Je vois que tu as utilisé la 0.6.2. La dernière version est 0.6.5+ et à priori le support de high Sierra est moins certain. Pour revenir sur la version précédente, j’imagine que j’ai juste à modifier le contenu du fichier OC ?

Si je résume maintenant Une fois que j’ai fait tout cela, je flash le vbios ( roulement de tambour, panique à bord, finger crossed), je reco le sdd, je mets mon Catalina loader et j’allume la bécane. ( c’est l’étape la ou tu peux soit utiliser le loader soit le trick avec l’écran externe ? ) Si tout se passe bien j’ai un écran de boot et un screen qui me proposera le DD sur lequel je veux booter .

voili voilou pour le message matinal /-)
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
258
108
Nice
www.nojo.fr
concernant la distro Linux bootable. Quand je regarde dans les fichiers je ne vois pas l’utilitaire amdvbfmash que tu as utilisé. Tu l’as ajouté de ton côté ? Sur macrumors ils utilisent un autre utilitaire qui lui est bien présent dans le répertoire de fichier.

J'ai utilisé la méthode qui est conseillée par macrumors, qui est décrite ici , je n'ai rien changé (à part prendre par précaution la dernière version de amdvbflash).

EDIT: je vois que j'ai utilisé la version 4.71, on la trouve ici le cas échéant.

Pour le catalinaloader et OC, il suffit juste de créer l’image sur la SD c’est bien cela ?

Oui. Je l'ai crée avec balena etcher et il faut simplement choisir le fichier config.plist correspondant à la CG employée:

Capture d’écran 2021-03-06 à 11.35.10.png

Je vois que tu as utilisé la 0.6.2. La dernière version est 0.6.5+ et à priori le support de high Sierra est moins certain.

J'ai utilisé la version 0.6.3 (c'est indiqué 0.6.2 dans le post mais la version 0.6.3 a du sortir au moment où je faisais les derniers essais) que l'on trouve ici


Si tout se passe bien j’ai un écran de boot et un screen qui me proposera le DD sur lequel je veux booter .

Oui... Si tu as 2 disques bootables, tu verras les 2 :)
 
Dernière édition:

globetribe

Membre junior
12 Décembre 2020
50
5
41
@sergiodadi Ce que tu dis me rassure, au moins j'ai un peu compris comment tout cela fonctionnait :bookworm:
Je viens de faire un test en ssh en bootant sur la clé, sans avoir encore changer la carte, et j'arrive bien à me connecter. :up:
En revanche je suis étonné car quand je rentre la commande ./amdvbflash -i (ou -ai), il me sort qu'aucune CG n'est trouvée alors qu'il y a la Radeon avec proc AMD d'origine. Tu as eu ça aussi ?
Je devrai avoir d'autres nouvelles dans le courant de l'aprem ou du week end. Keep posted.
et Merci encore pour les précieux conseils :)
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
258
108
Nice
www.nojo.fr
@sergiodadi Ce que tu dis me rassure, au moins j'ai un peu compris comment tout cela fonctionnait :bookworm:
Je viens de faire un test en ssh en bootant sur la clé, sans avoir encore changer la carte, et j'arrive bien à me connecter. :up:

C'est déjà bien :up:

En revanche je suis étonné car quand je rentre la commande ./amdvbflash -i (ou -ai), il me sort qu'aucune CG n'est trouvée alors qu'il y a la Radeon avec proc AMD d'origine. Tu as eu ça aussi ?

Je n'avais pas fait l'essai avec la carte d'origine donc je ne sais pas. Ceci dit, la carte d'origine a été très probablement modifiée avec un cahier des charges Apple, donc elle pourrait ne pas être vue, peut-être volontairement d'ailleurs ...
 

globetribe

Membre junior
12 Décembre 2020
50
5
41
@sergiodadi
Suis en train de démonter la bête.... a priori ce n'est pas la première fois :eek:
Apparemment le branchement du capteur de température gauche a été cassé et les fils ont été branché directement avec des micro cosses. En soit ce n'est pas un problème, rien n'est abimé mais j'ai juste oublié de prendre une photo avant :nailbiting:
Tu ne saurais pas par hasard si en ce basant sur la photo ci-dessous c'est le fil gris va à gauche et le noir à droite ? ou l'inverse ?
Capture d’écran 2021-03-06 à 16.07.00.png


Sinon faudra que je te repose des questions sur Catalina loader et OC... je crois que j'ai pas tout pigé en fait...

Mille mercis
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
258
108
Nice
www.nojo.fr
@sergiodadi
Suis en train de démonter la bête.... a priori ce n'est pas la première fois :eek:
Apparemment le branchement du capteur de température gauche a été cassé et les fils ont été branché directement avec des micro cosses. En soit ce n'est pas un problème, rien n'est abimé mais j'ai juste oublié de prendre une photo avant :nailbiting:
Tu ne saurais pas par hasard si en ce basant sur la photo ci-dessous c'est le fil gris va à gauche et le noir à droite ? ou l'inverse ?

Voila :)


Capture d’écran 2021-03-06 à 16.40.14.jpg
 

globetribe

Membre junior
12 Décembre 2020
50
5
41
@sergiodadi Coucou :coucou:
bilan de la journée, je crois qu'on est pas mal là !!!!!
J'ai réussi la manip pour le moment, la nouvelle CG est reconnue comme une Radeon RX 460 comme prévu. Je ne sais comment te remercier car tes conseils ont été tout du long extrêmement précieux :up:

Sans titre.png


Reste maintenant à installer le bootloader.

Je ne te cache pas que tout à l'heure j'ai installé le fichier disponible ici mais je crois que j'ai loupé qq ch ! le fichier fait 10MB. Après unzip (avec code) j'ai accès à un readme en pdf qui me parle d'un fichier de 500mb.
J'ai utilisé balena pour écrire sur une carte SD mais j'ai pas l'impression que ça crée une image
Bref je suis un peu perdu... mais content ;-)
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
258
108
Nice
www.nojo.fr
@sergiodadi Coucou :coucou:
bilan de la journée, je crois qu'on est pas mal là !!!!!
J'ai réussi la manip pour le moment, la nouvelle CG est reconnue comme une Radeon RX 460 comme prévu.

:up:

L'écran fonctionne sans écran externe et sans bootloader ?

Je ne sais comment te remercier car tes conseils ont été tout du long extrêmement précieux :up:

Reste maintenant à installer le bootloader.

Je ne te cache pas que tout à l'heure j'ai installé le fichier disponible ici

Lequel exactement ? Il en faut 2 ;) ,voir plus loin.

mais je crois que j'ai loupé qq ch ! le fichier fait 10MB. Après unzip (avec code) j'ai accès à un readme en pdf qui me parle d'un fichier de 500mb.

Mes cartes SD "Catalina loader" font 50 Mo et 90 Mo environ...

J'ai utilisé balena pour écrire sur une carte SD mais j'ai pas l'impression que ça crée une image
Bref je suis un peu perdu... mais content ;-)

Il faut :
1) utiliser Balena Etcher avec l'image catalinaloader.dmg pour la flasher sur la carte
2) Ensuite , il faut ajouter les fichiers de la version voulue sur la carte
 

globetribe

Membre junior
12 Décembre 2020
50
5
41
L'écran fonctionne sans écran externe et sans bootloader ? >> je ne serai te dire car j’ai utilisé l’écran externe dans les premiers heures et ensuite j’ai fait des bidouilles avec le catalina loader sans écran externe mais je ne sais pas souvenir si ça changeait qqch; l’OS finissait toujours par se lancer au finish :)

Du coup J’ai passé pas mal de temps hier soir sur le forum macrumors et je crois que j’ai enfin compris comment le loader et open core fonctionnent.. enfin à peu près :)

Âpres flash de la clé, install des différents compléments et reset de la nvram, j’ai un bootloader fonctionnel. J’ai eu des kernel panic en sortie de sleep mode que j’ai fixé. j’ai installé Catalina avec le patcher de dosdude1.

Les problèmes que j’ai vu pour le moment c’est
1/ la carte graphique interne au CPU est vu comme une 2000 malgré l’installation de tout le kext file nécessaires. Quand je patche ça passe en 3000 mais au redémarrage suivant on repasse en 2000
2/ la gestion des DRM ne fonctionne pas puisque je n’arrive pas à regarder Netflix sur Safari.
En soit ce ne sont pas des problèmes très gênant pour moi vu l’utilisation que j’en ai.

j’ai aussi fait les benchmarkings. La config est à 18000 sur metal et à 800/3200 sur le CPU. Je vais booste un peu la ram pour passer à 24 où 32 ce qui devrait influer positivement sur les performances !

Next step installer bigsur sur une partition du SSD.
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
258
108
Nice
www.nojo.fr
@sergiodadi Ce que tu dis me rassure, au moins j'ai un peu compris comment tout cela fonctionnait :bookworm:
Je viens de faire un test en ssh en bootant sur la clé, sans avoir encore changer la carte, et j'arrive bien à me connecter. :up:
En revanche je suis étonné car quand je rentre la commande ./amdvbflash -i (ou -ai), il me sort qu'aucune CG n'est trouvée alors qu'il y a la Radeon avec proc AMD d'origine. Tu as eu ça aussi ?

En fait, j'avais fait la commande et je voyais bien la carte et elle était bien identifiée Apple, heureusement ;)

Voir la pièce jointe 217985

L'écran fonctionne sans écran externe et sans bootloader ? >> je ne serai te dire car j’ai utilisé l’écran externe dans les premiers heures et ensuite j’ai fait des bidouilles avec le catalina loader sans écran externe mais je ne sais pas souvenir si ça changeait qqch; l’OS finissait toujours par se lancer au finish :)

C'est le principal !

Âpres flash de la clé, install des différents compléments et reset de la nvram, j’ai un bootloader fonctionnel.

:up:

J’ai eu des kernel panic en sortie de sleep mode que j’ai fixé. j’ai installé Catalina avec le patcher de dosdude1.

Les problèmes que j’ai vu pour le moment c’est
1/ la carte graphique interne au CPU est vu comme une 2000

Avec quel utilitaire vois-tu la référence ?

Il me semble que la CG intégrée ne sert qu'un "petit" moment au boot, ensuite c'est la "vraie" CG qui est utilisée, quel serait le problème pour la CG intégrée ?

malgré l’installation de tout le kext file nécessaires. Quand je patche ça passe en 3000 mais au redémarrage suivant on repasse en 2000
2/ la gestion des DRM ne fonctionne pas puisque je n’arrive pas à regarder Netflix sur Safari.

A priori , sous Catalina c'est géré à partir des versions OC 0.6.5 DRM et OC 0.6.6 DRM, tu as essayé avec ces versions ?

En soit ce ne sont pas des problèmes très gênant pour moi vu l’utilisation que j’en ai.

j’ai aussi fait les benchmarkings. La config est à 18000 sur metal

J'ai à peu près la même chose 19695:

Voir la pièce jointe 217987
et à 800/3200 sur le CPU. Je vais booste un peu la ram pour passer à 24 où 32 ce qui devrait influer positivement sur les performances !

Next step installer bigsur sur une partition du SSD.

Rendez-vous alors sur le thread installation-sur-des-mac-incompatibles-big-sur j'ai posté pas mal de choses sur les patchers pour les iMacs mi 2011 particulièrement :)
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
258
108
Nice
www.nojo.fr
Bonjour les modérateurs,

j'ai posté 2 images dans le post précédent comme d'habitude et lorsqu'on clique sur "Voir la pièce jointe" , il y a un message:

Anaccount upgradeis required to continue.

Il y a un problème ou j'ai fait une erreur ?

merci d'avance
 
Dernière édition:

SuperCed

Membre d’élite
Club MacG
20 Juin 2001
1 216
53
42
superced.rb38.eu
Hello, pour ma part, j'ai un imac mi 2010 et une carte NVIDIA gtx 870.
J'avais essayé de la flasher via un module ch341a depuis Linux et macos mais sans succès car la puce programmable semblait bloquée en écriture.
Entre temps, quelqu'un a testé cette carte sur un imac mais ans succès car l'écran restait noir sur Macos et Windows. Mais il n'a pas testé la clé bootable Linux pour flasher la carte.

Est-ce que, d'après vous, ça vaut le coup que j'essaye dans mon imac avec la méthode sous Linux en ssh ou bien il y a peu de chance que ça fonctionne ?

J'hésite à tenter la manip, car ça prend pas mal de temps...

Merci !
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
258
108
Nice
www.nojo.fr
Bonjour,

Hello, pour ma part, j'ai un imac mi 2010 et une carte NVIDIA gtx 870.
J'avais essayé de la flasher via un module ch341a depuis Linux et macos mais sans succès car la puce programmable semblait bloquée en écriture.
Entre temps, quelqu'un a testé cette carte sur un imac mais ans succès car l'écran restait noir sur Macos et Windows. Mais il n'a pas testé la clé bootable Linux pour flasher la carte.

Est-ce que, d'après vous, ça vaut le coup que j'essaye dans mon imac avec la méthode sous Linux en ssh ou bien il y a peu de chance que ça fonctionne ?

J'hésite à tenter la manip, car ça prend pas mal de temps...

Merci !

C'est à tenter, il y a des cartes NVIDIA qui ne peuvent pas être programmées avec un clip:

"Most if not all of these cards have a WSON type BIOS chip which cannot be programmed using a clip. You need nvflash with Windows or Linux."

Voir le post de référence sur macrumors :)

Mais c'est pas sur à 100 % bien sur ...
 

SuperCed

Membre d’élite
Club MacG
20 Juin 2001
1 216
53
42
superced.rb38.eu
ok, c'est cool d'avoir la réponse, car je me demandais pourquoi ça passait pas.
J'arrivais bien à lire et faire un dump du bios, mais jamais réussi à écrire.

Mais le fait qu'il y ait un écran totalement noir sur MacOS et Windows, c'est pas mauvais signe pour la suite ?

Bon, j'ai déjà essayé de booter sur la clé Linux et ça semble fonctionner, même en wifi. J'ai bien pu me connecter en ssh.

Reste qu'il faudra sélectionner le disque à l'aveugle, donc je vais le faire quelques fois les yeux fermés pour être sur... Pas trop envie de déconnecter tous les disques. Je le ferai cependant si je n'arrive pas à booter sur Linux.

Ensuite, il faut que je retrouve les commandes qui permettent de flasher depuis la clé Linux... Mais je crois qu'on peut les trouver sur macosrumors. Si quelqu'un les a sous la main, ça m'intéresse.