iMac Catalina sur Imac 27 " mi 2011 et carte graphique 1/4

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
316
128
Nice
www.nojo.fr
ok, c'est cool d'avoir la réponse, car je me demandais pourquoi ça passait pas.
J'arrivais bien à lire et faire un dump du bios, mais jamais réussi à écrire.

Mais le fait qu'il y ait un écran totalement noir sur MacOS et Windows, c'est pas mauvais signe pour la suite ?

Pas du tout, sur un iMac c'est "normal" avec une CG non flashée

Bon, j'ai déjà essayé de booter sur la clé Linux et ça semble fonctionner, même en wifi. J'ai bien pu me connecter en ssh.

Reste qu'il faudra sélectionner le disque à l'aveugle, donc je vais le faire quelques fois les yeux fermés pour être sur... Pas trop envie de déconnecter tous les disques. Je le ferai cependant si je n'arrive pas à booter sur Linux.

Ensuite, il faut que je retrouve les commandes qui permettent de flasher depuis la clé Linux... Mais je crois qu'on peut les trouver sur macosrumors. Si quelqu'un les a sous la main, ça m'intéresse.

Il faut tout bien préparer AVANT ces opérations ne tolèrent pas l'à peu près :
  • (re)lis le post numéro 1 de macrumors, tout est bien décrit (A Short Plan of the Complete Hardware Upgrade Process)
  • (re)lis tous les posts de ce fil , plusieurs forumeurs ont réalisé cette opération, tu trouveras des retours d'expérience utile
 

SuperCed

Membre d’élite
Club MacG
20 Juin 2001
1 218
53
42
superced.rb38.eu
J'ai du mal à retrouver les commandes pour flasher la carte NVidia via la clef USB Linux. Tu aurais un lien ou juste la commande ?

Après, j'ai pas bien compris l'histoire de Catalina Loader, de OpenCore et de l'histoire de la modif du firmware de l'iMac et l'utilité de chacune de ces étapes. J'ai cru comprendre que le OpenCore était plutôt destiné au carte AMD...

En fait, il me semble qu'un flash de la carte Nidia + le tool pour gérer les ventilos devrait suffire.

EDIT: (finalement, j'ai trouvé)
Bloc de code:
cd /lib/live/mount/medium/flash

./nvflash_linux --save ~/k2000m.rom
./nvflash_linux --protectoff
diff ~/k2000m.rom ~/k2000m_2ndtime.rom

./nvflash_linux +6 Quadro_beta1.2/k2000.rom

En gros, on fait 2 backup de la ROM, on vérifie avec un diff qu'elles sont bien identiques, sinon, ça veut dire que l'une des 2 est corrompue.

Ensuite, on fait sauter la protection, chose qu'il m'a été impossible à faire avec l'utilitaire flashrom et un module ch341a.

Et finalement, on écrit la nouvelle ROM.
 
Dernière édition:

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
316
128
Nice
www.nojo.fr
J'ai du mal à retrouver les commandes pour flasher la carte NVidia via la clef USB Linux. Tu aurais un lien ou juste la commande ?

J'ai flashé des AMD, je n'ai pas de NVIDIA, ce ne sont pas les mêmes commandes. Je vois que tu as trouvé :)

Après, j'ai pas bien compris l'histoire de Catalina Loader, de OpenCore et de l'histoire de la modif du firmware de l'iMac et l'utilité de chacune de ces étapes. J'ai cru comprendre que le OpenCore était plutôt destiné au carte AMD...

Non, ça dépend des cartes, il y a des cartes NVIDIA qui nécessitent OpenCore, d'autres non. Apparement la tienne , GTX870, n'a pas besoin d'OC. C'est décrit dans le post numéro 1 de macrumors ....

Il y a une vingtaine de cartes possibles pour plusieurs types d'iMac, cela fait beaucoup de configurations possibles , c'est pour cela qu'il n'y a pas une description universelle des modifications à faire et qui fonctionneraient avec toutes les cartes et pour tous les types d'iMac...
 

globetribe

Membre junior
12 Décembre 2020
64
12
41
@sergiodadi et moi je m'aperçois que je n'ai pas fait de sauvegarde de la ROM de la CG avant de la flasher :banghead:
Nous avons tout les deux une WX4130. Si je rencontre un jour des problèmes, je te solliciterai pour récupérer une copie :siffle:

D'ailleurs rien à voir mais j'ai toujours un 21'' de 2011 sur lequel il faudrait que je bosse. Dans l'absolu j'aimerai y mettre un SSD et la WX4130 que j'ai actuellement dans le 27''. Ce qui me laisserai donc la possibilité d'installer une autre carte dans le 27''. Tu as une préférence, des conseils ?
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
316
128
Nice
www.nojo.fr
@sergiodadi et moi je m'aperçois que je n'ai pas fait de sauvegarde de la ROM de la CG avant de la flasher :banghead:
Nous avons tout les deux une WX4130. Si je rencontre un jour des problèmes, je te solliciterai pour récupérer une copie :siffle:

Je n'en ai pas fait non plus, c'est la ROM de l'iMac que j'ai sauvegardée ... pas le VBIOS de la CG :(. Après, comme elle fonctionne , ça ne pose pas de problème majeur ;)

D'ailleurs rien à voir mais j'ai toujours un 21'' de 2011 sur lequel il faudrait que je bosse. Dans l'absolu j'aimerai y mettre un SSD et la WX4130 que j'ai actuellement dans le 27''. Ce qui me laisserai donc la possibilité d'installer une autre carte dans le 27''. Tu as une préférence, des conseils ?

Comme il est aussi indiqué sur macrumors, ce sont les cartes AMD qui sont conseillées car plus récentes et plus "modernes" que les NVIDIA. Par contre, il y a toujours le risque qu'elles ne fonctionnent pas, c'est le problème, cette "loterie" ...

Pour le choix, les 4 AMD fonctionnent sur un 27 pouces:

Capture d’écran 2021-03-31 à 14.05.19.png

Si tu as besoin de performances graphiques (jeux, vidéo, etc...) tu as les benchmarks en OpenGL (OGL) et en metal (MET), si tu en as pas besoin, autant prendre la WX4130 qui consomme le moins.

Je ne fais pas de jeux et de montages vidéo, je ne peux en dire plus sur le coté graphique
 
  • J’aime
Réactions: globetribe

GregBZH35

Membre junior
11 Avril 2021
21
8
39
Bonjour à tous,
Merci pour le thread qui aide un peu à comprendre. J’ai quand même un problème et j’espère que quelqu’un pourra m’aider :
Ou j’en suis :
  • iMac 27pouces de mi-2011 12,2
  • Carte wx4130 installée avec bios flashé
  • Le mac boot bien sur high Sierra (SSD Principal) avec l’écran externe sur le thunderbolt. (Il boot aussi sur le second DD avec catalina dessus)
Je voudrais maintenant installer open core pour avoir l’interface au boot permettant de démarrer sur une clé usb pour refaire l’installation sur mon sud de Big Sur.
Problème mon boot version est 82.0.0.0 au lieu de 87.0.0.0 et je ne vois pas du tout comment le mettre à jour ? Mon mac semble être à jour sur les patchs de sécurité.
Pour le moment le démarrage sur mes clés usb restent sur un écran noir :-(
Merci
 

GregBZH35

Membre junior
11 Avril 2021
21
8
39
Bonjour à tous,
Merci pour le thread qui aide un peu à comprendre. J’ai quand même un problème et j’espère que quelqu’un pourra m’aider :
Ou j’en suis :
  • iMac 27pouces de mi-2011 12,2
  • Carte wx4130 installée avec bios flashé
  • Le mac boot bien sur high Sierra (SSD Principal) avec l’écran externe sur le thunderbolt. (Il boot aussi sur le second DD avec catalina dessus)
Je voudrais maintenant installer open core pour avoir l’interface au boot permettant de démarrer sur une clé usb pour refaire l’installation sur mon SSD de Big Sur.
Problème mon boot version est 82.0.0.0 au lieu de 87.0.0.0 et je ne vois pas du tout comment le mettre à jour ? Mon mac semble être à jour sur les patchs de sécurité.
Pour le moment le démarrage sur mes clés usb restent sur un écran noir :-(
Merci
 

globetribe

Membre junior
12 Décembre 2020
64
12
41
Oui j'ai un MacBook Air mais je vois pas comment cela va mettre à jour le firmware de l’imac
Si tu bootes sur le DD externe avec la dernière version de HS à jour, et qu’ensuite tu copies cette version à la place de celle que tu as actuellement, ça pourrait faire le truc. Sinon démonter la CG, remettre l’ancienne, installer HS avec la dernière version.
 

GregBZH35

Membre junior
11 Avril 2021
21
8
39
Si tu bootes sur le DD externe avec la dernière version de HS à jour, et qu’ensuite tu copies cette version à la place de celle que tu as actuellement, ça pourrait faire le truc. Sinon démonter la CG, remettre l’ancienne, installer HS avec la dernière version.
Je peux tenter ça, par contre encore 2 questions :
1. Comment tu recopies l'installation ?
2. High Sierra sur mon SSD actuel me dit que je suis le plus à jour et ne trouve pas de nouvelle update ... Je ne risque pas d'avoir le même problème ?
 

globetribe

Membre junior
12 Décembre 2020
64
12
41
A mon avis, il faut refaire une full install avec le package de 12go. Sinon la méthode barbare consisterait à flasher ta rom avec la dernière version 87.0..... mais franchement ça pourrait être risqué.

@sergiodadi une idée ?
 

GregBZH35

Membre junior
11 Avril 2021
21
8
39
Bon je viens de faire une install du dernier patch de sécurité 2020-006 et toujours le problème...
Je crois que le firmware ne se met pas à jour si on n'a pas un HDD d'origine dans le mac...?
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
316
128
Nice
www.nojo.fr
Sinon la méthode barbare consisterait à flasher ta rom avec la dernière version 87.0..... mais franchement ça pourrait être risqué.
Depuis plusieurs années, Apple n'offre plus cette possibilité officiellement, c'était vrai avant ;) , voir mises à jour de l’EFI .

Certains ont développé des outils pour des cas précis pour mettre à jour uniquement le firmware, voir par exemple ici . Cela permet par exemple de pouvoir démarrer à partir d'un disque formaté APFS sur un Mac qui n'a jamais eu APFS auparavant ;).

ATTENTION: ne pas utiliser ces méthodes si on est débutant. Dans tous les cas , faire un backup du firmware avant et avoir la possibilité de flasher l'ancien firmware...

Si tu bootes sur le DD externe avec la dernière version de HS à jour, et qu’ensuite tu copies cette version à la place de celle que tu as actuellement, ça pourrait faire le truc.

Pour que le firmware soit mis à jour, il faut que l'upgrade avec la dernière version de HS soit effectuée sur le disque interne. Si l'upgrade est réalisé sur un disque externe USB, HS est bien mis à jour , mais pas le firmware.

Il y a eu des cas (rares) où la mise à jour du firmware n'était pas effectuée si le disque interne n'était pas d'origine , même problème pour certains SSD , qui étaient bien mis à jour mais pas le firmware.

Sinon démonter la CG, remettre l’ancienne, installer HS avec la dernière version.

Je crois que c'est la solution la plus efficace et la plus sure. Tu peux aussi faciliter les changements de CG en perçant 2 petits trous, voir ici :)


EDIT: @GregBZH35 , la solution la plus efficace pour minimiser les démontages et les problèmes semble être:
  • remettre la CG d'origine
  • remettre le disque d'origine (déconnecter le deuxième disque)
  • faire une clean install de HS
  • si tu n'as plus le disque d'origine, mettre un SSD différent du SSD actuel pour que la mise à jour du firmware se passe bien, ensuite tu remets ton SSD actuel
 
Dernière édition:
  • J’aime
Réactions: globetribe

GregBZH35

Membre junior
11 Avril 2021
21
8
39
Depuis plusieurs années, Apple n'offre plus cette possibilité officiellement, c'était vrai avant ;) , voir mises à jour de l’EFI .

Certains ont développé des outils pour des cas précis pour mettre à jour uniquement le firmware, voir par exemple ici . Cela permet par exemple de pouvoir démarrer à partir d'un disque formaté APFS sur un Mac qui n'a jamais eu APFS auparavant ;).

ATTENTION: ne pas utiliser ces méthodes si on est débutant. Dans tous les cas , faire un backup du firmware avant et avoir la possibilité de flasher l'ancien firmware...



Pour que le firmware soit mis à jour, il faut que l'upgrade avec la dernière version de HS soit effectuée sur le disque interne. Si l'upgrade est réalisé sur un disque externe USB, HS est bien mis à jour , mais pas le firmware.

Il y a eu des cas (rares) où la mise à jour du firmware n'était pas effectuée si le disque interne n'était pas d'origine , même problème pour certains SSD , qui étaient bien mis à jour mais pas le firmware.



Je crois que c'est la solution la plus efficace et la plus sure. Tu peux aussi faciliter les changements de CG en perçant 2 petits trous, voir ici :)


EDIT: @GregBZH35 , la solution la plus efficace pour minimiser les démontages et les problèmes semble être:
  • remettre la CG d'origine
  • remettre le disque d'origine (déconnecter le deuxième disque)
  • faire une clean install de HS
  • si tu n'as plus le disque d'origine, mettre un SSD différent du SSD actuel pour que la mise à jour du firmware se passe bien, ensuite tu remets ton SSD actuel
  • remettre la CG d'origine => Bon je voulais éviter cette partie là mais je crois que c'est mort ...
  • Je n'ai plus le Disque d'origine, je vais devoir tenter avec un vieux disque et voir si cela fonctionne...
Grrr Apple ....
Merci pour les infos, je vous tiens au courant...
 
  • J’aime
Réactions: globetribe

GregBZH35

Membre junior
11 Avril 2021
21
8
39
Bon truc de magicien que j'ai rien compris, j'avais fait une clé big sur je sais pas trop comment (avec OCLP je crois), après avoir remis la carte graphique d'origine j'ai booté dessus > super l'install big sur arrive... je formate mon SSD... j'installe... après les 50 reboot de l'installation bam j'arrive sur l'écran bienvenue de big sur !!!!!!!!!!
Je configure big sur avec ma vieille carte graphique du coup (bon là faut pas être pressé...), je l'arrête correctement, je remets la CG WX4130 que j'avais déjà flashé, redémarre et rebam un big sur qui n'avance comme une fleur... obsolescence programmée grrrr...

bon qqs truc à voir encore en terme de comportement car j'ai toujours l'écran externe de branché et au boot j'ai le menu open core je crois.

Bon boot firmware est désormais : Version du programme interne du système : 9999.999.999.999.999
Bizarre mais ca fonctionne nickel je suis content !
 

globetribe

Membre junior
12 Décembre 2020
64
12
41
:up:

Tu as utilisé quel patcher OCLP ou MicroPatcher ?
Avec OCLP la magie va même plus loin car ton iMac doit désormais être vu comme un iMac Pro dernière génération :)
pour la version interne du fichier, je crois que c'est en quelque sorte ce qu'on appelle le spoofing pour faire croire au Mac que la machine est bien une machine compatible.

Petite question tu as intégré l'EFI sur ton disque dur interne ou tu utilises la clé USB, ou encore le Catalina Loader avec l'EFI d'OCLP ?
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
316
128
Nice
www.nojo.fr
Bon truc de magicien que j'ai rien compris, j'avais fait une clé big sur je sais pas trop comment (avec OCLP je crois), après avoir remis la carte graphique d'origine j'ai booté dessus > super l'install big sur arrive... je formate mon SSD... j'installe... après les 50 reboot de l'installation bam j'arrive sur l'écran bienvenue de big sur !!!!!!!!!!

C'est High Sierra qu'il faut (fallait ?) installer pour avoir le dernier firmware 87.0.0.0 ....

Je configure big sur avec ma vieille carte graphique du coup (bon là faut pas être pressé...), je l'arrête correctement, je remets la CG WX4130 que j'avais déjà flashé, redémarre et rebam un big sur qui n'avance comme une fleur... obsolescence programmée grrrr...

bon qqs truc à voir encore en terme de comportement car j'ai toujours l'écran externe de branché et au boot j'ai le menu open core je crois.

Bon boot firmware est désormais : Version du programme interne du système : 9999.999.999.999.999
Bizarre

C'est "normal", c'est OCLP qui le met à cette valeur:

Sets BIOSVersion to 9999.999.999.999.999, recommended for legacy Macs when using Automatic PlatformInfo, to avoid BIOS updates in unofficially supported macOS versions.