iMac Catalina sur Imac 27 " mi 2011 et carte graphique 1/4

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
590
207
Nice
blog.nojo.fr
Bonjour,
J’ai tenté il y a quelques semaines une migration de mon iMac 27 pouces mi 2011 vers Mojave avec le matcher Dosdude et je me suis vu confronté à un problème de CG. Les couleurs étaient dénaturées, écran anormalement bleu ! Mon iMac dispose d’une CG AMD Radeon HD 6970M 2048Mo. J’ai cru comprendre que les migrations au-delà de HS fonctionnaient correctement mais que cela nécessitait une CG compatible « Metal ». De quelle manière puis-je m’assurer que c’est bien le cas avec ma CG ?

La réponse est très simple, la carte AMD Radeon HD 6970M n'est pas compatible metal, c'est tout l'objet de ce post ;)
 
  • J’aime
Réactions: Dominique39

GregBZH35

Membre confirmé
11 Avril 2021
22
8
40
Bonjour,
J’ai tenté il y a quelques semaines une migration de mon iMac 27 pouces mi 2011 vers Mojave avec le matcher Dosdude et je me suis vu confronté à un problème de CG. Les couleurs étaient dénaturées, écran anormalement bleu ! Mon iMac dispose d’une CG AMD Radeon HD 6970M 2048Mo. J’ai cru comprendre que les migrations au-delà de HS fonctionnaient correctement mais que cela nécessitait une CG compatible « Metal ». De quelle manière puis-je m’assurer que c’est bien le cas avec ma CG ?
Un grand merci pour vos réponse et d’avance bravo pour ce forum qui est une vraie mine d’or.
Un petit coup d’eBay, une centaine d’euros lâchés et zou tu repars avec un iMac pour 10ans :) surtout t’as plus le truc qui fâche grrr obsolescence programmée : « ce logiciel n’est pas compatible avec votre version de Mac OS »
 
  • J’aime
Réactions: globetribe

Dominique39

Membre enregistré
30 Avril 2021
3
0
57
Un petit coup d’eBay, une centaine d’euros lâchés et zou tu repars avec un iMac pour 10ans :) surtout t’as plus le truc qui fâche grrr obsolescence programmée : « ce logiciel n’est pas compatible avec votre version de Mac OS »
Merci pour le conseil. Mon 27 pouces i7 n’est plus tout jeune mais me semble encore intéressant effectivement. Je souhaiterais pouvoir faire tourner xplane convenablement. Quelle CG me conseillerais-tu pour ce jeu et également pour pouvoir procéder à la migration vers catalina.
 

GregBZH35

Membre confirmé
11 Avril 2021
22
8
40
Merci pour le conseil. Mon 27 pouces i7 n’est plus tout jeune mais me semble encore intéressant effectivement. Je souhaiterais pouvoir faire tourner xplane convenablement. Quelle CG me conseillerais-tu pour ce jeu et également pour pouvoir procéder à la migration vers catalina.
Alors en jeux vidéos je sais pas te dire. Je suis comme toi avec un i7 27pouces de 2011. De mon côté j’ai fait le choix de la wx4130 parce que pas besoin de modifier le radiateur de la carte et tout est fonctionnel une fois demarré. Et tu peux aller en Big Sur directement ça fait plusieurs semaines que je l’ai et ras tout fonctionne bien.
 

globetribe

Membre confirmé
12 Décembre 2020
75
14
42
Merci pour le conseil. Mon 27 pouces i7 n’est plus tout jeune mais me semble encore intéressant effectivement. Je souhaiterais pouvoir faire tourner xplane convenablement. Quelle CG me conseillerais-tu pour ce jeu et également pour pouvoir procéder à la migration vers catalina.
Deux salles deux ambiances: d'un côté les cartes NVIDIA avec un support Open GL probablement plus adapté aux jeux, de l'autre les cartes AMBD qui offrent un support natif de l'encodage / décodage en 4k. Chaque type de carte à ses avantages et inconvénients: bootlicker, contraste / luminosité, etc etc. Il n'y a pas réellement de martingale. pour ma part j'ai opté également comme @sergiodadi et @GregBZH35 pour une WX4130. La raison principale c'est que les cartes AMD sont plus modernes (fabrication en 2017/2018) donc à priori elles dureront probablement plus longtemps que les cartes NVIDIA dont les dates de fabrication oscillent de 2012 à 2014. Je te conseille de lire attentivement le forum de macrumors mentionné en première page qui détaille tout cela.
 

Dominique39

Membre enregistré
30 Avril 2021
3
0
57
Deux salles deux ambiances: d'un côté les cartes NVIDIA avec un support Open GL probablement plus adapté aux jeux, de l'autre les cartes AMBD qui offrent un support natif de l'encodage / décodage en 4k. Chaque type de carte à ses avantages et inconvénients: bootlicker, contraste / luminosité, etc etc. Il n'y a pas réellement de martingale. pour ma part j'ai opté également comme @sergiodadi et @GregBZH35 pour une WX4130. La raison principale c'est que les cartes AMD sont plus modernes (fabrication en 2017/2018) donc à priori elles dureront probablement plus longtemps que les cartes NVIDIA dont les dates de fabrication oscillent de 2012 à 2014. Je te conseille de lire attentivement le forum de macrumors mentionné en première page qui détaille tout cela.
Merci pour toutes ces précisions. Je vais poursuivre ma lecture comme tu me le conseille. En revanche j’ai l’impression que les cartes AMD sont difficiles à trouver.
 

GregBZH35

Membre confirmé
11 Avril 2021
22
8
40
Merci pour toutes ces précisions. Je vais poursuivre ma lecture comme tu me le conseille. En revanche j’ai l’impression que les cartes AMD sont difficiles à trouver.
J’ai retenu 2 trucs c’est qu’il faut une dell et quelle soit verte par contre c’est dit que même si elle remplit les conditions ça peut ne pas marcher.
celle que j’ai achetée https://www.ebay.fr/itm/154077286794
 
  • J’aime
Réactions: globetribe

globetribe

Membre confirmé
12 Décembre 2020
75
14
42
J’ai retenu 2 trucs c’est qu’il faut une dell et quelle soit verte par contre c’est dit que même si elle remplit les conditions ça peut ne pas marcher.
celle que j’ai achetée https://www.ebay.fr/itm/154077286794
Il y a effectivement une part d'aléa non nul mais qui est valable pour les AMD et les Nvidia.

Les AMD doivent être de marque Dell et avoir une puce Bios pour supporter le flash c'est impératif. Certaines cartes ne sont pas forcément compatibles pour des raisons que l'on ignore, mais la plupart des personnes qui ont fait le switch sont retombées sur leur pied soit en réceptionnant la bonne carte soit en la renvoyant et en rachetant une autre. Pour les Nvidia, il arrive régulièrement que la carte soir DOA (Dead On Arrival), compte tenu de leur age avancée.

Pour les trouver AliExpress ou Ebay. Les vendeurs savent bien que ces cartes sont détournées de leur fonction première pour être installé dans des iMac 2009 à 2011. Les produits correspondent donc généralement à leur description chez les vendeurs "reconnus" (offre importante, nombre de reco positive, etc...). En revanche ce qui est certain c'est que cela crée de l'inflation sur la marchandise... depuis que j'ai acheté ma WX4130, les prix que je constate ne cesse d'augmenter...

EDIT: si vous achetez une carte sur ces plateformes, je vous conseille de prendre un envoi standard et non pas express. Ca mettra certes plus de temps (3 semaines pour AliExpress par ex) mais ça réduit franchement le risque de dédouanement... on vous vous retrouvez à payer en plus 20% de droits de douane et 20% de TVA.
 

bmael

Membre confirmé
3 Septembre 2007
43
0
44
Bonjour et merci pour toutes ces infos.
Je recherche une carte (ce n'est pas si facile à trouver à prix abordable) pour mon iMac 27'' 2011.
Il y a une chose qui n'est pas très claire pour moi c'est le flashage de la nouvelle carte. Où trouver la bonne ROM.
Sur MacRumors le lien pour chaque carte renvoie vers la page du forum qui fait maintenant 600 pages. N'y a-t-il pas quelque part un résumé : telle carte telle ROM -> lien de téléchargement ?
Merci pour votre aide.
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
590
207
Nice
blog.nojo.fr
Bonjour et merci pour toutes ces infos.
Je recherche une carte (ce n'est pas si facile à trouver à prix abordable) pour mon iMac 27'' 2011.
Il y a une chose qui n'est pas très claire pour moi c'est le flashage de la nouvelle carte. Où trouver la bonne ROM.
Sur MacRumors le lien pour chaque carte renvoie vers la page du forum qui fait maintenant 600 pages. N'y a-t-il pas quelque part un résumé : telle carte telle ROM -> lien de téléchargement ?
Merci pour votre aide.

Voir le post numéro 1 de 2011-imac-graphics-card-upgrade , pour chaque carte, il y a le lien du vBIOS (BIOS link) :)
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
590
207
Nice
blog.nojo.fr
Hello,

j'ai commencé quelques essais de Monterey sur mon iMac 27 " mi 2011 , voir ici :)
 

Pogoon

Membre enregistré
3 Septembre 2021
6
0
32
Salut sergiodadi.

Bravo pour ce tuto clair et précis !

J'avais une question concernant l'accélération matérielle. Dans un de tes tutos (je ne sais plus lequel cependant), tu as réussi à l'activer dans VideoProc après changement du GPU. Il se trouve que j'ai pris un iMac mi-2011 avec un GPU déjà changé compatible Metal (NVIDIA Quadro K3100M by nikey22), et je pensais donc que je pourrais avoir l'accélération matérielle dans VideoProc, mais j'ai beau cocher la case et actualiser, je n'ai rien. Pense-tu que cela viendrait du GPU ou il y a une autre manip à faire ? Merci pour ton aide :)

Capture d’écran 2021-09-11 à 09.35.43.png Capture d’écran 2021-09-11 à 09.36.02.png

Voici la configuration de l'ordinateur :

Capture d’écran 2021-09-11 à 09.38.14.png
 
Dernière édition par un modérateur:

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
590
207
Nice
blog.nojo.fr
Salut sergiodadi.

Bravo pour ce tuto clair et précis !

Merci

J'avais une question concernant l'accélération matérielle. Dans un de tes tutos (je ne sais plus lequel cependant), tu as réussi à l'activer dans VideoProc après changement du GPU.

Pas exactement, je ne l'ai pas "activé", c'est VideoProc qui teste et qui l'active lui-même si l'accélération est disponible.

Il se trouve que j'ai pris un iMac mi-2011 avec un GPU déjà changé compatible Metal (NVIDIA Quadro K3100M by nikey22), et je pensais donc que je pourrais avoir l'accélération matérielle dans VideoProc, mais j'ai beau cocher la case et actualiser, je n'ai rien. Pense-tu que cela viendrait du GPU ou il y a une autre manip à faire ? Merci pour ton aide :)

As-tu bien "metal family" pris en charge:

Capture d’écran 2021-09-11 à 11.47.30.png
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
590
207
Nice
blog.nojo.fr
Non, juste "Metal" qui est bien en "Géré".

C'est donc OK.

Cependant, qu'est ce donc "Metal Family" par rapport à la version "Metal" ?

Je pense que c'est simplement une différence d'affichage . Je pense que "Metal Family" est affiché quand on utilise OCLP.

Tu utilises OCLP ou un patcher ?

Pour essayer de résoudre le problème, je vois plusieurs essais à faire:
  • essayer de flasher avec d'autres ROM , j'ai vu qu'il en existe au moins 3 crées par nikey22
  • si tu as utilisé un patcher, reinstaller Big Sur mais avec OCLP
 
Dernière édition:

Pogoon

Membre enregistré
3 Septembre 2021
6
0
32
Merci pour ces précisions :)

Alors oui j'utilise déjà OCLP (récupéré sur le github) sous Big Sur (clean install via une clé USB de Big Sur 11.5.2 préparée sous OCLP).

J'ai un doute mais il y a cependant une option que je n'ai pas effectué dans OCLP. C'est l'option "Post-Install Volume Patch" après installation de Big Sur, car normalement si j'ai bien compris celle-ci est réservée aux systèmes non-metal pour assurer une certaine compatibilité avec l'OS. Et comme il est déjà géré, je ne devrais pas avoir besoin de passer par là en logique.

J'ai cru comprendre également qu'il fallait bidouiller dans Clover Configurator pour avoir l'accélération matérielle, mais je ne suis pas sûr.

Si besoin de flasher, connais-tu la méthode à faire ? Je cherche de mon côté car je n'ai jamais flashé sous mac. Et je vois qu'il y a une version 4 de la ROM par nikey22 qui doit être la version la plus récente à ce jour.

Merci !
 
Dernière édition:

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
590
207
Nice
blog.nojo.fr
Merci pour ces précisions :)

Alors oui j'utilise déjà OCLP (récupéré sur le github) sous Big Sur (clean install via une clé USB de Big Sur 11.5.2 préparée sous OCLP).

Tu as bien vérifié ou sélectionné "Nvidia GPU" dans la configuration d'OCLP ?

Capture d’écran 2021-09-11 à 16.19.59.png


J'ai un doute mais il y a cependant une option que je n'ai pas effectué dans OCLP. C'est l'option "Post-Install Volume Patch" après installation de Big Sur, car normalement si j'ai bien compris celle-ci est réservée aux systèmes non-metal pour assurer une certaine compatibilité avec l'OS. Et comme il est déjà géré, je ne devrais pas avoir besoin de passer par là en logique.

A priori, inutile pour les iMacs mi 2011 avec une CG compatible metal, je ne l'ai pas utilisé .

Si besoin de flasher, connais-tu la méthode à faire ?

Regarde le début de ce thread, je décris la procédure dans un des posts 1 à 4
 

Pogoon

Membre enregistré
3 Septembre 2021
6
0
32
Désolé pour le double post.

Cela dit j'ai réinstallé Big Sur en sélectionnant bien cette fois-ci l'option pour forcer "Nvidia" en tant que GPU Metal dans la configuration de OCLP (lors du build de l'USB d'installation et ensuite lors du build pour l'EFI boot donc) mais ça n'a rien changé et Videoproc ne détecte toujours pas l'accélération matérielle, même en cochant la case et en actualisant.

Concernant le fait de flasher le GPU, apparemment il faudrait ouvrir l'ordinateur pour détacher des câbles à ce que j'ai cru comprendre (vu sur le forum macrumors) ? je ne suis pas sûr d'effectuer l'opération dans l'immédiat car cela a l'air d'être un peu technique, et hormis ce petit problème, le mac fonctionne très bien donc cela ne presse pas. Éventuellement, je ferais une demande sur le forum de macrumors.
 
Dernière édition:

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
590
207
Nice
blog.nojo.fr
Désolé pour le double post.

Cela dit j'ai réinstallé Big Sur en sélectionnant bien cette fois-ci l'option pour forcer "Nvidia" en tant que GPU Metal dans la configuration de OCLP (lors du build de l'USB d'installation et ensuite lors du build pour l'EFI boot donc) mais ça n'a rien changé et Videoproc ne détecte toujours pas l'accélération matérielle, même en cochant la case et en actualisant.

Je n'ai utilisé que des cartes AMD, je n'ai plus trop d'idée, peut-être y a t'il un spécificité pour les cartes Nvidia (en effet, tu peux poser la question sur Macrumors)

Concernant le fait de flasher le GPU, apparemment il faudrait ouvrir l'ordinateur pour détacher des câbles à ce que j'ai cru comprendre (vu sur le forum macrumors) ?

Non, il ne faut pas ouvrir l'iMac si on utilise la méthode de boot sur une clef USB linux , aucun problème dans 99 % des cas, je l'ai fait plusieurs fois pour tester différentes versions des vBIOS :) . Le conseil de déconnecter les disques internes est surtout pour le premier "flashage" où on peut avoir un écran noir et rien sur l'écran externe. Si on a le "boot menu picker" d'OCLP , ce n'est pas la peine.

je ne suis pas sûr d'effectuer l'opération dans l'immédiat car cela a l'air d'être un peu technique,

C'est un peu technique, en effet, mais c'est bien décrit , voir ici et ici :)
 
Dernière édition: