MacBook Pro Disque dur externe se déconnecte tout seul

B'Zar

L'ordre, mon cul ! La liberté m'habite !
23 Janvier 2019
26
0
Omicron Perseï 8
Bonjour à tous,

j'ai acheté récemment un macbook pro late-2013 sous Mojave, pour de la MAO.
J'ai connecté mon disque dur externe 2.5" (auto-alimenté donc) pour la première fois, et au bout de 2 secondes environ il se déconnecte, avec le message d'erreur habituel de type "erreur d'injection du disque" ou un truc comme ça.
Pourtant ce disque dur externe fonctionne parfaitement sur mon ancien macbook de 2009 sous Maverick (testé et utilisé dessus encore régulièrement). Disque dur bien évidemment formaté mac.

Parfois le disque se déconnecte au bout de quelques secondes, parfois il tourne bien pendant un moment, je peux même faire des copies de 2 ou 3 go, contenant des centaines de fichiers sans qu'il se déconnecte, mais au bout d'un moment il se déconnecte tout de même.
J'ai vérifié le câble usb, il est parfait, il n'y a pas de jeu, la connexion est propre, pas de soucis de ce côté-là.
Surtout qu'il fonctionne normalement sur l'autre mac.
Le modèle du disque est un Storeva PocketStor 2.5" USB 3.0 (compatible 1.1 et 2.0) acheté sur MacWay.

Je n'ai pas d'autres disques durs formaté pour mac, j'ai par contre d'autres hd externes en 3.5" alimentés sur secteur, mais formatés pour Windows.
Je n'ai pas encore pu aller les récupérer pour les tester.
Par contre, j'ai plusieurs clés usb, et j'ai tenté plusieurs copies jusqu'à 16 go environ, sans problème, jamais aucune déconnexion, aucun soucis.
J'ai juste remarqué un truc, peut-être sans rapport, pendant la copie de samples audio du mac vers la clé usb, lorsque je lisais des samples depuis la clé usb, samples d'un dossier déjà copié mais avec d'autres en cours de copie, il y avait des coupures et autres bugs pendant la lecture du sample audio, mais c'est peut-être simplement la clé qui a du mal à suivre pendant la copie.

Savez-vous quel serait le problème svp ?
J'ai contacté Apple, ils m'ont fait faire une réinitialisation du SMC, mais le problème n'a pas été résolu.
Ils m'ont conseillé une maj vers Catalina, mais c'est impossible, la quasi totalité de mes softs MAO ne sont pas compatibles avec Catalina.

Si je veux tester mes autres HD externe formaté pour Windows, il faudrait que je fasse des copies, il me faudrait donc installer un utilitaire de type Parangon NTFS for mac.
Me conseillez-vous de faire ce test ?
Je n'ai pas vraiment trouvé d'équivalent de Parangon en free, à part un ou deux logiciels, mais qui semblent compliqués et pas très stables, voire entrainer des pertes de données.
Parangon semble le plus sympa, et apparemment il est gratuit pendant 10 jours, mais je ne sais pas s'il y a des restrictions ou s'il est complet.

Comme les clés usb fonctionnent normalement, est-ce que le soucis viendrait du disque dur, ou en tout cas du boitier Storeva, qui buggerait sur Mojave et pas sur Maverick ?
Ou bien peut-être les ports usb qui n'envoient pas assez de puissance pour un disque auto-alimenté ?

Existe-t-il un moyen de savoir sur les sorties usb ont une "puissance" normale ?

Merci d'avance pour votre aide.
 
Dernière édition:

B'Zar

L'ordre, mon cul ! La liberté m'habite !
23 Janvier 2019
26
0
Omicron Perseï 8
J'ai remarqué autre chose.
Il y a 2 ports usb sur le macbook, un de chaque côté.
Quand je connecte le disque dur externe sur celui de gauche, le disque se déconnecte directement avant même de se lancer, et si je le laisse connecté, le message d'erreur de déconnexion s'affiche plusieurs fois d'affilé, et le disque ne se lance jamais vraiment, il ne s'affiche jamais dans le finder (en tout cas les quelques fois que je viens de tenter).
Par contre, sur le 2nd port usb, côté droit, là le disque se connecte normalement, il y a parfois un message d'erreur au début, mais il se reconnecte en suite bien.
Je peux faire quelques copies avant qu'il se redéconnecte quand-même à force au bout d'un moment.

Mais par contre, quand je connecte une clé usb sur le port de gauche, donc celui qui fonctionne le plus mal avec le disque dur externe, avec la clé usb, pas de problème, elle fonctionne normalement (en tout cas ne se déconnecte pas).
Je peux lire, copier/coller des fichiers, sans déconnexion ni rien.
Pareil pour l'autre port, les clés usb fonctionnent sur les 2.

Donc apparemment un des deux ports supportent encore moins le HD externe que l'autre.

Quelqu'un aurait-il une explication à ce problème, ou une idée ?

Merci encore.
 
M

Membre supprimé 1138547

Invité
Peut être un problème d’alimentation.
Va dans Pomme> à propos de ce Mac > Rapport système > USB
Tu peux vérifier les ampèrages disponibles et le booster éventuel.
Tu n’as pas forcément la même puissance disponible sur les 2 ports d’où un comportement différent
 

B'Zar

L'ordre, mon cul ! La liberté m'habite !
23 Janvier 2019
26
0
Omicron Perseï 8
Merci oyapoque.
Je l'avais fait justement, mais je ne comprends rien aux données indiquées...
Je ne vois nulle part quelque-chose qui indiquerait port usb 1 et port usb 2.
Peut-être en connectant une clé ou le disque sur port j'aurai d'autres infos ?
Sinon, sans rien connecter, il a ceci:

Bus USB 3.0
Clavier interne/trackpad Apple
BRCM20702 Hub
Contrôleur de l'hôte USB Bluetooth

Bus USB 3.0 :

Gestionnaire du contrôleur de l’hôte : AppleUSBXHCILPTH
Identifiant du périphérique PCI : 0x8c31
Identifiant de révision du PCI : 0x0005
Identifiant du fournisseur du PCI : 0x8086

Clavier interne / trackpad Apple :

Identifiant du produit : 0x0263
Identifiant du fournisseur : 0x05ac (Apple Inc.)
Version : 2.25
Vitesse : Jusqu’à 12 Mb/s
Fabricant : Apple Inc.
Identifiant de l’emplacement : 0x14400000 / 3
Courant disponible (mA) : 500
Courant requis (mA) : 40
Exploitation supplémentaire actuelle (mA) : 0
Intégré : Oui

BRCM20702 Hub :

Identifiant du produit : 0x4500
Identifiant du fournisseur : 0x0a5c (Broadcom Corp.)
Version : 1.00
Vitesse : Jusqu’à 12 Mb/s
Fabricant : Apple Inc.
Identifiant de l’emplacement : 0x14300000 / 2
Courant disponible (mA) : 500
Courant requis (mA) : 94
Exploitation supplémentaire actuelle (mA) : 0
Intégré : Oui

Contrôleur de l’hôte USB Bluetooth :

Identifiant du produit : 0x8289
Identifiant du fournisseur : 0x05ac (Apple Inc.)
Version : 1.50
Fabricant : Apple Inc.
Identifiant de l’emplacement : 0x14330000

Clavier interne / trackpad Apple :

Identifiant du produit : 0x0263
Identifiant du fournisseur : 0x05ac (Apple Inc.)
Version : 2.25
Vitesse : Jusqu’à 12 Mb/s
Fabricant : Apple Inc.
Identifiant de l’emplacement : 0x14400000 / 3
Courant disponible (mA) : 500
Courant requis (mA) : 40
Exploitation supplémentaire actuelle (mA) : 0
Intégré : Oui

BRCM20702 Hub :

Identifiant du produit : 0x4500
Identifiant du fournisseur : 0x0a5c (Broadcom Corp.)
Version : 1.00
Vitesse : Jusqu’à 12 Mb/s
Fabricant : Apple Inc.
Identifiant de l’emplacement : 0x14300000 / 2
Courant disponible (mA) : 500
Courant requis (mA) : 94
Exploitation supplémentaire actuelle (mA) : 0
Intégré : Oui

Contrôleur de l’hôte USB Bluetooth :

Identifiant du produit : 0x8289
Identifiant du fournisseur : 0x05ac (Apple Inc.)
Version : 1.50
Fabricant : Apple Inc.
Identifiant de l’emplacement : 0x14330000

Contrôleur de l’hôte USB Bluetooth :

Identifiant du produit : 0x8289
Identifiant du fournisseur : 0x05ac (Apple Inc.)
Version : 1.50
Fabricant : Apple Inc.
Identifiant de l’emplacement : 0x14330000
 

B'Zar

L'ordre, mon cul ! La liberté m'habite !
23 Janvier 2019
26
0
Omicron Perseï 8
Sinon utiliser les ports thunderbolt 2 ?
Avec une espèce de hub thunderbolt vers usb.
J'ai cherché mais pas vraiment trouvé.
A part un truc à 250 euros, et en plus en thunderbolt 3, pour les mac plus récents.
 

B'Zar

L'ordre, mon cul ! La liberté m'habite !
23 Janvier 2019
26
0
Omicron Perseï 8
Lorsque je connecte une clé usb, autant sur le port de droite ou de gauche, j'ai ça:


Identifiant du produit : 0x1000
Identifiant du fournisseur : 0x090c (Silicon Motion, Inc. - Taiwan)
Version : 11.00
Vitesse : Jusqu’à 480 Mb/s
Fabricant : SMI Corporation
Identifiant de l’emplacement : 0x14200000 / 31
Courant disponible (mA) : 500
Courant requis (mA) : 500
Exploitation supplémentaire actuelle (mA) : 0
Media :
USB DISK :
Capacité : 16,03 Go (16 025 444 352 octets)
Support amovible : Oui
Nom BSD : disk2
Logical Unit : 0
Type de carte de partition : MBR (partition Master Boot Record)
USB Interface : 0
 

B'Zar

L'ordre, mon cul ! La liberté m'habite !
23 Janvier 2019
26
0
Omicron Perseï 8
Lorsque je branche le hd externe sur le port usb de droite qui fonctionne le mieux, il y a ça:

Bus USB 3.0 :

Gestionnaire du contrôleur de l’hôte : AppleUSBXHCILPTH
Identifiant du périphérique PCI : 0x8c31
Identifiant de révision du PCI : 0x0005
Identifiant du fournisseur du PCI : 0x8086

PocketStor :

Identifiant du produit : 0x55aa
Identifiant du fournisseur : 0x174c (ASMedia Technology Inc.)
Version : 1.00
Numéro de série : 123456789012
Vitesse : Jusqu’à 5 Gb/s
Fabricant : PocketStor
Identifiant de l’emplacement : 0x14600000 / 5
Courant disponible (mA) : 900
Courant requis (mA) : 0
Exploitation supplémentaire actuelle (mA) : 0
Media :
2115 :
Capacité : 1 To (1 000 204 886 016 octets)
Support amovible : Non
Nom BSD : disk2
Logical Unit : 0
Type de carte de partition : MBR (partition Master Boot Record)
USB Interface : 0
 

B'Zar

L'ordre, mon cul ! La liberté m'habite !
23 Janvier 2019
26
0
Omicron Perseï 8
On voit que ce coup-ci par contre, que le courant disponible est de 900mA, et le courant requis est de 0.
Contrairement avec la clé usb où c'est 500mA en courant disponible et 500mA également en courant requis.
C'est bizarre... Pourtant le HD externe tourne au moment où je consulte le rapport système, section USB.
Pourquoi le courant requis est de 0....?
 

baron

Membre d’élite
22 Avril 2008
1 495
370
LLN
Ton disque te tire 900 mA (et les ports sont prévus pour en délivrer 500).
Ça semble bien être un problème d'alimentation insuffisante.

Essaie de brancher ton disque sur un hub USB avec alimentation autonome (ou utilise un câble en Y branché sur deux ports pour doubler la puissance disponible).

(P.S. Je vois qu'entretemps, tu es arrivé aux mêmes conclusions.) ;)
:up:
 

mokuchley

Membre d’élite
Club MacG
27 Août 2010
4 193
271
les home studio n'aiment pas les appareils auto-alimenté ; j'en ai fait l'experience plusieurs fois, il faut donc utiliser un disque dur externe alimenté.

Avez vous un clavier maître auto-alimenté ou d'autre comme la carte son externe ?
 

B'Zar

L'ordre, mon cul ! La liberté m'habite !
23 Janvier 2019
26
0
Omicron Perseï 8
Merci pour vos réponses, c'est sympa.

Concernant la réponse de mokuchley, ce qui est bizarre c'est que ce disque externe autoalimenté fonctionne très bien sur mon autre MacBook mid-2009, beaucoup moins performant.
Home-studio ou pas, c'est juste un macbook seul, sans rien connecté dessus, qui n'arrive pas à lire un HD externe, c'est quand-même fou...
En suite, j'utilise un contrôleur Maschine mk3 avec carte son intégrée, le tout connecté en USB.
Le contrôleur fonctionne normalement même si je ne branche pas son alimentation externe (on peut l'utiliser avec juste l'USB, ou avec en + son alim externe).
C'est donc bizarre que ça fonctionne sans alim, mais par contre, pas le HD externe... (et quand je branche le HD externe, le Maschine mk3 n'est pas connecté au MacBook donc, il n'y a rien dessus, à part le HD externe donc).

Autre chose, j'ai pas compris ça moi sur les ports, c'est écrit "courant disponible 900mA" et non le courant requis par le disque.
Ça voudrait dire que le disque tire 900mA ça, le terme "courant disponible" ?
C'est bizarre...

Sinon, est-ce certain qu'avec un hub USB avec alim externe réglerait le problème ?
J'ai pas envie d'acheter ça pour rien (l'achat du macbook, même d'occase, m'a ruiné...).
Et concernant un câble en Y c'est pas possible,il n'y a qu'un port USB de chaque côté. À moins d'un très long Y.

Plus j'essaye de comprendre, moins je comprends....
 
Dernière édition:

ecatomb

Vétéran
Club MacG
21 Septembre 2016
5 438
2 355
Je tenterais bien en passant via un hub usb alimenté. Si tu pouvais t'en faire prêter un plutôt que d'en acheter, ce serait top. Rien ne garantissant que ton problème disparaitra.
 

B'Zar

L'ordre, mon cul ! La liberté m'habite !
23 Janvier 2019
26
0
Omicron Perseï 8
Je vais ramener ce soir un HD externe 3.5" avec alim externe donc, mais formaté pour PC.
Je verrai déjà s'il se déconnecte en lecture seule.
S'il ne se déconnecte pas, il me faudrait donc installer Paragon pour pouvoir le tester en copie également.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
46 250
8 056
Nancy___
Ok merci ecatomb.
Mais je ne connais personne qui aurait un hub avec alim externe...
En achetant sur Internet, on a le droit de renvoyer du matériel sous 14 jours. Pas mal pour essayer avant d'acheter (mais ne pas en abuser tout de même ;))
 

B'Zar

L'ordre, mon cul ! La liberté m'habite !
23 Janvier 2019
26
0
Omicron Perseï 8
J'y avais pensé mais en général on ne peut pas déballer l'objet si l'on veut avoir un remboursement, et ça dépend de l'emballage, parfois c'est infaisable, le déballage est trop évident, et c'est difficile voire impossible de remballer comme du neuf.
Mais je garde ça de côté, sait-on jamais.
Je vais déjà essayer un de mes disques externe NTFS avec alim, et voir comment ça marche.
Dire que je viens de l'acheter ce macbook...
J'aurais aimé savoir ce que veulent dire précisément ces données concernant les ports USB, si ils sortent une puissance normale, etc...
Perso je ne comprends pas du tout la même chose que ce que disait baron concernant les 900mA.
Il dit que c'est ce qu'a besoin le disque, moi je comprends plutôt que c'est le courant dispo sur le port. Donc l'inverse...

Merci pour vos conseils.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 820
4 343
Bonsoir, je ne peux pas tester un autre câble, c'est un format particulier (côté disque donc).
Comment ça, tu pourrais préciser ce qu'est ce format particulier ? Et quel est donc le modèle exact de ce disque dur ?