Fichiers NTFS bloqués par le Finder sous Snow léopard

neopenpen

Membre enregistré
23 Novembre 2009
4
0
41
Bonjour,
Après deux jours de recherche, j'ai un espèce de bug sous snow léopard que je ne m'explique pas et je ne trouve aucune solution nulle part (du moins personne n'en parle en ma connaissance).

Config : Mac book pro (été 2009), Snow Léopard 10.6.2 / Bootcamp Windows 7 64bits

Avant j'étais sous Léopard / XP 64 avec les NTFS 3-G : je n'ai jamais eu ce problème

Le problème :

Parfois (par ce qu'en plus ça n'arrive pas tout le temps) quand j'utilise NTFS mounter pour copier des fichiers sur mes disques NTFS (pour les utiliser sous Windows donc) depuis snow, une fois copier les fichiers ne peuvent plus être ouvert sous snow léopard.

Le finder me dit l'élément "nom du fichier blabla . qq chose" est utilisé par Mac OS X et ne peut être ouvert (l'icone sur le fichier à disparu)

Sous windows 7 je peu l'ouvrir et le manipuler, il marche sans problème mais il y a un cadenas dessus !

Ce que j'ai tenté pour résoudre le problème :

- Alors j'ai bo manipuler les droit sous windows 7 (qui du coup m'enlève le cadenas) Snow léopard lui ne veux rien savoir.

- Si je transfère ce fichier sur un autre disque, l'histoire est la même, Snow refuse, enfin il me demande mon code, copie puis finalement n'as rien fait, sans m'afficher aucun message d'erreur (sous windows ça marche, je peu le copier ailleurs mais ou qu'il soit : le fichier affiche toujours le même problème et garde visiblement cette propriété une fois revenu sous snow quelque soit l'emplacement)

- Je vire le DS store (sous mac et sous windows), ça ne change rien

- J'ai mis à jour NTFS mounter en 0.4 (qui, à ma grande faute était en 0.2 quand j'ai fais l'opération), rien ne change

- Je répare les droits avec ONYX, essaye de vider tout les caches, tente de réparer les autorisations generé par NTFS mounter dans le dossier /private/tmp/ avec Onyx ça ne change toujours rien, même en virant tout les DS store.

- Je tente de refaire l'index de spot light : ça ne change rien

- Quand je demande les infos sur le fichier par le finder, il me dit bien que la lecture et l'écriture sont autorisées.

- J'ai réparer le file système sous windows 7 avec scan disque : Windows ne me trouve aucune erreur et peu toujours manipuler le fichier sans problème. Retour sous snow léopard le problème reste le même.

- J'ai formater Snow léopard complétement et le problème persiste quand je rebranche mon disque (il s'agit bien d'un problème au sein du fichier, puis ce qu'en plus quelque soit le disque ce bug continue sur le fichier incriminé) Même sous Linux, le fichier NTFS en question n'est pas manipulable correctement.

Je vous avoue que la je sèche complètement... Car il n'y à eu aucune erreur lors de la copie à la base sous SL de mon disque HFS+ vers ce disque NTFS en parfaite santé

Avant je rajouté les autorisations d'écriture à la main sous SL sans ntfs mounter pour les disque NTFS : je n'ai jamais eu ce problème (qui à mon sens vient inévitablement de NTFS mounter)

Alors peut être étais ce un bug de NTFS mounter 0.2... Qui n'arrive pas sur la 0.4, en tout cas je n'ose plus trop tester. Pitié aidez moi, j'ai besoin de pouvoir manipuler ces fichiers autant sous windows que sous Snow L, ce bug est récent et me bloque complètement.

Y'a t'il un moyen de corriger le fichier NTFS en question avec qq logiciel que ce soit ?

Merci d'avance à ceux qui ce pencherons la dessus...
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 952
3 163
Si Apple n'a pas fait en sorte que ses pilotes NTFS soient en mode RW automatiquement, ce n'est pas simplement pour ennuyer ses utilisateurs ... C'est que ça ne marche pas très bien.

Pour ton problème, tu devrais contacter le fournisseur de NTFS-Mounter : il a peut-être une super idée.
 

neopenpen

Membre enregistré
23 Novembre 2009
4
0
41
Merci je vais essayer comme ça. Personne n'as l'air d'avoir de solution à ce problème ici
Si jamais qq est ds le même cs que moi qu'il n'hésite pas à me faire part de ses tentatives
 

neopenpen

Membre enregistré
23 Novembre 2009
4
0
41
Ayé j'ai trouvé... J'ai contacter le créateur de NTFS mounter pour lui en parler.

Les problèmes de corruption du ntfs mounter et donc du driver Snow léopard viennent du 64bits...

En gros quand snow léopard est en 32 bits aucun problème. Mais une fois en 64 bits les problèmes arrivent presque à chaque fois

Je comprend mieux pourquoi apple ne les active pas. En effet le fait que SL soit vendu partout pour être le premier OS 64bits d'apple, il on fait une croix temporaire sur le NTFS :rolleyes:
 

niscaro

Membre enregistré
5 Décembre 2009
7
0
montpellier
bonjour,

nouvel utilisateur de mac depuis très peu!!!

Imac i5

je peux lire est écrire sur un support NTFS


j'ai installé ceci NTFS-3G pour Mac OS X 2009.11.14 uniquement, sur le site suivant


http://macntfs-3g.blogspot.com/2009/12/ntfs-3g-for-mac-os-x-20091114.html

on m'a demandé de cocher une option (une histoire de mise en cache, j'ai oublié de la noté).... j'ai choisi la seconde !
j'ai redémarré mon mac comme demandé puis branché mon support externe en NTFS.
j'ai forcé la reconnaissance comme demandé, voilà...



capturedcran20091211140.png
 

looyl

Membre confirmé
18 Novembre 2009
60
1
Paris
Bonjour,
Après deux jours de recherche, j'ai un espèce de bug sous snow léopard que je ne m'explique pas et je ne trouve aucune solution nulle part (du moins personne n'en parle en ma connaissance).

Config : Mac book pro (été 2009), Snow Léopard 10.6.2 / Bootcamp Windows 7 64bits

Avant j'étais sous Léopard / XP 64 avec les NTFS 3-G : je n'ai jamais eu ce problème

Le problème :

Parfois (par ce qu'en plus ça n'arrive pas tout le temps) quand j'utilise NTFS mounter pour copier des fichiers sur mes disques NTFS (pour les utiliser sous Windows donc) depuis snow, une fois copier les fichiers ne peuvent plus être ouvert sous snow léopard.

Le finder me dit l'élément "nom du fichier blabla . qq chose" est utilisé par Mac OS X et ne peut être ouvert (l'icone sur le fichier à disparu)

Sous windows 7 je peu l'ouvrir et le manipuler, il marche sans problème mais il y a un cadenas dessus !

Ce que j'ai tenté pour résoudre le problème :

- Alors j'ai bo manipuler les droit sous windows 7 (qui du coup m'enlève le cadenas) Snow léopard lui ne veux rien savoir.

- Si je transfère ce fichier sur un autre disque, l'histoire est la même, Snow refuse, enfin il me demande mon code, copie puis finalement n'as rien fait, sans m'afficher aucun message d'erreur (sous windows ça marche, je peu le copier ailleurs mais ou qu'il soit : le fichier affiche toujours le même problème et garde visiblement cette propriété une fois revenu sous snow quelque soit l'emplacement)

- Je vire le DS store (sous mac et sous windows), ça ne change rien

- J'ai mis à jour NTFS mounter en 0.4 (qui, à ma grande faute était en 0.2 quand j'ai fais l'opération), rien ne change

- Je répare les droits avec ONYX, essaye de vider tout les caches, tente de réparer les autorisations generé par NTFS mounter dans le dossier /private/tmp/ avec Onyx ça ne change toujours rien, même en virant tout les DS store.

- Je tente de refaire l'index de spot light : ça ne change rien

- Quand je demande les infos sur le fichier par le finder, il me dit bien que la lecture et l'écriture sont autorisées.

- J'ai réparer le file système sous windows 7 avec scan disque : Windows ne me trouve aucune erreur et peu toujours manipuler le fichier sans problème. Retour sous snow léopard le problème reste le même.

- J'ai formater Snow léopard complétement et le problème persiste quand je rebranche mon disque (il s'agit bien d'un problème au sein du fichier, puis ce qu'en plus quelque soit le disque ce bug continue sur le fichier incriminé) Même sous Linux, le fichier NTFS en question n'est pas manipulable correctement.

Je vous avoue que la je sèche complètement... Car il n'y à eu aucune erreur lors de la copie à la base sous SL de mon disque HFS+ vers ce disque NTFS en parfaite santé

Avant je rajouté les autorisations d'écriture à la main sous SL sans ntfs mounter pour les disque NTFS : je n'ai jamais eu ce problème (qui à mon sens vient inévitablement de NTFS mounter)

Alors peut être étais ce un bug de NTFS mounter 0.2... Qui n'arrive pas sur la 0.4, en tout cas je n'ose plus trop tester. Pitié aidez moi, j'ai besoin de pouvoir manipuler ces fichiers autant sous windows que sous Snow L, ce bug est récent et me bloque complètement.

Y'a t'il un moyen de corriger le fichier NTFS en question avec qq logiciel que ce soit ?

Merci d'avance à ceux qui ce pencherons la dessus...

Bonsoir,

Je réagis un peu tard à ton message, mais je peux te dire que tu n'es pas le seul dans ce cas. En effet, j'étais sous SL en 10.6.2? Et en utilisation MacFuse, NTFS3G, ou NTFS for mac, le problème que je rencontrais était que la copie de fichiers sur un disque ntfs... provoquait un message d'erreurqui faisait que je ne pouvais pas continuer l'opération. En bref, impossible de copier sur ntfs, car ça bug. Alors qu'en bootant sous windows via bootcamp, no problem.

J'ai réinstallé SL en 10.6 (clean install) et refait le test: no problem. Idem en 10.6.1. Par contre en 10.6.2 ça passe toujours pas.

Si tu rencontres encore ce problème, un conseil : fait une sauvegarde de tes données, formate tout, et réinstalle tout en mettant à jour jusqu'à la version 10.6.1. En espérant qu'une prochaine version de SL ne soit pas si contraignante d'un point de vue de la gestion du NTFS. Sauf si on a le courage de booter via bootcamp à chaque fois qu'on veut copier un fichier sur du ntfs...
 

AshleyRiot

Membre enregistré
23 Avril 2010
1
0
Je réagis tard aussi, mais si jamais ça peut aider d'autres gens qui ont le même problème...

J'ai aussi rencontré le souci avec ntfs mounter. Pour y remédier, j'ai changé les attributs du fichier concerné. Dans mon cas, avec le terminal et la commande GetFileInfo, j'avais comme résultat:

> /Developer/tools/GetFileInfo monfichier

file: "monfichier"
type: "brok"
creator: "MACS"
attributes: avbstclinmedz
created: 04/22/2010 23:34:02
modified: 04/23/2010 21:53:44

Les attributs ayant l'air mauvais, la commande:

/Developer/Tools/SetFile -t "" -c "" monfichier

a fixé le problème. Je pouvais réutiliser mon fichier sans pb. Au détail près qu'en démontant et remontant le disque, le fichier était à nouveau inaccessible. Pour l'instant, je n'ai pas trouvé d'autre solution que de copier le fichier réparé (cp monfichier monfichier2) avant de démonter le disque. Le fichier copié lui, reste sain, même après démontage-remontage.
 

loubobby

Membre enregistré
18 Août 2012
2
0
Parce que j'ai découvert une façon efficace qui me semble très simple, je réagis encore plus tardivement, au cas où cela pourrait aider d'autres gens qui ont le même problème...

J'ai réussi à régler le problème relatif à ce message concernant le dossier"X" simplement en vidant la Corbeille. Au besoin, si cela ne fonctionne pas, il semble qu'une autre manière est de vider la corbeille en mode sécurisé dans le Finder. Toutefois cette dernière procédure ne fut pas nécessaire dans mon cas.