10.10 Yosemite Impossible d'accéder au menu de choix du disque de boot

armel35

Membre confirmé
10 Octobre 2008
46
3
Bonjour,

L'utilitaire de disques ayant signalé que le disque interne mécanique de l'iMac était endommagé, j'ai fait un clone avec carnon copy cloner sur un SSD 1 To Samsung en suivant un tuto. Lorsque j'ai voulu accéder au menu de boot pour essayer le clone, l'appui sur la touche alt/option n'a rien donné, l'iMac a booté sur le disque mécanique, aucun menu n'est apparu.

J'ai lu que certaines fois, la réinitialisation de la ram/pram pouvait aider à récupérer l'usages de touches bloquées au démarrage, aussi ai-je essaye la combinaison cmd + option + P + R idem, il ne se passe rien, aucun bip, la machine boote sur le disque mécanique. La commande alt cmd esc fonctionne correctement, j'ai essayé les touches du clavier filaire, elles sembles être ok

Comment puis-je atteindre le menu pour choisir le disque de boot, avez-vous une idée ?

D'avance, merci

Didier
 
Dernière édition par un modérateur:

armel35

Membre confirmé
10 Octobre 2008
46
3
Dans les Préférences Système, le choix du disque de démarrage est-il opérationnel ?
Oui, j'ai aussi essayé de redémarrer après avoir sélectionné "clone", le SSD au lieu de Macintosh HD mais pareil, l'iMac a démarré sur le disque mécanique
Mais rien ne me dit que le clone est en état de booter, que le clonage s'est bien passé, et c'est ce que je voulais vérifier

Quelle machine ?
Et surtout, quel OS sur cette machine ?
C'est un iMac fin 2013 sous Yosemite
 
Dernière édition par un modérateur:

mokuchley

Membre expert
Club MacG
27 Août 2010
4 681
337
Je suis dans la même configuration ; au boot, j'appuie sur ALT et je ne vois pas de CCC ; il n'y a que le disque Macintosh HD et mon disque de sauvegarde. En cliquant sur le disque de sauvegarde, je me retrouve dans une session, (comme indiqué dans la vidéo du lien de SLY)... mais à partir de là, je ne sais pas quoi faire.
 
Dernière édition par un modérateur:

armel35

Membre confirmé
10 Octobre 2008
46
3
PS un iMac fin 2013, c'est dommage de le laisser sous Yosemite…
Oui, en fait il était sous Mojave : il est resté sous Yosemite parce que c'est usage pro et que le passage à un autre os tel High Sierra m'interrogeait sur la retro-compatibilité d'un système de fichiers différents => j'ai préféré acheter un bon SSD et le cloner à partir du mécanique que je trouvais lent il y a deux ans.

En février 2021 j'ai passé le SSD sous Mojave, cela a paru bien se passer, jusqu'au 19 juin où le SSD externe Mojave refusa d'aller plus loin que la pomme ; le backup était assuré par un Lacie 3T et superduper incrémental (ts les jours) mais quand j'ai essayé de booter sur le lacie idem, "error" => direction un dépanneur sur Rennes qui a remis en usage le disque mécanique sous Yosemite et s'est servi du lacie pour sauvegarder le reste des données dont mes dossiers professionnels.

Sur un autre SSD neuf, il a mis une copie du Windows sous Parallels Desktop, mais je crois qu'il s'est un peu planté car il a utilisé Time Machine pour mettre à jour la machine virtuelle mais aucun snapshot n'a été copié, je m'en suis aperçu la semaine dernière, et là le gars est en vacances…

Cette fois, c'est le disque mécanique sous Yosemite qui est en train de lâcher, et ce clone avec cc cloner que j'ai fait avant hier soir est un peu mon dernier espoir. Aussi, tu te doutes du flip quand je n'arrive pas à accéder au menu de boot, y compris quand je passe par les préférences systeme => disque de démarrage, que je selectionne le clone et que l'iMac boote toujours sur le vieux disque qui est à chaque fois un peu plus lent...

Je regrette Mojave, j'aimais beaucoup, mais là je sens que c'est peut être l'ensemble que je vais regretter

Je suis dans la même configuration ; au boot, j'appuie sur ALT et je ne vois pas de CCC ; il n'y a que le disque Macintosh HD et mon disque de sauvegarde.
N'est-ce pas parce que tu penses que ton disque de sauvegarde est bien bootable quand pour une raison ou une autre il ne l'est pas ? Cela me l'a fait, une fois, du temps où ma machine ne déconnait pas, le boot avait foiré mais cependant ccloner ou superduper (je ne sais plus) m'avait indiqué que la copie était un succés => en fait non, j'ai dû recommencer la copie (avec superduper) et là ça a marché. De plus le clone apparaissait cette fois en pressant ALT au démarrage, le fait qu'il apparaisse dans preferences système => démarrage n'implique pas forcément qu'il soit réellement bootable, que le clonage s'est bien passé
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 678
26 333
Forêt de Fontainebleau
Bonjour armel

Pour qu'un volume soit affiché comme démarrable par le gestionnaire de démarrage de l'EFI (boot_manager - déclenché par la touche "alt") --> 2 conditions doivent être remplies :

- que le volume recèle un Système démarrable (du moins dans ses fondamentaux)​
- que son en-tête soit "béni" (blessed) : càd. porte inscrit un chemin de démarrage pointant dans l'arborescence du Système démarrable du volume => au démarreur boot.efi de l'OS​

Peux-tu actuellement ouvrir ta session d'utiilsateur régulière --> qu'on vérifie le statut du volume de ton clone ?
 

armel35

Membre confirmé
10 Octobre 2008
46
3
Peux-tu actuellement ouvrir ta session d'utiilsateur régulière --> qu'on vérifie le statut du volume de ton clone ?
Macomaniac, je n'ai pas bien compris la question, mais l'iMac est ouvert, tourne encore (là j'écris d'un autre appareil), que souhaites-tu que je regarde et comment ?
 
Dernière édition par un modérateur:

armel35

Membre confirmé
10 Octobre 2008
46
3
Oui, il y a deux disques externes SSD : celui de 2 To utilisé à la fois pour stocker windows.pvm (parallels, machine virtuelle) et le second SSD qui lui est le clone que j'ai fait du DD interne mécanique à l'aide de carbon copy cloner
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 678
26 333
Forêt de Fontainebleau
D'accord -->

- va à : Applications > Utilitaires > lance le «Terminal». Dans la fenêtre ouverte > saisis la commande informative (ce qui est inscrit sous Bloc de code) :​
Bloc de code:
diskutil list
et ↩︎ (presse la touche "Entrée" du clavier pour exécuter la commande)
  • tu vas voir s'afficher en mode texte le tableau des disques attachés au Mac (en interne / externe) > avec leurs configurations

Poste le retour en copier-coller > en veillant à faire le coller dans un Bloc de code (c'est plus lisible !) par le procédé suivant -->

- en bas de cette page des forums MacGé => utilise le menu (le 16è depuis la gauche = vers le milieu de la barre) dans la barre de menus au-dessus du champ de saisie d'un message > sous-menu : </> (= Bloc de code) => tu fais ton coller dans la fenêtre de code et Continuer.​

=> ces informations montreront la configuration du disque du clone : type de table de partition > format du volume > nom du volume - notamment.
 

armel35

Membre confirmé
10 Octobre 2008
46
3
Bloc de code:
Last login: Tue Aug 10 22:13:50 on console
iMac-de-MDOuest:~ mdouest$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            999.3 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *2.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS 2to_usb                 2.0 TB     disk1s2
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS Clone                   999.2 GB   disk2s2
   3:                 Apple_Boot Recovery HD             784.2 MB   disk2s3
/dev/disk3
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *3.0 TB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS Lacie 3T                3.0 TB     disk3s2
/dev/disk5
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *63.1 GB    disk5
   1:               Windows_NTFS update_Moja             63.1 GB    disk5s1
iMac-de-MDOuest:~ mdouest$

j'espère que c'est ce que tu m'as demandé
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 678
26 333
Forêt de Fontainebleau
Bien posté ! Voici le disque de ton clone :
Bloc de code:
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS Clone                   999.2 GB   disk2s2
   3:                 Apple_Boot Recovery HD             784.2 MB   disk2s3
  • rien à redire formellement parlant : table de partition GPT (GUID) > format jhfs+ > nom Clone. Tu as même une partition de secours Recovery HD en-dessous.

On examine le volume Clone. Passe les 2 commandes informatives (copier-coller - l'une après l'autre) :
Bloc de code:
ls /Vol*/Clone
bless --info /Vol*/Clone
  • la 1ère liste les objets de 1er rang (fichiers ou dossiers) de Clone
  • la 2è affiche son chemin de démarrage

Poste les retours (pas la peine de me citer d'abord) => on pourra voir si Clone est a priori valide et démarrable.
 

armel35

Membre confirmé
10 Octobre 2008
46
3
Bloc de code:
Last login: Wed Aug 11 17:44:07 on ttys000
iMac-de-MDOuest:~ mdouest$ ls /Vol*/Clone
Applications                home
Informations sur l’utilisateur        installer.failurerequests
Library                    opt
System                    private
Users                    sbin
Volumes                    tmp
bin                    usr
dev                    var
etc
iMac-de-MDOuest:~ mdouest$  bless --info /Vol*/Clone
finderinfo[0]: 337424 => Blessed System Folder is /Volumes/Clone/System/Library/CoreServices
finderinfo[1]: 379124 => Blessed System File is /Volumes/Clone/System/Library/CoreServices/boot.efi
finderinfo[2]:      0 => Open-folder linked list empty
finderinfo[3]:      0 => No alternate OS blessed file/folder
finderinfo[4]:      0 => Unused field unset
finderinfo[5]: 337424 => OS X blessed folder is /Volumes/Clone/System/Library/CoreServices
64-bit VSDB volume id:  0xDB62F7159945B0DD
iMac-de-MDOuest:~ mdouest$
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 678
26 333
Forêt de Fontainebleau
Je ne vois formellement parlant rien à redire -->

- la distribution des dossiers du Clone est logiquement conforme à celle d'un OS valide de type Yosemite
- un chemin de démarrage existe bien sur l'en-tête du volume => pointant au démarreur boot.efi de l'OS du clone​

Carbon Copy Cloner a rendu une copie conforme et a même créé une partition de secours sur le disque du clone. Ton volume Clone est a priori démarrable. Je ne m'explique pas que le gestionnaire de démarrage de l'EFI (touche "alt") ne l'affiche pas.
  • veux-tu tenter une expérience d'incrire en NVRAM une préférence de démarrage automatique sur Clone et de voir ensuite si cette instruction est suivie ?
 

armel35

Membre confirmé
10 Octobre 2008
46
3
veux-tu tenter une expérience d'incrire en NVRAM une préférence de démarrage automatique sur Clone et de voir ensuite si cette instruction est suivie ?
Oui, je veux bien !
Je précise si besoin est que j'ai essayé de réinitialiser la pram/nvram avec les cominaisons 4 touches au boot, cela n'a pas marché
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 678
26 333
Forêt de Fontainebleau
Passe d'abord la commande (copier-coller) :
Bloc de code:
sudo bless --mount /Vol*/Clone --setBoot
  • à validation > une demande de password s'affiche (commande sudo) --> tape ton mot-de-passe de session admin en aveugle - aucun caractère ne se montrant à la frappe - et revalide
  • à condition que le volume-cible (Clone) soit déjà "béni" (blessed) de manière valide (ce qui est le cas) --> cette commande change en NVRAM la désignation du volume de démarrage automatique pour l'EFI. Commande muette si elle passe.

Si tel a été le cas > passe ensuite la commande :
Bloc de code:
nvram efi-boot-device
  • qui lit dans la NVRAM la valeur associée à la variable : efi-boot-device qui renseigne le chemin de démarrage automatique pour l'EFI (programme de boot primaire de la carte-mère) du Mac

Poste le retour (abstrus).
 

armel35

Membre confirmé
10 Octobre 2008
46
3
Bloc de code:
Last login: Wed Aug 11 18:00:30 on ttys000
iMac-de-MDOuest:~ mdouest$ sudo bless --mount /Vol*/Clone --setBoot

To proceed, enter your password, or type Ctrl-C to abort.

Password:
iMac-de-MDOuest:~ mdouest$ nvram efi-boot-device
efi-boot-device    <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>79A25468-4A83-4A40-90D5-3361596D5C1F</string></dict></dict><key>BLLastBSDName</key><string>disk2s2</string></dict></array>
iMac-de-MDOuest:~ mdouest$

bon, faut le dire, ça fout un peu les pétoches....
 
Dernière édition par un modérateur: