Les pistes d'un album ne veulent pas rester en ordre

Adrienhb

Membre d’élite
Club MacG
25 Octobre 2002
3 447
281
43
La Ville Lumière
Lors d'un classement par album, en théorie les pistes se mettent dans l'ordre de leur numéro de piste.
Ben là, l'ordre est on ne peut plus aléatoire. Pourtant les numéros des pistes sont bons et correctement renseignés.
Une idée du pourquoi de la chose et comment le régler? Merci.
 

Beun

Membre junior
19 Août 2008
29
3
Göteborg, Suède
J'ai le même problème mais je n'arrive pas à le résoudre : j'ai plusieurs sections dans l'affichage d'iTunes pour un même album, même artiste. Ca désorganise les pistes... Pas chouette pour la lecture !
Si quelqu'un à une idée, je suis aussi preneur, merci !
 

wath68

•••
Club MacG
2 Novembre 2007
5 901
783
French East Coast
Voir si sur un ou plusieurs morceaux de l'album, le tag "artiste de l'album " est rempli ou pas.
Il doit l'être soit sur tous, ou sur aucun.
 

Beun

Membre junior
19 Août 2008
29
3
Göteborg, Suède
Qu'entends-tu par "dans les options de tri" ?
Je classe par piste dans ma bibliothèque, et le regroupement par album et artiste se fait tout seul.
 

wath68

•••
Club MacG
2 Novembre 2007
5 901
783
French East Coast
Le n° de disque est-il identique pour tout les morceaux de l'album ?

Je viens d'essayer, pour tester, d'enlever l'indication du numéro de disque sur certains morceaux d'un album, et ça fout un peu le boxon



Pour vérifier, active l'affichage du numéro de disque, tu verras tout de suite si certains morceaux sont renseignés et d'autres non.

Pour être clair, imaginons que tu as un album de 10 morceaux.
Les morceaux 1,2,5 et 8 sont tagués "album 1 sur 1", et le reste des morceaux sans tags de n° d'album,
et bien dans ta liste les morceaux n° 1,2,5 et 8 se retrouveront à la fin de l'album.

Je pense que c'est pour ça que quand tu importes un cd avec iTunes il met automatiquement le n° du disque.

Si c'est pas ça, ben je cale, je ne vois pas d'autres solutions.
 

Beun

Membre junior
19 Août 2008
29
3
Göteborg, Suède
Malheureusement j'ai déjà regardé ça.
J'ai seulement renseigné le numéro de piste, l'artiste, l'album et le titre de ces morceaux (qui posent problème). L'artiste et l'album sont exactement les mêmes pour les différents morceaux (majuscules aux mêmes lettres).
Je sèche aussi depuis quelques temps...
 

Adrienhb

Membre d’élite
Club MacG
25 Octobre 2002
3 447
281
43
La Ville Lumière
Je viens d'ajouter le numéro du disque, cela n'a rien changé.

Par contre... j'ai trouvé comment résoudre le problème. :D
Dans l'onglet "Tri", j'ai effacé le contenu du champs "Artiste de l'album" qui pour une raison inconnue était renseigné.
Et les morceaux ont repris leurs places.

Je me demande à quoi ça sert cet onglet "Tri"... :nailbiting:
 

Beun

Membre junior
19 Août 2008
29
3
Göteborg, Suède
Je n'ai rien dans "Artiste de l'album" mais ça ne marche pas quand même :(
Je ne l'ai pas non plus dans la sélection de tri
 

wath68

•••
Club MacG
2 Novembre 2007
5 901
783
French East Coast
L'option Tri te permet, par exemple pour The Cure, de classer le groupe dans les T ou dans les C.
D'ailleurs pour tout les groupes en THE, iTunes le fait automatiquement, il supprime le THE dans les options de tri (que ce soit dans album, chanson ou nom d'artiste), ce que je ne trouve pas très pratique pour ma part.

@ Beun : désolé si tu l'as déjà fais, mais je te conseille d'essayer de prendre un album qui déconne, de sélectionner le premier morceaux de la liste, clic droit, obtenir les info, et comparer tout les tags dans les onglets info, tri et options, en cliquant sur suivant.
D'après moi ça ne peut que venir de là, un tag en trop ou manquant.
 

Beun

Membre junior
19 Août 2008
29
3
Göteborg, Suède
J'ai finalement trouvé un plan B ! C'est un peu batard comme technique, mais ça fonctionne.
J'ai drag&droppé mes morceaux de musique dans un dossier lambda, je les ai ensuite supprimés de ma bibliothèque iTunes puis re-ajoutés. Et là, magie, tout rentre dans l'ordre ! :up:
Conclusion : ça ne devait être qu'un bug, et non un problème d'id3tag

Bonne journée
 

miaou

Membre d’élite
Club MacG
25 Mars 2001
1 465
48
marseille
content pour toi

pour en revenir à ce problème , sur les tags , il faut bien s'assurer dans un tag "vide" qu'il soit bien vide ......
ça m'est déjà arrivé.. qu'un tag que je croyais vide en fait ne l'était pas ... il y avait " un espace " . invisible à l'oeil nu donc .... mais ça change tout.... :siffle: